MIBs Depot

Printer-MIB

Registered at
1.3.6.1.2.1.43
Last updated
2004-06-02 00:00
Organization
PWG IEEE/ISTO Printer Working Group
Revisions
2004-06-02 00:00, 1994-11-25 00:00
Namespace
standard
Source file
Printer-MIB
Digest
sha256:4b9cadc68d89c78c3700b65d9c7452e3ef1c71c0d4d120d26a2c8cea7a099190

Description

The MIB module for management of printers. Copyright (C) The Internet Society (2004). This version of this MIB module was published in RFC 3805. For full legal notices see the RFC itself.

Contact

Harry Lewis IBM Phone (303) 924-5337 Email: harryl@us.ibm.com http://www.pwg.org/index.html Send comments to the printmib WG using the Printer MIB Project (PMP) Mailing List: pmp@pwg.org For further information, access the PWG web page under 'Printer MIB': http://www.pwg.org/ Implementers of this specification are encouraged to join the pmp mailing list in order to participate in discussions on any clarifications needed and registration proposals being reviewed in order to achieve consensus.

Imports

FromSymbols
HOST-RESOURCES-MIBhrDeviceIndex, hrStorageIndex
IANA-CHARSET-MIBIANACharset
IANA-PRINTER-MIBPrtAlertCodeTC, PrtAlertGroupTC, PrtAlertTrainingLevelTC, PrtChannelTypeTC, PrtConsoleColorTC, PrtConsoleDisableTC, PrtCoverStatusTC, PrtGeneralResetTC, PrtInputTypeTC, PrtInterpreterLangFamilyTC, PrtMarkerMarkTechTC, PrtMarkerSuppliesTypeTC, PrtMediaPathTypeTC, PrtOutputTypeTC
IF-MIBInterfaceIndexOrZero
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, TimeTicks, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION

Imported by

1 module(s) in this corpus import this one.

Load order

Every file a consumer needs in order to load this module, dependencies first.

HOST-RESOURCES-MIB
IANA-CHARSET-MIB
IANA-PRINTER-MIB
IANAifType-MIB
IF-MIB
Printer-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC

Under this module's arcs

Where the registration tree carries on below this module.

ArcNameModule
1.3.6.1.2.1.43.2prtMIBConformance
1.3.6.1.2.1.43.30finDeviceFinisher-MIB
1.3.6.1.2.1.43.31finSupplyFinisher-MIB
1.3.6.1.2.1.43.32finSupplyMediaInputFinisher-MIB
1.3.6.1.2.1.43.33finDeviceAttributeFinisher-MIB

Textual conventions

NameOIDSyntaxAccessStatus
CapacityUnit
TEXTUAL-CONVENTION
Units of measure for media capacity.
deprecated
CodedCharSet
TEXTUAL-CONVENTION
The original description clause from RFC 1759 [RFC1759] was technically inaccurate and therefore has been deleted.
deprecated
MediaUnit
TEXTUAL-CONVENTION
Units of measure for media dimensions.
deprecated
PresentOnOff
TEXTUAL-CONVENTION
Presence and configuration of a device or feature.
current
PrtAlertSeverityLevelTC
TEXTUAL-CONVENTION
The level of severity of this alert table entry. The printer determines the severity level assigned to each entry in the table. A critical alert is binary by nature and definition. A warning is defined to be a non-critical alert. The original and most common warning is unary. The binary warning was added later and given a more distinguished name.
current
PrtCapacityUnitTC
TEXTUAL-CONVENTION
Units of measure for media capacity.
current
PrtChannelStateTC
TEXTUAL-CONVENTION
The state of this print job delivery channel. The value determines whether print data is allowed through this channel.
current
PrtConsoleDescriptionStringTC
TEXTUAL-CONVENTION
An object MUST use this TEXTUAL-CONVENTION when its 'charset' is controlled by the value of prtConsoleLocalization.
current
PrtInterpreterTwoWayTC
TEXTUAL-CONVENTION
Indicates whether or not this interpreter returns information back to the host.
current
PrtLocalizedDescriptionStringTC
TEXTUAL-CONVENTION
An object MUST use this TEXTUAL-CONVENTION when its 'charset' is controlled by the value of prtGeneralCurrentLocalization.
current
PrtMarkerAddressabilityUnitTC
TEXTUAL-CONVENTION
The unit of measure of distances, as applied to the marker's resolution.
current
PrtMarkerColorantRoleTC
TEXTUAL-CONVENTION
The role played by this colorant.
current
PrtMarkerCounterUnitTC
TEXTUAL-CONVENTION
The unit that will be used by the printer when reporting counter values for this marking sub-unit. The time units of measure are provided for a device like a strip recorder that does not or cannot track the physical dimensions of the media and does not use characters, lines or sheets.
current
PrtMarkerSuppliesClassTC
TEXTUAL-CONVENTION
Indicates whether this supply entity represents a supply that is consumed or a receptacle that is filled.
current
PrtMarkerSuppliesSupplyUnitTC
TEXTUAL-CONVENTION
Unit of this marker supply container/receptacle.
current
PrtMediaPathMaxSpeedPrintUnitTC
TEXTUAL-CONVENTION
The unit of measure used in specifying the speed of all media paths in the printer.
current
PrtMediaUnitTC
TEXTUAL-CONVENTION
Units of measure for media dimensions.
current
PrtOutputPageDeliveryOrientationTC
TEXTUAL-CONVENTION
The reading surface that will be 'up' when pages are delivered to the associated output sub-unit. Values are Face-Up and Face Down (Note: interpretation of these values is, in general, context-dependent based on locale; presentation of these values to an end-user should be normalized to the expectations of the user.
current
PrtOutputStackingOrderTC
TEXTUAL-CONVENTION
The current state of the stacking order for the associated output sub-unit. 'firstToLast' means that as pages are output, the front of the next page is placed against the back of the previous page. 'lastToFirst' means that as pages are output, the back of the next page is placed against the front of the previous page.
current
PrtPrintOrientationTC
TEXTUAL-CONVENTION
A generic representation for printing orientation on a 'page'.
current
PrtSubUnitStatusTC
TEXTUAL-CONVENTION
Status of a printer sub-unit. The SubUnitStatus is an integer that is the sum of 5 distinct values, Availability, Non-Critical, Critical, On-line, and Transitioning. These values are: Availability Value Available and Idle 0 0000'b Available and Standby 2 0010'b Available and Active 4 0100'b Available and Busy 6 0110'b Unavailable and OnRequest 1 0001'b Unavailable because Broken 3 0011'b Unknown 5 0101'b Non-Critical No Non-Critical Alerts 0 0000'b Non-Critical Alerts 8 1000'b Critical No Critical Alerts 0 0000'b Critical Alerts 16 1 0000'b On-Line State is On-Line 0 0000'b State is Off-Line 32 10 0000'b Transitioning At intended state 0 0000'b Transitioning to intended state 64 100 0000'b
current
SubUnitStatus
TEXTUAL-CONVENTION
Status of a printer sub-unit. The SubUnitStatus is an integer that is the sum of 5 distinct values, Availability, Non-Critical, Critical, On-line, and Transitioning. These values are: Availability Value Available and Idle 0 0000'b Available and Standby 2 0010'b Available and Active 4 0100'b Available and Busy 6 0110'b Unavailable and OnRequest 1 0001'b Unavailable because Broken 3 0011'b Unknown 5 0101'b Non-Critical No Non-Critical Alerts 0 0000'b Non-Critical Alerts 8 1000'b Critical No Critical Alerts 0 0000'b Critical Alerts 16 1 0000'b On-Line State is On-Line 0 0000'b State is Off-Line 32 10 0000'b Transitioning At intended state 0 0000'b Transitioning to intended state 64 100 0000'b
deprecated

Objects

NameOIDSyntaxAccessStatus
prtMIBConformance
OBJECT-IDENTITY
1.3.6.1.2.1.43.2
prtMIBGroups
OBJECT-IDENTITY
1.3.6.1.2.1.43.2.2
prtMIB2Groups
OBJECT-IDENTITY
1.3.6.1.2.1.43.2.4
prtGeneral
OBJECT-IDENTITY
1.3.6.1.2.1.43.5
prtGeneralTable
OBJECT-TYPE
A table of general information per printer. Objects in this table are defined in various places in the MIB, nearby the groups to which they apply. They are all defined here to minimize the number of tables that would otherwise need to exist.
1.3.6.1.2.1.43.5.1not-accessiblecurrent
prtGeneralEntry
OBJECT-TYPE
An entry exists in this table for each device entry in the host resources MIB device table with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1not-accessiblecurrent
prtGeneralConfigChanges
OBJECT-TYPE
Counts configuration changes within the printer. A configuration change is defined to be an action that results in a change to any MIB object other than those that reflect status or level, or those that act as counters or gauges. In addition, any action that results in a row being added or deleted from any table in the Printer MIB is considered a configuration change. Such changes will often affect the capability of the printer to service certain types of print jobs. Management applications may cache infrequently changed configuration information about sub units within the printer. This object should be incremented whenever the agent wishes to notify management applications that any cached configuration information for this device is to be considered 'stale'. At this point, the management application should flush any configuration information cached about this device and fetch new configuration information. The following are examples of actions that would cause the prtGeneralConfigChanges object to be incremented: - Adding an output bin - Changing the media in a sensing input tray - Changing the value of prtInputMediaType Note that the prtGeneralConfigChanges counter would not be incremented when an input tray is temporarily removed to load additional paper or when the level of an input device changes. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1.1Counter32read-onlycurrent
prtGeneralCurrentLocalization
OBJECT-TYPE
The value of the prtLocalizationIndex corresponding to the current language, country, and character set to be used for localized string values that are identified as being dependent on the value of this object. Note that this object does not apply to localized strings in the prtConsole group or to any object that is not explicitly identified as being localized according to prtGeneralCurrentLocalization. When an object's 'charset' is controlled by the value of prtGeneralCurrentLocalization, it MUST specify PrtLocalizedDescriptionStringTC as its syntax. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1.2Integer32 (1..65535)read-writecurrent
prtGeneralReset
OBJECT-TYPE
Setting this value to 'powerCycleReset', 'resetToNVRAM', or 'resetToFactoryDefaults' will result in the resetting of the printer. When read, this object will always have the value 'notResetting(3)', and a SET of the value 'notResetting' shall have no effect on the printer. Some of the defined values are optional. However, every implementation must support at least the values 'notResetting' and 'resetToNVRAM'.
1.3.6.1.2.1.43.5.1.1.3PrtGeneralResetTCread-writecurrent
prtGeneralCurrentOperator
OBJECT-TYPE
The name of the person who is responsible for operating this printer. It is suggested that this string include information that would enable other humans to reach the operator, such as a phone number. As a convention to facilitate automatic notification of the operator by the agent or network management station, the phone number, fax number or email address should be indicated by the URL schemes 'tel:', 'fax:' and 'mailto:', respectively. If either the phone, fax, or email information is not available, then a line should not be included for this information. NOTE: For interoperability purposes, it is advisable to use email addresses formatted according to [RFC2822] requirements. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1.4OCTET STRING (SIZE(0..127))read-writecurrent
prtGeneralServicePerson
OBJECT-TYPE
The name of the person responsible for servicing this printer. It is suggested that this string include information that would enable other humans to reach the service person, such as a phone number. As a convention to facilitate automatic notification of the operator by the agent or network management station, the phone number, fax number or email address should be indicated by the URL schemes 'tel:', 'fax:' and 'mailto:', respectively. If either the phone, fax, or email information is not available, then a line should not be included for this information. NOTE: For interoperability purposes, it is advisable to use email addresses formatted per [RFC2822] requirements. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1.5OCTET STRING (SIZE(0..127))read-writecurrent
prtInputDefaultIndex
OBJECT-TYPE
The value of prtInputIndex corresponding to the default input sub-unit: that is, this object selects the default source of input media.
1.3.6.1.2.1.43.5.1.1.6Integer32 (1..65535)read-writecurrent
prtOutputDefaultIndex
OBJECT-TYPE
The value of prtOutputIndex corresponding to the default output sub-unit; that is, this object selects the default output destination.
1.3.6.1.2.1.43.5.1.1.7Integer32 (1..65535)read-writecurrent
prtMarkerDefaultIndex
OBJECT-TYPE
The value of prtMarkerIndex corresponding to the default marker sub-unit; that is, this object selects the default marker.
1.3.6.1.2.1.43.5.1.1.8Integer32 (1..65535)read-writecurrent
prtMediaPathDefaultIndex
OBJECT-TYPE
The value of prtMediaPathIndex corresponding to the default media path; that is, the selection of the default media path.
1.3.6.1.2.1.43.5.1.1.9Integer32 (1..65535)read-writecurrent
prtConsoleLocalization
OBJECT-TYPE
The value of the prtLocalizationIndex corresponding to the language, country, and character set to be used for the console. This localization applies both to the actual display on the console as well as the encoding of these console objects in management operations. When an object's 'charset' is controlled by the value of prtConsoleLocalization, it MUST specify PrtConsoleDescriptionStringTC as its syntax. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1.10Integer32 (1..65535)read-writecurrent
prtConsoleNumberOfDisplayLines
OBJECT-TYPE
The number of lines on the printer's physical display. This value is 0 if there are no lines on the physical display or if there is no physical display
1.3.6.1.2.1.43.5.1.1.11Integer32 (0..65535)read-onlycurrent
prtConsoleNumberOfDisplayChars
OBJECT-TYPE
The number of characters per line displayed on the physical display. This value is 0 if there are no lines on the physical display or if there is no physical display
1.3.6.1.2.1.43.5.1.1.12Integer32 (0..65535)read-onlycurrent
prtConsoleDisable
OBJECT-TYPE
This value indicates how input is (or is not) accepted from the operator console. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.1.1.13PrtConsoleDisableTCread-writecurrent
prtAuxiliarySheetStartupPage
OBJECT-TYPE
Used to enable or disable printing a startup page. If enabled, a startup page will be printed shortly after power-up, when the device is ready. Typical startup pages include test patterns and/or printer configuration information.
1.3.6.1.2.1.43.5.1.1.14PresentOnOffread-writecurrent
prtAuxiliarySheetBannerPage
OBJECT-TYPE
Used to enable or disable printing banner pages at the beginning of jobs. This is a master switch which applies to all jobs, regardless of interpreter.
1.3.6.1.2.1.43.5.1.1.15PresentOnOffread-writecurrent
prtGeneralPrinterName
OBJECT-TYPE
An administrator-specified name for this printer. Depending upon implementation of this printer, the value of this object may or may not be same as the value for the MIB-II 'SysName' object.
1.3.6.1.2.1.43.5.1.1.16OCTET STRING (SIZE(0..127))read-writecurrent
prtGeneralSerialNumber
OBJECT-TYPE
A recorded serial number for this device that indexes some type device catalog or inventory. This value is usually set by the device manufacturer but the MIB supports the option of writing for this object for site-specific administration of device inventory or tracking.
1.3.6.1.2.1.43.5.1.1.17OCTET STRING (SIZE(0..255))read-writecurrent
prtAlertCriticalEvents
OBJECT-TYPE
A running counter of the number of critical alert events that have been recorded in the alert table. The value of this object is RESET in the event of a power cycle operation (i.e., the value is not persistent.
1.3.6.1.2.1.43.5.1.1.18Counter32read-onlycurrent
prtAlertAllEvents
OBJECT-TYPE
A running counter of the total number of alert event entries (critical and non-critical) that have been recorded in the alert table
1.3.6.1.2.1.43.5.1.1.19Counter32read-onlycurrent
prtStorageRefTable
OBJECT-TYPE
This table defines which printer, amongst multiple printers serviced by one agent, owns which storage units. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.2not-accessiblecurrent
prtStorageRefEntry
OBJECT-TYPE
This table will have an entry for each entry in the Host Resources MIB storage table that represents storage associated with a printer managed by this agent. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.2.1not-accessiblecurrent
prtStorageRefSeqNumber
OBJECT-TYPE
This value will be unique amongst all entries with a common value of hrStorageIndex. This object allows a storage entry to point to the multiple printer devices with which it is associated.
1.3.6.1.2.1.43.5.2.1.1Integer32 (1..65535)not-accessiblecurrent
prtStorageRefIndex
OBJECT-TYPE
The value of the hrDeviceIndex of the printer device that this storageEntry is associated with.
1.3.6.1.2.1.43.5.2.1.2Integer32 (0..2147483647)read-onlycurrent
prtDeviceRefTable
OBJECT-TYPE
This table defines which printer, amongst multiple printers serviced by one agent, is associated with which devices. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.3not-accessiblecurrent
prtDeviceRefEntry
OBJECT-TYPE
This table will have an entry for each entry in the Host Resources MIB device table that represents a device associated with a printer managed by this agent. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.5.3.1not-accessiblecurrent
prtDeviceRefSeqNumber
OBJECT-TYPE
This value will be unique amongst all entries with a common value of hrDeviceIndex. This object allows a device entry to point to the multiple printer devices with which it is associated.
1.3.6.1.2.1.43.5.3.1.1Integer32 (1..65535)not-accessiblecurrent
prtDeviceRefIndex
OBJECT-TYPE
The value of the hrDeviceIndex of the printer device that this deviceEntry is associated with.
1.3.6.1.2.1.43.5.3.1.2Integer32 (0..2147483647)read-onlycurrent
prtCover
OBJECT-IDENTITY
1.3.6.1.2.1.43.6
prtCoverTable
OBJECT-TYPE
A table of the covers and interlocks of the printer.
1.3.6.1.2.1.43.6.1not-accessiblecurrent
prtCoverEntry
OBJECT-TYPE
Information about a cover or interlock. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.6.1.1not-accessiblecurrent
prtCoverIndex
OBJECT-TYPE
A unique value used by the printer to identify this Cover sub unit. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new cover sub-units to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.6.1.1.1Integer32 (1..65535)not-accessiblecurrent
prtCoverDescription
OBJECT-TYPE
The manufacturer provided cover sub-mechanism name in the localization specified by prtGeneralCurrentLocalization.
1.3.6.1.2.1.43.6.1.1.2PrtLocalizedDescriptionStringTCread-onlycurrent
prtCoverStatus
OBJECT-TYPE
The status of this cover sub-unit.
1.3.6.1.2.1.43.6.1.1.3PrtCoverStatusTCread-onlycurrent
prtLocalization
OBJECT-IDENTITY
1.3.6.1.2.1.43.7
prtLocalizationTable
OBJECT-TYPE
The available localizations in this printer.
1.3.6.1.2.1.43.7.1not-accessiblecurrent
prtLocalizationEntry
OBJECT-TYPE
A description of a localization. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.7.1.1not-accessiblecurrent
prtLocalizationIndex
OBJECT-TYPE
A unique value used by the printer to identify this localization entry. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new localization data to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.7.1.1.1Integer32 (1..65535)not-accessiblecurrent
prtLocalizationLanguage
OBJECT-TYPE
A two character language code from ISO 639. Examples en, es, fr, de. NOTE: These examples were shown as upper case in RFC 1759 and are now shown as lower case to agree with ISO 639.
1.3.6.1.2.1.43.7.1.1.2OCTET STRING (SIZE(2))read-onlycurrent
prtLocalizationCountry
OBJECT-TYPE
A two character country code from ISO 3166, a blank string (two space characters) shall indicate that the country is not defined. Examples: US, GB, FR, DE, ...
1.3.6.1.2.1.43.7.1.1.3OCTET STRING (SIZE(2))read-onlycurrent
prtLocalizationCharacterSet
OBJECT-TYPE
The coded character set used for this localization.
1.3.6.1.2.1.43.7.1.1.4IANACharsetread-onlycurrent
prtInput
OBJECT-IDENTITY
1.3.6.1.2.1.43.8
prtInputTable
OBJECT-TYPE
A table of the devices capable of providing media for input to the printing process.
1.3.6.1.2.1.43.8.2not-accessiblecurrent
prtInputEntry
OBJECT-TYPE
Attributes of a device capable of providing media for input to the printing process. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.8.2.1not-accessiblecurrent
prtInputIndex
OBJECT-TYPE
A unique value used by the printer to identify this input sub-unit. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new input sub-units to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.8.2.1.1Integer32 (1..65535)not-accessiblecurrent
prtInputType
OBJECT-TYPE
The type of technology (discriminated primarily according to feeder mechanism type) employed by the input sub-unit. Note, the Input Class provides for a descriptor field to further qualify the other choice.
1.3.6.1.2.1.43.8.2.1.2PrtInputTypeTCread-onlycurrent
prtInputDimUnit
OBJECT-TYPE
The unit of measurement for use calculating and relaying dimensional values for this input sub-unit.
1.3.6.1.2.1.43.8.2.1.3PrtMediaUnitTCread-onlycurrent
prtInputMediaDimFeedDirDeclared
OBJECT-TYPE
This object provides the value of the declared dimension, in the feed direction, of the media that is (or, if empty, was or will be) in this input sub-unit. The feed direction is the direction in which the media is fed on this sub-unit. This dimension is measured in input sub-unit dimensional units (controlled by prtInputDimUnit, which uses PrtMediaUnitTC). If this input sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed by management requests. Otherwise, the value may be changed. The value (-1) means other and specifically means that this sub-unit places no restriction on this parameter. The value (-2) indicates unknown.
1.3.6.1.2.1.43.8.2.1.4Integer32 (-2..2147483647)read-writecurrent
prtInputMediaDimXFeedDirDeclared
OBJECT-TYPE
This object provides the value of the declared dimension, in the cross feed direction, of the media that is (or, if empty, was or will be) in this input sub-unit. The cross feed direction is ninety degrees relative to the feed direction associated with this sub-unit. This dimension is measured in input sub-unit dimensional units (controlled by prtInputDimUnit,which uses PrtMediaUnitTC). If this input sub- unit can reliably sense this value, the value is sensed by the printer and may not be changed by management requests. Otherwise, the value may be changed. The value (-1) means other and specifically means that this sub-unit places no restriction on this parameter. The value (-2) indicates unknown.
1.3.6.1.2.1.43.8.2.1.5Integer32 (-2..2147483647)read-writecurrent
prtInputMediaDimFeedDirChosen
OBJECT-TYPE
The printer will act as if media of the chosen dimension (in the feed direction) is present in this input source. Note that this value will be used even if the input tray is empty. Feed dimension measurements are taken relative to the feed direction associated with that sub-unit and are in input sub-unit dimensional units (controlled by prtInputDimUnit, which uses PrtMediaUnitTC). If the printer supports the declared dimension,the granted dimension is the same as the declared dimension. If not, the granted dimension is set to the closest dimension that the printer supports when the declared dimension is set. The value (-1) means other and specifically indicates that this sub-unit places no restriction on this parameter. The value (-2)indicates unknown.
1.3.6.1.2.1.43.8.2.1.6Integer32 (-2..2147483647)read-onlycurrent
prtInputMediaDimXFeedDirChosen
OBJECT-TYPE
The printer will act as if media of the chosen dimension (in the cross feed direction) is present in this input source. Note that this value will be used even if the input tray is empty. The cross feed direction is ninety degrees relative to the feed direction associated with this sub-unit. This dimension is measured in input sub-unit dimensional units (controlled by prtInputDimUnit, which uses PrtMediaUnitTC). If the printer supports the declare dimension, the granted dimension is the same as the declared dimension. If not, the granted dimension is set to the closest dimension that the printer supports when the declared dimension is set. The value (-1) means other and specifically indicates that this sub-unit places no restriction on this parameter. The value (-2) indicates unknown.
1.3.6.1.2.1.43.8.2.1.7Integer32 (-2..2147483647)read-onlycurrent
prtInputCapacityUnit
OBJECT-TYPE
The unit of measurement for use in calculating and relaying capacity values for this input sub-unit.
1.3.6.1.2.1.43.8.2.1.8PrtCapacityUnitTCread-onlycurrent
prtInputMaxCapacity
OBJECT-TYPE
The maximum capacity of the input sub-unit in input sub-unit capacity units (PrtCapacityUnitTC). There is no convention associated with the media itself so this value reflects claimed capacity. If this input sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed by management requests; otherwise, the value may be written (by a Remote Control Panel or a Management Application). The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown.
1.3.6.1.2.1.43.8.2.1.9Integer32 (-2..2147483647)read-writecurrent
prtInputCurrentLevel
OBJECT-TYPE
The current capacity of the input sub-unit in input sub-unit capacity units (PrtCapacityUnitTC). If this input sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed by management requests; otherwise, the value may be written (by a Remote Control Panel or a Management Application). The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. The value (-3) means that the printer knows that at least one unit remains.
1.3.6.1.2.1.43.8.2.1.10Integer32 (-3..2147483647)read-writecurrent
prtInputStatus
OBJECT-TYPE
The current status of this input sub-unit.
1.3.6.1.2.1.43.8.2.1.11PrtSubUnitStatusTCread-onlycurrent
prtInputMediaName
OBJECT-TYPE
A description of the media contained in this input sub-unit; This description is to be used by a client to format and Localize a string for display to a human operator. This description is not processed by the printer. It is used to provide information not expressible in terms of the other media attributes (e.g., prtInputMediaDimFeedDirChosen, prtInputMediaDimXFeedDirChosen, prtInputMediaWeight, prtInputMediaType).
1.3.6.1.2.1.43.8.2.1.12OCTET STRING (SIZE(0..63))read-writecurrent
prtInputName
OBJECT-TYPE
The name assigned to this input sub-unit.
1.3.6.1.2.1.43.8.2.1.13OCTET STRING (SIZE(0..63))read-writecurrent
prtInputVendorName
OBJECT-TYPE
The vendor name of this input sub-unit.
1.3.6.1.2.1.43.8.2.1.14OCTET STRING (SIZE(0..63))read-onlycurrent
prtInputModel
OBJECT-TYPE
The model name of this input sub-unit.
1.3.6.1.2.1.43.8.2.1.15OCTET STRING (SIZE(0..63))read-onlycurrent
prtInputVersion
OBJECT-TYPE
The version of this input sub-unit.
1.3.6.1.2.1.43.8.2.1.16OCTET STRING (SIZE(0..63))read-onlycurrent
prtInputSerialNumber
OBJECT-TYPE
The serial number assigned to this input sub-unit.
1.3.6.1.2.1.43.8.2.1.17OCTET STRING (SIZE(0..32))read-onlycurrent
prtInputDescription
OBJECT-TYPE
A free-form text description of this input sub-unit in the localization specified by prtGeneralCurrentLocalization.
1.3.6.1.2.1.43.8.2.1.18PrtLocalizedDescriptionStringTCread-onlycurrent
prtInputSecurity
OBJECT-TYPE
Indicates if this input sub-unit has some security associated with it.
1.3.6.1.2.1.43.8.2.1.19PresentOnOffread-writecurrent
prtInputMediaWeight
OBJECT-TYPE
The weight of the medium associated with this input sub-unit in grams / per meter squared. The value (-2) means unknown.
1.3.6.1.2.1.43.8.2.1.20Integer32 (-2..2147483647)read-writecurrent
prtInputMediaType
OBJECT-TYPE
The name of the type of medium associated with this input sub unit. This name need not be processed by the printer; it might simply be displayed to an operator. NOTE: The above description has been modified from RFC 1759.
1.3.6.1.2.1.43.8.2.1.21OCTET STRING (SIZE(0..63))read-writecurrent
prtInputMediaColor
OBJECT-TYPE
The name of the color of the medium associated with this input sub-unit using standardized string values. NOTE: The above description has been modified from RFC 1759.
1.3.6.1.2.1.43.8.2.1.22OCTET STRING (SIZE(0..63))read-writecurrent
prtInputMediaFormParts
OBJECT-TYPE
The number of parts associated with the medium associated with this input sub-unit if the medium is a multi-part form. The value (-1) means other and specifically indicates that the device places no restrictions on this parameter. The value (-2) means unknown.
1.3.6.1.2.1.43.8.2.1.23Integer32 (-2..2147483647)read-writecurrent
prtInputMediaLoadTimeout
OBJECT-TYPE
When the printer is not able to print due to a subunit being empty or the requested media must be manually loaded, the printer will wait for the duration (in seconds) specified by this object. Upon expiration of the time-out, the printer will take the action specified by prtInputNextIndex. The event which causes the printer to enter the waiting state is product specific. If the printer is not waiting for manually fed media, it may switch from an empty subunit to a different subunit without waiting for the time-out to expire. A value of (-1) implies 'other' or 'infinite' which translates to 'wait forever'. The action which causes printing to continue is product specific. A value of (-2) implies 'unknown'.
1.3.6.1.2.1.43.8.2.1.24Integer32 (-2..2147483647)read-writecurrent
prtInputNextIndex
OBJECT-TYPE
The value of prtInputIndex corresponding to the input subunit which will be used when this input subunit is emptied and the time-out specified by prtInputMediaLoadTimeout expires. A value of zero(0) indicates that auto input switching will not occur when this input subunit is emptied. If the time-out specified by prtInputLoadMediaTimeout expires and this value is zero(0), the job will be aborted. A value of (-1) means other. The value (-2)means 'unknown' and specifically indicates that an implementation specific method will determine the next input subunit to use at the time this subunit is emptied and the time out expires. The value(-3) means input switching is not supported for this subunit.
1.3.6.1.2.1.43.8.2.1.25Integer32 (-3..2147483647)read-writecurrent
prtOutput
OBJECT-IDENTITY
1.3.6.1.2.1.43.9
prtOutputTable
OBJECT-TYPE
A table of the devices capable of receiving media delivered from the printing process.
1.3.6.1.2.1.43.9.2not-accessiblecurrent
prtOutputEntry
OBJECT-TYPE
Attributes of a device capable of receiving media delivered from the printing process. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.9.2.1not-accessiblecurrent
prtOutputIndex
OBJECT-TYPE
A unique value used by this printer to identify this output sub-unit. Although these values may change due to a major reconfiguration of the sub-unit (e.g., the addition of new output devices to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.9.2.1.1Integer32 (1..65535)not-accessiblecurrent
prtOutputType
OBJECT-TYPE
The type of technology supported by this output sub-unit.
1.3.6.1.2.1.43.9.2.1.2PrtOutputTypeTCread-onlycurrent
prtOutputCapacityUnit
OBJECT-TYPE
The unit of measurement for use in calculating and relaying capacity values for this output sub-unit.
1.3.6.1.2.1.43.9.2.1.3PrtCapacityUnitTCread-onlycurrent
prtOutputMaxCapacity
OBJECT-TYPE
The maximum capacity of this output sub-unit in output sub- unit capacity units (PrtCapacityUnitTC). There is no convention associated with the media itself so this value essentially reflects claimed capacity. If this output sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed by management requests; otherwise, the value may be written (by a Remote Control Panel or a Management Application). The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown.
1.3.6.1.2.1.43.9.2.1.4Integer32 (-2..2147483647)read-writecurrent
prtOutputRemainingCapacity
OBJECT-TYPE
The remaining capacity of the possible output sub-unit capacity in output sub-unit capacity units (PrtCapacityUnitTC)of this output sub-unit. If this output sub- unit can reliably sense this value, the value is sensed by the printer and may not be modified by management requests; otherwise, the value may be written (by a Remote Control Panel or a Management Application). The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. The value (-3) means that the printer knows that there remains capacity for at least one unit.
1.3.6.1.2.1.43.9.2.1.5Integer32 (-3..2147483647)read-writecurrent
prtOutputStatus
OBJECT-TYPE
The current status of this output sub-unit.
1.3.6.1.2.1.43.9.2.1.6PrtSubUnitStatusTCread-onlycurrent
prtOutputName
OBJECT-TYPE
The name assigned to this output sub-unit.
1.3.6.1.2.1.43.9.2.1.7OCTET STRING (SIZE(0..63))read-writecurrent
prtOutputVendorName
OBJECT-TYPE
The vendor name of this output sub-unit.
1.3.6.1.2.1.43.9.2.1.8OCTET STRING (SIZE(0..63))read-onlycurrent
prtOutputModel
OBJECT-TYPE
The model name assigned to this output sub-unit. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.9.2.1.9OCTET STRING (SIZE(0..63))read-onlycurrent
prtOutputVersion
OBJECT-TYPE
The version of this output sub-unit.
1.3.6.1.2.1.43.9.2.1.10OCTET STRING (SIZE(0..63))read-onlycurrent
prtOutputSerialNumber
OBJECT-TYPE
The serial number assigned to this output sub-unit.
1.3.6.1.2.1.43.9.2.1.11OCTET STRING (SIZE(0..63))read-onlycurrent
prtOutputDescription
OBJECT-TYPE
A free-form text description of this output sub-unit in the localization specified by prtGeneralCurrentLocalization.
1.3.6.1.2.1.43.9.2.1.12PrtLocalizedDescriptionStringTCread-onlycurrent
prtOutputSecurity
OBJECT-TYPE
Indicates if this output sub-unit has some security associated with it and if that security is enabled or not.
1.3.6.1.2.1.43.9.2.1.13PresentOnOffread-writecurrent
prtOutputDimUnit
OBJECT-TYPE
The unit of measurement for use in calculating and relaying dimensional values for this output sub-unit.
1.3.6.1.2.1.43.9.2.1.14PrtMediaUnitTCread-onlycurrent
prtOutputMaxDimFeedDir
OBJECT-TYPE
The maximum dimensions supported by this output sub-unit for measurements taken parallel relative to the feed direction associated with that sub-unit in output sub-unit dimensional units (controlled by prtOutputDimUnit, which uses PrtMediaUnitTC). If this output sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed with management protocol operations. The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. NOTE: The above description has been modified from RFC 1759 for clarification and to explain the purpose of (-1) and (-2).
1.3.6.1.2.1.43.9.2.1.15Integer32 (-2..2147483647)read-writecurrent
prtOutputMaxDimXFeedDir
OBJECT-TYPE
The maximum dimensions supported by this output sub-unit for measurements taken ninety degrees relative to the feed direction associated with that sub-unit in output sub-unit dimensional units (controlled by prtOutputDimUnit, which uses PrtMediaUnitTC). If this output sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed with management protocol operations. The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. NOTE: The above description has been modified from RFC 1759 for clarification and to explain the purpose of (-1) and (-2).
1.3.6.1.2.1.43.9.2.1.16Integer32 (-2..2147483647)read-writecurrent
prtOutputMinDimFeedDir
OBJECT-TYPE
The minimum dimensions supported by this output sub-unit for measurements taken parallel relative to the feed direction associated with that sub-unit in output sub-unit dimensional units (controlled by prtOutputDimUnit, which uses PrtMediaUnitTC). If this output sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed with management protocol operations. The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. NOTE: The above description has been modified from RFC 1759 for clarification and to explain the purpose of (-1) and (-2).
1.3.6.1.2.1.43.9.2.1.17Integer32 (-2..2147483647)read-writecurrent
prtOutputMinDimXFeedDir
OBJECT-TYPE
The minimum dimensions supported by this output sub-unit for measurements taken ninety degrees relative to the feed direction associated with that sub-unit in output sub-unit dimensional units (controlled by prtOutputDimUnit, which uses PrtMediaUnitTC). If this output sub-unit can reliably sense this value, the value is sensed by the printer and may not be changed with management protocol operations. The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. NOTE: The above description has been modified from RFC 1759 for clarification and to explain the purpose of (-1) and (-2).
1.3.6.1.2.1.43.9.2.1.18Integer32 (-2..2147483647)read-writecurrent
prtOutputStackingOrder
OBJECT-TYPE
The current state of the stacking order for the associated output sub-unit. 'FirstToLast' means that as pages are output the front of the next page is placed against the back of the previous page. 'LasttoFirst' means that as pages are output the back of the next page is placed against the front of the previous page.
1.3.6.1.2.1.43.9.2.1.19PrtOutputStackingOrderTCread-writecurrent
prtOutputPageDeliveryOrientation
OBJECT-TYPE
The reading surface that will be 'up' when pages are delivered to the associated output sub-unit. Values are faceUp and faceDown. (Note: interpretation of these values is in general context-dependent based on locale; presentation of these values to an end-user should be normalized to the expectations of the user).
1.3.6.1.2.1.43.9.2.1.20PrtOutputPageDeliveryOrientationTCread-writecurrent
prtOutputBursting
OBJECT-TYPE
This object indicates that the outputting sub-unit supports bursting, and if so, whether the feature is enabled. Bursting is the process by which continuous media is separated into individual sheets, typically by bursting along pre-formed perforations.
1.3.6.1.2.1.43.9.2.1.21PresentOnOffread-writecurrent
prtOutputDecollating
OBJECT-TYPE
This object indicates that the output supports decollating, and if so, whether the feature is enabled. Decollating is the process by which the individual parts within a multi-part form are separated and sorted into separate stacks for each part.
1.3.6.1.2.1.43.9.2.1.22PresentOnOffread-writecurrent
prtOutputPageCollated
OBJECT-TYPE
This object indicates that the output sub-unit supports page collation, and if so, whether the feature is enabled. See RFC 3805 Appendix A, Glossary Of Terms, for definition of how this document defines collation. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.9.2.1.23PresentOnOffread-writecurrent
prtOutputOffsetStacking
OBJECT-TYPE
This object indicates that the output supports offset stacking,and if so, whether the feature is enabled. See RFC 3805 Appendix A, Glossary Of Terms, for how Offset Stacking is defined by this document. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.9.2.1.24PresentOnOffread-writecurrent
prtMarker
OBJECT-IDENTITY
1.3.6.1.2.1.43.10
prtMarkerTable
OBJECT-TYPE
The marker table provides a description of each marker sub-unit contained within the printer. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2not-accessiblecurrent
prtMarkerEntry
OBJECT-TYPE
Entries in this table define the characteristics and status of each marker sub-unit in the printer. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1not-accessiblecurrent
prtMarkerIndex
OBJECT-TYPE
A unique value used by the printer to identify this marking SubUnit. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new marking sub-units to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1.1Integer32 (1..65535)not-accessiblecurrent
prtMarkerMarkTech
OBJECT-TYPE
The type of marking technology used for this marking sub-unit.
1.3.6.1.2.1.43.10.2.1.2PrtMarkerMarkTechTCread-onlycurrent
prtMarkerCounterUnit
OBJECT-TYPE
The unit that will be used by the printer when reporting counter values for this marking sub-unit. The time units of measure are provided for a device like a strip recorder that does not or cannot track the physical dimensions of the media and does not use characters, lines or sheets.
1.3.6.1.2.1.43.10.2.1.3PrtMarkerCounterUnitTCread-onlycurrent
prtMarkerLifeCount
OBJECT-TYPE
The count of the number of units of measure counted during the life of printer using units of measure as specified by prtMarkerCounterUnit. Note: This object should be implemented as a persistent object with a reliable value throughout the lifetime of the printer.
1.3.6.1.2.1.43.10.2.1.4Counter32read-onlycurrent
prtMarkerPowerOnCount
OBJECT-TYPE
The count of the number of units of measure counted since the equipment was most recently powered on using units of measure as specified by prtMarkerCounterUnit.
1.3.6.1.2.1.43.10.2.1.5Counter32read-onlycurrent
prtMarkerProcessColorants
OBJECT-TYPE
The number of process colors supported by this marker. A process color of 1 implies monochrome. The value of this object and prtMarkerSpotColorants cannot both be 0. The value of prtMarkerProcessColorants must be 0 or greater. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1.6Integer32 (0..65535)read-onlycurrent
prtMarkerSpotColorants
OBJECT-TYPE
The number of spot colors supported by this marker. The value of this object and prtMarkerProcessColorants cannot both be 0. Must be 0 or greater. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1.7Integer32 (0..65535)read-onlycurrent
prtMarkerAddressabilityUnit
OBJECT-TYPE
The unit of measure of distances, as applied to the marker's resolution. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1.8PrtMarkerAddressabilityUnitTCread-onlycurrent
prtMarkerAddressabilityFeedDir
OBJECT-TYPE
The maximum number of addressable marking positions in the feed direction per 10000 units of measure specified by prtMarkerAddressabilityUnit. A value of (-1) implies 'other' or 'infinite' while a value of (-2) implies 'unknown'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1.9Integer32 (-2..2147483647)read-onlycurrent
prtMarkerAddressabilityXFeedDir
OBJECT-TYPE
The maximum number of addressable marking positions in the cross feed direction in 10000 units of measure specified by prtMarkerAddressabilityUnit. A value of (-1) implies 'other' or 'infinite' while a value of (-2) implies 'unknown'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.10.2.1.10Integer32 (-2..2147483647)read-onlycurrent
prtMarkerNorthMargin
OBJECT-TYPE
The margin, in units identified by prtMarkerAddressabilityUnit, from the leading edge of the medium as the medium flows through the marking engine with the side to be imaged facing the observer. The leading edge is the North edge and the other edges are defined by the normal compass layout of directions with the compass facing the observer. Printing within the area bounded by all four margins is guaranteed for all interpreters. The value (-2) means unknown.
1.3.6.1.2.1.43.10.2.1.11Integer32 (-2..2147483647)read-onlycurrent
prtMarkerSouthMargin
OBJECT-TYPE
The margin from the South edge (see prtMarkerNorthMargin) of the medium in units identified by prtMarkerAddressabilityUnit. Printing within the area bounded by all four margins is guaranteed for all interpreters. The value (-2) means unknown.
1.3.6.1.2.1.43.10.2.1.12Integer32 (-2..2147483647)read-onlycurrent
prtMarkerWestMargin
OBJECT-TYPE
The margin from the West edge (see prtMarkerNorthMargin) of the medium in units identified by prtMarkerAddressabilityUnit. Printing within the area bounded by all four margins is guaranteed for all interpreters. The value (-2) means unknown.
1.3.6.1.2.1.43.10.2.1.13Integer32 (-2..2147483647)read-onlycurrent
prtMarkerEastMargin
OBJECT-TYPE
The margin from the East edge (see prtMarkerNorthMargin) of the medium in units identified by prtMarkerAddressabilityUnit. Printing within the area bounded by all four margins is guaranteed for all interpreters. The value (-2) means unknown.
1.3.6.1.2.1.43.10.2.1.14Integer32 (-2..2147483647)read-onlycurrent
prtMarkerStatus
OBJECT-TYPE
The current status of this marker sub-unit.
1.3.6.1.2.1.43.10.2.1.15PrtSubUnitStatusTCread-onlycurrent
prtMarkerSupplies
OBJECT-IDENTITY
1.3.6.1.2.1.43.11
prtMarkerSuppliesTable
OBJECT-TYPE
A table of the marker supplies available on this printer.
1.3.6.1.2.1.43.11.1not-accessiblecurrent
prtMarkerSuppliesEntry
OBJECT-TYPE
Attributes of a marker supply. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.11.1.1not-accessiblecurrent
prtMarkerSuppliesIndex
OBJECT-TYPE
A unique value used by the printer to identify this marker supply. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new marker supplies to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.11.1.1.1Integer32 (1..65535)not-accessiblecurrent
prtMarkerSuppliesMarkerIndex
OBJECT-TYPE
The value of prtMarkerIndex corresponding to the marking sub unit with which this marker supply sub-unit is associated.
1.3.6.1.2.1.43.11.1.1.2Integer32 (0..65535)read-onlycurrent
prtMarkerSuppliesColorantIndex
OBJECT-TYPE
The value of prtMarkerColorantIndex corresponding to the colorant with which this marker supply sub-unit is associated. This value shall be 0 if there is no colorant table or if this supply does not depend on a single specified colorant. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.11.1.1.3Integer32 (0..65535)read-onlycurrent
prtMarkerSuppliesClass
OBJECT-TYPE
Indicates whether this supply entity represents a supply that is consumed or a receptacle that is filled. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.11.1.1.4PrtMarkerSuppliesClassTCread-onlycurrent
prtMarkerSuppliesType
OBJECT-TYPE
The type of this supply.
1.3.6.1.2.1.43.11.1.1.5PrtMarkerSuppliesTypeTCread-onlycurrent
prtMarkerSuppliesDescription
OBJECT-TYPE
The description of this supply container/receptacle in the localization specified by prtGeneralCurrentLocalization.
1.3.6.1.2.1.43.11.1.1.6PrtLocalizedDescriptionStringTCread-onlycurrent
prtMarkerSuppliesSupplyUnit
OBJECT-TYPE
Unit of measure of this marker supply container/receptacle. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.11.1.1.7PrtMarkerSuppliesSupplyUnitTCread-onlycurrent
prtMarkerSuppliesMaxCapacity
OBJECT-TYPE
The maximum capacity of this supply container/receptacle expressed in prtMarkerSuppliesSupplyUnit. If this supply container/receptacle can reliably sense this value, the value is reported by the printer and is read-only; otherwise, the value may be written (by a Remote Control Panel or a Management Application). The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown.
1.3.6.1.2.1.43.11.1.1.8Integer32 (-2..2147483647)read-writecurrent
prtMarkerSuppliesLevel
OBJECT-TYPE
The current level if this supply is a container; the remaining space if this supply is a receptacle. If this supply container/receptacle can reliably sense this value, the value is reported by the printer and is read-only; otherwise, the value may be written (by a Remote Control Panel or a Management Application). The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. A value of (-3) means that the printer knows that there is some supply/remaining space, respectively.
1.3.6.1.2.1.43.11.1.1.9Integer32 (-3..2147483647)read-writecurrent
prtMarkerColorant
OBJECT-IDENTITY
1.3.6.1.2.1.43.12
prtMarkerColorantTable
OBJECT-TYPE
A table of all of the colorants available on the printer.
1.3.6.1.2.1.43.12.1not-accessiblecurrent
prtMarkerColorantEntry
OBJECT-TYPE
Attributes of a colorant available on the printer. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.12.1.1not-accessiblecurrent
prtMarkerColorantIndex
OBJECT-TYPE
A unique value used by the printer to identify this colorant. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new colorants to the printer) , values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.12.1.1.1Integer32 (1..65535)not-accessiblecurrent
prtMarkerColorantMarkerIndex
OBJECT-TYPE
The value of prtMarkerIndex corresponding to the marker sub unit with which this colorant entry is associated.
1.3.6.1.2.1.43.12.1.1.2Integer32 (0..65535)read-onlycurrent
prtMarkerColorantRole
OBJECT-TYPE
The role played by this colorant.
1.3.6.1.2.1.43.12.1.1.3PrtMarkerColorantRoleTCread-onlycurrent
prtMarkerColorantValue
OBJECT-TYPE
The name of the color of this colorant using standardized string names from ISO 10175 (DPA) and ISO 10180 (SPDL) such as: other unknown white red green blue cyan magenta yellow black Implementers may add additional string values. The naming conventions in ISO 9070 are recommended in order to avoid potential name clashes
1.3.6.1.2.1.43.12.1.1.4OCTET STRING (SIZE(0..255))read-onlycurrent
prtMarkerColorantTonality
OBJECT-TYPE
The distinct levels of tonality realizable by a marking sub unit when using this colorant. This value does not include the number of levels of tonal difference that an interpreter can obtain by techniques such as half toning. This value must be at least 2.
1.3.6.1.2.1.43.12.1.1.5Integer32 (2..2147483647)read-onlycurrent
prtMediaPath
OBJECT-IDENTITY
1.3.6.1.2.1.43.13
prtMediaPathTable
OBJECT-TYPE
The media path table includes both physical and logical paths within the printer. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4not-accessiblecurrent
prtMediaPathEntry
OBJECT-TYPE
Entries may exist in the table for each device index with a device type of 'printer' Each entry defines the physical characteristics of and the status of the media path. The data provided indicates the maximum throughput and the media size limitations of these subunits. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4.1not-accessiblecurrent
prtMediaPathIndex
OBJECT-TYPE
A unique value used by the printer to identify this media path. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new media paths to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4.1.1Integer32 (1..65535)not-accessiblecurrent
prtMediaPathMaxSpeedPrintUnit
OBJECT-TYPE
The unit of measure used in specifying the speed of all media paths in the printer.
1.3.6.1.2.1.43.13.4.1.2PrtMediaPathMaxSpeedPrintUnitTCread-onlycurrent
prtMediaPathMediaSizeUnit
OBJECT-TYPE
The units of measure of media size for use in calculating and relaying dimensional values for all media paths in the printer.
1.3.6.1.2.1.43.13.4.1.3PrtMediaUnitTCread-onlycurrent
prtMediaPathMaxSpeed
OBJECT-TYPE
The maximum printing speed of this media path expressed in prtMediaPathMaxSpeedUnit's. A value of (-1) implies 'other'.
1.3.6.1.2.1.43.13.4.1.4Integer32 (-2..2147483647)read-onlycurrent
prtMediaPathMaxMediaFeedDir
OBJECT-TYPE
The maximum physical media size in the feed direction of this media path expressed in units of measure specified by PrtMediaPathMediaSizeUnit. A value of (-1) implies 'unlimited' a value of (-2) implies 'unknown'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4.1.5Integer32 (-2..2147483647)read-onlycurrent
prtMediaPathMaxMediaXFeedDir
OBJECT-TYPE
The maximum physical media size across the feed direction of this media path expressed in units of measure specified by prtMediaPathMediaSizeUnit. A value of (-2) implies 'unknown'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4.1.6Integer32 (-2..2147483647)read-onlycurrent
prtMediaPathMinMediaFeedDir
OBJECT-TYPE
The minimum physical media size in the feed direction of this media path expressed in units of measure specified by prtMediaPathMediaSizeUnit. A value of (-2) implies 'unknown'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4.1.7Integer32 (-2..2147483647)read-onlycurrent
prtMediaPathMinMediaXFeedDir
OBJECT-TYPE
The minimum physical media size across the feed direction of this media path expressed in units of measure specified by prtMediaPathMediaSizeUnit. A value of (-2) implies 'unknown'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.13.4.1.8Integer32 (-2..2147483647)read-onlycurrent
prtMediaPathType
OBJECT-TYPE
The type of the media path for this media path.
1.3.6.1.2.1.43.13.4.1.9PrtMediaPathTypeTCread-onlycurrent
prtMediaPathDescription
OBJECT-TYPE
The manufacturer-provided description of this media path in the localization specified by prtGeneralCurrentLocalization.
1.3.6.1.2.1.43.13.4.1.10PrtLocalizedDescriptionStringTCread-onlycurrent
prtMediaPathStatus
OBJECT-TYPE
The current status of this media path.
1.3.6.1.2.1.43.13.4.1.11PrtSubUnitStatusTCread-onlycurrent
prtChannel
OBJECT-IDENTITY
1.3.6.1.2.1.43.14
prtChannelTable
OBJECT-TYPE
The channel table represents the set of input data sources which can provide print data to one or more of the interpreters available on a printer. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.14.1not-accessiblecurrent
prtChannelEntry
OBJECT-TYPE
Entries may exist in the table for each device index with a device type of 'printer'. Each channel table entry is characterized by a unique protocol stack and/or addressing. The channel may also have printer dependent features that are associated with a printing language. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.14.1.1not-accessiblecurrent
prtChannelIndex
OBJECT-TYPE
A unique value used by the printer to identify this data channel. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new data channels to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.14.1.1.1Integer32 (1..65535)not-accessiblecurrent
prtChannelType
OBJECT-TYPE
The type of this print data channel. This object provides the linkage to ChannelType-specific groups that may (conceptually) extend the prtChannelTable with additional details about that channel.
1.3.6.1.2.1.43.14.1.1.2PrtChannelTypeTCread-onlycurrent
prtChannelProtocolVersion
OBJECT-TYPE
The version of the protocol used on this channel. The format used for version numbering depends on prtChannelType.
1.3.6.1.2.1.43.14.1.1.3OCTET STRING (SIZE(0..63))read-onlycurrent
prtChannelCurrentJobCntlLangIndex
OBJECT-TYPE
The value of prtInterpreterIndex corresponding to the Control Language Interpreter for this channel. This interpreter defines the syntax used for control functions, such as querying or changing environment variables and identifying job boundaries (e.g., PJL, PostScript, NPAP). A value of zero indicates that there is no current Job Control Language Interpreter for this channel. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.14.1.1.4Integer32 (0..65535)read-writecurrent
prtChannelDefaultPageDescLangIndex
OBJECT-TYPE
The value of prtInterpreterIndex corresponding to the Page Description Language Interpreter for this channel. This interpreter defines the default Page Description Language interpreter to be used for the print data unless the Control Language is used to select a specific interpreter (e.g., PCL, PostScript Language, auto-sense). A value of zero indicates that there is no default page description language interpreter for this channel. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.14.1.1.5Integer32 (0..65535)read-writecurrent
prtChannelState
OBJECT-TYPE
The state of this print data channel. The value determines whether control information and print data is allowed through this channel or not.
1.3.6.1.2.1.43.14.1.1.6PrtChannelStateTCread-writecurrent
prtChannelIfIndex
OBJECT-TYPE
The value of ifIndex in the ifTable; see the Interfaces Group MIB [RFC2863] which corresponds to this channel. When more than one row of the ifTable is relevant, this is the index of the row representing the topmost layer in the interface hierarchy. A value of zero indicates that no interface is associated with this channel. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.14.1.1.7InterfaceIndexOrZeroread-writecurrent
prtChannelStatus
OBJECT-TYPE
The current status of the channel.
1.3.6.1.2.1.43.14.1.1.8PrtSubUnitStatusTCread-onlycurrent
prtChannelInformation
OBJECT-TYPE
Auxiliary information to allow a printing application to use the channel for data submission to the printer. An application capable of using a specific PrtChannelType should be able to use the combined information from the prtChannelInformation and other channel and interface group objects to 'bootstrap' its use of the channel. prtChannelInformation is not intended to provide a general channel description, nor to provide information that is available once the channel is in use. The encoding and interpretation of the prtChannelInformation object is specific to channel type. The description of each PrtChannelType enum value for which prtChannelInformation is defined specifies the appropriate encoding and interpretation, including interaction with other objects. For channel types that do not specify a prtChannelInformation value, its value shall be null (0 length). When a new PrtChannelType enumeration value is registered, its accompanying description must specify the encoding and interpretation of the prtChannelInformation value for the channel type. prtChannelInformation semantics for an existing PrtChannelType may be added or amended in the same manner as described in section 2.4.1 for type 2 enumeration values. The prtChannelInformation specifies values for a collection of channel attributes, represented as text according to the following rules: 1. The prtChannelInformation is not affected by localization. 2. The prtChannelInformation is a list of entries representing the attribute values. Each entry consists of the following items, in order: a. A keyword, composed of alphabetic characters (A-Z, a-z) represented by their NVT ASCII [RFC854] codes, that identifies a channel attribute, b. The NVT ASCII code for an Equals Sign (=) (code 61) to delimit the keyword, c. A data value encoded using rules specific to the PrtChannelType to with the prtChannelInformation applies which must in no case allow an octet with value 10 (the NVT ASCII Line Feed code), d. the NVT ASCII code for a Line Feed character (code 10) to delimit the data value. No other octets shall be present. Keywords are case-sensitive. Conventionally, keywords are capitalized (including each word of a multi-word keyword) and since they occupy space in the prtChannelInformation, they are kept short. 3. If a channel attribute has multiple values, it is represented by multiple entries with the same keyword, each specifying one value. Otherwise, there shall be at most one entry for each attribute. 4. By default, entries may appear in any order. If there are ordering constraints for particular entries, these must be specified in their definitions. 5. The prtChannelInformation value by default consists of text represented by NVT ASCII graphics character codes. However, other representations may be specified: a. In cases where the prtChannelInformation value contains information not normally coded in textual form, whatever symbolic representation is conventionally used for the information should be used for encoding the prtChannelInformation value. (For instance, a binary port value might be represented as a decimal number using NVT ASCII codes.) Such encoding must be specified in the definition of the value. b. The value may contain textual information in a character set other than NVT ASCII graphics characters. (For instance, an identifier might consist of ISO 10646 text encoded using the UTF-8 encoding scheme.) Such a character set and its encoding must be specified in the definition of the value. 6. For each PrtChannelType for which prtChannelInformation entries are defined, the descriptive text associated with the PrtChannelType enumeration value shall specify the following information for each entry: Title: Brief description phrase, e.g.: 'Port name', 'Service Name', etc. Keyword: The keyword value, e.g.: 'Port' or 'Service' Syntax: The encoding of the entry value if it cannot be directly represented by NVT ASCII. Status: 'Mandatory', 'Optional', or 'Conditionally Mandatory' Multiplicity: 'Single' or 'Multiple' to indicate whether the entry may be present multiple times. Description: Description of the use of the entry, other information required to complete the definition (e.g.: ordering constraints, interactions between entries). Applications that interpret prtChannelInformation should ignore unrecognized entries, so they are not affected if new entry types are added.
1.3.6.1.2.1.43.14.1.1.9OCTET STRING (SIZE(0..255))read-onlycurrent
prtInterpreter
OBJECT-IDENTITY
1.3.6.1.2.1.43.15
prtInterpreterTable
OBJECT-TYPE
The interpreter table is a table representing the interpreters in the printer. An entry shall be placed in the interpreter table for each interpreter on the printer. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.15.1not-accessiblecurrent
prtInterpreterEntry
OBJECT-TYPE
Entries may exist in the table for each device index with a device type of 'printer'. Each table entry provides a complete description of the interpreter, including version information, rendering resolutions, default character sets, output orientation, and communication capabilities. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.15.1.1not-accessiblecurrent
prtInterpreterIndex
OBJECT-TYPE
A unique value for each PDL or control language for which there exists an interpreter or emulator in the printer. The value is used to identify this interpreter. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new interpreters to the printer), values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.15.1.1.1Integer32 (1..65535)not-accessiblecurrent
prtInterpreterLangFamily
OBJECT-TYPE
The family name of a Page Description Language (PDL) or control language which this interpreter in the printer can interpret or emulate. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.15.1.1.2PrtInterpreterLangFamilyTCread-onlycurrent
prtInterpreterLangLevel
OBJECT-TYPE
The level of the language which this interpreter is interpreting or emulating. This might contain a value like '5e'for an interpreter which is emulating level 5e of the PCL language. It might contain '2' for an interpreter which is emulating level 2 of the PostScript language. Similarly it might contain '2' for an interpreter which is emulating level 2 of the HPGL language.
1.3.6.1.2.1.43.15.1.1.3OCTET STRING (SIZE(0..31))read-onlycurrent
prtInterpreterLangVersion
OBJECT-TYPE
The date code or version of the language which this interpreter is interpreting or emulating.
1.3.6.1.2.1.43.15.1.1.4OCTET STRING (SIZE(0..31))read-onlycurrent
prtInterpreterDescription
OBJECT-TYPE
A string to identify this interpreter in the localization specified by prtGeneralCurrentLocalization as opposed to the language which is being interpreted. It is anticipated that this string will allow manufacturers to unambiguously identify their interpreters.
1.3.6.1.2.1.43.15.1.1.5PrtLocalizedDescriptionStringTCread-onlycurrent
prtInterpreterVersion
OBJECT-TYPE
The date code, version number, or other product specific information tied to this interpreter. This value is associated with the interpreter, rather than with the version of the language which is being interpreted or emulated.
1.3.6.1.2.1.43.15.1.1.6OCTET STRING (SIZE(0..31))read-onlycurrent
prtInterpreterDefaultOrientation
OBJECT-TYPE
The current orientation default for this interpreter. This value may be overridden for a particular job (e.g., by a command in the input data stream).
1.3.6.1.2.1.43.15.1.1.7PrtPrintOrientationTCread-writecurrent
prtInterpreterFeedAddressability
OBJECT-TYPE
The maximum interpreter addressability in the feed direction in 10000 prtMarkerAddressabilityUnits (as specified by prtMarkerDefaultIndex) for this interpreter. The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.15.1.1.8Integer32 (-2..2147483647)read-onlycurrent
prtInterpreterXFeedAddressability
OBJECT-TYPE
The maximum interpreter addressability in the cross feed direction in 10000 prtMarkerAddressabilityUnits (as specified by prtMarkerDefaultIndex) for this interpreter. The value (-1) means other and specifically indicates that the sub-unit places no restrictions on this parameter. The value (-2) means unknown. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.15.1.1.9Integer32 (-2..2147483647)read-onlycurrent
prtInterpreterDefaultCharSetIn
OBJECT-TYPE
The default coded character set for input octets encountered outside a context in which the Page Description Language established the interpretation of the octets. (Input octets are presented to the interpreter through a path defined in the channel group.)
1.3.6.1.2.1.43.15.1.1.10IANACharsetread-writecurrent
prtInterpreterDefaultCharSetOut
OBJECT-TYPE
The default character set for data coming from this interpreter through the printer's output channel (i.e. the 'backchannel').
1.3.6.1.2.1.43.15.1.1.11IANACharsetread-writecurrent
prtInterpreterTwoWay
OBJECT-TYPE
Indicates whether or not this interpreter returns information back to the host.
1.3.6.1.2.1.43.15.1.1.12PrtInterpreterTwoWayTCread-onlycurrent
prtConsoleDisplayBuffer
OBJECT-IDENTITY
1.3.6.1.2.1.43.16
prtConsoleDisplayBufferTable
OBJECT-TYPE
Physical display buffer for printer console display or operator panel NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.16.5not-accessiblecurrent
prtConsoleDisplayBufferEntry
OBJECT-TYPE
This table contains one entry for each physical line on the display. Lines cannot be added or deleted. Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.16.5.1not-accessiblecurrent
prtConsoleDisplayBufferIndex
OBJECT-TYPE
A unique value for each console line in the printer. The value is used to identify this console line. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new console lines to the printer). Values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.16.5.1.1Integer32 (1..65535)not-accessiblecurrent
prtConsoleDisplayBufferText
OBJECT-TYPE
The content of a line in the logical display buffer of the operator's console of the printer. When a write operation occurs, normally a critical message, to one of the LineText strings, the agent should make that line displayable if a physical display is present. Writing a zero length string clears the line. It is an implementation- specific matter as to whether the agent allows a line to be overwritten before it has been cleared. Printer generated strings shall be in the localization specified by prtConsoleLocalization.Management Application generated strings should be localized by the Management Application.
1.3.6.1.2.1.43.16.5.1.2PrtConsoleDescriptionStringTCread-writecurrent
prtConsoleLights
OBJECT-IDENTITY
1.3.6.1.2.1.43.17
prtConsoleLightTable
OBJECT-TYPE
The console light table provides a description and state information for each light present on the printer console. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.17.6not-accessiblecurrent
prtConsoleLightEntry
OBJECT-TYPE
Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.17.6.1not-accessiblecurrent
prtConsoleLightIndex
OBJECT-TYPE
A unique value used by the printer to identify this light. Although these values may change due to a major reconfiguration of the device (e.g., the addition of new lights to the printer). Values SHOULD remain stable across successive printer power cycles. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.17.6.1.1Integer32 (1..65535)not-accessiblecurrent
prtConsoleOnTime
OBJECT-TYPE
This object, in conjunction with prtConsoleOffTime, defines the current status of the light. If both prtConsoleOnTime and prtConsoleOffTime are non-zero, the lamp is blinking and the values presented define the on time and off time, respectively, in milliseconds. If prtConsoleOnTime is zero and prtConsoleOffTime is non-zero, the lamp is off. If prtConsoleOffTime is zero and prtConsoleOnTime is non-zero, the lamp is on. If both values are zero the lamp is off. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.17.6.1.2Integer32 (0..2147483647)read-writecurrent
prtConsoleOffTime
OBJECT-TYPE
This object, in conjunction with prtConsoleOnTime, defines the current status of the light. If both prtConsoleOnTime and prtConsoleOffTime are non-zero, the lamp is blinking and the values presented define the on time and off time, respectively, in milliseconds. If prtConsoleOnTime is zero and prtConsoleOffTime is non-zero, the lamp is off. If prtConsoleOffTime is zero and prtConsoleOnTime is non-zero, the lamp is on. If both values are zero the lamp is off. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.17.6.1.3Integer32 (0..2147483647)read-writecurrent
prtConsoleColor
OBJECT-TYPE
The color of this light.
1.3.6.1.2.1.43.17.6.1.4PrtConsoleColorTCread-onlycurrent
prtConsoleDescription
OBJECT-TYPE
The vendor description or label of this light in the localization specified by prtConsoleLocalization.
1.3.6.1.2.1.43.17.6.1.5PrtConsoleDescriptionStringTCread-onlycurrent
prtAlert
OBJECT-IDENTITY
1.3.6.1.2.1.43.18
prtAlertTable
OBJECT-TYPE
The prtAlertTable lists all the critical and non-critical alerts currently active in the printer. A critical alert is one that stops the printer from printing immediately and printing can not continue until the critical alert condition is eliminated. Non-critical alerts are those items that do not stop printing but may at some future time. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1not-accessiblecurrent
prtAlertEntry
OBJECT-TYPE
Entries may exist in the table for each device index with a device type of 'printer'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1.1not-accessiblecurrent
prtAlertIndex
OBJECT-TYPE
The index value used to determine which alerts have been added or removed from the alert table. This is an incrementing integer initialized to 1 when the printer is reset. (i.e., The first event placed in the alert table after a reset of the printer shall have an index value of 1.) When the printer adds an alert to the table, that alert is assigned the next higher integer value from the last item entered into the table. If the index value reaches its maximum value, the next index value used must be 1. NOTE: The management application will read the alert table when a trap or event notification occurs or at a periodic rate and then parse the table to determine if any new entries were added by comparing the last known index value with the current highest index value. The management application will then update its copy of the alert table. When the printer discovers that an alert is no longer active, the printer shall remove the row for that alert from the table and shall reduce the number of rows in the table. The printer may add or delete any number of rows from the table at any time. The management station can detect when binary change alerts have been deleted by requesting an attribute of each alert, and noting alerts as deleted when that retrieval is not possible. The objects 'prtAlertCriticalEvents'and 'prtAlertAllEvents' in the 'prtGeneralTable' reduce the need for management applications to scan the 'prtAlertTable'. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1.1.1Integer32 (1..2147483647)read-onlycurrent
prtAlertSeverityLevel
OBJECT-TYPE
The level of severity of this alert table entry. The printer determines the severity level assigned to each entry into the table.
1.3.6.1.2.1.43.18.1.1.2PrtAlertSeverityLevelTCread-onlycurrent
prtAlertTrainingLevel
OBJECT-TYPE
See TEXTUAL-CONVENTION PrtAlertTrainingLevelTC. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1.1.3PrtAlertTrainingLevelTCread-onlycurrent
prtAlertGroup
OBJECT-TYPE
The type of sub-unit within the printer model that this alert is related. Input, output, and markers are examples of printer model groups, i.e., examples of types of sub-units. Wherever possible, these enumerations match the sub-identifier that identifies the relevant table in the printmib.
1.3.6.1.2.1.43.18.1.1.4PrtAlertGroupTCread-onlycurrent
prtAlertGroupIndex
OBJECT-TYPE
The low-order index of the row within the table identified by prtAlertGroup that represents the sub-unit of the printer that caused this alert, or -1 if not applicable. The combination of the prtAlertGroup and the prtAlertGroupIndex defines exactly which printer sub-unit caused the alert; for example, Input #3, Output#2, and Marker #1. Every object in this MIB is indexed with hrDeviceIndex and optionally, another index variable. If this other index variable is present in the table that generated the alert, it will be used as the value for this object. Otherwise, this value shall be -1. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1.1.5Integer32 (-1..2147483647)read-onlycurrent
prtAlertLocation
OBJECT-TYPE
The sub-unit location that is defined by the printer manufacturer to further refine the location of this alert within the designated sub-unit. The location is used in conjunction with the Group and GroupIndex values; for example, there is an alert in Input #2 at location number 7. The value (-2) indicates unknown. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1.1.6Integer32 (-2..2147483647)read-onlycurrent
prtAlertCode
OBJECT-TYPE
See associated TEXTUAL-CONVENTION PrtAlertCodeTC. NOTE: The above description has been modified from RFC 1759 for clarification.
1.3.6.1.2.1.43.18.1.1.7PrtAlertCodeTCread-onlycurrent
prtAlertDescription
OBJECT-TYPE
A description of this alert entry in the localization specified by prtGeneralCurrentLocalization. The description is provided by the printer to further elaborate on the enumerated alert or provide information in the case where the code is classified as 'other' or 'unknown'. The printer is required to return a description string but the string may be a null string.
1.3.6.1.2.1.43.18.1.1.8PrtLocalizedDescriptionStringTCread-onlycurrent
prtAlertTime
OBJECT-TYPE
The value of sysUpTime at the time that this alert was generated.
1.3.6.1.2.1.43.18.1.1.9TimeTicksread-onlycurrent
printerV1Alert
OBJECT-IDENTITY
The value of the enterprise-specific OID in an SNMPv1 trap sent signaling a critical event in the prtAlertTable.
1.3.6.1.2.1.43.18.2current
printerV2AlertPrefix
OBJECT-IDENTITY
1.3.6.1.2.1.43.18.2.0

Notifications

NameOIDStatus
printerV2Alert
NOTIFICATION-TYPE
This trap is sent whenever a critical event is added to the prtAlertTable. NOTE: The prtAlertIndex object was redundantly included in the bindings of the 'printerV2Alert' notification in RFC 1759, even though the value exists in the instance qualifier of all the other bindings. This object has been retained to provide compatiblity with existing RFC 1759 implementaions.
1.3.6.1.2.1.43.18.2.0.1current

Conformance

NameOIDStatus
prtMIBCompliance
MODULE-COMPLIANCE
The compliance statement for agents that implement the printer MIB as defined by RFC 1759.
1.3.6.1.2.1.43.2.1current
prtGeneralGroup
OBJECT-GROUP
The general printer group.
1.3.6.1.2.1.43.2.2.1current
prtResponsiblePartyGroup
OBJECT-GROUP
The responsible party group contains contact information for humans responsible for the printer.
1.3.6.1.2.1.43.2.2.2current
prtInputGroup
OBJECT-GROUP
The input group.
1.3.6.1.2.1.43.2.2.3current
prtExtendedInputGroup
OBJECT-GROUP
The extended input group.
1.3.6.1.2.1.43.2.2.4current
prtInputMediaGroup
OBJECT-GROUP
The input media group.
1.3.6.1.2.1.43.2.2.5current
prtOutputGroup
OBJECT-GROUP
The output group.
1.3.6.1.2.1.43.2.2.6current
prtExtendedOutputGroup
OBJECT-GROUP
The extended output group.
1.3.6.1.2.1.43.2.2.7current
prtOutputDimensionsGroup
OBJECT-GROUP
The output dimensions group
1.3.6.1.2.1.43.2.2.8current
prtOutputFeaturesGroup
OBJECT-GROUP
The output features group.
1.3.6.1.2.1.43.2.2.9current
prtMarkerGroup
OBJECT-GROUP
The marker group.
1.3.6.1.2.1.43.2.2.10current
prtMarkerSuppliesGroup
OBJECT-GROUP
The marker supplies group.
1.3.6.1.2.1.43.2.2.11current
prtMarkerColorantGroup
OBJECT-GROUP
The marker colorant group.
1.3.6.1.2.1.43.2.2.12current
prtMediaPathGroup
OBJECT-GROUP
The media path group.
1.3.6.1.2.1.43.2.2.13current
prtChannelGroup
OBJECT-GROUP
The channel group.
1.3.6.1.2.1.43.2.2.14current
prtInterpreterGroup
OBJECT-GROUP
The interpreter group.
1.3.6.1.2.1.43.2.2.15current
prtConsoleGroup
OBJECT-GROUP
The console group.
1.3.6.1.2.1.43.2.2.16current
prtAlertTableGroup
OBJECT-GROUP
The alert table group.
1.3.6.1.2.1.43.2.2.17current
prtAlertTimeGroup
OBJECT-GROUP
The alert time group. Implementation of prtAlertTime is strongly RECOMMENDED.
1.3.6.1.2.1.43.2.2.18current
prtAuxiliarySheetGroup
OBJECT-GROUP
The auxiliary sheet group.
1.3.6.1.2.1.43.2.2.19current
prtInputSwitchingGroup
OBJECT-GROUP
The input switching group.
1.3.6.1.2.1.43.2.2.20current
prtGeneralV2Group
OBJECT-GROUP
The general printer group with new v2 objects.
1.3.6.1.2.1.43.2.2.21current
prtAlertTableV2Group
OBJECT-GROUP
The alert table group with new v2 objects and prtAlertIndex changed to MAX-ACCESS of 'read-only' for inclusion in the trap bindings (as originally defined in RFC 1759).
1.3.6.1.2.1.43.2.2.22current
prtChannelV2Group
OBJECT-GROUP
The channel group with a new v2 object.
1.3.6.1.2.1.43.2.2.23current
prtAlertTrapGroup
NOTIFICATION-GROUP
The alert trap group.
1.3.6.1.2.1.43.2.2.24current
prtMIB2Compliance
MODULE-COMPLIANCE
The compliance statement for agents that implement the printer MIB V2.
1.3.6.1.2.1.43.2.3current