IANA-PRINTER-MIB
- Registered at
- 1.3.6.1.2.1.109
- Last updated
- 2024-02-06 00:00
- Organization
- IANA
- Revisions
- 2024-02-06 00:00, 2019-07-08 00:00, 2016-09-14 00:00, 2016-08-17 00:00, 2014-05-22 00:00, 2013-09-23 00:00, 2012-07-19 00:00, 2011-11-04 00:00, 2010-05-17 00:00, 2010-04-07 00:00, 2009-11-23 00:00, 2009-10-14 00:00, 2009-02-06 00:00, 2005-09-14 00:00, 2004-06-02 00:00
- Namespace
- standard
- Source file
IANA-PRINTER-MIB- Digest
sha256:2c14edf82df3644292faabf825db91bdd9e335a5596ade9a7e0d51d3f96fe5c4
Description
This MIB module defines a set of printing-related TEXTUAL-CONVENTIONs for use in Printer MIB (RFC 3805), Finisher MIB (RFC 3806), and other MIBs which need to specify printing mechanism details. Any additions or changes to the contents of this MIB module require either publication of an RFC, or Designated Expert Review as defined in RFC 2434, Guidelines for Writing an IANA Considerations Section in RFCs. The Designated Expert will be selected by the IESG Area Director(s) of the Applications Area. Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3805. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html
Contact
Internet Assigned Numbers Authority Postal: ICANN 12025 Waterfront Drive, Suite 300 Los Angeles, CA 90094-2536 Tel: +1 310-301-5800 E-Mail: iana&iana.org
Imports
| From | Symbols |
|---|---|
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP |
| SNMPv2-SMI | MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso, mib-2 |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION |
Imported by
2 module(s) in this corpus import this one.
Load order
Every file a consumer needs in order to load this module, dependencies first.
IANA-PRINTER-MIB SNMPv2-CONF SNMPv2-SMI SNMPv2-TC
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| PrtAlertCodeTC TEXTUAL-CONVENTION The code that describes the type of alert for this entry in the table. Binary change event alerts describe states of the subunit while unary change event alerts describe a single event. The same alert code can be used for a binary change event or a unary change event, depending on implementation. Also, the same alert code can be used to indicate a critical or non-critical (warning) alert, depending on implementation. The value of prtAlertSeverityLevel specifies binary vs. unary and critical vs. non-critical for each event for the implementation. While there are some specific codes for many subunits, the generic codes should be used for most subunit alerts. The network management station can then query the subunit specified by prtAlertGroup to determine further subunit status and other subunit information. An agent shall not add two entries to the alert table for the same event, one containing a generic event code and the other containing a specific event code; the agent shall add only one entry in the alert table for each event; either generic (preferred) or specific, not both. Implementation of the unary change event alertRemovalOfBinaryChangeEntry(1801) is optional. When implemented, this alert code shall indicate to network management stations that the trailing edge of a binary change event has occurred and the corresponding alert entry has been removed from the alert table. As with all events, the alertRemovalOfBinaryChangeEntry(1801) alert shall be placed at the end of the alert table. Such an alert table entry shall specify the following information: prtAlertSeverityLevel warningUnaryChangeEvent(4) prtAlertTrainingLevel noInterventionRequired(7) prtAlertGroup alert(18) prtAlertGroupIndex the index of the row in the alert table of the binary change event that this event has removed. prtAlertLocation unknown (-2) prtAlertCode alertRemovalOfBinaryChangeEntry(1801) prtAlertDescription <description or null string> prtAlertTime the value of sysUpTime at the time of the removal of the binary change event from the alert table. Optionally, the agent may generate a trap coincident with removing the binary change event and placing the unary change event alertRemovalOfBinaryChangeEntry(1801) in the alert table. For such a trap, the prtAlertIndex sent with the above trap parameters shall be the index of the alertRemovalOfBinaryChangeEvent row that was added to the prtAlertTable; not the index of the row that was removed from the prtAlertTable. | current | |||
| PrtAlertGroupTC TEXTUAL-CONVENTION The type of subunit within the printer model that this alert is related. Input, output, and markers are examples of printer model groups, i.e., examples of types of subunits. Wherever possible, the enumerations match the sub-identifier that identifies the relevant table in the Printer MIB. NOTE: Alert type codes have been added for the Host Resources MIB storage table and device table. These additional types are for situations in which the printer's storage and device objects must generate alerts (and possibly traps for critical alerts). | current | |||
| PrtAlertTrainingLevelTC TEXTUAL-CONVENTION The level of training required to handle this alert, if human intervention is required. The noInterventionRequired value should be used if the event does not require any human intervention. The training level is an enumeration that is determined and assigned by the printer manufacturer based on the information or training required to handle this alert. The printer will break alerts into these different training levels. It is the responsibility of a management application in the system to determine how a particular alert is handled and how and to whom that alert is routed. The following are the four training levels of alerts: Field Service - Alerts that typically require advanced training and technical knowledge of the printer and its subunits. An example of a technical person would be a manufacturer's Field Service representative, or other person formally trained by the manufacturer or similar representative. Trained - Alerts that require an intermediate or moderate knowledge of the printer and its subunits. A typical example of such an alert is replacing a toner cartridge. Untrained - Alerts that can be fixed without prior training either because the action to correct the alert is obvious or the printer can help the untrained person fix the problem. A typical example of such an alert is reloading paper trays or emptying output bins on a low end printer. Management - Alerts that have to do with overall operation of and configuration of the printer. Examples of such management events are configuration change of subunits. | current | |||
| PrtChannelTypeTC TEXTUAL-CONVENTION This enumeration indicates the type of channel that is receiving jobs. | current | |||
| PrtConsoleColorTC TEXTUAL-CONVENTION The color of this light. | current | |||
| PrtConsoleDisableTC TEXTUAL-CONVENTION This value indicates whether or not input is accepted from the operator console. A value of 'enabled' indicates that input is accepted from the console, and a value of 'disabled' indicates that input is not accepted from the console. | current | |||
| PrtCoverStatusTC TEXTUAL-CONVENTION Values for encoding the state of a particular cover or access panel on the printer case or enclosure. | current | |||
| PrtGeneralResetTC TEXTUAL-CONVENTION Values for reading and writing the prtGeneralReset object. If a device does not have NVRAM, the device shall none the less respond to a SET with the value resetToNVRAM(5) with a sort of warm reset that resets the device to implementation- defined state that is preferably under control of the system administrator by some means outside the scope of the Printer MIB specification. | current | |||
| PrtInputTypeTC TEXTUAL-CONVENTION The type of technology (discriminated primarily according to feeder mechanism type) employed by a specific component or components. | current | |||
| PrtInterpreterLangFamilyTC TEXTUAL-CONVENTION This enumeration indicates the type of interpreter that is receiving jobs. | current | |||
| PrtMarkerMarkTechTC TEXTUAL-CONVENTION The type of marking technology used for this marking subunit. | current | |||
| PrtMarkerSuppliesTypeTC TEXTUAL-CONVENTION The type of this supply. | current | |||
| PrtMediaPathTypeTC TEXTUAL-CONVENTION The type of the media path for this media path. | current | |||
| PrtOutputTypeTC TEXTUAL-CONVENTION The Type of technology supported by this output subunit. | current |