MIBs Depot

IANA-CHARSET-MIB

Registered at
1.3.6.1.2.1.106
Last updated
2021-01-04 00:00
Organization
IANA
Revisions
2021-01-04 00:00, 2014-05-22 00:00, 2011-10-30 00:00, 2011-09-23 00:00, 2010-11-04 00:00, 2010-09-15 00:00, 2007-05-14 00:00, 2006-12-07 00:00, 2004-06-08 00:00
Namespace
standard
Source file
IANA-CHARSET-MIB
Digest
sha256:55d3553194e108eb3f036e1cc6f8ebd10695a0301255f99b7b0308274ccc70cc

Description

This MIB module defines the IANACharset TEXTUAL-CONVENTION. The IANACharset TC is used to specify the encoding of string objects defined in a MIB. Each version of this MIB will be released based on the IANA Charset Registry file (see RFC 2978) at http://www.iana.org/assignments/character-sets. Note: The IANACharset TC, originally defined in RFC 1759, was inaccurately named CodedCharSet. Note: Best practice is to define new MIB string objects with invariant UTF-8 (RFC 3629) syntax using the SnmpAdminString TC (defined in RFC 3411) in accordance with IETF Policy on Character Sets and Languages (RFC 2277). Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3808; for full legal notices see the RFC itself. Supplementary information may be available on http://www.ietf.org/copyrights/ianamib.html.

Contact

Internet Assigned Numbers Authority Postal: ICANN 12025 Waterfront Drive, Suite 300 Los Angeles, CA 90094-2536 Tel: +1 310-301-5800 E-Mail: iana&iana.org

Imports

FromSymbols
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP
SNMPv2-SMIMODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION

Imported by

1 module(s) in this corpus import this one.

Load order

Every file a consumer needs in order to load this module, dependencies first.

IANA-CHARSET-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Textual conventions

NameOIDSyntaxAccessStatus
IANACharset
TEXTUAL-CONVENTION
Specifies an IANA registered 'charset' - coded character set (CCS) plus optional character encoding scheme (CES) - terms defined in 'IANA Charset Registration Procedures' (RFC 2978). Objects of this syntax are used to specify the encoding for string objects defined in one or more MIBs. For example, the prtLocalizationCharacterSet, prtInterpreterDefaultCharSetIn, and prtInterpreterDefaultCharSetOut objects defined in Printer MIB. The current list of 'charset' names and enumerated values is contained in the IANA Character Set Registry at: http://www.iana.org/assignments/character-sets Enum names are derived from the IANA Charset Registry 'Alias' fields that begin with 'cs' (for character set). Enum values are derived from the parallel 'MIBenum' fields.
current