BTI-TC-MIB
- Registered at
- 1.3.6.1.4.1.18070.1.2
- Last updated
- 2012-05-02 12:00
- Organization
- BTI Systems Inc.
- Revisions
- 2012-06-01 12:00, 2012-05-02 12:00, 2012-02-10 12:00, 2011-09-26 12:00, 2010-08-06 12:00, 2010-06-18 12:00, 2010-02-12 12:00, 2009-01-19 12:00, 2008-12-19 12:00, 2008-10-10 12:00, 2008-05-30 12:00, 2007-09-14 12:00, 2007-07-16 12:00, 2007-03-09 12:00, 2005-12-05 12:00, 2005-07-25 12:00, 2005-02-07 12:00, 2004-09-23 12:00, 2004-01-29 18:21, 2003-12-01 12:00
- Namespace
- bti
- Source file
BTI-TC-MIB- Digest
sha256:08f724074f51e50cb71065fd51b843af9973cba8d953f3bf702d88f446e81bd9
Description
Textual conventions defined for BTI Systems MIBs.
Contact
Technical Support BTI Systems Inc. 50 Northside Road Ottawa, Ontario, Canada K2H 5Z6 (613) 248-9154 support@btisystems.com
Imports
| From | Symbols |
|---|---|
| BTI-MIB | btiModules |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP |
| SNMPv2-SMI | Counter64, Integer32, IpAddress, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION |
Imported by
3 module(s) in this corpus import this one.
Load order
Every file a consumer needs in order to load this module, dependencies first.
BTI-MIB BTI-TC-MIB SNMPv2-CONF SNMPv2-SMI SNMPv2-TC
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| AdminStatus TEXTUAL-CONVENTION An indicator of the status of a resource according to whether or not the resource has been administratively enabled or disabled to perform its provisioned function. | current | |||
| AmdPortType TEXTUAL-CONVENTION A categorization of types of ports on an Active Multiplexer-Demultiplexer circuit pack. | obsolete | |||
| AmdType TEXTUAL-CONVENTION A categorization of types of Active Multiplexer-Demultiplexer facilities, based on type of AMD module type. | obsolete | |||
| AreaID TEXTUAL-CONVENTION An OSPF Area Identifier. | current | |||
| BERType TEXTUAL-CONVENTION A measure of the bit error rate in a received signal, expressed as an exponential. | current | |||
| CirTestResult TEXTUAL-CONVENTION CIR test result. | current | |||
| CommandStateType TEXTUAL-CONVENTION SLA measurement command state type. | current | |||
| CondReportType TEXTUAL-CONVENTION An object of this type is associated with active conditions reported in Trap messages. The condition report type is a coarse qualifier of the significance of the event that is being reported. The values defined are: - 'condition': reports non-alarmed conditions: events that are of general interest, and do not require immediate attention by an operator. - 'alarm': alarmed-conditions generally report a fault condition detected on the NE. Such events generally require immediate attention by an apropriate operator. | current | |||
| CondServiceAffecting TEXTUAL-CONVENTION An object of this type is associated with active conditions reported bin Trap messages. A service affecting indicator provides a clear indication of whether or not the condition being reported has impacted the system's ability to continue to carry traffic. | current | |||
| CondSeverity TEXTUAL-CONVENTION An object of this type is associated with active conditions reported in Trap messages. The condition severity is a more specific qualifier of the urgency of the event that is being reported. The values defined are: - 'minor': attributed to the least severe alarm conditions reported - 'major': attributed to somewhat more severe alarms - 'critical': attributed to the most severe alarm conditions - 'notAlarmed': for conditions that are of significance, but do not require follow-up action - 'notReported': for conditions that are of note, but are not reported by way of notification, and are only viewable as entries in the actCondTable - 'default': used only for setting the severity of a trap back to its original value. - 'critical-major': visible only when retrieving the current setting for severity. It indicates that the severity changes. If the corresponding entity is provisioned then the trap will be raised as critical otherwise it will be raised as major. This severity may not be set directly only by resetting a alarm to its default value. | current | |||
| CpType TEXTUAL-CONVENTION A categorization of types of circuit packs available for BTI Systems equipment based on functionality provided. | current | |||
| DesignatedRouterPriority TEXTUAL-CONVENTION The values defined for the priority of a system for becoming the designated router. | current | |||
| DuplexModeType TEXTUAL-CONVENTION The duplex operational mode for a data interface. | current | |||
| EnvNotifCodeType TEXTUAL-CONVENTION A list of the types of environmental conditions and alarms that may be raised on the system. It is a subset of the list of all alarms, conditions and event types identified in the NotifCodeType textual convention. | current | |||
| FcType TEXTUAL-CONVENTION A categorization of types of Fiber Channel facility ports based on signal rate. | current | |||
| FiberType TEXTUAL-CONVENTION The types of optical fiber that may be used in fiber optic system networks. | current | |||
| FixedX10 TEXTUAL-CONVENTION This represents a fixed point number with a single digit after the decimal point. However, because SNMP does not support floats, the value represented is the actual value multiplied by 10. To derive the actual value, divide by 10 and keep the remainder as the value after the decimal point. | current | |||
| FixedX100 TEXTUAL-CONVENTION This represents a fixed point number with two digits after the decimal point. However, because SNMP does not support floats, the value represented is the actual value multiplied by 100. To derive the actual value, divide by 100 and keep the remainder as the value after the decimal point. | current | |||
| FixedX1000 TEXTUAL-CONVENTION This represents a fixed point number with 3 digits after the decimal point. However, because SNMP does not support floats, the value represented is the actual value multiplied by 1000. To derive the actual value, divide by 1000 and keep the remainder as the value after the decimal point. | current | |||
| HoursAndMinutes TEXTUAL-CONVENTION A textual string representation of a time duration value expressed as the number of hours and minutes. The format of the string is to be HHH-MM, where - HHH is the number of hours and can be 0 to 999 - MM is the number of minutes and can be 0 to 59. The '-' character must be used to separate the hours and minutes values, and the string is expected to be NULL-terminated. | current | |||
| InetAddress TEXTUAL-CONVENTION Denotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. | current | |||
| InetAddressDNS TEXTUAL-CONVENTION Represents a DNS domain name. The name SHOULD be fully qualified whenever possible. The corresponding InetAddressType is dns(16). The DESCRIPTION clause of InetAddress objects that may have InetAddressDNS values MUST fully describe how (and when) these names are to be resolved to IP addresses. The resolution of an InetAddressDNS value may require to query multiple DNS records (e.g., A for IPv4 and AAAA for IPv6). The order of the resolution process and which DNS record takes precedence depends on the configuration of the resolver. This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. | current | |||
| InetAddressIPv4 TEXTUAL-CONVENTION Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. | current | |||
| InetAddressIPv4z TEXTUAL-CONVENTION Represents a non-global IPv4 network address, together with its zone index: Octets Contents Encoding 1-4 IPv4 address network-byte order 5-8 zone index network-byte order The corresponding InetAddressType value is ipv4z(3). The zone index (bytes 5-8) is used to disambiguate identical address values on nodes that have interfaces attached to different zones of the same scope. The zone index may contain the special value 0, which refers to the default zone for each scope. This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. | current | |||
| InetAddressIPv6 TEXTUAL-CONVENTION Represents an IPv6 network address: Octets Contents Encoding 1-16 IPv6 address network-byte order The corresponding InetAddressType value is ipv6(2). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. | current | |||
| InetAddressIPv6z TEXTUAL-CONVENTION Represents a non-global IPv6 network address, together with its zone index: Octets Contents Encoding 1-16 IPv6 address network-byte order 17-20 zone index network-byte order The corresponding InetAddressType value is ipv6z(4). The zone index (bytes 17-20) is used to disambiguate identical address values on nodes that have interfaces attached to different zones of the same scope. The zone index may contain the special value 0, which refers to the default zone for each scope. This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. | current | |||
| InetAddressType TEXTUAL-CONVENTION A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). | current | |||
| InitializeCmd TEXTUAL-CONVENTION Used to initialize an integral-valued object to 0. An object defined of this type must have an access of read-write. When read, the object will return the value 'idle'. When the object is set, the only allowable value is 'initialize'. Setting the value to initialize will result in the initialization of an associated integral-valued object. | current | |||
| LldpChassisId TEXTUAL-CONVENTION This TC describes the format of a chassis identifier string. Objects of this type are always used with an associated LldpChassisIdSubtype object, which identifies the format of the particular LldpChassisId object instance. If the associated LldpChassisIdSubtype object has a value of 'chassisComponent(1)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a chassis component (i.e., an entPhysicalClass value of 'chassis(3)'). If the associated LldpChassisIdSubtype object has a value of 'interfaceAlias(2)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863) for an interface on the containing chassis. If the particular ifAlias object does not contain any values, another chassis identifier type should be used. If the associated LldpChassisIdSubtype object has a value of 'portComponent(3)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component within the containing chassis. If the associated LldpChassisIdSubtype object has a value of 'macAddress(4)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), of a port on the containing chassis as defined in IEEE Std 802-2001. If the associated LldpChassisIdSubtype object has a value of 'networkAddress(5)', then this string identifies a particular network address, encoded in network byte order, associated with one or more ports on the containing chassis. The first octet contains the IANA Address Family Numbers enumeration value for the specific address type, and octets 2 through N contain the network address value in network byte order. If the associated LldpChassisIdSubtype object has a value of 'interfaceName(6)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863) for an interface on the containing chassis. If the particular ifName object does not contain any values, another chassis identifier type should be used. If the associated LldpChassisIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned Chassis ID. | current | |||
| LldpChassisIdSubtype TEXTUAL-CONVENTION This TC describes the source of a chassis identifier. The enumeration 'chassisComponent(1)' represents a chassis identifier based on the value of entPhysicalAlias object (defined in IETF RFC 2737) for a chassis component (i.e., an entPhysicalClass value of 'chassis(3)'). The enumeration 'interfaceAlias(2)' represents a chassis identifier based on the value of ifAlias object (defined in IETF RFC 2863) for an interface on the containing chassis. The enumeration 'portComponent(3)' represents a chassis identifier based on the value of entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component (i.e., entPhysicalClass value of 'port(10)' or 'backplane(4)'), within the containing chassis. The enumeration 'macAddress(4)' represents a chassis identifier based on the value of a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), of a port on the containing chassis as defined in IEEE Std 802-2001. The enumeration 'networkAddress(5)' represents a chassis identifier based on a network address, associated with a particular chassis. The encoded address is actually composed of two fields. The first field is a single octet, representing the IANA AddressFamilyNumbers value for the specific address type, and the second field is the network address value. The enumeration 'interfaceName(6)' represents a chassis identifier based on the value of ifName object (defined in IETF RFC 2863) for an interface on the containing chassis. The enumeration 'local(7)' represents a chassis identifier based on a locally defined value. | current | |||
| LldpPortId TEXTUAL-CONVENTION This TC describes the format of a port identifier string. Objects of this type are always used with an associated LldpPortIdSubtype object, which identifies the format of the particular LldpPortId object instance. If the associated LldpPortIdSubtype object has a value of 'interfaceAlias(1)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863). If the particular ifAlias object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'portComponent(2)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component. If the associated LldpPortIdSubtype object has a value of 'macAddress(3)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order) associated with the port (IEEE Std 802-2001). If the associated LldpPortIdSubtype object has a value of 'networkAddress(4)', then this string identifies a network address associated with the port. The first octet contains the IANA AddressFamilyNumbers enumeration value for the specific address type, and octets 2 through N contain the networkAddress address value in network byte order. If the associated LldpPortIdSubtype object has a value of 'interfaceName(5)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863). If the particular ifName object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'agentCircuitId(6)', then this string identifies a agent-local identifier of the circuit (defined in RFC 3046). If the associated LldpPortIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned port ID. | current | |||
| LldpPortIdSubtype TEXTUAL-CONVENTION This TC describes the source of a particular type of port identifier used in the LLDP MIB. The enumeration 'interfaceAlias(1)' represents a port identifier based on the ifAlias MIB object, defined in IETF RFC 2863. The enumeration 'portComponent(2)' represents a port identifier based on the value of entPhysicalAlias (defined in IETF RFC 2737) for a port component (i.e., entPhysicalClass value of 'port(10)'), within the containing chassis. The enumeration 'macAddress(3)' represents a port identifier based on a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), which has been detected by the agent and associated with a particular port (IEEE Std 802-2001). The enumeration 'networkAddress(4)' represents a port identifier based on a network address, detected by the agent and associated with a particular port. The enumeration 'interfaceName(5)' represents a port identifier based on the ifName MIB object, defined in IETF RFC 2863. The enumeration 'agentCircuitId(6)' represents a port identifier based on the agent-local identifier of the circuit (defined in RFC 3046), detected by the agent and associated with a particular port. The enumeration 'local(7)' represents a port identifier based on a value locally assigned. | current | |||
| LoopbackType TEXTUAL-CONVENTION The type of loopback on a port | current | |||
| MediaRateType TEXTUAL-CONVENTION The media rate for a data interface. | current | |||
| MirrorConfigType TEXTUAL-CONVENTION Mirror configuration as applied on a physical ethernet interface | current | |||
| MonitorPeriodType TEXTUAL-CONVENTION SLA measurement monitor period type. | current | |||
| NotifCodeType TEXTUAL-CONVENTION A list of the types of conditions, alarms and events that may be raised on the system. | current | |||
| NotifObjectType TEXTUAL-CONVENTION A list of the types of objects on the system against which conditions, alarms and events may be raised. | current | |||
| OaType TEXTUAL-CONVENTION A categorization of types of optical amplifiers available for the BTI Systems equipment based on amplification application. | current | |||
| OcnType TEXTUAL-CONVENTION A categorization of types of SONET OC-N facility ports based on signal rate. | current | |||
| OdunType TEXTUAL-CONVENTION A categorization of types of OTN ODU-N facility ports based on signal rate. | current | |||
| OperStatQlfr TEXTUAL-CONVENTION A qualification of the operational status of a resource. The information is in the form of a textual display string, which lists 0 or more comma-delimited qualification identifiers. The set of qualifiers includes: - nr: Normal - anr: Abnormal - au: Autonomous - auma: Autonomous Management - ma: Management - maanr: Management Abnormal - ains: Auto In-service (Auto-enabled) - flt: Fault - mea: Mismatch - swdl: Software Download - mt: Maintenance - sgeo: Supporting Entity Outage - ueq: Unequipped - wrk: Working - comm: Communication Failure - lpbk: Loopback - stdby: Standby - frcd: Forced - lkdo: Locked Out | current | |||
| OperStatus TEXTUAL-CONVENTION An indicator of the status of a resource according to whether or not it is both enabled to perform its function and capable of performing its function. | current | |||
| PMIntervalType TEXTUAL-CONVENTION The type of time interval used to collect performance monitoring statistics. | current | |||
| PMMontype TEXTUAL-CONVENTION A list of performance monitoring monitored types supported for various monitored entites on the system. | current | |||
| PMValidity TEXTUAL-CONVENTION An indicator of the degree of validity attributed to a reported performance monitoring value. | current | |||
| PassivePortType TEXTUAL-CONVENTION A listing of port types found on passive circuit packs. | current | |||
| PmTestCmdState TEXTUAL-CONVENTION SLA measurement test command state. | current | |||
| PowerFeedModeType TEXTUAL-CONVENTION This determines the power feed mode for a given shelf. | current | |||
| ProfileNameType TEXTUAL-CONVENTION Profile Names are restricted to the character set of upper case ASCII characters, the digits 0-9 and the '_' (underscore) character, e.g. [A-Z0-9_]. Any row creation operation for a profile name containing any character outside this set will be rejected with a 'noCreation' error code. | current | |||
| ProtSwEvtType TEXTUAL-CONVENTION When a notification is generated to signal that a protection switching event occurred, an object of this type is used to indicate which type of protection switching event occurred. | current | |||
| ProtSwOpCmd TEXTUAL-CONVENTION Used to perform a protection switch operation on a facility configured as part of a protection group or pairing. | current | |||
| ProtectionStatusType TEXTUAL-CONVENTION A status indicator for a facility involved in a protection switching grouping. | current | |||
| ProtocolActionType TEXTUAL-CONVENTION This it behavior of the packets on the switch | current | |||
| PvxL1PortType TEXTUAL-CONVENTION L2 port type: gigbit ethernet or 10 gigbit ethernet | current | |||
| PvxPortType TEXTUAL-CONVENTION The identifying characteristic of the port. Ports are numbers sequentially for each port type. | current | |||
| ShelfConfigType TEXTUAL-CONVENTION Identifies the configuration for a shelf based on the mix and number of single width and double width slots. | deprecated | |||
| ShelfType TEXTUAL-CONVENTION An identifier that indicates if a shelf functions as a main shelf or as an expansion shelf. | current | |||
| SlaTestRole TEXTUAL-CONVENTION SLA measurement test role. | current | |||
| SlotType TEXTUAL-CONVENTION An identifier that is used to indicate a type of slot on a network element shelf. The slots are differentiated based on the type of replaceable unit they accomodate. Regular slots are where most circuit packs are installed. The other types of slots are the dedicated locations for the shelf interface card and for the cooling unit. | current | |||
| StmnType TEXTUAL-CONVENTION A categorization of types of SDH STM-N facility ports based on signal rate. | current | |||
| StsnType TEXTUAL-CONVENTION A categorization of types of SONET STS-N facilities based on signal rate. | current | |||
| SwitchIdxType TEXTUAL-CONVENTION An object of this type is associated with the index range of switch module. Switch module is a logical entity which can contail multiple circuit packs. | current | |||
| SyncSwEvtType TEXTUAL-CONVENTION When a notification is generated to signal that a synchronization switching event occurred, an object of this type is used to indicate which type of switching event occurred. | current | |||
| TimeZone TEXTUAL-CONVENTION A list of world time zones based on geo-political identifiers. | current | |||
| Unsigned64 TEXTUAL-CONVENTION Used for the transfer of 64-bit unsigned integral values. The value is based on the Counter64 type, but unlike the Counter64, it has 0-based semantics. | current | |||
| UpgradeCompleteStage TEXTUAL-CONVENTION A list of stages involved in the software upgrade procedure used on the network element. Notifications are provided during the course of a software upgrade, making reference to one of the values in this list to indicate the progress of upgrade. | current | |||
| VcnType TEXTUAL-CONVENTION A categorization of types of SDH VC-N facilities based on signal rate. | current | |||
| WDMGrid TEXTUAL-CONVENTION The types of optical grid schemes that may be in use for wavelength division multiplexing according to spacing of optical wavelengths. | current | |||
| XCType TEXTUAL-CONVENTION The types of cross connections that can be provisioned. | current | |||
| XcvrProtocolType TEXTUAL-CONVENTION A listing of the types of communication protocols that a optical transceiver port can be configured to carry. | current | |||
| XcvrType TEXTUAL-CONVENTION A categorization of types of transceiver ports on wavelength translator, regenerator or manager cards based on wavelength management application. | current | |||
| ZeroBasedCounter32 TEXTUAL-CONVENTION This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. | current |