MIBs Depot

VPLS-GENERIC-MIB

Registered at
1.3.6.1.2.1.10.274
Last updated
2014-05-19 12:00
Organization
Layer 2 Virtual Private Networks (L2VPN) Working Group
Revisions
2014-05-19 12:00
Namespace
standard
Source file
VPLS-GENERIC-MIB
Digest
sha256:51cd25ac4e9d7939ee25165e1c928ebef3bef3441759457be058f9a1ece188ff

Description

Copyright (c) 2014 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). The initial version of this MIB module was published in RFC 7257; for full legal notices see the RFC itself. This MIB module contains generic managed object definitions for Virtual Private LAN Service as defined in RFC 4761 and RFC 4762. This MIB module enables the use of any underlying pseudowire network.

Contact

Thomas D. Nadeau Email: tnadeau@lucidvison.com The L2VPN Working Group (email distribution l2vpn@ietf.org, http://www.ietf.org/wg/l2vpn/charter)

Imports

FromSymbols
PW-STD-MIBpwIndex
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, transmission
SNMPv2-TCDisplayString, RowStatus, StorageType, TEXTUAL-CONVENTION, TruthValue
VPN-TC-STD-MIBVPNIdOrZero

Imported by

2 module(s) in this corpus import this one.

Load order

Every file a consumer needs in order to load this module, dependencies first.

HC-PerfHist-TC-MIB
IANA-PWE3-MIB
IANAifType-MIB
IF-MIB
INET-ADDRESS-MIB
PW-STD-MIB
PW-TC-STD-MIB
PerfHist-TC-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
VPLS-GENERIC-MIB
VPN-TC-STD-MIB

Textual conventions

NameOIDSyntaxAccessStatus
VplsBgpRouteDistinguisher
TEXTUAL-CONVENTION
Syntax for a route distinguisher that matches the definition in RFC 4364. For a complete definition of a route distinguisher, see RFC 4364. For more details on use of a route distinguisher for a VPLS service, see RFC 4761.
current
VplsBgpRouteTarget
TEXTUAL-CONVENTION
Syntax for a Route Target that matches the definition in RFC 4364. For a complete definition of a Route Target, see RFC 4364.
current
VplsBgpRouteTargetType
TEXTUAL-CONVENTION
Used to define the type of a Route Target usage. Route Targets can be specified to be imported, exported, or both. For a complete definition of a Route Target, see RFC 4364.
current

Objects

NameOIDSyntaxAccessStatus
vplsNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.10.274.0
vplsObjects
OBJECT-IDENTITY
1.3.6.1.2.1.10.274.1
vplsConfigIndexNext
OBJECT-TYPE
This object contains an appropriate value to be used for vplsConfigIndex when creating entries in the vplsConfigTable. The value 0 indicates that no unassigned entries are available. To obtain the value of vplsConfigIndex for a new entry in the vplsConfigTable, the manager issues a management protocol retrieval operation to obtain the current value of vplsConfigIndex. After each retrieval operation, the agent should modify the value to reflect the next unassigned index. After a manager retrieves a value the agent will determine through its local policy when this index value will be made available for reuse.
1.3.6.1.2.1.10.274.1.1Unsigned32read-onlycurrent
vplsConfigTable
OBJECT-TYPE
This table specifies information for configuring and monitoring Virtual Private LAN Service (VPLS).
1.3.6.1.2.1.10.274.1.2not-accessiblecurrent
vplsConfigEntry
OBJECT-TYPE
A row in this table represents a Virtual Private LAN Service (VPLS) in a packet network. It is indexed by vplsConfigIndex, which uniquely identifies a single VPLS. A row is created via SNMP or by the agent if a VPLS service is created by a non-SNMP application or due to the Auto-Discovery process. All of the read-create objects values except vplsConfigSignalingType can be changed when vplsConfigRowStatus is in the active(1) state. Changes for vplsConfigSignalingType are only allowed when the vplsConfigRowStatus is in notInService(2) or notReady(3) states.
1.3.6.1.2.1.10.274.1.2.1not-accessiblecurrent
vplsConfigIndex
OBJECT-TYPE
Unique index for the conceptual row identifying a VPLS service.
1.3.6.1.2.1.10.274.1.2.1.1Unsigned32 (1..2147483647)not-accessiblecurrent
vplsConfigName
OBJECT-TYPE
A textual name of the VPLS. If there is no local name, or this object is otherwise not applicable, then this object MUST contain a zero-length octet string.
1.3.6.1.2.1.10.274.1.2.1.2SnmpAdminStringread-createcurrent
vplsConfigDescr
OBJECT-TYPE
A textual string containing information about the VPLS service. If there is no information for this VPLS service, then this object MUST contain a zero-length octet string.
1.3.6.1.2.1.10.274.1.2.1.3SnmpAdminStringread-createcurrent
vplsConfigAdminStatus
OBJECT-TYPE
The desired administrative state of the VPLS service. If the administrative status of the VPLS service is changed to enabled, then this service is able to utilize pseudowires to perform the tasks of a VPLS service. The testing(3) state indicates that no operational packets can be passed.
1.3.6.1.2.1.10.274.1.2.1.4INTEGER {up(1), down(2), testing(3)}read-createcurrent
vplsConfigMacLearning
OBJECT-TYPE
This object specifies if MAC Learning is enabled in this service. If this object is true then MAC Learning is enabled. If false, then MAC Learning is disabled.
1.3.6.1.2.1.10.274.1.2.1.6TruthValueread-createcurrent
vplsConfigDiscardUnknownDest
OBJECT-TYPE
If the value of this object is 'true', then frames received with an unknown destination MAC are discarded in this VPLS. If 'false', then the packets are processed.
1.3.6.1.2.1.10.274.1.2.1.7TruthValueread-createcurrent
vplsConfigMacAging
OBJECT-TYPE
If the value of this object is 'true', then the MAC aging process is enabled in this VPLS. If 'false', then the MAC aging process is disabled.
1.3.6.1.2.1.10.274.1.2.1.8TruthValueread-createcurrent
vplsConfigFwdFullHighWatermark
OBJECT-TYPE
This object specifies the utilization of the forwarding database for this VPLS instance at which the vplsFwdFullAlarmRaised notification will be sent. The value of this object must be higher than vplsConfigFwdFullLowWatermark.
1.3.6.1.2.1.10.274.1.2.1.10Unsigned32 (0..100)read-createcurrent
vplsConfigFwdFullLowWatermark
OBJECT-TYPE
This object specifies the utilization of the forwarding database for this VPLS instance at which the vplsFwdFullAlarmCleared notification will be sent. The value of this object must be less than vplsConfigFwdFullHighWatermark.
1.3.6.1.2.1.10.274.1.2.1.11Unsigned32 (0..99)read-createcurrent
vplsConfigRowStatus
OBJECT-TYPE
For creating, modifying, and deleting this row. All other objects in this row must be set to valid values before this object can be set to active(1). None of the read-create objects in the conceptual rows may be changed when this object is in the active(1) state. If this object is set to destroy(6) or deleted by the agent, all associated entries in the vplsPwBindTable, vplsBgpRteTargetTable, and vplsBgpVETable shall be deleted.
1.3.6.1.2.1.10.274.1.2.1.12RowStatusread-createcurrent
vplsConfigMtu
OBJECT-TYPE
The value of this object specifies the MTU of this VPLS instance. This can be used to limit the MTU to a value lower than the MTU supported by the associated pseudowires.
1.3.6.1.2.1.10.274.1.2.1.13Unsigned32 (64..9192)read-createcurrent
vplsConfigVpnId
OBJECT-TYPE
This objects indicates the IEEE 802-1990 VPN ID of the associated VPLS service.
1.3.6.1.2.1.10.274.1.2.1.14VPNIdOrZeroread-createcurrent
vplsConfigStorageType
OBJECT-TYPE
This variable indicates the storage type for this row.
1.3.6.1.2.1.10.274.1.2.1.15StorageTyperead-createcurrent
vplsConfigSignalingType
OBJECT-TYPE
Desired signaling type of the VPLS service. If the value of this object is ldp(1), then a corresponding entry in vplsLdpConfigTable is required. If the value of this object is bgp(2), then a corresponding entry in vplsBgpConfigTable is required. If the value of this object is none(3), then it indicates a static configuration of PW labels.
1.3.6.1.2.1.10.274.1.2.1.16INTEGER {ldp(1), bgp(2), none(3)}read-createcurrent
vplsStatusTable
OBJECT-TYPE
This table provides information for monitoring Virtual Private LAN Service (VPLS).
1.3.6.1.2.1.10.274.1.3not-accessiblecurrent
vplsStatusEntry
OBJECT-TYPE
A row in this table represents a Virtual Private LAN Service (VPLS) in a packet network. It is indexed by vplsConfigIndex, which uniquely identifies a single VPLS. A row in this table is automatically created by the agent when a VPLS service is first set to active.
1.3.6.1.2.1.10.274.1.3.1not-accessiblecurrent
vplsStatusOperStatus
OBJECT-TYPE
The current operational state of this VPLS service.
1.3.6.1.2.1.10.274.1.3.1.1INTEGER {other(0), up(1), down(2)}read-onlycurrent
vplsStatusPeerCount
OBJECT-TYPE
This objects specifies the number of peers (pseudowires) present in this VPLS instance.
1.3.6.1.2.1.10.274.1.3.1.2Counter32read-onlycurrent
vplsPwBindTable
OBJECT-TYPE
This table provides an association between a VPLS service and the corresponding pseudowires. A service can have more than one pseudowire association. Pseudowires are defined in the pwTable
1.3.6.1.2.1.10.274.1.4not-accessiblecurrent
vplsPwBindEntry
OBJECT-TYPE
Each row represents an association between a VPLS instance and a pseudowire defined in the pwTable. Each index is unique in describing an entry in this table. However, both indexes are required to define the one to many association of service to pseudowire. Entries in this table may be created or deleted through SNMP, as side effects of console or other non-SNMP management commands, or upon learning via autodiscovery. It is optional for the agent to allow entries to be created that point to nonexistent entries in vplsConfigTable.
1.3.6.1.2.1.10.274.1.4.1not-accessiblecurrent
vplsPwBindConfigType
OBJECT-TYPE
The value of this object indicates whether the pseudowire Binding was created via SNMP/Console or via Auto-Discovery. The value of this object must be specified when the row is created and cannot be changed while the row status is active(1)
1.3.6.1.2.1.10.274.1.4.1.1INTEGER {manual(1), autodiscovery(2)}read-createcurrent
vplsPwBindType
OBJECT-TYPE
The value of this object indicates whether the pseudowire Binding is of type mesh or spoke. The value of this object must be specified when the row is created and cannot be changed while the row status is active(1)
1.3.6.1.2.1.10.274.1.4.1.2INTEGER {mesh(1), spoke(2)}read-createcurrent
vplsPwBindRowStatus
OBJECT-TYPE
For creating, modifying, and deleting this row. All other objects in this row must be set to valid values before this object can be set to active(1). None of the read-create objects in the conceptual rows may be changed when this object is in the active(1) state. If autodiscovered entries are deleted they would likely re-appear in the next autodiscovery interval.
1.3.6.1.2.1.10.274.1.4.1.3RowStatusread-createcurrent
vplsPwBindStorageType
OBJECT-TYPE
This variable indicates the storage type for this row.
1.3.6.1.2.1.10.274.1.4.1.4StorageTyperead-createcurrent
vplsBgpADConfigTable
OBJECT-TYPE
This table specifies information for configuring BGP Auto-Discovery parameters for a given VPLS service.
1.3.6.1.2.1.10.274.1.5not-accessiblecurrent
vplsBgpADConfigEntry
OBJECT-TYPE
A row in this table indicates that BGP based Auto- Discovery is in use for this instance of VPLS. A row in this table is indexed by vplsConfigIndex, which uniquely identifies a single VPLS. Entries in this table may be created or deleted through SNMP, as side effects of console or other non-SNMP management commands, or upon learning via autodiscovery. All of the read-create objects can be changed when vplsBGPADConfigRowStatus is in active(1) state.
1.3.6.1.2.1.10.274.1.5.1not-accessiblecurrent
vplsBgpADConfigRouteDistinguisher
OBJECT-TYPE
The route distinguisher for this VPLS. See RFC 4364 for a complete definition of a route distinguisher. For more details on use of a route distinguisher for a VPLS service, see RFC 4761. When not configured, the value is derived from the lower 6 bytes of vplsBgpADConfigVplsId.
1.3.6.1.2.1.10.274.1.5.1.1VplsBgpRouteDistinguisherread-createcurrent
vplsBgpADConfigPrefix
OBJECT-TYPE
In case of auto-discovery, the default prefix advertised is the IP address of the loopback. In case the user wants to override the loopback address, vplsBgpADConfigPrefix should be set. When this value is non-zero, this value is used along with vplsBgpADConfigRouteDistinguisher in the Network Layer Reachability Information (NLRI), see RFC 6074.
1.3.6.1.2.1.10.274.1.5.1.2Unsigned32read-createcurrent
vplsBgpADConfigVplsId
OBJECT-TYPE
VplsId is a unique identifier for all Virtual Switch Instances (VSIs) belonging to the same VPLS. It is advertised as an extended community.
1.3.6.1.2.1.10.274.1.5.1.3VplsBgpRouteDistinguisherread-createcurrent
vplsBgpADConfigRowStatus
OBJECT-TYPE
For creating, modifying, and deleting this row. All other objects in this row must be set to valid values before this object can be set to active(1). None of the read-create objects in the conceptual rows may be changed when this object is in the active(1) state.
1.3.6.1.2.1.10.274.1.5.1.4RowStatusread-createcurrent
vplsBgpADConfigStorageType
OBJECT-TYPE
This variable indicates the storage type for this row.
1.3.6.1.2.1.10.274.1.5.1.5StorageTyperead-createcurrent
vplsBgpRteTargetTable
OBJECT-TYPE
This table specifies the list of Route Targets imported or exported by BGP during auto-discovery of VPLS.
1.3.6.1.2.1.10.274.1.6not-accessiblecurrent
vplsBgpRteTargetEntry
OBJECT-TYPE
An entry in this table specifies the value of the Route Target being used by BGP. Depending on the value of vplsBgpRteTargetType, a Route Target might be exported, imported, or both. Every VPLS that uses auto-discovery for finding peer nodes can import and export multiple Route Targets. This representation allows support for hierarchical VPLS. Entries in this table may be created or deleted through SNMP, as side effects of console or other non-SNMP management commands, or upon learning via autodiscovery. It is optional for the agent to allow entries to be created that point to nonexistent entries in vplsConfigTable.
1.3.6.1.2.1.10.274.1.6.1not-accessiblecurrent
vplsBgpRteTargetIndex
OBJECT-TYPE
This index, along with vplsConfigIndex, identifies one entry in the vplsBgpRteTargetTable. By keeping vplsConfigIndex constant and using a new value of vplsBgpRteTargetIndex, users can configure multiple Route Targets for the same VPLS.
1.3.6.1.2.1.10.274.1.6.1.1Unsigned32not-accessiblecurrent
vplsBgpRteTargetRTType
OBJECT-TYPE
Used to define the type of a Route Target usage. Route Targets can be specified to be imported, exported, or both. For a complete definition of a Route Target, see RFC 4364.
1.3.6.1.2.1.10.274.1.6.1.2VplsBgpRouteTargetTyperead-createcurrent
vplsBgpRteTargetRT
OBJECT-TYPE
The Route Target associated with the VPLS service. For more details on use of Route Targets for a VPLS service, see RFC 4761.
1.3.6.1.2.1.10.274.1.6.1.3VplsBgpRouteTargetread-createcurrent
vplsBgpRteTargetRowStatus
OBJECT-TYPE
This variable is used to create, modify, and/or delete a row in this table. All other objects in this row must be set to valid values before this object can be set to active(1). When a row in this table is in active(1) state, no objects in that row can be modified. If autodiscovered entries are deleted they would likely re-appear in the next autodiscovery interval.
1.3.6.1.2.1.10.274.1.6.1.4RowStatusread-createcurrent
vplsBgpRteTargetStorageType
OBJECT-TYPE
This variable indicates the storage type for this row.
1.3.6.1.2.1.10.274.1.6.1.5StorageTyperead-createcurrent
vplsStatusNotifEnable
OBJECT-TYPE
If this object is set to true(1), then it enables the emission of a vplsStatusChanged notification; otherwise, this notification is not emitted.
1.3.6.1.2.1.10.274.1.7TruthValueread-writecurrent
vplsNotificationMaxRate
OBJECT-TYPE
This object indicates the maximum number of notifications issued per second. If events occur more rapidly, the implementation may simply fail to emit these notifications during that period, or it may queue them until an appropriate time. A value of 0 means no throttling is applied and events may be notified at the rate at which they occur.
1.3.6.1.2.1.10.274.1.8Unsigned32read-writecurrent
vplsConformance
OBJECT-IDENTITY
1.3.6.1.2.1.10.274.2
vplsCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.10.274.2.1
vplsGroups
OBJECT-IDENTITY
1.3.6.1.2.1.10.274.2.2

Notifications

NameOIDStatus
vplsStatusChanged
NOTIFICATION-TYPE
The vplsStatusChanged notification is generated when there is a change in the administrative or operating status of a VPLS service. The object instances included in the notification are the ones associated with the VPLS service whose status has changed.
1.3.6.1.2.1.10.274.0.1current
vplsFwdFullAlarmRaised
NOTIFICATION-TYPE
The vplsFwdFullAlarmRaised notification is generated when the utilization of the Forwarding database is above the value specified by vplsConfigFwdFullHighWatermark. The object instances included in the notification are the ones associated with the VPLS service that has exceeded the threshold.
1.3.6.1.2.1.10.274.0.2current
vplsFwdFullAlarmCleared
NOTIFICATION-TYPE
The vplsFwdFullAlarmCleared notification is generated when the utilization of the Forwarding database is below the value specified by vplsConfigFwdFullLowWatermark. The object instances included in the notification are the ones associated with the VPLS service that has fallen below the threshold.
1.3.6.1.2.1.10.274.0.3current

Conformance

NameOIDStatus
vplsModuleFullCompliance
MODULE-COMPLIANCE
Compliance requirement for implementations that provide full support for VPLS-GENERIC-MIB. Such devices can then be monitored and configured using this MIB module.
1.3.6.1.2.1.10.274.2.1.1current
vplsModuleReadOnlyCompliance
MODULE-COMPLIANCE
Compliance requirement for implementations that only provide read-only support for VPLS-GENERIC-MIB. Such devices can then be monitored but cannot be configured using this MIB modules.
1.3.6.1.2.1.10.274.2.1.2current
vplsGroup
OBJECT-GROUP
The group of objects supporting management of L2VPN VPLS services
1.3.6.1.2.1.10.274.2.2.1current
vplsPwBindGroup
OBJECT-GROUP
The group of objects supporting management of pseudowire (PW) Binding to VPLS.
1.3.6.1.2.1.10.274.2.2.2current
vplsNotificationGroup
NOTIFICATION-GROUP
The group of notifications supporting the Notifications generated for VPLS services.
1.3.6.1.2.1.10.274.2.2.3current