SAF-ALARM-MIB
- Registered at
- 1.3.6.1.4.1.7571.100.118
- Last updated
- 2012-12-07 00:00
- Organization
- SAF Tehnika
- Revisions
- 2012-12-07 00:00
- Namespace
- saf
- Source file
SAF-ALARM-MIB- Digest
sha256:fbb100fc1ffd1edf90795c46c8df2311b7f454b5ee99a30bbe98bdfcc494948b
Description
The MIB module describes a solution to SAF Tehnika equipment alarms and to store the current list of active alarms. Copyright (C) SAF Tehnika, 2007-2012.
Contact
EMail: support@saftehnika.com http://www.saftehnika.com/
Imports
| From | Symbols |
|---|---|
| ALARM-MIB | alarmActiveDateAndTime, alarmActiveIndex, alarmListName, alarmModelIndex |
| IANA-ITU-ALARM-TC-MIB | IANAItuEventType |
| ITU-ALARM-TC-MIB | ItuTrendIndication |
| SAF-ENTERPRISE | tehnika |
| SNMP-FRAMEWORK-MIB | SnmpAdminString |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, TimeTicks, Unsigned32, iso |
| SNMPv2-TC | AutonomousType, DateAndTime, DisplayString, RowPointer, TEXTUAL-CONVENTION |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
ALARM-MIB IANA-ITU-ALARM-TC-MIB IANAifType-MIB IF-MIB INET-ADDRESS-MIB ITU-ALARM-TC-MIB RFC1158-MIB RFC1271-MIB RMON-MIB RMON2-MIB SAF-ALARM-MIB SAF-ENTERPRISE SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC TOKEN-RING-RMON-MIB
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| SafAlarmProbableCause TEXTUAL-CONVENTION ITU-T probable cause values. Duplicate values defined in X.733 are appended with X733 to ensure syntactic uniqueness. Probable cause value 0 is reserved for special purposes. The Internet Assigned Number Authority (IANA) is responsible for the assignment of the enumerations in this TC. IANAItuProbableCause value of 0 is reserved for special purposes and MUST NOT be assigned. Values of IANAItuProbableCause in the range 1 to 1023 are reserved for causes that correspond to ITU-T probable cause. All other requests for new causes will be handled on a first-come, first served basis and will be assigned enumeration values starting with 1025. Request should come in the form of well-formed SMI [RFC2578] for enumeration names that are unique and sufficiently descriptive. While some effort will be taken to ensure that new probable causes do not conceptually duplicate existing probable causes it is acknowledged that the existence of conceptual duplicates in the starting probable cause list is an known industry reality. To aid IANA in the administration of probable cause names and values, the OPS Area Director will appoint one or more experts to help review requests. See http://www.iana.org | current | |||
| SafPerceivedSeverity TEXTUAL-CONVENTION modified ITU perceived severity values | current |
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| safAlarmNotifications OBJECT-IDENTITY | 1.3.6.1.4.1.7571.100.118.0 | |||
| safAlarmObjects OBJECT-IDENTITY | 1.3.6.1.4.1.7571.100.118.1 | |||
| safAlarmActive OBJECT-IDENTITY | 1.3.6.1.4.1.7571.100.118.1.1 | |||
| safAlarmActiveLastChanged OBJECT-TYPE The value of sysUpTime at the time of the last creation, deletion or modification of an entry in the safAlarmTable(s). | 1.3.6.1.4.1.7571.100.118.1.1.1 | TimeTicks | read-only | current |
| safAlarmActiveTable OBJECT-TYPE Alarm table. | 1.3.6.1.4.1.7571.100.118.1.1.2 | not-accessible | current | |
| safAlarmActiveEntry OBJECT-TYPE Entries of alarm table. | 1.3.6.1.4.1.7571.100.118.1.1.2.1 | not-accessible | current | |
| safAlarmActiveIndex OBJECT-TYPE An integer that acts as an alarm Id to uniquely identify each alarm within the alarm list. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.1 | Unsigned32 (1..4294967295) | not-accessible | current |
| safAlarmActiveManagedObj OBJECT-TYPE Object, which raises an alarm. Indicates specific object, which raises an alarm. This should refer to interfaces or Object class and instance. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.2 | OBJECT IDENTIFIER | read-only | current |
| safAlarmActiveDateAndTime OBJECT-TYPE Alarm date and time. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.3 | DateAndTime | read-only | current |
| safAlarmActiveEventType OBJECT-TYPE Alarm type in accordance with IANA. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.4 | IANAItuEventType | read-only | current |
| safAlarmActiveProbableCause OBJECT-TYPE This parameter defines further qualification as to the probable cause of the alarm. Probable cause values for notifications shall be indicated in te behaviour clause of the object class definition. This parameter defines standard probables causes that have wide applicability across managed object classes. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.5 | SafAlarmProbableCause | read-only | current |
| safAlarmActivePerceivedSeverity OBJECT-TYPE ITU perceived severity values. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.6 | SafPerceivedSeverity | read-only | current |
| safAlarmActiveThresholdTrigered OBJECT-TYPE The identifier of the threshold attribute that caused the notification. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.7 | Integer32 | read-only | current |
| safAlarmActiveThresholdValue OBJECT-TYPE The value of the gauge or counter which crossed the threshold. This may be different from the threshold value if, for example, the gauge may only take on descrete values. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.8 | Integer32 | read-only | current |
| safAlarmActiveThresholdTTrigered OBJECT-TYPE | 1.3.6.1.4.1.7571.100.118.1.1.2.1.9 | DisplayString | read-only | current |
| safAlarmActiveThresholdTValue OBJECT-TYPE | 1.3.6.1.4.1.7571.100.118.1.1.2.1.10 | DisplayString | read-only | current |
| safAlarmActiveAdditionalText OBJECT-TYPE Alarm information interpreted in user friendly text. For example, 'Ethernet interface'. | 1.3.6.1.4.1.7571.100.118.1.1.2.1.11 | SnmpAdminString | read-only | current |
| safAlarmActiveLastChangedDateAndTime OBJECT-TYPE The value of Date and Time when the last creation, deletion or modification of an entry in the safAlarmTable(s). | 1.3.6.1.4.1.7571.100.118.1.1.3 | DateAndTime | read-only | current |
| safAlarmConformance OBJECT-IDENTITY | 1.3.6.1.4.1.7571.100.118.3 | |||
| safAlarmGroups OBJECT-IDENTITY | 1.3.6.1.4.1.7571.100.118.3.2 |
Notifications
| Name | OID | Status |
|---|---|---|
| safAlarmActiveState NOTIFICATION-TYPE An instance of the alarm indicated. | 1.3.6.1.4.1.7571.100.118.0.2 | current |
| safAlarmActiveTState NOTIFICATION-TYPE An instance of the alarm indicated. | 1.3.6.1.4.1.7571.100.118.0.3 | current |
| safAlarmClearState NOTIFICATION-TYPE An instance of the clear alarm. | 1.3.6.1.4.1.7571.100.118.0.4 | deprecated |
Conformance
| Name | OID | Status |
|---|---|---|
| safAlarmActiveGroup OBJECT-GROUP Active Alarm list group. | 1.3.6.1.4.1.7571.100.118.3.2.1 | current |
| safAlarmNotificationsGroup NOTIFICATION-GROUP The collection of notifications that can be used to alarms for faults. | 1.3.6.1.4.1.7571.100.118.3.2.2 | deprecated |
| safAlarmNotificationsGroup1 NOTIFICATION-GROUP The collection of notifications that can be used to alarms for faults. | 1.3.6.1.4.1.7571.100.118.3.2.3 | current |