OLSRv2-MIB
- Registered at
- 1.3.6.1.2.1.219
- Last updated
- 2014-04-09 00:00
- Organization
- IETF MANET Working Group
- Revisions
- 2014-04-09 00:00
- Namespace
- standard
- Source file
OLSRv2-MIB- Digest
sha256:0226aba5b52d582860ddd9a6e6ccd1a043d2d0d80540823328e93f6da9842e44
Description
This OLSRv2-MIB module is applicable to routers implementing the Optimized Link State Routing Protocol version 2 (OLSRv2) defined in RFC 7181. Copyright (c) 2014 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 7184; see the RFC itself for full legal notices.
Contact
WG E-Mail: manet@ietf.org WG Chairs: sratliff@cisco.com jmacker@nrl.navy.mil Editors: Ulrich Herberg Fujitsu Laboratories of America 1240 East Arques Avenue Sunnyvale, CA 94085 USA Email: ulrich@herberg.name URI: http://www.herberg.name/ Thomas Heide Clausen Ecole Polytechnique LIX 91128 Palaiseau Cedex France Email: T.Clausen@computer.org URI: http://www.thomasclausen.org/ Robert G. Cole US Army CERDEC Space and Terrestrial Communications 6010 Frankford Street Bldg 6010, Room 453H Aberdeen Proving Ground, MD 21005 USA Phone: +1 443 395-8744 Email: robert.g.cole@us.army.mil URI: http://www.cs.jhu.edu/~rgcole
Imports
| From | Symbols |
|---|---|
| IANA-OLSRv2-LINK-METRIC-TYPE-MIB | IANAolsrv2LinkMetricTypeTC |
| INET-ADDRESS-MIB | InetAddress, InetAddressPrefixLength, InetAddressType |
| NHDP-MIB | nhdpIib2HopSetEntry, nhdpIibLinkSetEntry, nhdpInterfaceEntry, nhdpInterfacePerfEntry, nhdpNibNeighborSetEntry |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Counter32, Counter64, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, TimeTicks, Unsigned32, iso, mib-2 |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION, TimeStamp, TruthValue |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
FLOAT-TC-MIB IANA-OLSRv2-LINK-METRIC-TYPE-MIB IANAifType-MIB IF-MIB INET-ADDRESS-MIB NHDP-MIB OLSRv2-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| Olsrv2MetricValueCompressedFormTC TEXTUAL-CONVENTION OLSRv2 Metrics are expressed in terms of a Link Metric Compressed Form within the OLSRv2 protocol. This textual convention defines the syntax of the metric objects consistent with the definitions of the OLSRv2 Link Metric Compressed Form in Section 6.2 of RFC 7181. The 12-bit compressed form of a link metric uses a modified form of a representation with an 8-bit mantissa (denoted a) and a 4-bit exponent (denoted b). Note that if represented as the 12-bit value 256b+a, then the ordering of those 12-bit values is identical to the ordering of the represented values. The value so represented is (257+a)2^b - 256, where ^ denotes exponentiation. This has a minimum value (when a = 0 and b = 0) of MINIMUM_METRIC = 1 and a maximum value (when a = 255 and b = 15) of MAXIMUM_METRIC = 2^24 - 256. Hence, the metric values so represented range from 1 to 16776960. The special value of 0 is reserved for the UNKNOWN_METRIC value. If a network manager sets the metric value 'm' through the MIB module, then the OLSRv2 code can both use this value and derive a compressed representation of 'm' (as used in messages) as specified in Section 6.2 of RFC7181. The value 'm' is persistently stored by the MIB module. If the MIB module is pulling this metric's value from some other source, e.g., the protocol instance, then this value is stored as is. | current | |||
| Olsrv2StatusTC TEXTUAL-CONVENTION Controls the operation of the OLSRv2 protocol on the device or a specific interface. For example, for an interface, 'enabled' indicates that OLSRv2 is permitted to operate, and 'disabled' indicates that it is not. | current | |||
| Olsrv2TimeValueCompressedForm32TC TEXTUAL-CONVENTION OLSRv2 time values may be expressed in terms of a compressed form within the OLSRv2 protocol. This textual convention defines the syntax of the time objects defined in terms of an integer number of milliseconds, consistent with the definitions of the 8-bit exponent-mantissa compressed form defined in Section 5 of RFC 5497. Time values with this representation are defined in terms of a constant C, which is represented in terms of seconds. The constant C (time granularity) is used as specified in RFC 5497. It MUST be the same as is used by NHDP (RFC 6130). The 8-bit compressed form of a time value uses a modified form of a representation with a 3-bit mantissa (denoted a) and a 5-bit exponent (denoted b). Note that if represented as the 8-bit value 8b+a, then the ordering of those 8-bit values is identical to the ordering of the represented values. The minimum time value that can be represented in this manner is C. The maximum time value that can be represented in this manner is 15 * 2^28 * C, 15*268,435,456 * C, 4,026,531,840 * C, or about 45 days if, for example, C = 1/1024 second. This TEXTUAL-CONVENTION limits the maximum value of the time granularity constant C to be no greater than 1/1024 seconds due to its use of the Unsigned32 syntax limiting the maximum number of milliseconds to no more than 3932160000. When OLSRv2 uses this 8-bit exponent-mantissa compressed form, this object value MUST be translated from the integer form represented in this MIB module into the exponent-mantissa form for the OLSRv2 protocol to use according to the algorithm defined in Section 5 of RFC 5497 for finding the next larger time value within the exponent-mantissa format. If a network manager sets the time value 't' through the MIB module, then the OLSRv2 code can derive 'compressed_t' = T(a,b) according to the algorithm in RFC 5497 and 'compressed_t' is the value represented in the OLSRv2 messages. But, the value 't' is persistently stored by the MIB module. If the MIB module is pulling this time parameter from some other source that is using the compressed form, i.e., the protocol instance, then this value is stored as is, after converting from number of time constants C into number of milliseconds. | current | |||
| WillingnessTC TEXTUAL-CONVENTION A willingness value that evaluates to the device's interest in participating in a particular function, process, or behavior. The willingness ranges from a low value of WILL_NEVER(0) to a high value of WILL_ALWAYS(15). For each parameter x, there is an associated willingness value W(x) such that WILL_NEVER < W(x) <= WILL_ALWAYS. | current |
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| olsrv2MIBNotifications OBJECT-IDENTITY | 1.3.6.1.2.1.219.0 | |||
| olsrv2NotificationsObjects OBJECT-IDENTITY | 1.3.6.1.2.1.219.0.0 | |||
| olsrv2NotificationsControl OBJECT-IDENTITY | 1.3.6.1.2.1.219.0.1 | |||
| olsrv2RoutingSetRecalculationCountThreshold OBJECT-TYPE A threshold value for the olsrv2RoutingSetRecalculationCount object. If the number of occurrences exceeds this threshold within the previous olsrv2RoutingSetRecalculationCountWindow, then the olsrv2RoutingSetRecalculationCountChange notification is to be generated. It is RECOMMENDED that the value of this threshold be set to at least 20 and higher in dense topologies with frequent expected topology changes. | 1.3.6.1.2.1.219.0.1.1 | Integer32 (0..255) | read-write | current |
| olsrv2RoutingSetRecalculationCountWindow OBJECT-TYPE This object is used to determine whether to generate an olsrv2RoutingSetRecalculationCountChange notification. This object represents an interval from the present moment, extending into the past, expressed in hundredths of a second. If the change in the value of the olsrv2RoutingSetRecalculationCount object during this interval has exceeded the value of olsrv2RoutingSetRecalculationCountThreshold, then an olsrv2RoutingSetRecalculationCountChange notification is generated. It is RECOMMENDED that the value for this window be set to at least 5 times the nhdpHelloInterval (whose default value is 2 seconds. | 1.3.6.1.2.1.219.0.1.2 | TimeTicks | read-write | current |
| olsrv2MPRSetRecalculationCountThreshold OBJECT-TYPE A threshold value for the olsrv2MPRSetRecalculationCount object. If the number of occurrences exceeds this threshold within the previous olsrv2MPRSetRecalculationCountWindow, then the olsrv2MPRSetRecalculationCountChange notification is to be generated. It is RECOMMENDED that the value of this threshold be set to at least 20 and higher in dense topologies with frequent expected topology changes. | 1.3.6.1.2.1.219.0.1.3 | Integer32 (0..255) | read-write | current |
| olsrv2MPRSetRecalculationCountWindow OBJECT-TYPE This object is used to determine whether to generate an olsrv2MPRSetRecalculationCountChange notification. This object represents an interval from the present moment, extending into the past, expressed in hundredths of a second. If the change in the value of the olsrv2MPRSetRecalculationCount object during that interval has exceeded the value of olsrv2MPRSetRecalculationCountThreshold, then the an olsrv2MPRSetRecalculationCountChange notification is generated. It is RECOMMENDED that the value for this window be set to at least 5 times the nhdpHelloInterval. | 1.3.6.1.2.1.219.0.1.4 | TimeTicks | read-write | current |
| olsrv2NotificationsStates OBJECT-IDENTITY | 1.3.6.1.2.1.219.0.2 | |||
| olsrv2PreviousOrigIpAddrType OBJECT-TYPE The type of the olsrv2PreviousOrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. This object MUST have the same persistence characteristics as olsrv2PreviousOrigIpAddr. | 1.3.6.1.2.1.219.0.2.1 | InetAddressType {ipv4(1), ipv6(2)} | read-only | current |
| olsrv2PreviousOrigIpAddr OBJECT-TYPE The previous origination IP address of this OLSRv2 router. This object SHOULD be updated each time the olsrv2OrigIpAddr is modified. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.0.2.2 | InetAddress (SIZE(4 | 16)) | read-only | current |
| olsrv2MIBObjects OBJECT-IDENTITY | 1.3.6.1.2.1.219.1 | |||
| olsrv2ConfigurationGroup OBJECT-IDENTITY | 1.3.6.1.2.1.219.1.1 | |||
| olsrv2AdminStatus OBJECT-TYPE The configured status of the OLSRv2 process on this device. 'enabled(1)' means that OLSRv2 is configured to run on this device. 'disabled(2)' mean that the OLSRv2 process is configured off. Operation of the OLSRv2 protocol requires the operation of the Neighborhood Discovery Protocol (RFC 6130). Hence, this object cannot have a status of 'enabled' unless at least one interface on the device is a MANET interface with NHDP enabled on that interface. If a network manager attempts to set this object to 'enabled' when no interfaces on this device have NHDP enabled, the device MUST fail the set with inconsistentValue. If all device interfaces running NHDP become disabled or removed, then the olsrv2AdminStatus MUST be 'disabled'. If the network manager, or other means, sets this object to 'disabled', then the associated interface specific objects, i.e., the olsrv2InterfaceAdminStatus objects MUST all be 'disabled'. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.1 | Olsrv2StatusTC | read-write | current |
| olsrv2InterfaceTable OBJECT-TYPE The olsrv2InterfaceTable describes the OLSRv2 status on the NHDP interfaces of this router. As such, this table augments the nhdpInterfaceTable defined in the NHDP-MIB (RFC 6779). NHDP interfaces are explicitly defined by network management, command line interface (CLI) or other means for interfaces on the device that are intended to run MANET protocols. The olsrv2InterfaceTable contains a single object: the olsrv2InterfaceAdminStatus object. This object is set by network management, or by other means, e.g., CLI. A conceptual row in this table exists if and only if a corresponding entry in the nhdpInterfaceTable exists. If the corresponding entry with nhdpIfIndex value is deleted from the nhdpInterfaceTable, then the entry in this table is automatically deleted and OLSRv2 is disabled on this interface, and all configuration and state information related to this interface is to be removed from memory. The olsrv2InterfaceAdminStatus can only be 'enabled' if the corresponding olsrv2AdminStatus object is also set to 'enabled'. | 1.3.6.1.2.1.219.1.1.2 | not-accessible | current | |
| olsrv2InterfaceEntry OBJECT-TYPE The olsrv2InterfaceEntry describes one OLSRv2 local interface configuration as indexed by its nhdpIfIndex, as defined in the NHDP-MIB (RFC 6779). The objects in this table are persistent, and when written, the device SHOULD save the change to non-volatile storage. For further information on the storage behavior for these objects, refer to the description for the nhdpIfRowStatus object in the NHDP-MIB (RFC6779). | 1.3.6.1.2.1.219.1.1.2.1 | not-accessible | current | |
| olsrv2InterfaceAdminStatus OBJECT-TYPE The OLSRv2 interface's administrative status. The value 'enabled(1)' denotes that the interface is permitted to participate in the OLSRv2 routing process. The value 'disabled(2)' denotes that the interface is not permitted to participate in the OLSRv2 routing process. The configuration objects for the OLSRv2 routing process, other than the administrative status objects, are common to all interfaces on this device. As such, the OLSRv2 configuration objects are globally defined for the device and are not contained within the olsrv2InterfaceTable. | 1.3.6.1.2.1.219.1.1.2.1.1 | Olsrv2StatusTC | read-create | current |
| olsrv2OrigIpAddrType OBJECT-TYPE The type of the olsrv2OrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.1.3 | InetAddressType {ipv4(1), ipv6(2)} | read-write | current |
| olsrv2OrigIpAddr OBJECT-TYPE The router's originator address. An address that is unique (within the MANET) to this router. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.4 | InetAddress (SIZE(4 | 16)) | read-write | current |
| olsrv2OHoldTime OBJECT-TYPE olsrv2OHoldTime corresponds to O_HOLD_TIME of OLSRv2, and represents the time for which a recently used and replaced originator address is used to recognize the router's own messages. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2OHoldTime > 0 This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.5 | Unsigned32 | read-write | current |
| olsrv2TcInterval OBJECT-TYPE olsrv2TcInterval corresponds to TC_INTERVAL of OLSRv2 and represents the maximum time between the transmission of two successive TC messages by this router. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2TcInterval > 0 o olsrv2TcInterval >= olsrv2TcMinInterval This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.6 | Olsrv2TimeValueCompressedForm32TC | read-write | current |
| olsrv2TcMinInterval OBJECT-TYPE olsrv2TcMinInterval corresponds to TC_MIN_INTERVAL of OLSRv2 and represents the minimum interval between transmission of two successive TC messages by this router. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2TcInterval >= olsrv2TcMinInterval The OLSRv2 protocol may choose to represent this time interval in terms of the 8-bit exponent-mantissa form defined in Section 5 of RFC 5497. When this is the case, this object value MUST be translated from the integer form represented in this MIB module into the exponent-mantissa form for the OLSRv2 protocol to use according to the algorithm defined in Section 5 of RFC 5497 for finding the next larger time value within the exponent-mantissa format. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.7 | Olsrv2TimeValueCompressedForm32TC | read-write | current |
| olsrv2THoldTime OBJECT-TYPE olsrv2THoldTime corresponds to T_HOLD_TIME of OLSRv2 and is used as the minimum value in the TLV with Type = VALIDITY_TIME included in all TC messages sent by this router. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2THoldTime >= olsrv2TcInterval o If TC messages can be lost, then olsrv2THoldTime SHOULD be significantly greater than olsrv2TcInterval; a value >= 3 x olsrv2TcInterval is RECOMMENDED. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.8 | Olsrv2TimeValueCompressedForm32TC | read-write | current |
| olsrv2AHoldTime OBJECT-TYPE olsrv2AHoldTime corresponds to A_HOLD_TIME of OLSRv2 and represents the period during which TC messages are sent after they no longer have any advertised information to report, but are sent in order to accelerate outdated information removal by other routers. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o If TC messages can be lost, then olsrv2AHoldTime SHOULD be significantly greater than olsrv2TcInterval; a value >= 3 x olsrv2TcInterval is RECOMMENDED. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.9 | Olsrv2TimeValueCompressedForm32TC | read-write | current |
| olsrv2RxHoldTime OBJECT-TYPE olsrv2RxHoldTime corresponds to RX_HOLD_TIME of OLSRv2 and represents the period after receipt of a message by the appropriate OLSRv2 interface of this router for which that information is recorded, in order that the message is recognized as having been previously received on this OLSRv2 interface. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2RxHoldTime > 0 o This parameter SHOULD be greater than the maximum difference in time that a message may take to traverse the MANET, taking into account any message forwarding jitter as well as propagation, queuing, and processing delays. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.10 | Unsigned32 | read-write | current |
| olsrv2PHoldTime OBJECT-TYPE olsrv2PHoldTime corresponds to P_HOLD_TIME of OLSRv2 and represents the period after receipt of a message that is processed by this router for which that information is recorded, in order that the message is not processed again if received again. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2PHoldTime > 0 o This parameter SHOULD be greater than the maximum difference in time that a message may take to traverse the MANET, taking into account any message forwarding jitter as well as propagation, queuing, and processing delays. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.11 | Unsigned32 | read-write | current |
| olsrv2FHoldTime OBJECT-TYPE olsrv2FHoldTime corresponds to F_HOLD_TIME of OLSRv2 and represents the period after receipt of a message that is forwarded by this router for which that information is recorded, in order that the message is not forwarded again if received again. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o olsrv2FHoldTime > 0 o This parameter SHOULD be greater than the maximum difference in time that a message may take to traverse the MANET, taking into account any message forwarding jitter as well as propagation, queuing, and processing delays. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.12 | Unsigned32 | read-write | current |
| olsrv2TpMaxJitter OBJECT-TYPE olsrv2TpMaxJitter corresponds to TP_MAXJITTER of OLSRv2 and represents the value of MAXJITTER used in RFC 5148 for periodically generated TC messages sent by this router. For constraints on these parameters, see RFC 5148. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.13 | Unsigned32 | read-write | current |
| olsrv2TtMaxJitter OBJECT-TYPE olsrv2TtMaxJitter corresponds to TT_MAXJITTER of OLSRv2 and represents the value of MAXJITTER used in RFC 5148 for externally triggered TC messages sent by this router. For constraints on these parameters, see RFC 5148. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.14 | Unsigned32 | read-write | current |
| olsrv2FMaxJitter OBJECT-TYPE olsrv2FMaxJitter corresponds to F_MAXJITTER of OLSRv2 and represents the default value of MAXJITTER used in RFC 5148 for messages forwarded by this router. For constraints on these parameters, see RFC 5148. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.15 | Unsigned32 | read-write | current |
| olsrv2TcHopLimit OBJECT-TYPE olsrv2TcHopLimit corresponds to TC_HOP_LIMIT of OLSRv2. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o The maximum value of olsrv2TcHopLimit >= the network diameter in hops, a value of 255 is RECOMMENDED. o olsrv2TcHopLimit >= 2. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.16 | Unsigned32 (0..255) | read-write | current |
| olsrv2WillRouting OBJECT-TYPE olsrv2WillRouting corresponds to WILL_ROUTING of OLSRv2. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o WILL_NEVER (0) <= olsrv2WillRouting <= WILL_ALWAYS (15) This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.17 | WillingnessTC | read-write | current |
| olsrv2WillFlooding OBJECT-TYPE olsrv2WillFlooding corresponds to WILL_FLOODING of OLSRv2. Guidance for setting this object may be found in Section 5 of the OLSRv2 specification (RFC 7181), which indicates that: o WILL_NEVER (0) <= olsrv2WillFlooding <= WILL_ALWAYS (15) This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.18 | WillingnessTC | read-write | current |
| olsrv2LinkMetricType OBJECT-TYPE olsrv2LinkMetricType corresponds to LINK_METRIC_TYPE of OLSRv2. If olsrv2LinkMetricType changes, then all link metric information recorded by this router is invalid. The router MUST take the actions described in Section 5.5. 'Parameter Change Constraints' and Section 17 'Information Base Changes' in RFC 7181. This object is persistent, and when written, the entity SHOULD save the change to non-volatile storage. | 1.3.6.1.2.1.219.1.1.19 | IANAolsrv2LinkMetricTypeTC | read-write | current |
| olsrv2StateGroup OBJECT-IDENTITY | 1.3.6.1.2.1.219.1.2 | |||
| olsrv2IibLinkSetTable OBJECT-TYPE A Link Set of an interface records all links from other routers that are, or recently were, 1-hop neighbors. | 1.3.6.1.2.1.219.1.2.1 | not-accessible | current | |
| olsrv2IibLinkSetEntry OBJECT-TYPE A Link Set consists of Link Tuples, each representing a single link indexed by the local and remote interface pair. Each Link Set from NHDP is extended by OLSRv2 by the following fields: (L_in_metric (olsrv2IibLinkSetInMetricValue), L_out_metric (olsrv2IibLinkSetOutMetricValue), L_mpr_selector (olsrv2IibLinkSetMprSelector)) | 1.3.6.1.2.1.219.1.2.1.1 | not-accessible | current | |
| olsrv2IibLinkSetInMetricValue OBJECT-TYPE olsrv2IibLinkSetInMetricValue is the metric of the link from the OLSRv2 interface with addresses L_neighbor_iface_addr_list to this OLSRv2 interface. The L_neighbor_iface_addr_list is identified by the nhdpDiscIfIndex, which is an index to the nhdpIibLinkSetTable, which this table augments. | 1.3.6.1.2.1.219.1.2.1.1.1 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2IibLinkSetOutMetricValue OBJECT-TYPE olsrv2IibLinkSetOutMetricValue is the metric of the link to the OLSRv2 interface with addresses L_neighbor_iface_addr_list from this OLSRv2 interface. The L_neighbor_iface_addr_list is identified by the nhdpDiscIfIndex, which is an index to the nhdpIibLinkSetTable, which this table augments. | 1.3.6.1.2.1.219.1.2.1.1.2 | Olsrv2MetricValueCompressedFormTC | read-write | current |
| olsrv2IibLinkSetMprSelector OBJECT-TYPE olsrv2IibLinkSetMprSelector is a boolean flag, recording whether this neighbor has selected this router as a flooding MPR, i.e., is a flooding MPR selector of this router. | 1.3.6.1.2.1.219.1.2.1.1.3 | TruthValue | read-only | current |
| olsrv2Iib2HopSetTable OBJECT-TYPE A 2-Hop Set of an interface records network addresses of symmetric 2-hop neighbors, and the symmetric links to symmetric 1-hop neighbors through which these symmetric 2-hop neighbors can be reached. It consists of 2-Hop Tuples. | 1.3.6.1.2.1.219.1.2.2 | not-accessible | current | |
| olsrv2Iib2HopSetEntry OBJECT-TYPE olsrv2Iib2HopSetTable consists of 2-Hop Tuples, each representing a single network address of a symmetric 2-hop neighbor and a single MANET interface of a symmetric 1-hop neighbor. Each 2-Hop Set from NHDP is extended by OLSRv2 by the following fields: (N2_in_metric (olsrv2Iib2HopSetInMetricValue), N2_out_metric (olsrv2Iib2HopSetOutMetricValue)) | 1.3.6.1.2.1.219.1.2.2.1 | not-accessible | current | |
| olsrv2Iib2HopSetInMetricValue OBJECT-TYPE olsrv2Iib2HopSetInMetricValue is the neighbor metric from the router with address N2_2hop_iface_addr to the router with OLSRv2 interface addresses N2_neighbor_iface_addr_list. The N2_2hop_iface_addr is identified by the (nhdpIib2HopSetIpAddressType, nhdpIib2HopSetIpAddress) pair from the nhdpIibLinkSetTable, which this table augments. The N2_neighbor_iface_addr_list is defined by the nhdpDiscIfIndex, which is an index of the nhdpIibLinkSetTable, which this table augments. | 1.3.6.1.2.1.219.1.2.2.1.1 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2Iib2HopSetOutMetricValue OBJECT-TYPE olsrv2Iib2HopSetOutMetricValue is the neighbor metric to the router with address N2_2hop_iface_addr from the router with OLSRv2 interface addresses N2_neighbor_iface_addr_list. The N2_2hop_iface_addr is identified by the (nhdpIib2HopSetIpAddressType, nhdpIib2HopSetIpAddress) pair from the nhdpIibLinkSetTable, which this table augments. The N2_neighbor_iface_addr_list is defined by the nhdpDiscIfIndex, which is an index of the nhdpIibLinkSetTable, which this table augments. | 1.3.6.1.2.1.219.1.2.2.1.2 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2LibOrigSetTable OBJECT-TYPE A router's Originator Set records addresses that were recently used as originator addresses by this router. | 1.3.6.1.2.1.219.1.2.3 | not-accessible | current | |
| olsrv2LibOrigSetEntry OBJECT-TYPE A router's Originator Set consists of Originator Tuples: (O_orig_addr (olsrv2LibOrigSetIpAddrType and olsrv2LibOrigSetIpAddr), O_time (olsrv2LibOrigSetExpireTime)). | 1.3.6.1.2.1.219.1.2.3.1 | not-accessible | current | |
| olsrv2LibOrigSetIpAddrType OBJECT-TYPE The type of the olsrv2LibOrigSetIpAddr, as defined in the InetAddress MIB (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.3.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2LibOrigSetIpAddr OBJECT-TYPE An originator address recently employed by this router. | 1.3.6.1.2.1.219.1.2.3.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2LibOrigSetExpireTime OBJECT-TYPE olsrv2LibOrigSetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2LibOrigSetTable. This time is determined at the time the entry is added, derived from the following expression: O_time := current time + O_HOLD_TIME where O_time is olsrv2LibOrigSetExpireTime, current_time is current sysUptime, and O_HOLD_TIME is a parameter of the OLSRv2 protocol. In the event that the O_HOLD_TIME is changed, the olsrv2LibOrigSetExpireTime needs to be recomputed for each of the entries in this table. | 1.3.6.1.2.1.219.1.2.3.1.3 | TimeStamp | read-only | current |
| olsrv2LibLocAttNetSetTable OBJECT-TYPE A router's Local Attached Network Set records its local non-OLSRv2 interfaces via which it can act as a gateway to other networks. | 1.3.6.1.2.1.219.1.2.4 | not-accessible | current | |
| olsrv2LibLocAttNetSetEntry OBJECT-TYPE The entries include the Local Attached Network Tuples: (AL_net_addr (olsrv2LibLocAttNetSetIpAddr), AL_dist (olsrv2LibLocAttNetSetDistance), AL_metric (olsrv2LibLocAttNetSetMetricValue) ) where: AL_net_addr is the network address of an attached network that can be reached via this router. The AL_net_addr is defined in this MIB module by the tuple (olsrv2LibLocAttNetSetIpAddrType, olsrv2LibLocAttNetSetIpAddr, olsrv2LibLocAttNetSetIpAddrPrefixLen). AL_dist is the number of hops to the network with address AL_net_addr from this router. The AL_dist is defined in this MIB module by the olsrv2LibLocAttNetSetDistance object. AL_metric is the metric of the link to the attached network with address AL_net_addr from this router. The AL_metric is defined in this MIB module by the olsrv2LibLocAttNetSetMetricValue object. OLSRv2 (RFC 7181) defines the rules for managing entries within this table, e.g., populating and purging entries. Specific instructions for the olsrv2LibLocAttNetSetEntry(s) are found in Sections 7.2 and 17 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.2.4.1 | not-accessible | current | |
| olsrv2LibLocAttNetSetIpAddrType OBJECT-TYPE The type of the olsrv2LibLocAttNetSetIpAddr, as defined in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.4.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2LibLocAttNetSetIpAddr OBJECT-TYPE This is the network address of an attached network that can be reached via this router. | 1.3.6.1.2.1.219.1.2.4.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2LibLocAttNetSetIpAddrPrefixLen OBJECT-TYPE Indicates the number of leading one bits that form the mask to be logically ANDed with the destination address before being compared to the value in the olsrv2LibLocAttNetSetIpAddr field. | 1.3.6.1.2.1.219.1.2.4.1.3 | InetAddressPrefixLength | not-accessible | current |
| olsrv2LibLocAttNetSetDistance OBJECT-TYPE This object specifies the number of hops to the network with address olsrv2LibLocAttNetSetIpAddr from this router. | 1.3.6.1.2.1.219.1.2.4.1.4 | Unsigned32 (1..255) | read-only | current |
| olsrv2LibLocAttNetSetMetricValue OBJECT-TYPE This object specifies the metric of the link to the attached network with address AL_net_addr from this router. The AL_net_addr is defined by the tuple (olsrv2LibLocAttNetSetIpAddrType, olsrv2LibLocAttNetSetIpAddr, olsrv2LibLocAttNetSetIpAddrPrefixLen). | 1.3.6.1.2.1.219.1.2.4.1.5 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2NibNeighborSetTable OBJECT-TYPE A router's Neighbor Set records all network addresses of each 1-hop neighbor. It consists of Neighbor Tuples, each representing a single 1-hop neighbor. | 1.3.6.1.2.1.219.1.2.5 | not-accessible | current | |
| olsrv2NibNeighborSetEntry OBJECT-TYPE Each Neighbor Tuple in the Neighbor Set, defined in RFC 6130, has these additional elements: N_orig_addr (olsrv2NibNeighborSetNOrigIpAddrType, olsrv2NibNeighborSetNOrigIpAddr) N_in_metric (olsrv2NibNeighborSetNInMetricValue) N_out_metric (olsrv2NibNeighborSetNOutMetricValue) N_will_flooding (olsrv2NibNeighborSetNWillFlooding) N_will_routing (olsrv2NibNeighborSetNWillRouting) N_flooding_mpr (olsrv2NibNeighborSetNFloodingMpr) N_routing_mpr (olsrv2NibNeighborSetNRoutingMpr) N_mpr_selector (olsrv2NibNeighborSetNMprSelector) N_advertised (olsrv2NibNeighborSetNAdvertised) defined here as extensions. | 1.3.6.1.2.1.219.1.2.5.1 | not-accessible | current | |
| olsrv2NibNeighborSetNOrigIpAddrType OBJECT-TYPE The type of the olsrv2NibNeighborSetNOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.5.1.1 | InetAddressType {ipv4(1), ipv6(2)} | read-only | current |
| olsrv2NibNeighborSetNOrigIpAddr OBJECT-TYPE This is the originator IP address of the neighbor represented by this table entry. | 1.3.6.1.2.1.219.1.2.5.1.2 | InetAddress (SIZE(4 | 16)) | read-only | current |
| olsrv2NibNeighborSetNInMetricValue OBJECT-TYPE This object is the neighbor metric of any link from this neighbor to an OLSRv2 interface of this router, i.e., the minimum of all corresponding L_in_metric (olsrv2IibLinkSetInMetricValue) with L_status = SYMMETRIC and L_in_metric (olsrv2IibLinkSetInMetricValue) != UNKNOWN_METRIC, UNKNOWN_METRIC if there are no such Link Tuples. UNKNOWN_METRIC has a value of 0. | 1.3.6.1.2.1.219.1.2.5.1.3 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2NibNeighborSetNOutMetricValue OBJECT-TYPE This object is the neighbor metric of any link from an OLSRv2 interface of this router to this neighbor, i.e., the minimum of all corresponding L_out_metric (olsrv2IibLinkSetOutMetricValue) with L_status = SYMMETRIC and L_out_metric (olsrv2IibLinkSetOutMetricValue) != UNKNOWN_METRIC, UNKNOWN_METRIC if there are no such Link Tuples. UNKNOWN_METRIC has a value of 0. | 1.3.6.1.2.1.219.1.2.5.1.4 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2NibNeighborSetNWillFlooding OBJECT-TYPE This object is the neighbor's willingness to be selected as a flooding MPR, in the range from WILL_NEVER to WILL_ALWAYS, both inclusive, taking the value WILL_NEVER if no OLSRv2 specific information is received from this neighbor. | 1.3.6.1.2.1.219.1.2.5.1.5 | WillingnessTC | read-only | current |
| olsrv2NibNeighborSetNWillRouting OBJECT-TYPE This object is the neighbor's willingness to be selected as a routing MPR, in the range from WILL_NEVER to WILL_ALWAYS, both inclusive, taking the value WILL_NEVER if no OLSRv2 specific information is received from this neighbor. | 1.3.6.1.2.1.219.1.2.5.1.6 | WillingnessTC | read-only | current |
| olsrv2NibNeighborSetNFloodingMpr OBJECT-TYPE This object is a boolean flag, recording whether this neighbor is selected as a flooding MPR by this router. | 1.3.6.1.2.1.219.1.2.5.1.7 | TruthValue | read-only | current |
| olsrv2NibNeighborSetNRoutingMpr OBJECT-TYPE This object is a boolean flag, recording whether this neighbor is selected as a routing MPR by this router. | 1.3.6.1.2.1.219.1.2.5.1.8 | TruthValue | read-only | current |
| olsrv2NibNeighborSetNMprSelector OBJECT-TYPE This object is a boolean flag, recording whether this neighbor has selected this router as a routing MPR, i.e., is a routing MPR selector of this router. When set to 'true', then this router is selected as a routing MPR by the neighbor router. When set to 'false', then this router is not selected by the neighbor as a routing MPR. | 1.3.6.1.2.1.219.1.2.5.1.9 | TruthValue | read-only | current |
| olsrv2NibNeighborSetNAdvertised OBJECT-TYPE This object, N_mpr_selector (olsrv2NibNeighborSetNMprSelector), is a boolean flag, recording whether this router has elected to advertise a link to this neighbor in its TC messages. | 1.3.6.1.2.1.219.1.2.5.1.10 | TruthValue | read-only | current |
| olsrv2NibNeighborSetTableAnsn OBJECT-TYPE Advertised Neighbor Sequence Number (ANSN), is a variable, whose value is included in TC messages to indicate the freshness of the information transmitted. | 1.3.6.1.2.1.219.1.2.6 | Unsigned32 (0..65535) | read-only | current |
| olsrv2TibAdRemoteRouterSetTable OBJECT-TYPE A router's Advertising Remote Router Set records information describing each remote router in the network that transmits TC messages. | 1.3.6.1.2.1.219.1.2.7 | not-accessible | current | |
| olsrv2TibAdRemoteRouterSetEntry OBJECT-TYPE A router's Advertised Neighbor Set Table entry consists of Advertising Remote Router Tuples: (AR_orig_addr (olsrv2TibAdRemoteRouterSetIpAddrType, olsrv2TibAdRemoteRouterSetIpAddr), AR_seq_number (olsrv2TibAdRemoteRouterSetMaxSeqNo), AR_time (olsrv2TibAdRemoteRouterSetExpireTime). Addresses associated with this router are found in the NHDP-MIB module's nhdpDiscIfSetTable. OLSRv2 (RFC 7181) defines the rules for managing entries within this table, e.g., populating and purging entries. Specific instructions for the olsrv2TibAdRemoteRouterSetEntry(s) are found in Section 10.1 and Section 17 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.2.7.1 | not-accessible | current | |
| olsrv2TibAdRemoteRouterSetIpAddrType OBJECT-TYPE The type of the olsrv2TibAdRemoteRouterSetIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.7.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibAdRemoteRouterSetIpAddr OBJECT-TYPE This is the originator address of a received TC message. | 1.3.6.1.2.1.219.1.2.7.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibAdRemoteRouterSetMaxSeqNo OBJECT-TYPE This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address olsrv2TibAdRemoteRouterSetIpAddr. Sequence numbers are used in the OLSRv2 protocol for the purpose of discarding 'old' information, i.e., messages received out of order. However, with a limited number of bits for representing sequence numbers, wraparound (that the sequence number is incremented from the maximum possible value to zero) will occur. To prevent this from interfering with the operation of this protocol, OLSRv2 implementations observe the following when determining the ordering of sequence numbers. In OLSRv2, MAXVALUE designates one more than the largest possible value for a sequence number. For a 16-bit sequence number, MAXVALUE is 65536. The sequence number S1 is said to be 'greater than' the sequence number S2 if: o S1 > S2 AND S1 - S2 < MAXVALUE/2 OR o S2 > S1 AND S2 - S1 > MAXVALUE/2 When sequence numbers S1 and S2 differ by MAXVALUE/2, their ordering cannot be determined. In this case, which should not occur, either ordering may be assumed. Thus, when comparing two messages, it is possible - even in the presence of wraparound - to determine which message contains the most recent information. | 1.3.6.1.2.1.219.1.2.7.1.3 | Unsigned32 (0..65535) | read-only | current |
| olsrv2TibAdRemoteRouterSetExpireTime OBJECT-TYPE olsrv2TibAdRemoteRouterSetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibAdRemoteRouterSetTable. | 1.3.6.1.2.1.219.1.2.7.1.4 | TimeStamp | read-only | current |
| olsrv2TibRouterTopologySetTable OBJECT-TYPE A router's Router Topology Set records topology information about the network. | 1.3.6.1.2.1.219.1.2.8 | not-accessible | current | |
| olsrv2TibRouterTopologySetEntry OBJECT-TYPE It consists of Router Topology Tuples: (TR_from_orig_addr (olsrv2TibRouterTopologySetFromOrigIpAddrType, olsrv2TibRouterTopologySetFromOrigIpAddr), TR_to_orig_addr (olsrv2TibRouterTopologySetToOrigIpAddrType, olsrv2TibRouterTopologySetToOrigIpAddr), TR_seq_number (olsrv2TibRouterTopologySetSeqNo), TR_metric (olsrv2TibRouterTopologySetMetricValue), TR_time (olsrv2TibRouterTopologySetExpireTime)). OLSRv2 (RFC 7181) defines the rules for managing entries within this table, e.g., populating and purging entries. Specific instructions for the olsrv2TibRouterTopologySetEntry(s) are found in Section 10.2 and Section 17 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.2.8.1 | not-accessible | current | |
| olsrv2TibRouterTopologySetFromOrigIpAddrType OBJECT-TYPE The type of the olsrv2TibRouterTopologySetFromOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.8.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibRouterTopologySetFromOrigIpAddr OBJECT-TYPE This is the originator address of a router that can reach the router with originator address TR_to_orig_addr in one hop. | 1.3.6.1.2.1.219.1.2.8.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibRouterTopologySetToOrigIpAddrType OBJECT-TYPE The type of the olsrv2TibRouterTopologySetToOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.8.1.3 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibRouterTopologySetToOrigIpAddr OBJECT-TYPE This is the originator address of a router that can be reached by the router with originator address TR_to_orig_addr in one hop. | 1.3.6.1.2.1.219.1.2.8.1.4 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibRouterTopologySetSeqNo OBJECT-TYPE This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address TR_from_orig_addr, i.e., that contributed to the information contained in this Tuple and that is defined by the objects: (olsrv2TibRouterTopologySetFromOrigIpAddrType, olsrv2TibRouterTopologySetFromOrigIpAddr). Sequence numbers are used in the OLSRv2 protocol for the purpose of discarding 'old' information, i.e., messages received out of order. However, with a limited number of bits for representing sequence numbers, wraparound (that the sequence number is incremented from the maximum possible value to zero) will occur. To prevent this from interfering with the operation of this protocol, OLSRv2 implementations observe the following when determining the ordering of sequence numbers. In OLSRv2, MAXVALUE designates one more than the largest possible value for a sequence number. For a 16-bit sequence number, MAXVALUE is 65536. The sequence number S1 is said to be 'greater than' the sequence number S2 if: o S1 > S2 AND S1 - S2 < MAXVALUE/2 OR o S2 > S1 AND S2 - S1 > MAXVALUE/2 When sequence numbers S1 and S2 differ by MAXVALUE/2, their ordering cannot be determined. In this case, which should not occur, either ordering may be assumed. Thus, when comparing two messages, it is possible - even in the presence of wraparound - to determine which message contains the most recent information. | 1.3.6.1.2.1.219.1.2.8.1.5 | Unsigned32 (0..65535) | read-only | current |
| olsrv2TibRouterTopologySetMetricValue OBJECT-TYPE This is the neighbor metric from the router with originator address TR_from_orig_addr (olsrv2TibRouterTopologySetFromOrigIpAddrType, olsrv2TibRouterTopologySetFromOrigIpAddr) to the router with originator address TR_to_orig_addr (olsrv2TibRouterTopologySetToOrigIpAddrType, olsrv2TibRouterTopologySetToOrigIpAddr). | 1.3.6.1.2.1.219.1.2.8.1.6 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2TibRouterTopologySetExpireTime OBJECT-TYPE olsrv2TibRouterTopologySetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibRouterTopologySetTable. | 1.3.6.1.2.1.219.1.2.8.1.7 | TimeStamp | read-only | current |
| olsrv2TibRoutableAddressTopologySetTable OBJECT-TYPE A router's Routable Address Topology Set records topology information about the routable addresses within the MANET, including via which routers they may be reached. | 1.3.6.1.2.1.219.1.2.9 | not-accessible | current | |
| olsrv2TibRoutableAddressTopologySetEntry OBJECT-TYPE It consists of Router Topology Tuples: (TA_from_orig_addr (olsrv2TibRoutableAddressTopologySetFromOrigIpAddrType olsrv2TibRoutableAddressTopologySetFromOrigIpAddr), TA_dest_addr (olsrv2TibRoutableAddressTopologySetFromDestIpAddrType olsrv2TibRoutableAddressTopologySetFromDestIpAddr), TA_seq_number (olsrv2TibRoutableAddressTopologySetSeqNo) TA_metric (olsrv2TibRoutableAddressTopologySetMetricValue) TA_time (olsrv2TibRoutableAddressTopologySetExpireTime) ) OLSRv2 (RFC 7181) defines the rules for managing entries within this table, e.g., populating and purging entries. Specific instructions for the olsrv2TibRoutableAddressTopologySetEntry(s) are found in Section 10.3 and Section 17 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.2.9.1 | not-accessible | current | |
| olsrv2TibRoutableAddressTopologySetFromOrigIpAddrType OBJECT-TYPE The type of the olsrv2TibRoutableAddressTopologySetFromOrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.9.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibRoutableAddressTopologySetFromOrigIpAddr OBJECT-TYPE This is the originator address of a router that can reach the router with routable address TA_dest_addr in one hop. | 1.3.6.1.2.1.219.1.2.9.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibRoutableAddressTopologySetDestIpAddrType OBJECT-TYPE The type of the olsrv2TibRouterTopologySetToOrigIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.9.1.3 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibRoutableAddressTopologySetDestIpAddr OBJECT-TYPE This is a routable address of a router that can be reached by the router with originator address TA_from_orig_addr in one hop. The TA_from_orig_addr is defined by the tuple (olsrv2TibRoutableAddressTopologySetFromOrigIpAddrType olsrv2TibRoutableAddressTopologySetFromOrigIpAddr). | 1.3.6.1.2.1.219.1.2.9.1.4 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibRoutableAddressTopologySetSeqNo OBJECT-TYPE This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address TA_from_orig_addr, i.e., that contributed to the information contained in this Tuple. The TA_from_orig_addr is defined by the tuple (olsrv2TibRoutableAddressTopologySetFromOrigIpAddrType olsrv2TibRoutableAddressTopologySetFromOrigIpAddr). | 1.3.6.1.2.1.219.1.2.9.1.5 | Unsigned32 (0..65535) | read-only | current |
| olsrv2TibRoutableAddressTopologySetMetricValue OBJECT-TYPE This is the neighbor metric from the router with originator address TA_from_orig_addr (defined by the tuple (olsrv2TibRoutableAddressTopologySetFromOrigIpAddrType olsrv2TibRoutableAddressTopologySetFromOrigIpAddr)) to the router with OLSRv2 interface address TA_dest_addr (defined by the tuple (olsrv2TibRoutableAddressTopologySetFromDestIpAddrType olsrv2TibRoutableAddressTopologySetFromDestIpAddr)). | 1.3.6.1.2.1.219.1.2.9.1.6 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2TibRoutableAddressTopologySetExpireTime OBJECT-TYPE olsrv2TibRoutableAddressTopologySetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibRoutableAddressTopologySetTable. | 1.3.6.1.2.1.219.1.2.9.1.7 | TimeStamp | read-only | current |
| olsrv2TibAttNetworksSetTable OBJECT-TYPE A router's Attached Network Set records information about networks (which may be outside the MANET) attached to other routers and their routable addresses. | 1.3.6.1.2.1.219.1.2.10 | not-accessible | current | |
| olsrv2TibAttNetworksSetEntry OBJECT-TYPE It consists of Attached Network Tuples: (AN_orig_addr (olsrv2TibAttNetworksSetOrigIpAddrType, olsrv2TibAttNetworksSetOrigIpAddr), AN_net_addr (olsrv2TibAttNetworksSetNetIpAddrType, olsrv2TibAttNetworksSetNetIpAddr, olsrv2TibAttNetworksSetNetIpAddrPrefixLen), AN_seq_number (olsrv2TibAttNetworksSetSeqNo), AN_dist (olsrv2TibAttNetworksSetDist), AN_metric (olsrv2TibAttNetworksSetMetricValue), AN_time (olsrv2TibAttNetworksSetExpireTime) ) OLSRv2 (RFC 7181) defines the rules for managing entries within this table, e.g., populating and purging entries. Specific instructions for the olsrv2TibRoutableAddressTopologySetEntry(s) are found in Section 10.4 and Section 17 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.2.10.1 | not-accessible | current | |
| olsrv2TibAttNetworksSetOrigIpAddrType OBJECT-TYPE The type of the olsrv2TibAttNetworksSetOrigIpAddr, as defined in the InetAddress MIB module (RFC4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.10.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibAttNetworksSetOrigIpAddr OBJECT-TYPE This is the originator address, of type olsrv2TibAttNetworksSetOrigIpAddrType, of a router that can act as gateway to the network with address AN_net_addr. The AN_net_addr is defined by the tuple (olsrv2TibAttNetworksSetNetIpAddrType, olsrv2TibAttNetworksSetNetIpAddr, olsrv2TibAttNetworksSetNetIpAddrPrefixLen). | 1.3.6.1.2.1.219.1.2.10.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibAttNetworksSetNetIpAddrType OBJECT-TYPE The type of the olsrv2TibAttNetworksSetNetIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.10.1.3 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibAttNetworksSetNetIpAddr OBJECT-TYPE This is the network address, of type olsrv2TibAttNetworksSetNetIpAddrType, of an attached network, that may be reached via the router with originator address AN_orig_addr. The AN_orig_addr is defined by the tuple (olsrv2TibAttNetworksSetOrigIpAddrType, olsrv2TibAttNetworksSetOrigIpAddr). | 1.3.6.1.2.1.219.1.2.10.1.4 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibAttNetworksSetNetIpAddrPrefixLen OBJECT-TYPE Indicates the number of leading one bits that form the mask to be logically ANDed with the destination address before being compared to the value in the olsrv2TibAttNetworksSetNetIpAddr field. | 1.3.6.1.2.1.219.1.2.10.1.5 | InetAddressPrefixLength | not-accessible | current |
| olsrv2TibAttNetworksSetSeqNo OBJECT-TYPE This is the greatest Advertised Neighbor Sequence Number (ANSN) in any TC message received that originated from the router with originator address AN_orig_addr (i.e., that contributed to the information contained in this Tuple). The AN_orig_addr is defined by the tuple (olsrv2TibAttNetworksSetOrigIpAddrType, olsrv2TibAttNetworksSetOrigIpAddr). Sequence numbers are used in the OLSRv2 protocol for the purpose of discarding 'old' information, i.e., messages received out of order. However, with a limited number of bits for representing sequence numbers, wraparound (that the sequence number is incremented from the maximum possible value to zero) will occur. To prevent this from interfering with the operation of this protocol, the following MUST be observed when determining the ordering of sequence numbers. The term MAXVALUE designates in the following one more than the largest possible value for a sequence number. For a 16-bit sequence number (as are those defined in this specification), MAXVALUE is 65536. The sequence number S1 is said to be 'greater than' the sequence number S2 if: o S1 > S2 AND S1 - S2 < MAXVALUE/2 OR o S2 > S1 AND S2 - S1 > MAXVALUE/2 When sequence numbers S1 and S2 differ by MAXVALUE/2, their ordering cannot be determined. In this case, which should not occur, either ordering may be assumed. Thus, when comparing two messages, it is possible - even in the presence of wraparound - to determine which message contains the most recent information. | 1.3.6.1.2.1.219.1.2.10.1.6 | Unsigned32 (0..65535) | read-only | current |
| olsrv2TibAttNetworksSetDist OBJECT-TYPE The number of hops to the network with address AN_net_addr from the router with originator address AN_orig_addr. The AN_orig_addr is defined by the tuple (olsrv2TibAttNetworksSetOrigIpAddrType, olsrv2TibAttNetworksSetOrigIpAddr). | 1.3.6.1.2.1.219.1.2.10.1.7 | Unsigned32 (0..255) | read-only | current |
| olsrv2TibAttNetworksSetMetricValue OBJECT-TYPE The metric of the link from the router with originator address AN_orig_addr to the attached network with address AN_net_addr. The AN_net_addr is defined by the tuple (olsrv2TibAttNetworksSetNetIpAddrType, olsrv2TibAttNetworksSetNetIpAddr, olsrv2TibAttNetworksSetNetIpAddrPrefixLen). | 1.3.6.1.2.1.219.1.2.10.1.9 | Olsrv2MetricValueCompressedFormTC | read-only | current |
| olsrv2TibAttNetworksSetExpireTime OBJECT-TYPE olsrv2TibAttNetworksSetExpireTime specifies the value of sysUptime when this entry SHOULD expire and be removed from the olsrv2TibAttNetworksSetTable. | 1.3.6.1.2.1.219.1.2.10.1.10 | TimeStamp | read-only | current |
| olsrv2TibRoutingSetTable OBJECT-TYPE A router's Routing Set records the first hop along a selected path to each destination for which any such path is known. | 1.3.6.1.2.1.219.1.2.11 | not-accessible | current | |
| olsrv2TibRoutingSetEntry OBJECT-TYPE It consists of Routing Tuples: (R_dest_addr, R_next_iface_addr, R_local_iface_addr, R_dist, R_metric) | 1.3.6.1.2.1.219.1.2.11.1 | not-accessible | current | |
| olsrv2TibRoutingSetDestIpAddrType OBJECT-TYPE The type of the olsrv2TibRoutingSetDestIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.11.1.1 | InetAddressType {ipv4(1), ipv6(2)} | not-accessible | current |
| olsrv2TibRoutingSetDestIpAddr OBJECT-TYPE This is the address of the destination, either the address of an interface of a destination router or the network address of an attached network. | 1.3.6.1.2.1.219.1.2.11.1.2 | InetAddress (SIZE(4 | 16)) | not-accessible | current |
| olsrv2TibRoutingSetDestIpAddrPrefixLen OBJECT-TYPE Indicates the number of leading one bits that form the mask to be logically ANDed with the destination address before being compared to the value in the olsrv2TibRoutingSetDestIpAddr field. Note: This definition needs to be consistent with the current forwarding table MIB module description. Specifically, it SHOULD allow for longest prefix matching of network addresses. | 1.3.6.1.2.1.219.1.2.11.1.3 | InetAddressPrefixLength | not-accessible | current |
| olsrv2TibRoutingSetNextIfIpAddrType OBJECT-TYPE The type of the olsrv2TibRoutingSetNextIfIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.11.1.4 | InetAddressType {ipv4(1), ipv6(2)} | read-only | current |
| olsrv2TibRoutingSetNextIfIpAddr OBJECT-TYPE This object is the OLSRv2 interface address of the next hop on the selected path to the destination. | 1.3.6.1.2.1.219.1.2.11.1.5 | InetAddress (SIZE(4 | 16)) | read-only | current |
| olsrv2TibRoutingSetLocalIfIpAddrType OBJECT-TYPE The type of the olsrv2TibRoutingSetLocalIfIpAddr and olsrv2TibRoutingSetNextIfIpAddr, as defined in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported. | 1.3.6.1.2.1.219.1.2.11.1.6 | InetAddressType {ipv4(1), ipv6(2)} | read-only | current |
| olsrv2TibRoutingSetLocalIfIpAddr OBJECT-TYPE This object is the address of the local OLSRv2 interface over which a packet must be sent to reach the destination by the selected path. | 1.3.6.1.2.1.219.1.2.11.1.7 | InetAddress (SIZE(4 | 16)) | read-only | current |
| olsrv2TibRoutingSetDist OBJECT-TYPE This object is the number of hops on the selected path to the destination. | 1.3.6.1.2.1.219.1.2.11.1.8 | Unsigned32 (0..255) | read-only | current |
| olsrv2TibRoutingSetMetricValue OBJECT-TYPE This object is the metric of the route to the destination with address R_dest_addr. The maximum value of this object can be 256 times MAXIMUM_METRIC, as represented in Olsrv2MetricValueCompressedFormTC, i.e., 4294901760. | 1.3.6.1.2.1.219.1.2.11.1.9 | Unsigned32 (0..4294901760) | read-only | current |
| olsrv2PerformanceObjGrp OBJECT-IDENTITY | 1.3.6.1.2.1.219.1.3 | |||
| olsrv2InterfacePerfTable OBJECT-TYPE This table summarizes performance objects that are measured per each active local OLSRv2 interface. If the olsrv2InterfaceAdminStatus of the interface changes to 'disabled', then the row associated with this interface SHOULD be removed from this table. | 1.3.6.1.2.1.219.1.3.1 | not-accessible | current | |
| olsrv2InterfacePerfEntry OBJECT-TYPE A single entry contains performance counters for each active local OLSRv2 interface. | 1.3.6.1.2.1.219.1.3.1.1 | not-accessible | current | |
| olsrv2IfTcMessageXmits OBJECT-TYPE A counter is incremented each time a TC message has been transmitted on that interface. | 1.3.6.1.2.1.219.1.3.1.1.1 | Counter32 | read-only | current |
| olsrv2IfTcMessageRecvd OBJECT-TYPE A counter is incremented each time a TC message has been received on that interface. This excludes all messages that are ignored due to OLSRv2 protocol procedures, such as messages considered invalid for processing by this router, as defined in Section 16.3.1 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.3.1.1.2 | Counter32 | read-only | current |
| olsrv2IfTcMessageXmitAccumulatedSize OBJECT-TYPE A counter is incremented by the number of octets in a TC message each time a TC message has been sent. | 1.3.6.1.2.1.219.1.3.1.1.3 | Counter64 | read-only | current |
| olsrv2IfTcMessageRecvdAccumulatedSize OBJECT-TYPE A counter is incremented by the number of octets in a TC message each time a TC message has been received. This excludes all messages that are ignored due to OLSRv2 protocol procedures, such as messages considered invalid for processing by this router, as defined in Section 16.3.1 of OLSRv2 (RFC 7181). | 1.3.6.1.2.1.219.1.3.1.1.4 | Counter64 | read-only | current |
| olsrv2IfTcMessageTriggeredXmits OBJECT-TYPE A counter is incremented each time a triggered TC message has been sent. | 1.3.6.1.2.1.219.1.3.1.1.5 | Counter32 | read-only | current |
| olsrv2IfTcMessagePeriodicXmits OBJECT-TYPE A counter is incremented each time a periodic TC message has been sent. | 1.3.6.1.2.1.219.1.3.1.1.6 | Counter32 | read-only | current |
| olsrv2IfTcMessageForwardedXmits OBJECT-TYPE A counter is incremented each time a TC message has been forwarded. | 1.3.6.1.2.1.219.1.3.1.1.7 | Counter32 | read-only | current |
| olsrv2IfTcMessageXmitAccumulatedMPRSelectorCount OBJECT-TYPE A counter is incremented by the number of advertised MPR selectors in a TC each time a TC message has been sent. | 1.3.6.1.2.1.219.1.3.1.1.8 | Counter32 | read-only | current |
| olsrv2RoutingSetRecalculationCount OBJECT-TYPE This counter increments each time the Routing Set has been recalculated. | 1.3.6.1.2.1.219.1.3.2 | Counter32 | read-only | current |
| olsrv2MPRSetRecalculationCount OBJECT-TYPE This counter increments each time the MPRs of this router have been recalculated for any of its interfaces. | 1.3.6.1.2.1.219.1.3.3 | Counter32 | read-only | current |
| olsrv2MIBConformance OBJECT-IDENTITY | 1.3.6.1.2.1.219.2 | |||
| olsrv2Compliances OBJECT-IDENTITY | 1.3.6.1.2.1.219.2.1 | |||
| olsrv2MIBGroups OBJECT-IDENTITY | 1.3.6.1.2.1.219.2.2 |
Notifications
| Name | OID | Status |
|---|---|---|
| olsrv2RouterStatusChange NOTIFICATION-TYPE olsrv2RouterStatusChange is a notification generated when the OLSRv2 router changes it status. The router status is maintained in the olsrv2AdminStatus object. | 1.3.6.1.2.1.219.0.0.1 | current |
| olsrv2OrigIpAddrChange NOTIFICATION-TYPE olsrv2OrigIpAddrChange is a notification generated when the OLSRv2 router changes it originator IP address. The notification includes the new and the previous originator IP address of the OLSRv2 router. | 1.3.6.1.2.1.219.0.0.2 | current |
| olsrv2RoutingSetRecalculationCountChange NOTIFICATION-TYPE The olsrv2RoutingSetRecalculationCountChange notification is generated when a significant number of Routing Set recalculations have occurred in a short time. This notification SHOULD be generated no more than once per olsrv2RoutingSetRecalculationCountWindow. The network administrator SHOULD select appropriate values for 'significant number of Routing Set recalculations' and 'short time' through the settings of the olsrv2RoutingSetRecalculationCountThreshold and olsrv2RoutingSetRecalculationCountWindow objects. | 1.3.6.1.2.1.219.0.0.3 | current |
| olsrv2MPRSetRecalculationCountChange NOTIFICATION-TYPE The olsrv2MPRSetRecalculationCountChange notification is generated when a significant number of MPR set recalculations occur in a short period of time. This notification SHOULD be generated no more than once per olsrv2MPRSetRecalculationCountWindow. The network administrator SHOULD select appropriate values for 'significant number of MPR set recalculations' and 'short period of time' through the settings of the olsrv2MPRSetRecalculationCountThreshold and olsrv2MPRSetRecalculationCountWindow objects. | 1.3.6.1.2.1.219.0.0.4 | current |
Conformance
| Name | OID | Status |
|---|---|---|
| olsrv2BasicCompliance MODULE-COMPLIANCE The basic implementation requirements for managed network entities that implement the OLSRv2 routing process. | 1.3.6.1.2.1.219.2.1.1 | current |
| olsrv2FullCompliance MODULE-COMPLIANCE The full implementation requirements for managed network entities that implement the OLSRv2 routing process. | 1.3.6.1.2.1.219.2.1.2 | current |
| olsrv2ConfigObjectsGroup OBJECT-GROUP Objects to permit configuration of OLSRv2. All of these SHOULD be backed by non-volatile storage. | 1.3.6.1.2.1.219.2.2.1 | current |
| olsrv2StateObjectsGroup OBJECT-GROUP Objects to permit monitoring of OLSRv2 state. | 1.3.6.1.2.1.219.2.2.2 | current |
| olsrv2PerfObjectsGroup OBJECT-GROUP Objects to support monitoring of OLSRv2 performance. | 1.3.6.1.2.1.219.2.2.3 | current |
| olsrv2NotificationsObjectsGroup OBJECT-GROUP Objects to support the notification types in the olsrv2NotificationsGroup. Some of these appear in notification payloads, others serve to control notification generation. | 1.3.6.1.2.1.219.2.2.4 | current |
| olsrv2NotificationsGroup NOTIFICATION-GROUP Notification types to support management of OLSRv2. | 1.3.6.1.2.1.219.2.2.5 | current |