MIBs Depot

NHDP-MIB

Registered at
1.3.6.1.2.1.213
Last updated
2016-07-12 00:00
Organization
IETF MANET Working Group
Revisions
2016-07-12 00:00, 2012-10-22 10:00
Namespace
standard
Source file
NHDP-MIB
Digest
sha256:39cc24e03c60c56d3a07f1d2e2b3772626230bd9f5f9beca40fa9f02d8848f14

Description

This NHDP-MIB module is applicable to routers implementing the Mobile Ad Hoc Network (MANET) Neighborhood Discovery Protocol (NHDP) defined in RFC 6130. Copyright (c) 2016 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).

Contact

WG Email: manet@ietf.org WG web page: https://datatracker.ietf.org/wg/manet Editors: Ulrich Herberg United States of America ulrich@herberg.name http://www.herberg.name/ Robert G. Cole US Army CERDEC Space and Terrestrial Communications 6010 Frankford Street Aberdeen Proving Ground, Maryland 21005 United States of America +1 443 395-8744 robert.g.cole@us.army.mil http://www.cs.jhu.edu/~rgcole/ Ian D Chakeres Delvin Ellicott City, Maryland 21042 United States of America ian.chakeres@gmail.com http://www.ianchak.com/ Thomas Heide Clausen Ecole Polytechnique LIX 91128 Palaiseau Cedex France Email: T.Clausen@computer.org URI: http://www.thomasclausen.org/

Imports

FromSymbols
FLOAT-TC-MIBFloat32TC
IF-MIBInterfaceIndex
INET-ADDRESS-MIBInetAddress, InetAddressPrefixLength, InetAddressType
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, Counter64, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, TimeTicks, Unsigned32, iso, mib-2
SNMPv2-TCDisplayString, RowStatus, TEXTUAL-CONVENTION, TimeStamp, TruthValue

Imported by

1 module(s) in this corpus import this one.

Load order

Every file a consumer needs in order to load this module, dependencies first.

FLOAT-TC-MIB
IANAifType-MIB
IF-MIB
INET-ADDRESS-MIB
NHDP-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC

Textual conventions

NameOIDSyntaxAccessStatus
NeighborIfIndex
TEXTUAL-CONVENTION
An arbitrary, locally unique identifier associated with a virtual interface of a discovered NHDP neighbor. Due to the nature of NHDP, the local router may not know if two distinct addresses belong to the same interface of a neighbor or to two different interfaces. As the local router gains more knowledge of its neighbors, its local view may change, and this table will be updated to reflect the local router's current understanding, associating address sets to neighbor interfaces. The local router identifies a virtual neighbor interface through the receipt of address lists advertised through an NHDP HELLO message. All objects of type NeighborIfIndex are assigned by the agent out of a common number space. The value for each discovered virtual neighbor interface may not remain constant from one re-initialization of the entity's network management agent to the next re-initialization. If the local router gains information associating two virtual interfaces on a neighbor as a common interface, then the agent MUST aggregate the two address sets to a single index chosen from the set of aggregated indexes, and it MUST update all tables in this MIB module that are indexed by indexes of type NeighborIfIndex. It MAY then reuse freed index values following the next agent restart. The specific value is meaningful only within a given SNMP entity.
current
NeighborRouterIndex
TEXTUAL-CONVENTION
An arbitrary, locally unique identifier associated with a virtual discovered neighbor (one or two hop). Due to the nature of NHDP, the local router may identify multiple virtual neighbors that, in fact, are one and the same. Neighbors that are two hops away with more than one advertised address will exhibit this behavior. As the local router's knowledge of its neighbors' topology increases, the local router will be able to associate multiple virtual neighbor indexes into a single virtual neighbor index chosen from the set of aggregated indexes; it MUST update all tables in this MIB module indexed by these indexes, and it MAY reuse the freed indexes following the next agent re-initialization. All objects of type NeighborRouterIndex are assigned by the agent out of a common number space. The NeighborRouterIndex defines a discovered NHDP peer virtual neighbor of the local router. The value for each discovered virtual neighbor index MUST remain constant at least from one re-initialization of the entity's network management agent to the next re-initialization, except if an application is deleted and re-created. The specific value is meaningful only within a given SNMP entity. A NeighborRouterIndex value MUST NOT be reused until the next agent restart.
current

Objects

NameOIDSyntaxAccessStatus
nhdpNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.213.0
nhdpNotificationsObjects
OBJECT-IDENTITY
1.3.6.1.2.1.213.0.0
nhdpNotificationsControl
OBJECT-IDENTITY
1.3.6.1.2.1.213.0.1
nhdpNbrStateChangeThreshold
OBJECT-TYPE
A threshold value for the nhdpNbrStateChange object. If the number of occurrences exceeds this threshold within the previous nhdpNbrStateChangeWindow, then the nhdpNbrStateChange notification is to be sent. It is recommended that the value of this threshold be set to at least 10 and higher in dense topologies with frequent expected topology changes.
1.3.6.1.2.1.213.0.1.1Integer32 (0..255)read-writecurrent
nhdpNbrStateChangeWindow
OBJECT-TYPE
A time window for the nhdpNbrStateChange object. If the number of occurrences exceeds the nhdpNbrStateChangeThreshold within the previous nhdpNbrStateChangeWindow, then the nhdpNbrStateChange notification is to be sent. It is recommended that the value for this window be set to at least 5 times the nhdpHelloInterval. This object represents the time in hundredths of a second.
1.3.6.1.2.1.213.0.1.2TimeTicksread-writecurrent
nhdp2HopNbrStateChangeThreshold
OBJECT-TYPE
A threshold value for the nhdp2HopNbrStateChange object. If the number of occurrences exceeds this threshold within the previous nhdp2HopNbrStateChangeWindow, then the nhdp2HopNbrStateChange notification is to be sent. It is recommended that the value of this threshold be set to at least 10 and higher when topologies are expected to be highly dynamic.
1.3.6.1.2.1.213.0.1.3Integer32 (0..255)read-writecurrent
nhdp2HopNbrStateChangeWindow
OBJECT-TYPE
A time window for the nhdp2HopNbrStateChange object. If the number of occurrences exceeds the nhdp2HopNbrStateChangeThreshold within the previous nhdp2HopNbrStateChangeWindow, then the nhdp2HopNbrStateChange notification is to be sent. It is recommended that the value for this window be set to at least 5 times nhdpHelloInterval. This object represents the time in hundredths of a second.
1.3.6.1.2.1.213.0.1.4TimeTicksread-writecurrent
nhdpNotificationsStates
OBJECT-IDENTITY
1.3.6.1.2.1.213.0.2
nhdpNbrState
OBJECT-TYPE
NHDP neighbor states. In NHDP, it is not necessary to remove Protocol Tuples from Protocol Sets at the exact time indicated, only to behave as if the Protocol Tuples were removed at that time. This case is indicated here as 'down(0)', all other cases being indicated as 'asymmetric(1)' or 'symmetric(2)'. If 'down(0)', the direct neighbor is also added to the nhdpNibLostNeighborSetTable.
1.3.6.1.2.1.213.0.2.1INTEGER {down(0), asymmetric(1), symmetric(2)}read-onlycurrent
nhdp2HopNbrState
OBJECT-TYPE
NHDP 2-hop neighbor states. In NHDP, it is not necessary to remove Protocol Tuples from Protocol Sets at the exact time indicated, only to behave as if the Protocol Tuples were removed at that time. This case is indicated here as 'down(0)'; otherwise, it is either 'up(1)', if N2_lost for the 2-Hop Tuple is equal to false, or 'notconsidered(2)' otherwise.
1.3.6.1.2.1.213.0.2.2INTEGER {down(0), up(1), notconsidered(2)}read-onlycurrent
nhdpObjects
OBJECT-IDENTITY
1.3.6.1.2.1.213.1
nhdpConfigurationObjGrp
OBJECT-IDENTITY
1.3.6.1.2.1.213.1.1
nhdpInterfaceTable
OBJECT-TYPE
The nhdpInterfaceTable describes the configuration of the interfaces of this router that are intended to use MANET control protocols. As such, this table 'sparse augments' the ifTable specifically when NHDP is to be configured to operate over this interface. The interface is identified by the ifIndex from the Interfaces Group defined in the Interfaces Group MIB module. A conceptual row in this table exists if and only if the row has been administratively created or there is an interface on the managed device that supports and runs NHDP. A row can be administratively created by setting rowStatus to 'createAndGo' or 'createAndWait'. During the row creation, objects having associated DEFVAL clauses are automatically defined by the agent if not explicitly administratively defined. For each entry in the nhdpInterfaceTable, there is a corresponding entry in the Interface Table where nhdpIfIndex and ifIndex are equal. If that corresponding entry in the Interface Table is deleted, then the entry in the nhdpInterfaceTable is automatically deleted, NHDP is disabled on this interface, and all configuration and state information related to this interface is to be removed from memory.
1.3.6.1.2.1.213.1.1.1not-accessiblecurrent
nhdpInterfaceEntry
OBJECT-TYPE
The nhdpInterfaceEntry describes one NHDP local interface configuration as indexed by its ifIndex as defined in the Standard MIB II Interface Table (RFC 2863). The objects in this table are persistent, and when written, the device SHOULD save the change to nonvolatile storage. For further information on the storage behavior for these objects, refer to the description for the nhdpIfRowStatus object.
1.3.6.1.2.1.213.1.1.1.1not-accessiblecurrent
nhdpIfIndex
OBJECT-TYPE
This value MUST correspond to an ifIndex referring to a valid entry in the Interfaces Table.
1.3.6.1.2.1.213.1.1.1.1.1InterfaceIndexnot-accessiblecurrent
nhdpIfName
OBJECT-TYPE
The textual name of the interface. The value of this object SHOULD be the name of the interface as assigned by the local device. This can be a text-name, such as 'le0' or a simple port number, such as '1', depending on the interface-naming syntax of the device. If there is no local name or this object is otherwise not applicable, then this object contains a zero-length string.
1.3.6.1.2.1.213.1.1.1.1.2SnmpAdminStringread-onlycurrent
nhdpIfStatus
OBJECT-TYPE
nhdpIfStatus indicates whether this interface is currently running NHDP. A value of 'true(1)' indicates that NHDP is running on this interface. A value of 'false(2)' indicates that NHDP is not currently running on this interface. This corresponds to the I_manet parameter in the Local Interface Set of NHDP.
1.3.6.1.2.1.213.1.1.1.1.3TruthValueread-createcurrent
nhdpHelloInterval
OBJECT-TYPE
nhdpHelloInterval corresponds to HELLO_INTERVAL of NHDP and represents the maximum time between the transmission of two successive HELLO messages on this MANET interface. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o nhdpHelloInterval > 0 o nhdpHelloInterval >= nhdpHelloMinInterval
1.3.6.1.2.1.213.1.1.1.1.4Unsigned32read-createcurrent
nhdpHelloMinInterval
OBJECT-TYPE
nhdpHelloMinInterval corresponds to HELLO_MIN_INTERVAL of NHDP and represents the minimum interval between transmission of two successive HELLO messages on this MANET interface. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o nhdpHelloMinInterval <= nhdpHelloInterval
1.3.6.1.2.1.213.1.1.1.1.5Unsigned32read-createcurrent
nhdpRefreshInterval
OBJECT-TYPE
nhdpRefreshInterval corresponds to REFRESH_INTERVAL of NHDP and represents the maximum interval between advertisements of each 1-hop neighbor network address and its status. Each advertisement is in a HELLO message on this MANET interface. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o nhdpRefreshInterval >= nhdpHelloInterval
1.3.6.1.2.1.213.1.1.1.1.6Unsigned32read-createcurrent
nhdpLHoldTime
OBJECT-TYPE
nhdpLHoldTime corresponds to L_HOLD_TIME of NHDP and represents the period of advertisement, on this MANET interface, of former 1-hop neighbor network addresses as lost in HELLO messages, allowing recipients of these HELLO messages to accelerate removal of this information from their Link Sets. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that it should be assigned a value significantly greater than the refresh interval held by nhdpRefreshInterval.
1.3.6.1.2.1.213.1.1.1.1.7Unsigned32read-createcurrent
nhdpHHoldTime
OBJECT-TYPE
nhdpHHoldTime corresponds to H_HOLD_TIME of NHDP and is used as the value in the VALIDITY_TIME Message TLV included in all HELLO messages on this MANET interface. It is then used by each router receiving such a HELLO message to indicate the validity of the information taken from that HELLO message and recorded in the receiving router's Information Bases. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that it should be assigned a value significantly greater than the refresh interval held by nhdpRefreshInterval and must be representable as described in RFC 5497.
1.3.6.1.2.1.213.1.1.1.1.8Unsigned32read-createcurrent
nhdpHystAcceptQuality
OBJECT-TYPE
nhdpHystAcceptQuality corresponds to HYST_ACCEPT of NHDP and represents the link quality threshold at or above which a link becomes usable, if it was not already so. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o 0 <= nhdpHystRejectQuality <= nhdpHystAcceptQuality <= 1.0 The default value for this object is 1.0. According to RFC 6340: Since these textual conventions are defined in terms of the OCTET STRING type, the SMI's mechanisms for formally setting range constraints are not available. MIB designers using these textual conventions will need to use DESCRIPTION clauses to spell out any applicable range constraints beyond those implied by the underlying IEEE types. Therefore, this object does not have a DEFVAL clause.
1.3.6.1.2.1.213.1.1.1.1.9Float32TCread-createcurrent
nhdpHystRejectQuality
OBJECT-TYPE
nhdpHystRejectQuality corresponds to HYST_REJECT of NHDP and represents the link quality threshold below which a link becomes unusable, if it was not already so. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o 0 <= nhdpHystRejectQuality <= nhdpHystAcceptQuality <= 1.0 The default value for this object is 0.0. According to RFC 6340: Since these textual conventions are defined in terms of the OCTET STRING type, the SMI's mechanisms for formally setting range constraints are not available. MIB designers using these textual conventions will need to use DESCRIPTION clauses to spell out any applicable range constraints beyond those implied by the underlying IEEE types. Therefore, this object does not have a DEFVAL clause.
1.3.6.1.2.1.213.1.1.1.1.10Float32TCread-createcurrent
nhdpInitialQuality
OBJECT-TYPE
nhdpInitialQuality corresponds to INITIAL_QUALITY of NHDP and represents the initial quality of a newly identified link. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o 0 <= nhdpInitialQuality <= 1.0 The default value for this object is 1.0. According to RFC 6340: Since these textual conventions are defined in terms of the OCTET STRING type, the SMI's mechanisms for formally setting range constraints are not available. MIB designers using these textual conventions will need to use DESCRIPTION clauses to spell out any applicable range constraints beyond those implied by the underlying IEEE types. Therefore, this object does not have a DEFVAL clause.
1.3.6.1.2.1.213.1.1.1.1.11Float32TCread-createcurrent
nhdpInitialPending
OBJECT-TYPE
nhdpInitialPending corresponds to INITIAL_PENDING of NHDP. If the value of this object is 'true(1)', then a newly identified link is considered pending and is not usable until the link quality has reached or exceeded the nhdpHystAcceptQuality threshold. Guidance for setting this object may be found in Section 5 of the NHDP specification (RFC 6130), which indicates that: o If nhdpInitialQuality >= nhdpHystAcceptQuality, then nhdpInitialPending := false(2). o If nhdpInitialQuality < nhdpHystRejectQuality, then nhdpInitialPending := true(1).
1.3.6.1.2.1.213.1.1.1.1.12TruthValueread-createcurrent
nhdpHpMaxJitter
OBJECT-TYPE
nhdpHpMaxJitter corresponds to HP_MAXJITTER of NHDP and represents the value of MAXJITTER used in RFC 5148 for periodically generated HELLO messages on this MANET interface. Guidance for setting this object may be found in Section 5 of RFC 5148, which indicates that: o nhdpHpMaxJitter <= nhdpHelloInterval / 2 o nhdpHpMaxJitter should not be greater than nhdpHelloInterval / 4 o If nhdpMinHelloInterval > 0, then nhdpHpMaxJitter <= nhdpHelloMinInterval; and nhdpHpMaxJitter should not be greater than nhdpHelloMinInterval / 2
1.3.6.1.2.1.213.1.1.1.1.13Unsigned32read-createcurrent
nhdpHtMaxJitter
OBJECT-TYPE
nhdpHtMaxJitter corresponds to HT_MAXJITTER of NHDP and represents the value of MAXJITTER used in RFC 5148 for externally triggered HELLO messages on this MANET interface. Guidance for setting this object may be found in Section 5 of RFC 5148, which indicates that: o nhdpHtMaxJitter <= nhdpHelloInterval / 2 o nhdpHtMaxJitter should not be greater than nhdpHelloInterval / 4 o If nhdpMinHelloInterval > 0, then nhdpHtMaxJitter <= nhdpHelloMinInterval; and nhdpHtMaxJitter should not be greater than nhdpHelloMinInterval / 2
1.3.6.1.2.1.213.1.1.1.1.14Unsigned32read-createcurrent
nhdpIfRowStatus
OBJECT-TYPE
This object permits management of the table by facilitating actions such as row creation, construction, and destruction. The value of this object has no effect on whether other objects in this conceptual row can be modified. An entry may not exist in the 'active(1)' state unless all objects in the entry have a defined appropriate value. For objects with DEFVAL clauses, the management station does not need to specify the value of this object in order for the row to transit to the 'active(1)' state; the default value for this object is used. For objects that do not have DEFVAL clauses, the value of this object prior to this row transitioning to the 'active(1)' state MUST be administratively specified. When this object transitions to 'active(1)', all objects in this row SHOULD be written to nonvolatile (stable) storage. Read-create objects in this row MAY be modified. When an object in a row with nhdpIfRowStatus of 'active(1)' is changed, then the updated value MUST be reflected in NHDP, and this new object value MUST be written to nonvolatile storage. If the value of this object is not equal to 'active(1)', all associated entries in the nhdpLibLocalIfSetTable, nhdpInterfaceStateTable, nhdpIibLinkSetTable, and nhdpInterfacePerfTable MUST be deleted.
1.3.6.1.2.1.213.1.1.1.1.15RowStatusread-createcurrent
nhdpNHoldTime
OBJECT-TYPE
nhdpNHoldTime corresponds to N_HOLD_TIME of NHDP and is used as the period during which former 1-hop neighbor network addresses are advertised as lost in HELLO messages, allowing recipients of these HELLO messages to accelerate removal of this information from their 2-Hop Sets. This object is persistent, and when written, the entity SHOULD save the change to nonvolatile storage.
1.3.6.1.2.1.213.1.1.2Unsigned32read-writecurrent
nhdpIHoldTime
OBJECT-TYPE
nhdpIHoldTime corresponds to I_HOLD_TIME of NHDP and represents the period for which a recently used local interface network address is recorded. This object is persistent, and when written, the entity SHOULD save the change to nonvolatile storage.
1.3.6.1.2.1.213.1.1.3Unsigned32read-writecurrent
nhdpLibLocalIfSetTable
OBJECT-TYPE
A router's Local Interface Set records all network addresses that are defined as local MANET interface network addresses. As such, this table 'sparse augments' the nhdpInterfaceTable when network addresses are being defined for the interfaces existing within the nhdpInterfaceTable. The local interface is defined by the nhdpIfIndex. The Local Interface Set consists of Local Interface Address Tuples per MANET interface and their prefix lengths (in order to determine the network addresses related to the interface). A conceptual row in this table exists if and only if one has been administratively created. This can be done by setting rowStatus to 'createAndGo' or 'createAndWait'. Further guidance on the addition or removal of local addresses and network addresses is found in Section 9 of RFC 6130.
1.3.6.1.2.1.213.1.1.4not-accessiblecurrent
nhdpLibLocalIfSetEntry
OBJECT-TYPE
A router's Local Interface Set consists of Local Interface Tuples for each network interface. The objects in this table are persistent, and when written, the device SHOULD save the change to nonvolatile storage. For further information on the storage behavior for these objects, refer to the description for the nhdpLibLocalIfSetRowStatus object.
1.3.6.1.2.1.213.1.1.4.1not-accessiblecurrent
nhdpLibLocalIfSetIndex
OBJECT-TYPE
The index for this table. Necessary because multiple addresses may be associated with a given nhdpIfIndex.
1.3.6.1.2.1.213.1.1.4.1.1Integer32 (0..65535)not-accessiblecurrent
nhdpLibLocalIfSetIfIndex
OBJECT-TYPE
Specifies the local nhdpIfIndex for which this IP address was added.
1.3.6.1.2.1.213.1.1.4.1.2InterfaceIndexread-onlycurrent
nhdpLibLocalIfSetIpAddrType
OBJECT-TYPE
The type of the nhdpLibLocalIfSetIpAddr in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported.
1.3.6.1.2.1.213.1.1.4.1.3InetAddressTyperead-createcurrent
nhdpLibLocalIfSetIpAddr
OBJECT-TYPE
nhdpLibLocalIfSetIpAddr is an address of an interface of this router. This object is interpreted according to the setting of nhdpLibLocalIfSetIpAddrType.
1.3.6.1.2.1.213.1.1.4.1.4InetAddress (SIZE(4 | 16))read-createcurrent
nhdpLibLocalIfSetIpAddrPrefixLen
OBJECT-TYPE
Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpLibLocalIfSetIpAddr to determine the address prefix. A row match is true if the address used as an index falls within the network address range defined by the address prefix.
1.3.6.1.2.1.213.1.1.4.1.5InetAddressPrefixLengthread-createcurrent
nhdpLibLocalIfSetRowStatus
OBJECT-TYPE
This object permits management of the table by facilitating actions such as row creation, construction, and destruction. The value of this object has no effect on whether other objects in this conceptual row can be modified. An entry may not exist in the 'active(1)' state unless all read-create objects in the entry have a defined appropriate value. As no objects in this table have DEFVAL clauses, the management station MUST specify the values of all read-create objects prior to this row transitioning to the 'active(1)' state. When this object transitions to 'active(1)', all objects in this row SHOULD be written to nonvolatile (stable) storage. Read-create objects in this row MAY be modified. When an object in a row with nhdpIfRowStatus of 'active(1)' is changed, then the updated value MUST be reflected in NHDP, and this new object value MUST be written to nonvolatile storage.
1.3.6.1.2.1.213.1.1.4.1.6RowStatusread-createcurrent
nhdpLibRemovedIfAddrSetTable
OBJECT-TYPE
A router's Removed Interface Address Set records network addresses that were recently used as local interface network addresses. If a router's interface network addresses are immutable, then the Removed Interface Address Set is always empty and may be omitted. It consists of Removed Interface Address Tuples, one per network address.
1.3.6.1.2.1.213.1.1.5not-accessiblecurrent
nhdpLibRemovedIfAddrSetEntry
OBJECT-TYPE
A router's Removed Interface Address Set consists of Removed Interface Address Tuples, one per network address: (IR_local_iface_addr, IR_time) The association between these addresses and the router's Interface is found in RFC 4293 (ipAddressTable)
1.3.6.1.2.1.213.1.1.5.1not-accessiblecurrent
nhdpLibRemovedIfAddrSetIndex
OBJECT-TYPE
The index for this table. Necessary because multiple addresses may be associated with a given nhdpIfIndex.
1.3.6.1.2.1.213.1.1.5.1.1Integer32 (0..65535)not-accessiblecurrent
nhdpLibRemovedIfAddrSetIpAddrType
OBJECT-TYPE
The type of the nhdpLibRemovedIfAddrSetIpAddr in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported.
1.3.6.1.2.1.213.1.1.5.1.2InetAddressTyperead-onlycurrent
nhdpLibRemovedIfAddrSetIpAddr
OBJECT-TYPE
nhdpLibRemovedIfAddrSetIpAddr is a recently used address of an interface of this router.
1.3.6.1.2.1.213.1.1.5.1.3InetAddress (SIZE(4 | 16))read-onlycurrent
nhdpLibRemovedIfAddrSetIpAddrPrefixLen
OBJECT-TYPE
Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpLibRemovedIfAddrSetIpAddr to determine the address prefix. A row match is true if the address used as an index falls within the network address range defined by the address prefix.
1.3.6.1.2.1.213.1.1.5.1.4InetAddressPrefixLengthread-onlycurrent
nhdpLibRemovedIfAddrSetIfIndex
OBJECT-TYPE
Specifies the local IfIndex from which this IP address was recently removed.
1.3.6.1.2.1.213.1.1.5.1.5InterfaceIndexread-onlycurrent
nhdpLibRemovedIfAddrSetIRTime
OBJECT-TYPE
nhdpLibRemovedIfAddrSetIRTime specifies the value of sysUpTime when this entry should expire and be removed from the nhdpLibRemovedIfAddrSetTable.
1.3.6.1.2.1.213.1.1.5.1.6TimeStampread-onlycurrent
nhdpStateObjGrp
OBJECT-IDENTITY
1.3.6.1.2.1.213.1.2
nhdpUpTime
OBJECT-TYPE
The value of sysUpTime at the time the current NHDP process was initialized.
1.3.6.1.2.1.213.1.2.1TimeStampread-onlycurrent
nhdpInterfaceStateTable
OBJECT-TYPE
nhdpInterfaceStateTable lists state information related to specific interfaces of this router. The value of nhdpIfIndex is an ifIndex from the Interfaces Group defined in the Interfaces Group MIB. The objects in this table are persistent, and when written, the entity SHOULD save the change to nonvolatile storage.
1.3.6.1.2.1.213.1.2.2not-accessiblecurrent
nhdpInterfaceStateEntry
OBJECT-TYPE
nhdpInterfaceStateEntry describes one NHDP local interface state as indexed by its nhdpIfIndex.
1.3.6.1.2.1.213.1.2.2.1not-accessiblecurrent
nhdpIfStateUpTime
OBJECT-TYPE
The value of the sysUpTime when NHDP was last initialized on this MANET interface.
1.3.6.1.2.1.213.1.2.2.1.1TimeStampread-onlycurrent
nhdpDiscIfSetTable
OBJECT-TYPE
A router's set of discovered interfaces on neighboring routers.
1.3.6.1.2.1.213.1.2.3not-accessiblecurrent
nhdpDiscIfSetEntry
OBJECT-TYPE
The entries include the nhdpDiscRouterIndex of the discovered router, the nhdpDiscIfIndex of the discovered interface, and the current set of addresses associated with this neighbor interface. The nhdpDiscIfIndex uniquely identifies the remote interface address sets through this table. It does not need to be unique across the MANET but MUST be locally unique within this router.
1.3.6.1.2.1.213.1.2.3.1not-accessiblecurrent
nhdpDiscIfSetIndex
OBJECT-TYPE
The index for this table. Necessary because multiple addresses may be associated with a given nhdpDiscIfIndex.
1.3.6.1.2.1.213.1.2.3.1.1Integer32 (0..65535)not-accessiblecurrent
nhdpDiscIfIndex
OBJECT-TYPE
The NHDP interface index (locally created) of a neighbor's interface. Used for cross- indexing into other NHDP tables and other MIB modules.
1.3.6.1.2.1.213.1.2.3.1.2NeighborIfIndexread-onlycurrent
nhdpDiscRouterIndex
OBJECT-TYPE
The NHDP neighbor index (locally created) of a neighboring router. Used for cross- indexing into other NHDP tables and other MIB modules.
1.3.6.1.2.1.213.1.2.3.1.3NeighborRouterIndexread-onlycurrent
nhdpDiscIfSetIpAddrType
OBJECT-TYPE
The type of the nhdpDiscIfSetIpAddr in the InetAddress MIB (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported.
1.3.6.1.2.1.213.1.2.3.1.4InetAddressTyperead-onlycurrent
nhdpDiscIfSetIpAddr
OBJECT-TYPE
The nhdpDiscIfSetIpAddr is a recently used address of a neighbor of this router.
1.3.6.1.2.1.213.1.2.3.1.5InetAddress (SIZE(4 | 16))read-onlycurrent
nhdpDiscIfSetIpAddrPrefixLen
OBJECT-TYPE
Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpDiscIfSetIpAddr to determine the address prefix. A row match is true if the address used as an index falls within the network address range defined by the address prefix.
1.3.6.1.2.1.213.1.2.3.1.6InetAddressPrefixLengthread-onlycurrent
nhdpIibLinkSetTable
OBJECT-TYPE
A Link Set of an interface records all links from other routers that are, or recently were, 1-hop neighbors.
1.3.6.1.2.1.213.1.2.4not-accessiblecurrent
nhdpIibLinkSetEntry
OBJECT-TYPE
A Link Set consists of Link Tuples, each representing a single link indexed by the local and remote interface pair: (L_neighbor_iface_addr_list, L_HEARD_time, L_SYM_time, L_quality, L_pending, L_lost, L_time). The local interface is indexed via the nhdpIfIndex. The 1-hop interface is indexed via the nhdpDiscIfIndex. There SHOULD be an entry in this table for each local interface and associated 1-hop neighbor reachable on this local interface. Note that L_quality is not included in the entries below, because updates may be required too frequently.
1.3.6.1.2.1.213.1.2.4.1not-accessiblecurrent
nhdpIibLinkSetLHeardTime
OBJECT-TYPE
nhdpIibLinkSetLHeardTime corresponds to L_HEARD_time of NHDP and represents the time up to which the MANET interface of the 1-hop neighbor would be considered heard if not considering link quality.
1.3.6.1.2.1.213.1.2.4.1.1TimeStampread-onlycurrent
nhdpIibLinkSetLSymTime
OBJECT-TYPE
nhdpIibLinkSetLSymTime corresponds to L_SYM_time of NHDP and represents the time up to which the link to the 1-hop neighbor would be considered symmetric if not considering link quality.
1.3.6.1.2.1.213.1.2.4.1.2TimeStampread-onlycurrent
nhdpIibLinkSetLPending
OBJECT-TYPE
nhdpIibLinkSetLPending corresponds to L_pending of NHDP and is a boolean flag, describing if a link is considered pending (i.e., a candidate, but not yet established, link).
1.3.6.1.2.1.213.1.2.4.1.3TruthValueread-onlycurrent
nhdpIibLinkSetLLost
OBJECT-TYPE
nhdpIibLinkSetLLost corresponds to L_lost of NHDP and is a boolean flag, describing if a link is considered lost due to low link quality.
1.3.6.1.2.1.213.1.2.4.1.4TruthValueread-onlycurrent
nhdpIibLinkSetLTime
OBJECT-TYPE
nhdpIibLinkSetLTime specifies the value of sysUpTime when this entry should expire and be removed from the nhdpIibLinkSetTable.
1.3.6.1.2.1.213.1.2.4.1.5TimeStampread-onlycurrent
nhdpIib2HopSetTable
OBJECT-TYPE
A 2-Hop Set of an interface records network addresses of symmetric 2-hop neighbors and the symmetric links to symmetric 1-hop neighbors through which these symmetric 2-hop neighbors can be reached. It consists of 2-Hop Tuples.
1.3.6.1.2.1.213.1.2.5not-accessiblecurrent
nhdpIib2HopSetEntry
OBJECT-TYPE
nhdpIib2HopSetTable consists of 2-Hop Tuples, each representing a single network address of a symmetric 2-hop neighbor and a single MANET interface of a symmetric 1-hop neighbor. (N2_neighbor_iface_addr_list, N2_2hop_addr, N2_lost, N2_time). The entries include: - the 2-hop neighbor addresses ('N2_neighbor_iface_addr_list'), which act as the table index, - the associated symmetric 1-hop neighbor address set ('N2_2hop_addr'), designated through nhdpDiscIfIndex, - a flag indicating if the 1-hop neighbor through which this 2-hop neighbor is reachable ('N2_lost') is considered lost due to link quality, or not, - and the expiration time ('N2_time'). The nhdpIfIndex in the INDEX is the interface index of the local interface through which these 2-hop addresses are accessible. The nhdpDiscIfIndex in the INDEX represents the 1-hop neighbor interface through which these 2-hop neighbor addresses are reachable.
1.3.6.1.2.1.213.1.2.5.1not-accessiblecurrent
nhdpIib2HopSetIpAddressType
OBJECT-TYPE
The type of the nhdpIib2HopSetIpAddress in the InetAddress MIB module (RFC 4001). Only the values 'ipv4(1)' and 'ipv6(2)' are supported.
1.3.6.1.2.1.213.1.2.5.1.1InetAddressTypenot-accessiblecurrent
nhdpIib2HopSetIpAddress
OBJECT-TYPE
nhdpIib2HopSetIpAddr corresponds to N2_2hop_addr of NHDP and is a network address of a symmetric 2-hop neighbor that has a symmetric link (using any MANET interface) to the indicated symmetric 1-hop neighbor.
1.3.6.1.2.1.213.1.2.5.1.2InetAddress (SIZE(4 | 16))not-accessiblecurrent
nhdpIib2HopSetIpAddrPrefixLen
OBJECT-TYPE
Indicates the number of leading one bits that form the mask. The mask is logically ANDed to the nhdpIib2HopSetIpAddress to determine the address prefix. A row match is true if the address used as an index falls within the network address range defined by the address prefix.
1.3.6.1.2.1.213.1.2.5.1.3InetAddressPrefixLengthread-onlycurrent
nhdpIib2HopSet1HopIfIndex
OBJECT-TYPE
nhdpIib2HopSet1HopIfIndex is nhdpDiscIfIndex of the 1-hop neighbor that communicated the ipAddress of the 2-hop neighbor in this row entry.
1.3.6.1.2.1.213.1.2.5.1.4NeighborIfIndexread-onlycurrent
nhdpIib2HopSetN2Time
OBJECT-TYPE
nhdpIib2HopSetN2Time specifies the value of sysUpTime when this entry should expire and be removed from the nhdpIib2HopSetTable.
1.3.6.1.2.1.213.1.2.5.1.5TimeStampread-onlycurrent
nhdpIib2HopSetN2Lost
OBJECT-TYPE
nhdpIib2HopSetN2Lost corresponds to N2_lost of NHDP and is a boolean flag, describing if for a 2-Hop Tuple, the corresponding Link Tuple currently is considered lost due to link quality.
1.3.6.1.2.1.213.1.2.5.1.6TruthValueread-onlycurrent
nhdpNibNeighborSetTable
OBJECT-TYPE
A router's Neighbor Set records all network addresses of each 1-hop neighbor.
1.3.6.1.2.1.213.1.2.6not-accessiblecurrent
nhdpNibNeighborSetEntry
OBJECT-TYPE
A router's Neighbor Set consists of Neighbor Tuples, each representing a single 1-hop neighbor: (N_neighbor_addr_list, N_symmetric)
1.3.6.1.2.1.213.1.2.6.1not-accessiblecurrent
nhdpNibNeighborSetNSymmetric
OBJECT-TYPE
nhdpNibNeighborNSymmetric corresponds to N_symmetric of NHDP and is a boolean flag, describing if this is a symmetric 1-hop neighbor.
1.3.6.1.2.1.213.1.2.6.1.1TruthValueread-onlycurrent
nhdpNibLostNeighborSetTable
OBJECT-TYPE
A router's Lost Neighbor Set records network addresses of routers that were recently symmetric 1-hop neighbors but are now advertised as lost.
1.3.6.1.2.1.213.1.2.7not-accessiblecurrent
nhdpNibLostNeighborSetEntry
OBJECT-TYPE
A router's Lost Neighbor Set consists of Lost Neighbor Tuples, each representing a single such network address: (NL_neighbor_addr, NL_time)
1.3.6.1.2.1.213.1.2.7.1not-accessiblecurrent
nhdpNibLostNeighborSetNLTime
OBJECT-TYPE
nhdpNibLostNeighborSetNLTime specifies the value of sysUpTime when this entry should expire and be removed from the nhdpNibLostNeighborSetTable.
1.3.6.1.2.1.213.1.2.7.1.1TimeStampread-onlycurrent
nhdpPerformanceObjGrp
OBJECT-IDENTITY
1.3.6.1.2.1.213.1.3
nhdpInterfacePerfTable
OBJECT-TYPE
This table summarizes performance objects that are measured per local NHDP interface. nhdpIfPerfCounterDiscontinuityTime indicates the most recent occasion at which any one or more of this interface's counters listed in this table suffered a discontinuity.
1.3.6.1.2.1.213.1.3.1not-accessiblecurrent
nhdpInterfacePerfEntry
OBJECT-TYPE
A single entry contains performance counters for a local NHDP interface.
1.3.6.1.2.1.213.1.3.1.1not-accessiblecurrent
nhdpIfHelloMessageXmits
OBJECT-TYPE
A counter is incremented each time a HELLO message has been transmitted on that interface.
1.3.6.1.2.1.213.1.3.1.1.1Counter32read-onlycurrent
nhdpIfHelloMessageRecvd
OBJECT-TYPE
A counter is incremented each time a HELLO message has been received on that interface.
1.3.6.1.2.1.213.1.3.1.1.2Counter32read-onlycurrent
nhdpIfHelloMessageXmitAccumulatedSize
OBJECT-TYPE
A counter is incremented by the number of octets in a HELLO message each time a HELLO message has been sent.
1.3.6.1.2.1.213.1.3.1.1.3Counter64read-onlycurrent
nhdpIfHelloMessageRecvdAccumulatedSize
OBJECT-TYPE
A counter is incremented by the number of octets in a HELLO message each time a HELLO message has been received.
1.3.6.1.2.1.213.1.3.1.1.4Counter64read-onlycurrent
nhdpIfHelloMessageTriggeredXmits
OBJECT-TYPE
A counter is incremented each time a triggered HELLO message has been sent.
1.3.6.1.2.1.213.1.3.1.1.5Counter32read-onlycurrent
nhdpIfHelloMessagePeriodicXmits
OBJECT-TYPE
A counter is incremented each time a periodic HELLO message has been sent.
1.3.6.1.2.1.213.1.3.1.1.6Counter32read-onlycurrent
nhdpIfHelloMessageXmitAccumulatedSymmetricNeighborCount
OBJECT-TYPE
A counter is incremented by the number of advertised symmetric neighbors in a HELLO each time a HELLO message has been sent.
1.3.6.1.2.1.213.1.3.1.1.7Counter32read-onlycurrent
nhdpIfHelloMessageXmitAccumulatedHeardNeighborCount
OBJECT-TYPE
A counter is incremented by the number of advertised heard neighbors in a HELLO each time a HELLO message has been sent.
1.3.6.1.2.1.213.1.3.1.1.8Counter32read-onlycurrent
nhdpIfHelloMessageXmitAccumulatedLostNeighborCount
OBJECT-TYPE
A counter is incremented by the number of advertised lost neighbors in a HELLO each time a HELLO message has been sent.
1.3.6.1.2.1.213.1.3.1.1.9Counter32read-onlycurrent
nhdpIfPerfCounterDiscontinuityTime
OBJECT-TYPE
The value of sysUpTime on the most recent occasion at which any one or more of this interface's counters suffered a discontinuity. If no such discontinuities have occurred since the last reinitialization of the local management subsystem, then this object contains a zero value.
1.3.6.1.2.1.213.1.3.1.1.10TimeStampread-onlycurrent
nhdpDiscIfSetPerfTable
OBJECT-TYPE
A router's set of performance properties for each discovered interface of a neighbor.
1.3.6.1.2.1.213.1.3.2not-accessiblecurrent
nhdpDiscIfSetPerfEntry
OBJECT-TYPE
There is an entry for each discovered interface of a neighbor.
1.3.6.1.2.1.213.1.3.2.1not-accessiblecurrent
nhdpDiscIfRecvdPackets
OBJECT-TYPE
This counter increments each time this router receives a packet from that interface of the neighbor.
1.3.6.1.2.1.213.1.3.2.1.1Counter32read-onlycurrent
nhdpDiscIfExpectedPackets
OBJECT-TYPE
This counter increments by the number of missed packets from this neighbor based on the packet sequence number each time this router receives a packet from that interface of the neighbor.
1.3.6.1.2.1.213.1.3.2.1.2Counter32read-onlycurrent
nhdpNibNeighborSetChanges
OBJECT-TYPE
This counter increments each time the Neighbor Set changes. A change occurs whenever a new Neighbor Tuple has been added, a Neighbor Tuple has been removed, or any entry of a Neighbor Tuple has been modified.
1.3.6.1.2.1.213.1.3.3Counter32read-onlycurrent
nhdpDiscNeighborSetPerfTable
OBJECT-TYPE
A router's set of discovered neighbors and their properties.
1.3.6.1.2.1.213.1.3.4not-accessiblecurrent
nhdpDiscNeighborSetPerfEntry
OBJECT-TYPE
The entries include the nhdpDiscRouterIndex of the discovered router as well as performance objects related to changes of the Neighbor Set.
1.3.6.1.2.1.213.1.3.4.1not-accessiblecurrent
nhdpDiscNeighborNibNeighborSetChanges
OBJECT-TYPE
This object returns the number of changes to the given Neighbor Tuple.
1.3.6.1.2.1.213.1.3.4.1.1Counter32read-onlycurrent
nhdpDiscNeighborNibNeighborSetUpTime
OBJECT-TYPE
This object returns the sysUpTime when a new nhdpNibNeighborSetEntry has been created for a particular nhdpNibNeighborSetRouterIndex.
1.3.6.1.2.1.213.1.3.4.1.2TimeStampread-onlycurrent
nhdpDiscNeighborNibNeighborSetReachableLinkChanges
OBJECT-TYPE
This object counts each time the neighbor changes the interface(s) over which it is reachable. A change in the set of Link Tuples corresponding to the appropriate Neighbor Tuple is registered, i.e., a corresponding Link Tuple is added or removed from the set of all corresponding Link Tuples.
1.3.6.1.2.1.213.1.3.4.1.3Counter32read-onlycurrent
nhdpIib2HopSetPerfTable
OBJECT-TYPE
This table contains performance objects per discovered 2-hop neighbor.
1.3.6.1.2.1.213.1.3.5not-accessiblecurrent
nhdpIib2HopSetPerfEntry
OBJECT-TYPE
The entries contain performance objects per discovered 2-hop neighbor.
1.3.6.1.2.1.213.1.3.5.1not-accessiblecurrent
nhdpIib2HopSetPerfChanges
OBJECT-TYPE
This object counts the changes of the union of all N2_neighbor_iface_addr_list of 2-Hop Tuples with an N2_2hop_addr equal to one of the given 2-hop neighbor's addresses.
1.3.6.1.2.1.213.1.3.5.1.1Counter32read-onlycurrent
nhdpIib2HopSetPerfUpTime
OBJECT-TYPE
This object returns the sysUpTime when the 2-Hop Tuple corresponding to the given 2-hop neighbor IP address was registered in the nhdpIib2HopSetTable.
1.3.6.1.2.1.213.1.3.5.1.2TimeStampread-onlycurrent
nhdpConformance
OBJECT-IDENTITY
1.3.6.1.2.1.213.2
nhdpCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.213.2.1
nhdpMIBGroups
OBJECT-IDENTITY
1.3.6.1.2.1.213.2.2

Notifications

NameOIDStatus
nhdpNbrStateChange
NOTIFICATION-TYPE
nhdpNbrStateChange is a notification sent when more than nhdpNbrStateChangeThreshold neighbors change their status (i.e., 'down(0)', 'asymmetric(1)', or 'symmetric(2)') within a time window of nhdpNbrStateChangeWindow.
1.3.6.1.2.1.213.0.0.1current
nhdp2HopNbrStateChange
NOTIFICATION-TYPE
nhdp2HopNbrStateChange is a notification sent when more than nhdp2HopNbrStateChangeThreshold 2-hop neighbors change their nhdp2HopNbrState within a time window of nhdp2HopNbrStateChangeWindow.
1.3.6.1.2.1.213.0.0.2current
nhdpIfStateChange
NOTIFICATION-TYPE
nhdpIfStateChange is a notification sent when nhdpIfStatus has changed on this interface.
1.3.6.1.2.1.213.0.0.3current

Conformance

NameOIDStatus
nhdpBasicCompliance
MODULE-COMPLIANCE
The basic implementation requirements for managed network entities that implement NHDP.
1.3.6.1.2.1.213.2.1.1current
nhdpFullCompliance
MODULE-COMPLIANCE
The full implementation requirements for managed network entities that implement NHDP. For version-independence, this compliance statement is deprecated in favor of nhdpFullCompliance2.
1.3.6.1.2.1.213.2.1.2deprecated
nhdpFullCompliance2
MODULE-COMPLIANCE
The full implementation requirements for managed network entities that implement NHDP.
1.3.6.1.2.1.213.2.1.3current
nhdpConfigurationGroup
OBJECT-GROUP
Set of NHDP configuration objects implemented in this module.
1.3.6.1.2.1.213.2.2.2current
nhdpStateGroup
OBJECT-GROUP
Set of NHDP state objects implemented in this module. For version-independence, this compliance statement is deprecated in favor of nhdpStateGroup2.
1.3.6.1.2.1.213.2.2.3deprecated
nhdpPerformanceGroup
OBJECT-GROUP
Set of NHDP performance objects implemented in this module.
1.3.6.1.2.1.213.2.2.4current
nhdpNotificationObjectGroup
OBJECT-GROUP
Set of NHDP notification objects implemented in this module.
1.3.6.1.2.1.213.2.2.5current
nhdpNotificationGroup
NOTIFICATION-GROUP
Set of NHDP notifications implemented in this module.
1.3.6.1.2.1.213.2.2.6current
nhdpStateGroup2
OBJECT-GROUP
Set of NHDP state objects implemented in this module.
1.3.6.1.2.1.213.2.2.7current