MIBs Depot

ITU-ALARM-MIB

Registered at
1.3.6.1.2.1.121
Last updated
2004-09-09 00:00
Organization
IETF Distributed Management Working Group
Revisions
2004-09-09 00:00
Namespace
standard
Source file
ITU-ALARM-MIB
Digest
sha256:0f20cca4dbe3110e17b3f5601af4487a0ef22fd3c87a0d42c8bc0e163bacaedc

Description

The MIB module describes ITU Alarm information as defined in ITU Recommendation M.3100 [M.3100], X.733 [X.733] and X.736 [X.736]. Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3877. For full legal notices see the RFC itself. Supplementary information may be available on: http://www.ietf.org/copyrights/ianamib.html

Contact

WG EMail: disman@ietf.org Subscribe: disman-request@ietf.org http://www.ietf.org/html.charters/disman-charter.html Chair: Randy Presuhn randy_presuhn@mindspring.com Editors: Sharon Chisholm Nortel Networks PO Box 3511 Station C Ottawa, Ont. K1Y 4H7 Canada schishol@nortelnetworks.com Dan Romascanu Avaya Atidim Technology Park, Bldg. #3 Tel Aviv, 61131 Israel Tel: +972-3-645-8414 Email: dromasca@avaya.com

Imports

FromSymbols
ALARM-MIBalarmActiveDateAndTime, alarmActiveIndex, alarmListName, alarmModelIndex
IANA-ITU-ALARM-TC-MIBIANAItuEventType, IANAItuProbableCause
ITU-ALARM-TC-MIBItuPerceivedSeverity, ItuTrendIndication
RMON2-MIBZeroBasedCounter32
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIGauge32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso, mib-2
SNMPv2-TCAutonomousType, DisplayString, RowPointer, TEXTUAL-CONVENTION

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

ALARM-MIB
IANA-ITU-ALARM-TC-MIB
IANAifType-MIB
IF-MIB
INET-ADDRESS-MIB
ITU-ALARM-MIB
ITU-ALARM-TC-MIB
RFC1158-MIB
RFC1271-MIB
RMON-MIB
RMON2-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
TOKEN-RING-RMON-MIB

Objects

NameOIDSyntaxAccessStatus
ituAlarmObjects
OBJECT-IDENTITY
1.3.6.1.2.1.121.1
ituAlarmModel
OBJECT-IDENTITY
1.3.6.1.2.1.121.1.1
ituAlarmTable
OBJECT-TYPE
A table of ITU Alarm information for possible alarms on the system.
1.3.6.1.2.1.121.1.1.1not-accessiblecurrent
ituAlarmEntry
OBJECT-TYPE
Entries appear in this table whenever an entry is created in the alarmModelTable with a value of alarmModelState in the range from 1 to 6. Entries disappear from this table whenever the corresponding entries are deleted from the alarmModelTable, including in cases where those entries have been deleted due to local system action. The value of alarmModelSpecificPointer has no effect on the creation or deletion of entries in this table. Values of alarmModelState map to values of ituAlarmPerceivedSeverity as follows: alarmModelState -> ituAlarmPerceivedSeverity 1 -> clear (1) 2 -> indeterminate (2) 3 -> warning (6) 4 -> minor (5) 5 -> major (4) 6 -> critical (3) All other values of alarmModelState MUST NOT appear in this table. This table MUST be persistent across system reboots.
1.3.6.1.2.1.121.1.1.1.1not-accessiblecurrent
ituAlarmPerceivedSeverity
OBJECT-TYPE
ITU perceived severity values.
1.3.6.1.2.1.121.1.1.1.1.1ItuPerceivedSeveritynot-accessiblecurrent
ituAlarmEventType
OBJECT-TYPE
Represents the event type values for the alarms
1.3.6.1.2.1.121.1.1.1.1.2IANAItuEventTyperead-writecurrent
ituAlarmProbableCause
OBJECT-TYPE
ITU probable cause values.
1.3.6.1.2.1.121.1.1.1.1.3IANAItuProbableCauseread-writecurrent
ituAlarmAdditionalText
OBJECT-TYPE
Represents the additional text field for the alarm.
1.3.6.1.2.1.121.1.1.1.1.4SnmpAdminStringread-writecurrent
ituAlarmGenericModel
OBJECT-TYPE
This object points to the corresponding row in the alarmModelTable for this alarm severity. This corresponding entry to alarmModelTable could also be derived by performing the reverse of the mapping from alarmModelState to ituAlarmPerceivedSeverity defined in the description of ituAlarmEntry to determine the appropriate { alarmListName, alarmModelIndex, alarmModelState } for this { alarmListName, alarmModelIndex, ituAlarmPerceivedSeverity }.
1.3.6.1.2.1.121.1.1.1.1.5RowPointerread-writecurrent
ituAlarmActive
OBJECT-IDENTITY
1.3.6.1.2.1.121.1.2
ituAlarmActiveTable
OBJECT-TYPE
A table of ITU information for active alarms entries.
1.3.6.1.2.1.121.1.2.1not-accessiblecurrent
ituAlarmActiveEntry
OBJECT-TYPE
Entries appear in this table when alarms are active. They are removed when the alarm is no longer occurring.
1.3.6.1.2.1.121.1.2.1.1not-accessiblecurrent
ituAlarmActiveTrendIndication
OBJECT-TYPE
Represents the trend indication values for the alarms.
1.3.6.1.2.1.121.1.2.1.1.1ItuTrendIndicationread-onlycurrent
ituAlarmActiveDetector
OBJECT-TYPE
Represents the SecurityAlarmDetector object.
1.3.6.1.2.1.121.1.2.1.1.2AutonomousTyperead-onlycurrent
ituAlarmActiveServiceProvider
OBJECT-TYPE
Represents the ServiceProvider object.
1.3.6.1.2.1.121.1.2.1.1.3AutonomousTyperead-onlycurrent
ituAlarmActiveServiceUser
OBJECT-TYPE
Represents the ServiceUser object.
1.3.6.1.2.1.121.1.2.1.1.4AutonomousTyperead-onlycurrent
ituAlarmActiveStatsTable
OBJECT-TYPE
This table represents the ITU alarm statistics information.
1.3.6.1.2.1.121.1.2.2not-accessiblecurrent
ituAlarmActiveStatsEntry
OBJECT-TYPE
Statistics on the current active ITU alarms.
1.3.6.1.2.1.121.1.2.2.1not-accessiblecurrent
ituAlarmActiveStatsIndeterminateCurrent
OBJECT-TYPE
A count of the current number of active alarms with a ituAlarmPerceivedSeverity of indeterminate.
1.3.6.1.2.1.121.1.2.2.1.1Gauge32read-onlycurrent
ituAlarmActiveStatsCriticalCurrent
OBJECT-TYPE
A count of the current number of active alarms with a ituAlarmPerceivedSeverity of critical.
1.3.6.1.2.1.121.1.2.2.1.2Gauge32read-onlycurrent
ituAlarmActiveStatsMajorCurrent
OBJECT-TYPE
A count of the current number of active alarms with a ituAlarmPerceivedSeverity of major.
1.3.6.1.2.1.121.1.2.2.1.3Gauge32read-onlycurrent
ituAlarmActiveStatsMinorCurrent
OBJECT-TYPE
A count of the current number of active alarms with a ituAlarmPerceivedSeverity of minor.
1.3.6.1.2.1.121.1.2.2.1.4Gauge32read-onlycurrent
ituAlarmActiveStatsWarningCurrent
OBJECT-TYPE
A count of the current number of active alarms with a ituAlarmPerceivedSeverity of warning.
1.3.6.1.2.1.121.1.2.2.1.5Gauge32read-onlycurrent
ituAlarmActiveStatsIndeterminates
OBJECT-TYPE
A count of the total number of active alarms with a ituAlarmPerceivedSeverity of indeterminate since system restart.
1.3.6.1.2.1.121.1.2.2.1.6ZeroBasedCounter32read-onlycurrent
ituAlarmActiveStatsCriticals
OBJECT-TYPE
A count of the total number of active alarms with a ituAlarmPerceivedSeverity of critical since system restart.
1.3.6.1.2.1.121.1.2.2.1.7ZeroBasedCounter32read-onlycurrent
ituAlarmActiveStatsMajors
OBJECT-TYPE
A count of the total number of active alarms with a ituAlarmPerceivedSeverity of major since system restart.
1.3.6.1.2.1.121.1.2.2.1.8ZeroBasedCounter32read-onlycurrent
ituAlarmActiveStatsMinors
OBJECT-TYPE
A count of the total number of active alarms with a ituAlarmPerceivedSeverity of minor since system restart.
1.3.6.1.2.1.121.1.2.2.1.9ZeroBasedCounter32read-onlycurrent
ituAlarmActiveStatsWarnings
OBJECT-TYPE
A count of the total number of active alarms with a ituAlarmPerceivedSeverity of warning since system restart.
1.3.6.1.2.1.121.1.2.2.1.10ZeroBasedCounter32read-onlycurrent
ituAlarmConformance
OBJECT-IDENTITY
1.3.6.1.2.1.121.2
ituAlarmCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.121.2.1
ituAlarmGroups
OBJECT-IDENTITY
1.3.6.1.2.1.121.2.2

Conformance

NameOIDStatus
ituAlarmCompliance
MODULE-COMPLIANCE
The compliance statement for systems supporting the ITU Alarm MIB.
1.3.6.1.2.1.121.2.1.1current
ituAlarmGroup
OBJECT-GROUP
ITU alarm details list group.
1.3.6.1.2.1.121.2.2.1current
ituAlarmServiceUserGroup
OBJECT-GROUP
The use of these parameters is a service-user option.
1.3.6.1.2.1.121.2.2.2current
ituAlarmSecurityGroup
OBJECT-GROUP
Security Alarm Reporting Function
1.3.6.1.2.1.121.2.2.3current
ituAlarmStatisticsGroup
OBJECT-GROUP
ITU Active Alarm Statistics.
1.3.6.1.2.1.121.2.2.4current