MIBs Depot

ISNS-MIB

Registered at
1.3.6.1.2.1.163
Last updated
2007-07-11 00:00
Organization
IETF IPS Working Group
Revisions
2007-07-11 00:00
Namespace
standard
Source file
ISNS-MIB
Digest
sha256:8faa036f9aad4721567fd676575af5b8660337cafa5c67b5cab7b0dc34c5000e

Description

This module defines management information specific to internet Storage Name Service (iSNS) management. Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4939; see the RFC itself for full legal notices.

Contact

Attn: Kevin Gibbons 2Wire, Inc. 1704 Automation Parkway San Jose, CA 95131 USA Tel: +1 408-895-1387 Fax: +1 408-428-9590 Email: kgibbons@yahoo.com G.D. Ramkumar SnapTell, Inc. 2741 Middlefield Rd, Suite 200 Palo Alto, CA 94306 USA Tel: +1 650-326-7627 Fax: +1 650-326-7620 Email: gramkumar@stanfordalumni.org Scott Kipp Brocade 4 McDATA Pkwy Broomfield, CO 80021 USA Tel: +1 720-558-3452 Fax: +1 720-558-8999 Email: skipp@brocade.com

Imports

FromSymbols
ENTITY-MIBPhysicalIndex
FC-MGMT-MIBFcAddressIdOrZero, FcNameIdOrZero
INET-ADDRESS-MIBInetAddress, InetAddressType, InetPortNumber
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIGauge32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION, TimeStamp, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

ENTITY-MIB
FC-MGMT-MIB
IANA-ENTITY-MIB
IANAifType-MIB
IF-MIB
INET-ADDRESS-MIB
ISNS-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
UUID-TC-MIB

Textual conventions

NameOIDSyntaxAccessStatus
IsnsDdDdsModificationType
TEXTUAL-CONVENTION
The methods that can be used to modify the Discovery Domain and Discovery Domain Sets in an iSNS Server instance. Bit Flag Description --------- ------------------------------------ 0 Control Nodes are allowed 1 Target iSCSI Nodes are allowed 2 Initiator iSCSI Nodes are allowed 3 Target iFCP Ports are allowed 4 Initiator iFCP Ports are allowed Setting a bit to 1 indicates the feature is enabled. Otherwise, it is disabled.
current
IsnsDdFeatureType
TEXTUAL-CONVENTION
This type defines the features that each Discovery Domain (DD) has. Bit Status --------- --------- 31 Boot List All others RESERVED Boot List: this feature indicates that the targets in this DD provide boot capabilities for the member initiators. Setting a bit to 1 indicates the feature is enabled. Otherwise, it is disabled. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsDdsStatusType
TEXTUAL-CONVENTION
The status of a Discovery Domain Set (DDS) registered in the iSNS. The initially assigned values are below: Bit Status --------- --------- 31 DDS Enabled All others RESERVED Setting a bit to 1 indicates the feature is enabled. Otherwise, it is disabled. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsDiscoveryDomainId
TEXTUAL-CONVENTION
The unique Discovery Domain Identifier (DD_ID) associated with each Discovery Domain (DD). This is used to uniquely index and reference a DD.
current
IsnsDiscoveryDomainSetId
TEXTUAL-CONVENTION
The unique Discovery Domain Set Identifier associated with a Discovery Domain Set (DDS).
current
IsnsEntityIndexIdOrZero
TEXTUAL-CONVENTION
The identifier for the unique integer Entity Index associated with an iSNS registered Entity object, and the value zero. The value zero is object-specific and MUST therefore be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Entity is unknown, or not yet registered in the iSNS server. If a value of zero is not valid for an object, then that MUST be indicated.
current
IsnsFcClassOfServiceType
TEXTUAL-CONVENTION
This defines the Fibre Channel Class of Service types that are supported by the registered port. The definitions are as defined in RFC 4171. Bit FC COS Type --------- ---------------- 28 Fibre Channel Class 3 Supported 29 Fibre Channel Class 2 Supported All others RESERVED Setting a bit to 1 indicates the class of service is supported. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsFcPortRoleType
TEXTUAL-CONVENTION
The FC Port Role defines the functions of the registered object. The definitions of each setting are defined in RFC 4171. Bit Port Role --------- --------- 29 Control 30 FCP Initiator 31 FCP Target All others RESERVED Setting a bit to 1 indicates the port has the corresponding characteristics. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsIfcpScnType
TEXTUAL-CONVENTION
The iFCP State Change Notification (SCN) values for an iFCP object as defined in RFC 4171. Bit Description ------------ ---------------- 24 Initiator and self information only 25 Target and self information only 26 Management registration/SCN 27 Object removed 28 Object added 29 Object updated 30 DD or DDS member removed (Mgmt Reg/SCN only) 31 (Lsb) DD or DDS member added (Mgmt Reg/SCN only) All others Reserved Setting a bit to 1 indicates that type of SCN is enabled. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsIscsiNodeType
TEXTUAL-CONVENTION
The iSCSI Node Type defines the functions of the registered object. The definitions of each setting are defined in RFC 4171. Bit Node Type --------- --------- 29 Control 30 Initiator 31 Target All others RESERVED Setting a bit to 1 indicates the node has the corresponding characteristics. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsIscsiScnType
TEXTUAL-CONVENTION
The iSCSI Node State Change Notification (SCN) values for a node as defined in RFC 4171. Bit Description ------------ ---------------- 24 Initiator and self information only 25 Target and self information only 26 Management registration/SCN 27 Object removed 28 Object added 29 Object updated 30 DD or DDS member removed (Mgmt Reg/SCN only) 31 (Lsb) DD or DDS member added (Mgmt Reg/SCN only) All others Reserved Setting a bit to 1 indicates that type of SCN is enabled. The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsNodeIndexId
TEXTUAL-CONVENTION
The identifier for the unique integer Node Index associated with a storage node. This index provides a 1-to-1 mapping to an iSCSI node name. The iSCSI node name maximum length is too long to be used for an index directly. The iSCSI node index used for a specific iSCSI node name is identical in all DDs, and is persistent across server reinitializations when the iSCSI node is a member of a Discovery Domain (DD) or is registered as a Control Node. Furthermore, index values for recently deregistered objects SHOULD NOT be reused in the short term.
current
IsnsPortalGroupIndexId
TEXTUAL-CONVENTION
The identifier for the unique integer Portal Group Index associated with an iSNS registered Portal Group object.
current
IsnsPortalGroupTagIdOrNull
TEXTUAL-CONVENTION
The Portal Group Tag (PGT) represents an association between a Portal and iSCSI Node using the value range 0 to 65535. A PGT with no association is a NULL value. The value of -1 indicates a NULL value.
current
IsnsPortalIndexId
TEXTUAL-CONVENTION
The identifier for the unique integer Portal Index associated with an iSNS registered Portal object. The index is created by the iSNS Server for mapping between registered objects. The Portal Index used for a specific portal IP-address and port number pair is only persistent across reboots for portals that have been explicitly added to a Discovery Domain (DD). If a portal is not explicitly registered in any DD, then the index used for a portal can change after a server reinitialization.
current
IsnsPortalPortTypeId
TEXTUAL-CONVENTION
The UDP or TCP port type being used by a Portal for an Entity.
current
IsnsPortalSecurityType
TEXTUAL-CONVENTION
Indicates security attribute settings for a Portal that is registered in the iSNS server. The bitmapVALID field must be set in order for the contents to be considered valid information. The definitions of the bit fields are based on RFC 4171. The initial representation of each bit setting (0 or 1) is indicated below. Bit Flag Description --------- ------------------------------------ 25 1 = Tunnel Mode Preferred; 0 = No Preference 26 1 = Transport Mode Preferred; 0 = No Preference 27 1 = PFS Enabled; 0 = PFS Disabled 28 1 = Aggressive Mode Enabled; 0 = Disabled 29 1 = Main Mode Enabled; 0 = MM Disabled 30 1 = IKE/IPsec Enabled; 0 = IKE/IPsec Disabled 31 1 = Bitmap VALID; 0 = INVALID All others RESERVED The future assignment of any of the reserved values will be documented in a revision of RFC 4171.
current
IsnsSrvrDiscoveryMethodsType
TEXTUAL-CONVENTION
The types of iSNS Server discovery methods that are enabled on an iSNS Server. The options are DHCP, Service Location Protocol (SLP), multicast group iSNS heartbeat, broadcast group iSNS heartbeat, configured server list, and other. The iSNS Server may support additional discovery methods not indicated.
current

Objects

NameOIDSyntaxAccessStatus
isnsNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.163.0
isnsObjects
OBJECT-IDENTITY
1.3.6.1.2.1.163.1
isnsServerInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1
isnsServerTable
OBJECT-TYPE
This table provides a list of the iSNS Server instances that are managed through the same SNMP context.
1.3.6.1.2.1.163.1.1.1not-accessiblecurrent
isnsServerEntry
OBJECT-TYPE
This is a row in the iSNS Server instance table. The number of rows is dependent on the number of iSNS Server instances that are being managed through the same SNMP context.
1.3.6.1.2.1.163.1.1.1.1not-accessiblecurrent
isnsServerIndex
OBJECT-TYPE
This object uniquely identifies the iSNS Server being managed by the SNMP context and is the key for this table. This is an instance index for each iSNS Server being managed. The value of this object is used elsewhere in the MIB to reference specific iSNS Servers.
1.3.6.1.2.1.163.1.1.1.1.1Unsigned32 (1..4294967295)not-accessiblecurrent
isnsServerName
OBJECT-TYPE
A non-unique name that can be assigned to the iSNS Server instance. If not configured, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.1.1.2SnmpAdminStringread-onlycurrent
isnsServerIsnsVersion
OBJECT-TYPE
The iSNS version value as contained in messages received from the current primary server. The header of each iSNSP message contains the iSNS version of the sender. If unknown, the reported value is 0.
1.3.6.1.2.1.163.1.1.1.1.3Unsigned32 (0..65535)read-onlycurrent
isnsServerVendorInfo
OBJECT-TYPE
If this server instance is utilizing the product of a particular 'vendor', then this managed object contains that vendor's name and version. Otherwise, the string SHALL be zero-length. The format of the string is as follows: Vendor Name, Vendor Version, Vendor Defined Information. Field Description --------- ---------------- Vendor Name The name of the vendor (if one exists) Vendor Version The version of the vendor product Vendor Defined This follows the second comma in the string, if one exists, and is vendor defined
1.3.6.1.2.1.163.1.1.1.1.4SnmpAdminStringread-onlycurrent
isnsServerPhysicalIndex
OBJECT-TYPE
An index identifying the network interface for this iSNS Server within a network entity. This index maps to the entPhysicalIndex of entPhysicalTable table in RFC 4133. The entPhysicalClass value for the table row must be 'port', as the interface must be able to send and receive data.
1.3.6.1.2.1.163.1.1.1.1.5PhysicalIndexread-onlycurrent
isnsServerTcpPort
OBJECT-TYPE
Indicates the TCP port this iSNS instance is accepting iSNSP messages on, generally the iSNS well-known port. The well-known TCP port for iSNSP is 3205. If TCP is not supported by this server instance, then the value is 0.
1.3.6.1.2.1.163.1.1.1.1.6InetPortNumberread-onlycurrent
isnsServerUdpPort
OBJECT-TYPE
Indicates the UDP port this iSNS instance is accepting iSNSP messages on; generally, the iSNS well-known port. The well-known UDP port for iSNSP is 3205. If UDP is not supported by this server instance, then the value is 0.
1.3.6.1.2.1.163.1.1.1.1.7InetPortNumberread-onlycurrent
isnsServerDiscontinuityTime
OBJECT-TYPE
The value of sysUpTime on the most recent occasion that this iSNS server became active or suffered a discontinuity.
1.3.6.1.2.1.163.1.1.1.1.8TimeStampread-onlycurrent
isnsServerRole
OBJECT-TYPE
The current operational mode of this iSNS Server instance. Value Description --------- ---------------- notSet The iSNS Server role is not configured. server The iSNS Server instance is an operational iSNS Server. backupServer The iSNS Server instance is currently acting as a backup.
1.3.6.1.2.1.163.1.1.1.1.9INTEGER {notSet(1), server(2), backupServer(3)}read-onlycurrent
isnsServerDiscoveryMethodsEnabled
OBJECT-TYPE
Indicates the discovery methods currently enabled for this iSNS Server instance. This allows a client to determine what discovery methods can be used for this iSNS Server. Additional methods of discovery may also be supported.
1.3.6.1.2.1.163.1.1.1.1.10IsnsSrvrDiscoveryMethodsTyperead-onlycurrent
isnsServerDiscoveryMcGroupType
OBJECT-TYPE
The type of Internet address in isnsServerDiscoveryMcGroupAddress. If the address is specified, then it must be a valid multicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsServerDiscoveryMcGroupAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.1.1.11InetAddressTyperead-onlycurrent
isnsServerDiscoveryMcGroupAddress
OBJECT-TYPE
The multicast group that iSNS Heartbeat messages are sent to if multicast-based discovery has been enabled for this server instance. If not configured, then the string SHALL be zero-length. The format of this object is specified by isnsServerDiscoveryMcGroupType.
1.3.6.1.2.1.163.1.1.1.1.12InetAddressread-onlycurrent
isnsServerEsiNonResponseThreshold
OBJECT-TYPE
Entity Status Inquiry (ESI) Non-Response Threshold - the number of ESI messages that will be sent without receiving a response before an entity is deregistered from the iSNS database. A value of 0 indicates Entities will never be deregistered due to non-receipt of ESI messages.
1.3.6.1.2.1.163.1.1.1.1.13Unsigned32 (0..65535)read-onlycurrent
isnsServerEnableControlNodeMgtScn
OBJECT-TYPE
Indicates if the iSNS Server administrative option to send Management SCNs to Control Nodes is enabled. Management SCNs are used by Control Nodes to monitor and control an iSNS Server. If enabled, Control Nodes can register to receive Management SCNs.
1.3.6.1.2.1.163.1.1.1.1.14TruthValueread-onlycurrent
isnsServerDefaultDdDdsStatus
OBJECT-TYPE
This indicates the Discovery Domain (DD) and Discovery Domain Set (DDS) membership status for a new device when registered in the iSNS Server instance. Either the new device will not be in a DD/DDS, or will be placed into a default DD and default DDS. The default setting is inNoDomain.
1.3.6.1.2.1.163.1.1.1.1.15INTEGER {inNoDomain(1), inDefaultDdAndDds(2)}read-onlycurrent
isnsServerUpdateDdDdsSupported
OBJECT-TYPE
The methods that this iSNS Server instance supports to modify Discovery Domains and Discovery Domain Sets.
1.3.6.1.2.1.163.1.1.1.1.16IsnsDdDdsModificationTyperead-onlycurrent
isnsServerUpdateDdDdsEnabled
OBJECT-TYPE
This indicates the methods this server instance currently allows for modifying Discovery Domains and Discovery Domain Sets.
1.3.6.1.2.1.163.1.1.1.1.17IsnsDdDdsModificationTyperead-onlycurrent
isnsNumObjectsTable
OBJECT-TYPE
Table providing the number of registered objects of each type in the iSNS Server instance. The number of entries is dependent upon the number of iSNS Server instances being managed.
1.3.6.1.2.1.163.1.1.2not-accessiblecurrent
isnsNumObjectsEntry
OBJECT-TYPE
Entry of an iSNS Server instance.
1.3.6.1.2.1.163.1.1.2.1not-accessiblecurrent
isnsNumDds
OBJECT-TYPE
The current total number of Discovery Domain Sets in this iSNS instance. This is the number of rows in the isnsDdsTable.
1.3.6.1.2.1.163.1.1.2.1.1Gauge32 (0..4294967295)read-onlycurrent
isnsNumDd
OBJECT-TYPE
The current total number of Discovery Domains in this iSNS instance. This is the number of rows in the isnsDdTable.
1.3.6.1.2.1.163.1.1.2.1.2Gauge32 (0..4294967295)read-onlycurrent
isnsNumEntities
OBJECT-TYPE
The current number of Entities registered in this iSNS Server instance. This is the number of rows in the isnsRegEntityTable for this instance.
1.3.6.1.2.1.163.1.1.2.1.3Gauge32 (0..4294967295)read-onlycurrent
isnsNumPortals
OBJECT-TYPE
The current total number of Portals registered in iSNS. This is the number of rows in isnsRegPortalTable.
1.3.6.1.2.1.163.1.1.2.1.4Gauge32 (0..4294967295)read-onlycurrent
isnsNumPortalGroups
OBJECT-TYPE
The current total number of Portal Groups registered in iSNS. This is the number of rows in isnsRegPgTable.
1.3.6.1.2.1.163.1.1.2.1.5Gauge32 (0..4294967295)read-onlycurrent
isnsNumIscsiNodes
OBJECT-TYPE
The current total number of iSCSI node entries registered in the iSNS. This is the number rows in isnsRegIscsiNodeTable.
1.3.6.1.2.1.163.1.1.2.1.6Gauge32 (0..4294967295)read-onlycurrent
isnsNumFcPorts
OBJECT-TYPE
The current total number of FC Port entries registered in the iSNS. This is the number of rows in isnsRegFcPortTable.
1.3.6.1.2.1.163.1.1.2.1.7Gauge32 (0..4294967295)read-onlycurrent
isnsNumFcNodes
OBJECT-TYPE
The current total number of FC node entries registered in the iSNS. This is the number of rows in isnsRegFcNodeTable.
1.3.6.1.2.1.163.1.1.2.1.8Gauge32 (0..4294967295)read-onlycurrent
isnsControlNodeInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.3
isnsControlNodeIscsiTable
OBJECT-TYPE
Specified iSCSI Nodes that can register or are registered as control nodes. The number of rows is dependent on the number of iSCSI Control Nodes.
1.3.6.1.2.1.163.1.1.3.1not-accessiblecurrent
isnsControlNodeIscsiEntry
OBJECT-TYPE
This is an iSCSI Control Node entry for a specific iSNS server instance.
1.3.6.1.2.1.163.1.1.3.1.1not-accessiblecurrent
isnsControlNodeIscsiNodeIndex
OBJECT-TYPE
The index for the iSCSI storage node authorized to act as a control node.
1.3.6.1.2.1.163.1.1.3.1.1.1IsnsNodeIndexIdnot-accessiblecurrent
isnsControlNodeIscsiNodeName
OBJECT-TYPE
The iSCSI Name of the initiator or target associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS Server internal maximum size is 224 bytes to provide NULL termination. This is the iSCSI Node Name for the storage node authorized and/or acting as a control node.
1.3.6.1.2.1.163.1.1.3.1.1.2SnmpAdminStringread-onlycurrent
isnsControlNodeIscsiIsRegistered
OBJECT-TYPE
Indicates whether the control node is currently registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.3.1.1.3TruthValueread-onlycurrent
isnsControlNodeIscsiRcvMgtSCN
OBJECT-TYPE
Indicates whether the Control Node has registered to receive Management SCNs. Management SCNs are sent to a Control Node if they are enabled, as indicated by isnsServerEnableControlNodeMgtScn, and the Control Node has registered for them.
1.3.6.1.2.1.163.1.1.3.1.1.4TruthValueread-onlycurrent
isnsControlNodeFcPortTable
OBJECT-TYPE
Specified FC Ports that can register or are registered as control nodes. The number of rows is dependent on the number of FC Port Control Nodes.
1.3.6.1.2.1.163.1.1.3.2not-accessiblecurrent
isnsControlNodeFcPortEntry
OBJECT-TYPE
FC Port control node entry.
1.3.6.1.2.1.163.1.1.3.2.1not-accessiblecurrent
isnsControlNodeFcPortWwpn
OBJECT-TYPE
The FC Port World Wide Port Name that can and/or is acting as a Control Node for the specified iSNS Server. A zero- length string is not valid for this managed object. This managed object, combined with the isnsServerIndex, is the key for this table.
1.3.6.1.2.1.163.1.1.3.2.1.1FcNameIdOrZero (SIZE(8))not-accessiblecurrent
isnsControlNodeFcPortIsRegistered
OBJECT-TYPE
Indicates whether the control node is currently registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.3.2.1.2TruthValueread-onlycurrent
isnsControlNodeFcPortRcvMgtSCN
OBJECT-TYPE
Indicates whether the Control Node has registered to receive Management SCNs. Management SCNs are sent to a Control Node if they are enabled, as indicated by isnsServerEnableControlNodeMgtScn, and the Control Node has registered for them.
1.3.6.1.2.1.163.1.1.3.2.1.3TruthValueread-onlycurrent
isnsDdsInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.4
isnsDdsTable
OBJECT-TYPE
A table containing configuration information for each Discovery Domain Set (DDS) registered in the iSNS Server instance. The number of rows in the table is dependent on the number of DDSs registered in the specified iSNS server instance.
1.3.6.1.2.1.163.1.1.4.1not-accessiblecurrent
isnsDdsEntry
OBJECT-TYPE
Information on one Discovery Domain Set (DDS) registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.4.1.1not-accessiblecurrent
isnsDdsId
OBJECT-TYPE
The ID that refers to this Discovery Domain Set and index to the table.
1.3.6.1.2.1.163.1.1.4.1.1.1IsnsDiscoveryDomainSetIdnot-accessiblecurrent
isnsDdsSymbolicName
OBJECT-TYPE
The Discovery Domain Set Symbolic Name field contains a unique variable-length description (up to 255 bytes) that is associated with the DDS. If a Symbolic Name is not provided, then one will be generated by the iSNS server.
1.3.6.1.2.1.163.1.1.4.1.1.2SnmpAdminStringread-onlycurrent
isnsDdsStatus
OBJECT-TYPE
The status of this Discovery Domain Set (DDS).
1.3.6.1.2.1.163.1.1.4.1.1.3IsnsDdsStatusTyperead-onlycurrent
isnsDdsMemberTable
OBJECT-TYPE
A table containing Discovery Domains (DDs) that have been assigned to specific Discovery Domain Sets (DDSs). The number of rows in the table is dependent on the number of DD to DDS relationships in the iSNS instance.
1.3.6.1.2.1.163.1.1.4.2not-accessiblecurrent
isnsDdsMemberEntry
OBJECT-TYPE
The mapping of one Discovery Domain (DD) to a Discovery Domain Set (DDS). This indicates the DD is a member of the DDS.
1.3.6.1.2.1.163.1.1.4.2.1not-accessiblecurrent
isnsDdsMemberDdId
OBJECT-TYPE
The ID that identifies the Discovery Domain that is a member of the Discovery Domain Set.
1.3.6.1.2.1.163.1.1.4.2.1.1IsnsDiscoveryDomainIdnot-accessiblecurrent
isnsDdsMemberSymbolicName
OBJECT-TYPE
The Symbolic Name of the Discovery Domain that is a member of this DDS. This value SHALL be identical to the object isnsDdSymbolicName for the associated DD ID.
1.3.6.1.2.1.163.1.1.4.2.1.2SnmpAdminStringread-onlycurrent
isnsDdInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.5
isnsDdTable
OBJECT-TYPE
A table containing configuration information for each Discovery Domain (DD) registered in the iSNS. The number of rows in the table is dependent on the number of DDs registered in the iSNS instance.
1.3.6.1.2.1.163.1.1.5.1not-accessiblecurrent
isnsDdEntry
OBJECT-TYPE
Information on a Discovery Domain (DD) registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.5.1.1not-accessiblecurrent
isnsDdId
OBJECT-TYPE
The ID that refers to this Discovery Domain, and the index to the table.
1.3.6.1.2.1.163.1.1.5.1.1.1IsnsDiscoveryDomainIdnot-accessiblecurrent
isnsDdSymbolicName
OBJECT-TYPE
The Discovery Domain Symbolic Name field contains a unique variable-length description (up to 255 bytes) that is associated with the DD.
1.3.6.1.2.1.163.1.1.5.1.1.2SnmpAdminStringread-onlycurrent
isnsDdFeatures
OBJECT-TYPE
This defines the features the Discovery Domain has.
1.3.6.1.2.1.163.1.1.5.1.1.3IsnsDdFeatureTyperead-onlycurrent
isnsDdIscsiMemberTable
OBJECT-TYPE
A table containing iSCSI node indexes that have been assigned to specific DDs in this iSNS Server instance. The number of rows in the table is dependent on the number of relationships between iSCSI Nodes and DDs registered in the iSNS instance.
1.3.6.1.2.1.163.1.1.5.2not-accessiblecurrent
isnsDdIscsiMemberEntry
OBJECT-TYPE
The mapping of one iSCSI Node to a Discovery Domain to indicate membership in the DD. The indexes are the iSNS server instance, the DD ID of the Discovery Domain, and the iSCSI Node Index of the iSCSI Node.
1.3.6.1.2.1.163.1.1.5.2.1not-accessiblecurrent
isnsDdIscsiMemberIndex
OBJECT-TYPE
The index for this member iSCSI node entry.
1.3.6.1.2.1.163.1.1.5.2.1.1IsnsNodeIndexIdnot-accessiblecurrent
isnsDdIscsiMemberName
OBJECT-TYPE
The iSCSI Name associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS server internal maximum size is 224 bytes to provide NULL termination. This is the iSCSI Name for the storage node that is a member of the DD. This value maps 1 to 1 to the isnsDdIscsiMemberIndex node index. The iSCSI Name field is too long to be easily used for an index directly. The node index used for a specific node name is only persistent across iSNS Server reinitializations for nodes that are in a Discovery Domain (DD) or are registered control nodes. This value is only required during row creation if the storage node is not yet registered in the iSNS Server instance. If the storage node is not yet registered, then the iSCSI Name MUST be provided with the iSCSI node index during row creation in order to create the 1-to-1 mapping.
1.3.6.1.2.1.163.1.1.5.2.1.2SnmpAdminString (SIZE(0..223))read-onlycurrent
isnsDdIscsiMemberIsRegistered
OBJECT-TYPE
This indicates whether this member of the DD is currently registered in the iSNS Server instance. iSCSI Storage Node members do not need to be currently registered in order for their iSCSI Name and Index to be added to a DD.
1.3.6.1.2.1.163.1.1.5.2.1.3TruthValueread-onlycurrent
isnsDdPortalMemberTable
OBJECT-TYPE
A table containing currently registered and unregistered portal objects that have been explicitly assigned to specific DDs. Explicit assignment of a portal to a DD is only done when a specific set of portals are preferred for use within a DD. Otherwise, for iSCSI, the Portal Group Object should be used for identifying which portals provide access to which storage nodes. The number of rows in the table is dependent on the number of explicit relationships between portals and DDs registered in the iSNS.
1.3.6.1.2.1.163.1.1.5.3not-accessiblecurrent
isnsDdPortalMemberEntry
OBJECT-TYPE
Each entry indicates an explicit addition of a portal to a discovery domain. The explicit addition of an entity portal to a discovery domain indicates the portal is preferred for access to nodes of the entity for this discovery domain. Registered Portal Group objects are used in iSCSI to indicate mapping of portals to nodes across all discovery domains. Portals that have been explicitly mapped to a discovery domain will be returned as part of a query that is scoped to that discovery domain. If no portal of an entity has been explicitly mapped to a discovery domain, then all portals of the entity that provide access to a storage node are returned as part of a query. The table indexes are the server instance, the DD ID of the Discovery Domain, and the Portal Index of the portal.
1.3.6.1.2.1.163.1.1.5.3.1not-accessiblecurrent
isnsDdPortalMemberIndex
OBJECT-TYPE
The index for a portal explicitly contained in the discovery domain. This managed object, combined with isnsServerIndex and isnsDdId, is the key for this table.
1.3.6.1.2.1.163.1.1.5.3.1.1IsnsPortalIndexIdnot-accessiblecurrent
isnsDdPortalMemberAddressType
OBJECT-TYPE
The type of Inet address in isnsDdPortalMemberAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsDdPortalMemberAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.5.3.1.2InetAddressTyperead-onlycurrent
isnsDdPortalMemberAddress
OBJECT-TYPE
The Inet Address for the portal. The format of this object is specified by isnsDdPortalMemberAddressType.
1.3.6.1.2.1.163.1.1.5.3.1.3InetAddressread-onlycurrent
isnsDdPortalMemberPortType
OBJECT-TYPE
The port type for the portal, either UDP or TCP.
1.3.6.1.2.1.163.1.1.5.3.1.4IsnsPortalPortTypeIdread-onlycurrent
isnsDdPortalMemberPort
OBJECT-TYPE
The port number for the portal. Whether the portal type is TCP or UDP is indicated by isnsDdPortalMemberPortType.
1.3.6.1.2.1.163.1.1.5.3.1.5InetPortNumber (1..65535)read-onlycurrent
isnsDdPortalMemberIsRegistered
OBJECT-TYPE
This indicates whether this member of the DD is currently registered in the iSNS Server instance. Portals that are DD members do not need to be currently registered in order for them to be added to a DD.
1.3.6.1.2.1.163.1.1.5.3.1.6TruthValueread-onlycurrent
isnsDdFcPortMemberTable
OBJECT-TYPE
A table containing FC Port World Wide Names (WWN) that have been assigned to specific DDs. The number of rows in the table is dependent on the number of relationships between FC Ports and DDs registered in the iSNS.
1.3.6.1.2.1.163.1.1.5.4not-accessiblecurrent
isnsDdFcPortMemberEntry
OBJECT-TYPE
The association of one FC Port with a Discovery Domain. Membership of an FC Port in a Discovery Domain is indicated by creating a row for the appropriate DD ID and FC Port WWN.
1.3.6.1.2.1.163.1.1.5.4.1not-accessiblecurrent
isnsDdFcPortMemberPortName
OBJECT-TYPE
The Port WWN of the FC Port that is a member of the DD. The value MUST be a valid FC WWN, as per the FC-GS (Fibre Channel - Generic Services) standard. This managed object, combined with the isnsServerIndex and isnsDdId are the key for this table. A zero-length string is not a valid value for this managed object.
1.3.6.1.2.1.163.1.1.5.4.1.1FcNameIdOrZero (SIZE(8))not-accessiblecurrent
isnsDdFcPortMemberIsRegistered
OBJECT-TYPE
This indicates whether this member of the DD is currently registered in the iSNS Server instance.
1.3.6.1.2.1.163.1.1.5.4.1.2TruthValueread-onlycurrent
isnsReg
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.6
isnsRegEntityInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.6.1
isnsRegEntityTable
OBJECT-TYPE
A table containing registered Entity objects in each iSNS server instance. The number of entries in the table is dependent on the number of Entity objects registered in the iSNS Server instances. All Entity objects are registered in the iSNS using the iSNS protocol.
1.3.6.1.2.1.163.1.1.6.1.1not-accessiblecurrent
isnsRegEntityEntry
OBJECT-TYPE
Information on one registered Entity object in an iSNS server instance.
1.3.6.1.2.1.163.1.1.6.1.1.1not-accessiblecurrent
isnsRegEntityIndex
OBJECT-TYPE
The Entity Index for this entity. This index is assigned by the iSNS Server when an Entity is initially registered. The Entity Index can be used to represent a registered Entity object in situations where the Entity EID would be too long/unwieldy. Zero is not a valid value for this object.
1.3.6.1.2.1.163.1.1.6.1.1.1.1IsnsEntityIndexIdOrZero (1..4294967295)not-accessiblecurrent
isnsRegEntityEID
OBJECT-TYPE
The EID is a unique registered Entity object identifier, as specified in the iSNS Specification. This is the iSNS Entity Identifier for the registered Entity object.
1.3.6.1.2.1.163.1.1.6.1.1.1.2SnmpAdminStringread-onlycurrent
isnsRegEntityProtocol
OBJECT-TYPE
The block storage protocol supported by this entity, as defined in the iSNS Specification, Section 6.2.2. The following values are initially assigned. Type Value Entity Type ---------- ----------- 1 No Protocol 2 iSCSI 3 iFCP All Others As assigned by IANA The full set of current Block Storage Protocols are specified in the IANA-maintained registry of assigned iSNS parameters. Please refer to RFC 4171 and the iSNS parameters maintained at IANA.
1.3.6.1.2.1.163.1.1.6.1.1.1.3Unsigned32 (1..4294967295)read-onlycurrent
isnsRegEntityManagementAddressType
OBJECT-TYPE
The type of Inet address in isnsRegEntityManagementAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsRegEntityManagementAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.6.1.1.1.4InetAddressTyperead-onlycurrent
isnsRegEntityManagementAddress
OBJECT-TYPE
The iSNS Management IP Address for the registered Entity object. The format of this object is specified by isnsRegEntityManagementAddressType.
1.3.6.1.2.1.163.1.1.6.1.1.1.5InetAddressread-onlycurrent
isnsRegEntityTimestamp
OBJECT-TYPE
The iSNS Entity Registration Timestamp for the registered Entity object. This is the most recent date and time that the registered Entity object, and associated registered objects contained in the Entity, were registered or updated.
1.3.6.1.2.1.163.1.1.6.1.1.1.6TimeStampread-onlycurrent
isnsRegEntityVersionMin
OBJECT-TYPE
The minimum version supported for the block storage protocol specified by isnsRegEntityProtocol. The protocol version specified can be from 1 to 254. A value of 255 is a wildcard value, indicating no minimum version value has been specified for this Entity. Entity registrations with an isnsRegEntityProtocol of 'No Protocol' SHALL have an isnsRegEntityVersionMin value of 0.
1.3.6.1.2.1.163.1.1.6.1.1.1.7Unsigned32 (0..254 | 255)read-onlycurrent
isnsRegEntityVersionMax
OBJECT-TYPE
The maximum version supported for the block storage protocol specified by isnsRegEntityProtocol. The protocol version specified can be from 1 to 254. A value of 255 is a wildcard value, indicating no maximum version value has been specified for this Entity. Entity registrations with an isnsRegEntityProtocol of 'No Protocol' SHALL have an isnsRegEntityVersionMax value of 0.
1.3.6.1.2.1.163.1.1.6.1.1.1.8Unsigned32 (0..254 | 255)read-onlycurrent
isnsRegEntityRegistrationPeriod
OBJECT-TYPE
The iSNS Entity Status Inquiry (ESI) registration period, which indicates the maximum time, in seconds, that the registration will be maintained without receipt of an iSNSP message from the entity. If the Registration Period is set to 0, then the Entity SHALL NOT be deregistered due to no contact with the entity.
1.3.6.1.2.1.163.1.1.6.1.1.1.9Unsigned32 (0..4294967295)read-onlycurrent
isnsRegEntityNumObjectsTable
OBJECT-TYPE
A table containing information on the number of registered objects associated with a registered Entity in the iSNS server instance. The number of entries in the table is dependent on the number of registered Entity objects in the iSNS.
1.3.6.1.2.1.163.1.1.6.1.2not-accessiblecurrent
isnsRegEntityNumObjectsEntry
OBJECT-TYPE
Information on the number of registered objects associated with a registered Entity object in an iSNS Server instance.
1.3.6.1.2.1.163.1.1.6.1.2.1not-accessiblecurrent
isnsRegEntityInfoNumPortals
OBJECT-TYPE
The number of Portals associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.1Gauge32 (0..4294967295)read-onlycurrent
isnsRegEntityInfoNumPortalGroups
OBJECT-TYPE
The number of Portal Groups associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.2Gauge32 (0..4294967295)read-onlycurrent
isnsRegEntityInfoNumIscsiNodes
OBJECT-TYPE
The number of iSCSI Storage Nodes associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.3Gauge32 (0..4294967295)read-onlycurrent
isnsRegEntityInfoNumFcPorts
OBJECT-TYPE
The number of FC Ports associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.4Gauge32 (0..4294967295)read-onlycurrent
isnsRegEntityInfoNumFcNodes
OBJECT-TYPE
The number of FC Nodes associated with this Entity.
1.3.6.1.2.1.163.1.1.6.1.2.1.5Gauge32 (0..4294967295)read-onlycurrent
isnsRegPortalInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.6.2
isnsRegPortalTable
OBJECT-TYPE
A table containing the registered Portals in the iSNS. The number of entries is dependent on the number of Portals registered in the iSNS.
1.3.6.1.2.1.163.1.1.6.2.1not-accessiblecurrent
isnsRegPortalEntry
OBJECT-TYPE
Information on one registered Entity Portal in the iSNS. The Entity Index is part of the table index to quickly find Portals that support a specific Entity.
1.3.6.1.2.1.163.1.1.6.2.1.1not-accessiblecurrent
isnsRegPortalPortalIndex
OBJECT-TYPE
The index for this Entity Portal.
1.3.6.1.2.1.163.1.1.6.2.1.1.1IsnsPortalIndexIdnot-accessiblecurrent
isnsRegPortalAddressType
OBJECT-TYPE
The type of Inet address in isnsRegPortalAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsRegPortalAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.6.2.1.1.2InetAddressTyperead-onlycurrent
isnsRegPortalAddress
OBJECT-TYPE
The Inet Address for this Portal as defined in the iSNS Specification, RFC 4171. The format of this object is specified by isnsRegPortalAddressType.
1.3.6.1.2.1.163.1.1.6.2.1.1.3InetAddressread-onlycurrent
isnsRegPortalPortType
OBJECT-TYPE
The port type for this Portal, either UDP or TCP, as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.2.1.1.4IsnsPortalPortTypeIdread-onlycurrent
isnsRegPortalPort
OBJECT-TYPE
The port number for this Portal as defined in the iSNS Specification, RFC 4171. Whether the Portal type is TCP or UDP is indicated by isnsRegPortalPortType.
1.3.6.1.2.1.163.1.1.6.2.1.1.5InetPortNumber (1..65535)read-onlycurrent
isnsRegPortalSymbolicName
OBJECT-TYPE
The Symbolic Name for this Portal as defined in the iSNS Specification, RFC 4171. If not provided, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.6.2.1.1.6SnmpAdminStringread-onlycurrent
isnsRegPortalEsiInterval
OBJECT-TYPE
The Entity Status Inquiry (ESI) Interval for this Portal as defined in the iSNS Specification, RFC 4171. A value of 0 indicates that ESI monitoring has not been configured for this Portal.
1.3.6.1.2.1.163.1.1.6.2.1.1.7Unsigned32 (0..65535)read-onlycurrent
isnsRegPortalEsiPortType
OBJECT-TYPE
The port type for the ESI Port, either UDP or TCP, as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.2.1.1.8IsnsPortalPortTypeIdread-onlycurrent
isnsRegPortalEsiPort
OBJECT-TYPE
The TCP or UDP port number used for ESI monitoring. Whether the port type is TCP or UDP is indicated by isnsRegPortalEsiPortType. A value of 0 indicates that ESI monitoring is not enabled for this Portal.
1.3.6.1.2.1.163.1.1.6.2.1.1.9InetPortNumberread-onlycurrent
isnsRegPortalScnPortType
OBJECT-TYPE
The port type for the SCN Port, either UDP or TCP, as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.2.1.1.10IsnsPortalPortTypeIdread-onlycurrent
isnsRegPortalScnPort
OBJECT-TYPE
The TCP or UDP port used to receive SCN messages from the iSNS Server. Whether the port type is TCP or UDP is indicated by isnsRegPortalScnPortType. A value of 0 indicates that SCN message receipt is not enabled for this Portal.
1.3.6.1.2.1.163.1.1.6.2.1.1.11InetPortNumberread-onlycurrent
isnsRegPortalSecurityInfo
OBJECT-TYPE
Indicates security attribute settings for the Portal as registered in the iSNS server. The bit for bitmapVALID must be set in order for this attribute to contain valid information. Setting a bit to 1 indicates the feature is enabled.
1.3.6.1.2.1.163.1.1.6.2.1.1.12IsnsPortalSecurityTyperead-onlycurrent
isnsRegPortalGroupInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.6.3
isnsRegPgTable
OBJECT-TYPE
A table containing the registered Portal Groups (PGs) in the iSNS Server instance. The number of entries is dependent on the number of Portal Groups registered in the iSNS.
1.3.6.1.2.1.163.1.1.6.3.1not-accessiblecurrent
isnsRegPgEntry
OBJECT-TYPE
Information on one registered Portal Group in the iSNS server instance. The Entity Index is part of the table index to quickly find Portal Groups that support Portals and iSCSI Storage Nodes in a specific Entity.
1.3.6.1.2.1.163.1.1.6.3.1.1not-accessiblecurrent
isnsRegPgIndex
OBJECT-TYPE
The PG Index for this node. The index is created by the iSNS Server instance for uniquely identifying registered objects. The PG object is registered at the same time a Portal or Storage Node is registered using the iSNS protocol.
1.3.6.1.2.1.163.1.1.6.3.1.1.1IsnsPortalGroupIndexIdnot-accessiblecurrent
isnsRegPgIscsiNodeIndex
OBJECT-TYPE
The index for the iSCSI Node associated with this PG. This index can be used to reference the isnsRegIscsiNodeTable.
1.3.6.1.2.1.163.1.1.6.3.1.1.2IsnsNodeIndexIdread-onlycurrent
isnsRegPgIscsiName
OBJECT-TYPE
The iSCSI Name of the initiator or target associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS Server internal maximum size is 224 bytes to provide NULL termination. This is the PG iSCSI Name that uniquely identifies the iSCSI Storage Node that is associated with this PG.
1.3.6.1.2.1.163.1.1.6.3.1.1.3SnmpAdminString (SIZE(0..223))read-onlycurrent
isnsRegPgPortalPortalIndex
OBJECT-TYPE
The Portal Index for the Portal associated with this PG. This index can be used to reference the isnsRegPortalTable.
1.3.6.1.2.1.163.1.1.6.3.1.1.4IsnsPortalIndexIdread-onlycurrent
isnsRegPgPortalAddressType
OBJECT-TYPE
The type of Inet address in isnsRegPgPortalAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsRegPgPortalAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.6.3.1.1.5InetAddressTyperead-onlycurrent
isnsRegPgPortalAddress
OBJECT-TYPE
The Inet Address for the Portal that is associated with the PG. The format of this object is specified by isnsRegPgPortalAddressType.
1.3.6.1.2.1.163.1.1.6.3.1.1.6InetAddressread-onlycurrent
isnsRegPgPortalPortType
OBJECT-TYPE
The port type, either UDP or TCP, for the Portal that is associated with this registered PG object.
1.3.6.1.2.1.163.1.1.6.3.1.1.7IsnsPortalPortTypeIdread-onlycurrent
isnsRegPgPortalPort
OBJECT-TYPE
The port number for the Portal that is associated with this registered PG object. Whether the Portal type is TCP or UDP is indicated by isnsRegPgPortalPortType.
1.3.6.1.2.1.163.1.1.6.3.1.1.8InetPortNumber (1..65535)read-onlycurrent
isnsRegPgPGT
OBJECT-TYPE
The Portal Group Tag (PGT) for the registered iSCSI Portal Group object in an iSNS Server instance. This indicates the tag value that the Portal uses for access to the iSCSI Storage Node. The PGT is used for coordinated access between multiple Portals, as described in the iSCSI Specification, RFC 3720. A PGT with no association is a NULL value. The value of -1 indicates a NULL value.
1.3.6.1.2.1.163.1.1.6.3.1.1.9IsnsPortalGroupTagIdOrNullread-onlycurrent
isnsRegIscsiNodeInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.6.4
isnsRegIscsiNodeTable
OBJECT-TYPE
A table containing the registered iSCSI Nodes in the iSNS server instance. Storage devices register using the iSNS protocol. While a device cannot be registered in an iSNS server using SNMP, an entry can be deleted in order to remove 'stale' entries. The number of entries is related to the number of iSCSI nodes registered in the iSNS.
1.3.6.1.2.1.163.1.1.6.4.1not-accessiblecurrent
isnsRegIscsiNodeEntry
OBJECT-TYPE
Information on one iSCSI node that has been registered in the iSNS Server instance. New rows cannot be added using SNMP.
1.3.6.1.2.1.163.1.1.6.4.1.1not-accessiblecurrent
isnsRegIscsiNodeIndex
OBJECT-TYPE
The index for this iSCSI node.
1.3.6.1.2.1.163.1.1.6.4.1.1.1IsnsNodeIndexIdnot-accessiblecurrent
isnsRegIscsiNodeName
OBJECT-TYPE
The iSCSI Name of the initiator or target associated with the storage node. The iSCSI Name cannot be longer than 223 bytes. The iSNS Server internal maximum size is 224 bytes to provide NULL termination. This is the iSCSI Name that uniquely identifies the initiator, initiator/target, target, or control node in the network.
1.3.6.1.2.1.163.1.1.6.4.1.1.2SnmpAdminString (SIZE(0..223))read-onlycurrent
isnsRegIscsiNodeType
OBJECT-TYPE
The Node Type defining the functions of this iSCSI node.
1.3.6.1.2.1.163.1.1.6.4.1.1.3IsnsIscsiNodeTyperead-onlycurrent
isnsRegIscsiNodeAlias
OBJECT-TYPE
The Alias name of the iSCSI node. This is a variable-length text-based description of up to 255 bytes.
1.3.6.1.2.1.163.1.1.6.4.1.1.4SnmpAdminStringread-onlycurrent
isnsRegIscsiNodeScnTypes
OBJECT-TYPE
The State Change Notification (SCN) types enabled for this iSCSI node.
1.3.6.1.2.1.163.1.1.6.4.1.1.5IsnsIscsiScnTyperead-onlycurrent
isnsRegIscsiNodeWwnToken
OBJECT-TYPE
This contains a globally unique 64-bit integer value that can be used to represent the World Wide Node Name of the iSCSI device in a Fibre Channel fabric. This identifier is used during the device registration process, and MUST conform to the requirements in RFC 4171. A zero-length string for this managed object indicates that a Node WWN token has not been assigned.
1.3.6.1.2.1.163.1.1.6.4.1.1.6FcNameIdOrZeroread-onlycurrent
isnsRegIscsiNodeAuthMethod
OBJECT-TYPE
This attribute contains a null-terminated string containing UTF-8 text listing the iSCSI authentication methods enabled for this iSCSI Node, in order of preference. The text values used to identify iSCSI authentication methods are embedded in this string attribute and delineated by a comma. The text values are identical to those found in RFC 3720 - iSCSI. Additional vendor-specific text values are also possible.
1.3.6.1.2.1.163.1.1.6.4.1.1.7SnmpAdminStringread-onlycurrent
isnsRegFcNodeInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.1.6.5
isnsRegFcNodeTable
OBJECT-TYPE
A table containing the registered FC Nodes in the iSNS. This supports iFCP as defined in RFC 4172.
1.3.6.1.2.1.163.1.1.6.5.1not-accessiblecurrent
isnsRegFcNodeEntry
OBJECT-TYPE
Information on one registered FC node that has been registered in the iSNS.
1.3.6.1.2.1.163.1.1.6.5.1.1not-accessiblecurrent
isnsRegFcNodeWwnn
OBJECT-TYPE
The FC Node World Wide Node Name as defined in the iSNS Specification, RFC 4171. A zero-length string is not valid for this managed object.
1.3.6.1.2.1.163.1.1.6.5.1.1.1FcNameIdOrZero (SIZE(8))not-accessiblecurrent
isnsRegFcNodeSymbolicName
OBJECT-TYPE
The FC Node Symbolic Name of the node as defined in the iSNS Specification, RFC 4171. This is a variable-length text-based description. If not provided, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.6.5.1.1.2SnmpAdminStringread-onlycurrent
isnsRegFcNodeAddressType
OBJECT-TYPE
The type of Inet address in isnsRegFcNodeAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsRegFcNodeAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.6.5.1.1.3InetAddressTyperead-onlycurrent
isnsRegFcNodeAddress
OBJECT-TYPE
The FC Node Inet address of the node as defined in the iSNS Specification, RFC 4171. The format of this object is specified by isnsRegFcNodeAddressType.
1.3.6.1.2.1.163.1.1.6.5.1.1.4InetAddressread-onlycurrent
isnsRegFcNodeIPA
OBJECT-TYPE
This managed object identifies the FC Initial Process Associator of the node as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.1.1.5OCTET STRING (SIZE(8))read-onlycurrent
isnsRegFcNodeProxyIscsiName
OBJECT-TYPE
The iSCSI Name used to represent the FC Node in the IP network. It is used as a pointer to the matching iSCSI Name entry in the iSNS Server. Its value is usually registered by an FC-iSCSI gateway connecting the IP network to the fabric containing the FC device.
1.3.6.1.2.1.163.1.1.6.5.1.1.6SnmpAdminString (SIZE(0..223))read-onlycurrent
isnsRegFcNodeNumFcPorts
OBJECT-TYPE
The number of FC Ports associated with this FC Node.
1.3.6.1.2.1.163.1.1.6.5.1.1.7Gauge32 (0..4294967295)read-onlycurrent
isnsRegFcPortTable
OBJECT-TYPE
Information on registered FC N_Ports in the iSNS. FC Ports are associated with registered FC Nodes. This supports iFCP as defined in RFC 4172.
1.3.6.1.2.1.163.1.1.6.5.2not-accessiblecurrent
isnsRegFcPortEntry
OBJECT-TYPE
Information on one FC Port that has been registered in iSNS.
1.3.6.1.2.1.163.1.1.6.5.2.1not-accessiblecurrent
isnsRegFcPortWwpn
OBJECT-TYPE
The FC Port's World Wide Port Name as defined in the iSNS Specification, RFC 4171. A zero-length string is not valid for this managed object.
1.3.6.1.2.1.163.1.1.6.5.2.1.1FcNameIdOrZero (SIZE(8))not-accessiblecurrent
isnsRegFcPortID
OBJECT-TYPE
The FC Port's Port ID as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.2FcAddressIdOrZeroread-onlycurrent
isnsRegFcPortType
OBJECT-TYPE
The FC Port Type as defined in the iSNS Specification, RFC 4171, and the Fibre Channel Generic Services Specification. Current values are as shown below: unknown (0), nPort (1), nlPort (2), fNlPort (3), fPort (129), -- x'81' flPort (130), -- x'82' ePort (132), -- x'84' bPort (133), -- x'85' mFcpPort (65297), -- x'FF11' iFcpPort (65298), -- x'FF12' unknownEnd (65535) The future assignment of any additional values will be documented in a revision of RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.3Unsigned32 (0..65535)read-onlycurrent
isnsRegFcPortSymbolicName
OBJECT-TYPE
The FC Port Symbolic Name as defined in the iSNS Specification, RFC 4171. If not provided, then the string SHALL be zero-length.
1.3.6.1.2.1.163.1.1.6.5.2.1.4SnmpAdminStringread-onlycurrent
isnsRegFcPortFabricPortWwn
OBJECT-TYPE
The Fabric Port WWN for this entry as defined in the iSNS Specification, RFC 4171. A zero-length string for this managed object indicates that the Fabric Port WWN is not known, or has not yet been registered with the iSNS Server.
1.3.6.1.2.1.163.1.1.6.5.2.1.5FcNameIdOrZeroread-onlycurrent
isnsRegFcPortHA
OBJECT-TYPE
The FC Port Hard Address as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.6FcAddressIdOrZeroread-onlycurrent
isnsRegFcPortAddressType
OBJECT-TYPE
The type of Inet address in isnsRegFcPortAddress. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsRegFcPortAddress is the zero-length string.
1.3.6.1.2.1.163.1.1.6.5.2.1.7InetAddressTyperead-onlycurrent
isnsRegFcPortAddress
OBJECT-TYPE
The FC Port Inet Address as defined in the iSNS Specification, RFC 4171. The format of this object is specified by isnsRegFcPortAddressType.
1.3.6.1.2.1.163.1.1.6.5.2.1.8InetAddressread-onlycurrent
isnsRegFcPortFcCos
OBJECT-TYPE
The FC Port Class of Service as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.9IsnsFcClassOfServiceTyperead-onlycurrent
isnsRegFcPortFc4Types
OBJECT-TYPE
The FC Port FC-4 Types as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.10OCTET STRING (SIZE(32))read-onlycurrent
isnsRegFcPortFc4Descr
OBJECT-TYPE
The FC Port FC-4 Descriptor as defined in the iSNS Specification, RFC 4171. The FC-4 Descriptor cannot be longer than 255 bytes. The iSNS Server internal maximum size is 256 bytes to provide NULL termination.
1.3.6.1.2.1.163.1.1.6.5.2.1.11SnmpAdminString (SIZE(4..255))read-onlycurrent
isnsRegFcPortFc4Features
OBJECT-TYPE
The FC Port FC-4 Features as defined in the iSNS Specification, RFC 4171.
1.3.6.1.2.1.163.1.1.6.5.2.1.12OCTET STRING (SIZE(128))read-onlycurrent
isnsRegFcPortScnTypes
OBJECT-TYPE
The iFCP State Change Notification (SCN) types enabled for the registered object.
1.3.6.1.2.1.163.1.1.6.5.2.1.13IsnsIfcpScnTyperead-onlycurrent
isnsRegFcPortRole
OBJECT-TYPE
The FC Port Role defines the role of the registered object.
1.3.6.1.2.1.163.1.1.6.5.2.1.14IsnsFcPortRoleTyperead-onlycurrent
isnsRegFcPortFcNodeWwnn
OBJECT-TYPE
The FC Node World Wide Node Name that is associated with this FC Port as defined in the iSNS Specification, RFC 4171. This managed object may contain a zero-length string prior to a device registering this value with the iSNS Server.
1.3.6.1.2.1.163.1.1.6.5.2.1.15FcNameIdOrZeroread-onlycurrent
isnsRegFcPortPpnWwn
OBJECT-TYPE
The Permanent Port Name (PPN) attribute is the FC Port Name WWPN of the first Storage Node registered in the iSNS Database that is associated with a particular FC Device (FC Node). The PPN of all subsequent Storage Node registrations that are associated with that FC Device (FC Node) SHALL be set to the FC Port Name WWPN of the first Storage Node, as defined in the iSNS Specification, RFC 4171. This managed object may contain a zero-length string prior to a device registering this value with the iSNS Server.
1.3.6.1.2.1.163.1.1.6.5.2.1.16FcNameIdOrZeroread-onlycurrent
isnsRegFcNodePortTable
OBJECT-TYPE
A table containing the mapping of a registered FC Node and associated registered iFCP Port to the supporting registered Entity object in an iSNS Server instance.
1.3.6.1.2.1.163.1.1.6.5.3not-accessiblecurrent
isnsRegFcNodePortEntry
OBJECT-TYPE
Information on one mapping from an FC Node and iFCP Port to an Entity object registered in an iSNS.
1.3.6.1.2.1.163.1.1.6.5.3.1not-accessiblecurrent
isnsRegFcNodePortEntityIndex
OBJECT-TYPE
The Entity Index for the registered Entity object associated with the FC Port and FC Node. This managed object may contain the value of zero prior to a device registering this value with the iSNS Server.
1.3.6.1.2.1.163.1.1.6.5.3.1.1IsnsEntityIndexIdOrZeroread-onlycurrent
isnsNotificationsInfo
OBJECT-IDENTITY
1.3.6.1.2.1.163.1.2
isnsInstanceInfo
OBJECT-TYPE
Textual information about the notification event and the iSNS Server generating the notification. An example is: iSNS Server Started.
1.3.6.1.2.1.163.1.2.1SnmpAdminStringaccessible-for-notifycurrent
isnsAddressNotificationType
OBJECT-TYPE
The type of Inet address in isnsAddressNotification. If the address is specified, then it must be a valid unicast address and the value of this object must be ipv4(1), ipv6(2), ipv4z(3), or ipv6z(4); otherwise, the value of this object is unknown(0), and the value of isnsAddressNotification is the zero-length string.
1.3.6.1.2.1.163.1.2.2InetAddressTypeaccessible-for-notifycurrent
isnsAddressNotification
OBJECT-TYPE
Identifies the IP address of the iSNS Server. The format of this object is specified by isnsAddressNotificationType. The IP address will always be specified in the notification unless an error causes the IP address to not be known.
1.3.6.1.2.1.163.1.2.3InetAddressaccessible-for-notifycurrent
isnsTcpPortNotification
OBJECT-TYPE
Indicates the TCP port the iSNS Server is using, or 0 if TCP-based registrations are not supported.
1.3.6.1.2.1.163.1.2.4InetPortNumberaccessible-for-notifycurrent
isnsUdpPortNotification
OBJECT-TYPE
Indicates the UDP port the iSNS Server is using, or 0 if UDP-based registrations are not supported.
1.3.6.1.2.1.163.1.2.5InetPortNumberaccessible-for-notifycurrent
isnsConformance
OBJECT-IDENTITY
1.3.6.1.2.1.163.2
isnsCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.163.2.1
isnsGroups
OBJECT-IDENTITY
1.3.6.1.2.1.163.2.2

Notifications

NameOIDStatus
isnsServerStart
NOTIFICATION-TYPE
This notification is sent when an iSNS Server begins operation. The notification provides the following: isnsInstanceInfo : iSNS Server textual information isnsAddressTypeNotification : iSNS Server address type isnsAddressNotification : iSNS Server address isnsTcpPortNotification : iSNS Server TCP Port isnsUdpPortNotification : iSNS Server UDP Port
1.3.6.1.2.1.163.0.1current
isnsServerShutdown
NOTIFICATION-TYPE
This notification is sent when an iSNS Server is shutdown. The notification provides the following: isnsInstanceInfo : iSNS Server textual information isnsAddressTypeNotification : iSNS Server address type isnsAddressNotification : iSNS Server address isnsTcpPortNotification : iSNS Server TCP Port isnsUdpPortNotification : iSNS Server UDP Port
1.3.6.1.2.1.163.0.2current

Conformance

NameOIDStatus
isnsIscsiServerCompliance
MODULE-COMPLIANCE
Initial compliance statement for an iSNS Server providing support to iSCSI clients.
1.3.6.1.2.1.163.2.1.1current
isnsIfcpServerCompliance
MODULE-COMPLIANCE
Initial compliance statement for an iSNS Server providing support to iFCP Clients.
1.3.6.1.2.1.163.2.1.2current
isnsServerAttributesGroup
OBJECT-GROUP
iSNS Server attributes.
1.3.6.1.2.1.163.2.2.1current
isnsServerNumObjectsGroup
OBJECT-GROUP
Managed objects indicating the number of registered objects in an iSNS Server or the number of registered objects associated with a registered Entity. These managed objects are optional to implement.
1.3.6.1.2.1.163.2.2.2current
isnsServerIscsiControlNodeGroup
OBJECT-GROUP
iSNS Server iSCSI control node managed objects.
1.3.6.1.2.1.163.2.2.3current
isnsServerIfcpPortControlNodeGroup
OBJECT-GROUP
iSNS Server iFCP Port control node managed objects.
1.3.6.1.2.1.163.2.2.4current
isnsServerIscsiDdsDdObjGroup
OBJECT-GROUP
iSNS Server DDS and DD managed objects for iSCSI.
1.3.6.1.2.1.163.2.2.5current
isnsServerIfcpDdsDdObjGroup
OBJECT-GROUP
iSNS Server DDS and DD managed objects for iFCP.
1.3.6.1.2.1.163.2.2.6current
isnsServerRegIscsiObjGroup
OBJECT-GROUP
iSNS Server registered iSCSI managed objects.
1.3.6.1.2.1.163.2.2.7current
isnsServerRegIfcpObjGroup
OBJECT-GROUP
iSNS Server registered iFCP managed objects.
1.3.6.1.2.1.163.2.2.8current
isnsNotificationsObjGroup
OBJECT-GROUP
iSNS Notification managed objects.
1.3.6.1.2.1.163.2.2.9current
isnsServerNotificationGroup
NOTIFICATION-GROUP
iSNS Server Notification managed objects.
1.3.6.1.2.1.163.2.2.10current