ZHONE-COM-PPP-MIB
- Registered at
- 1.3.6.1.4.1.5504.6.69
- Last updated
- 2001-06-06 16:00
- Organization
- Zhone Technologies, Inc.
- Revisions
- 2001-06-06 16:00, 2001-04-19 15:00, 2001-03-20 09:30, 2001-03-12 11:00, 2001-03-01 11:00, 2001-02-08 10:02
- Namespace
- zhone
- Source file
ZHONE-COM-PPP-MIB- Digest
sha256:cfe7f9224a71d0b33ce011e9516df8880694cf883ced1d8b5396b61d4485842f
Description
Point-to-Point Protocol (PPP) MIB IP Software Minneapolis, MN
Contact
Postal: Zhone Technologies, Inc. @ Zhone Way 7001 Oakport Street Oakland, CA 94621 USA Toll-Free: +1 877-ZHONE20 (+1 877-946-6320) Tel: +1-510-777-7000 Fax: +1-510-777-7001 E-mail: support@zhone.com
Imports
| From | Symbols |
|---|---|
| ATM-TC-MIB | AtmVcIdentifier, AtmVpIdentifier |
| IF-MIB | InterfaceIndex, InterfaceIndexOrZero, ifIndex |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP |
| SNMPv2-SMI | Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION |
| Zhone | zhoneModules, zhonePpp |
| Zhone-TC | ZhoneRowStatus |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
ATM-TC-MIB IANAifType-MIB IF-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC ZHONE-COM-PPP-MIB Zhone Zhone-TC
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| EnableFlag TEXTUAL-CONVENTION A boolean type used to indicate if a feature is enabled or disabled. | current | |||
| ZhoneAuthenticationProtocol TEXTUAL-CONVENTION The protocol used for authentication: PAP - Password Authentication Protocol CHAP - Challenge Handshake Authentication Protocol | current |
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| pppInterfaceTable OBJECT-TYPE This table is used to configure attributes of a PPP interface that are not currently covered by the standard MIBs. This table is indexed by the ifIndex of the PPP interface. IANA iftype ppp is #23. | 1.3.6.1.4.1.5504.4.5.1 | not-accessible | current | |
| pppInterfaceEntry OBJECT-TYPE There is an entry in this table for every provisioned PPP interface. Rows are created by setting pppIfRowStatus to createAndGo(4). Rows are removed by setting pppIfRowStatus to destroy(6). When a row is created or deleted in this table, a row is also created or deleted in the pppLCPExtensionsTable in this MIB module and the pppLinkConfigTable and pppLqrConfigTable in RFC 1471. An entry will also be created/destroyed in the ifTable (RFC2233). The pppIfLowerIfIndex is required for row creation. | 1.3.6.1.4.1.5504.4.5.1.1 | not-accessible | current | |
| pppIfLowerIfIndex OBJECT-TYPE The ifIndex of the lower layer interface to which this PPP interface should be bound. Since PPP interfaces are always statically bound, this value can never be zero. Upon setting this field, the ifStack will be modified to reflect the appropriate binding. This object is required for row creation. | 1.3.6.1.4.1.5504.4.5.1.1.1 | InterfaceIndex | read-create | current |
| pppIfVpi OBJECT-TYPE If this IP interface is on an ATM VC, the ATM VPI is specified here. If the IP interface is not an ATM VC, this field is ignored. The VPI value for a VPL or VCL. The value VPI=0 is only allowed for a VCL. For ATM UNIs supporting VPCs the VPI value ranges from 0 to 255. The VPI value 0 is supported for ATM UNIs conforming to the ATM Forum UNI 4.0 Annex 8 (Virtual UNIs) specification. For ATM UNIs supporting VCCs the VPI value ranges from 0 to 255. For ATM NNIs the VPI value ranges from 0 to 4095. The maximum VPI value cannot exceed the value allowable by atmInterfaceMaxActiveVpiBits defined in ATM-MIB. | 1.3.6.1.4.1.5504.4.5.1.1.2 | AtmVpIdentifier | read-create | current |
| pppIfVci OBJECT-TYPE If this PPP interface is on an ATM VC, the ATM VCI is specified here. If the PPP interface is not an ATM VC, this field is ignored. The maximum VCI value cannot exceed the value allowable by atmInterfaceMaxActiveVciBits defined in ATM-MIB. | 1.3.6.1.4.1.5504.4.5.1.1.3 | AtmVcIdentifier | read-create | current |
| pppIfCallMode OBJECT-TYPE Indicates where the PPP call is initiated. noCall: No call is initiated inCall: Call is intiated remotely. outCall: Call is intiated locally. | 1.3.6.1.4.1.5504.4.5.1.1.4 | INTEGER {noCall(1), inCall(2), outCall(3)} | read-create | current |
| pppIfFrameType OBJECT-TYPE The type of framing used if the link type is ATM or Frame Relay. If link type is atm, pppIfFrameType must be atmLLC or atmVc. If link type is frameRelay, pppIfFrameType must be frameRelay. If link type is any other value, pppIfFrameType must be none. Currently, only atmLLC and atmVC are supported. | 1.3.6.1.4.1.5504.4.5.1.1.5 | INTEGER {none(1), frameRelay(2), atmLLC(3), atmVc(4)} | read-create | current |
| pppIfNumChannels OBJECT-TYPE The maximum number of channels allowed on this interface. Currently, only one channel is supported. | 1.3.6.1.4.1.5504.4.5.1.1.6 | Integer32 (1..65535) | read-create | current |
| pppIfRowStatus OBJECT-TYPE Zhone convention to support row creation and deletion. pppIfLgId is required to create or destroy a row in this table. | 1.3.6.1.4.1.5504.4.5.1.1.7 | ZhoneRowStatus | read-create | current |
| pppLCPExtensionsTable OBJECT-TYPE This table is used to configure attributes not found in the pppLinkConfigTable defined in RFC 1471. This table is indexed by the ifIndex of the PPP interface to which these LCP attributes apply. | 1.3.6.1.4.1.5504.4.5.2 | not-accessible | current | |
| pppLCPExtensionsEntry OBJECT-TYPE There is an entry in this table for every provisioned PPP interface. Rows in this table are created or deleted when a row in the pppInterfaceTable is created or deleted using pppIfRowStatus. Therefore, objects in this table cannot be set in the same SNMP PDU as the objects used to create a row in the pppInterfaceTable. | 1.3.6.1.4.1.5504.4.5.2.1 | not-accessible | current | |
| lcpExtReceiveAuthEnable OBJECT-TYPE Enable or disable incoming authentication. | 1.3.6.1.4.1.5504.4.5.2.1.1 | EnableFlag | read-create | current |
| lcpExtReceiveAuthProtocol OBJECT-TYPE The preferred protocol used for incoming authentication. If lcpExtReceiveAuthEnable is enabled, the authentication protocol will be negotiated with the peer. | 1.3.6.1.4.1.5504.4.5.2.1.2 | ZhoneAuthenticationProtocol | read-create | current |
| lcpExtSendAuthEnable OBJECT-TYPE Enable or disable outgoing authentication. | 1.3.6.1.4.1.5504.4.5.2.1.3 | EnableFlag | read-create | current |
| lcpExtSendAuthProtocol OBJECT-TYPE The protocol used with lcpExtSendAuthIdentity to look up the outgoing authentication information. | 1.3.6.1.4.1.5504.4.5.2.1.4 | ZhoneAuthenticationProtocol | read-create | current |
| lcpExtSendAuthIdentity OBJECT-TYPE The identity (PAP peer ID or CHAP name) used with lcpExtSendAuthProtocol to look up the outgoing authentication information. Default value is the empty string. | 1.3.6.1.4.1.5504.4.5.2.1.5 | OCTET STRING (SIZE(0..24)) | read-create | current |
| lcpExtQualityProtocol OBJECT-TYPE The Quality Protocol used. Currently, the only valid quality protocl is LQR. Quality protocol must be enabled using pppLqrConfigStatus in RFC1471. | 1.3.6.1.4.1.5504.4.5.2.1.6 | INTEGER {lqr(1)} | read-create | current |
| lcpExtMagicNumber OBJECT-TYPE The number used in Magic Number negotiation. Magic number negotiation must be enabled using pppLinkConfigMagicNumber in RFC1471. When set to zero, a random number will be used for the magic number. This allows us to better prevent having two devices with the same magic number. | 1.3.6.1.4.1.5504.4.5.2.1.7 | Unsigned32 | read-create | current |
| lcpExtMaxPad OBJECT-TYPE The number of padded bytes at the end of data. This is used for Self-Describing Padding, a method for placing unambiguous padding octets at the end of the PPP Information field in order to cause messages to fall on a natural boundary. | 1.3.6.1.4.1.5504.4.5.2.1.8 | Integer32 (1..255) | read-create | current |
| lcpExtCallbackEnable OBJECT-TYPE Enable or disable Callback negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.9 | EnableFlag | read-create | current |
| lcpExtCallbackType OBJECT-TYPE The method of determining the location to callback. byAuth: Location is determined by authorization information. byDialString: Location is determined by a dialing string. byIdentifier: Location is determined by a location ID. byE164: Location is determined by an E.164 number. byName: Location is determined by a distinguished name. These objects only apply when callback negotiation is enabled using lcpExtCallbackEnable. | 1.3.6.1.4.1.5504.4.5.2.1.10 | INTEGER {byAuth(1), byDialStr(2), byIdentifier(3), byE164(4), byName(5)} | read-create | current |
| lcpExtCallbackDialString OBJECT-TYPE The dialing string used for a callback. The format of this string is determined by lcpExtCallbackType. This object only applies when callback negotiation is enabled using lcpExtCallbackEnable. Default value is the empty string. | 1.3.6.1.4.1.5504.4.5.2.1.11 | OCTET STRING (SIZE(0..24)) | read-create | current |
| lcpExtRestartTimer OBJECT-TYPE Number of seconds before retransmission of an LCP packet. | 1.3.6.1.4.1.5504.4.5.2.1.12 | Integer32 (1..999) | read-create | current |
| lcpExtMaxConfigRetries OBJECT-TYPE Number of LCP configuration retries without response before the link is brought down. | 1.3.6.1.4.1.5504.4.5.2.1.13 | Integer32 (1..999) | read-create | current |
| lcpExtMaxTerminateRetries OBJECT-TYPE Number of LCP termination retries without response before the link is brought down. | 1.3.6.1.4.1.5504.4.5.2.1.14 | Integer32 (1..999) | read-create | current |
| lcpExtMaxFailureRetries OBJECT-TYPE Number of times a Configuration Nak is sent before a Configuration Rej is sent. | 1.3.6.1.4.1.5504.4.5.2.1.15 | Integer32 (1..999) | read-create | current |
| lcpExtMRUEnable OBJECT-TYPE Enable or disable MRU negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.16 | EnableFlag | read-create | current |
| lcpExtACCMEnable OBJECT-TYPE Enable or disable Asynchronous Control Character Map negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.17 | EnableFlag | read-create | current |
| lcpExtPFCEnable OBJECT-TYPE Enable or disable Protocol Field Compression negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.18 | EnableFlag | read-create | current |
| lcpExtACFCEnable OBJECT-TYPE Enable or disable Address and Control Field Compression negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.19 | EnableFlag | read-create | current |
| lcpExtFCSAltEnable OBJECT-TYPE Enable or disable FCS Alternative negotiation. The negotiated FCS values take effect only during Authentication and Network-Layer Protocol phases. | 1.3.6.1.4.1.5504.4.5.2.1.20 | EnableFlag | read-create | current |
| lcpExtSDPEnable OBJECT-TYPE Enable or disable Self-Describing Padding negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.21 | EnableFlag | read-create | current |
| lcpExtNumModeEnable OBJECT-TYPE Enable or disable Numbered Mode negotiation. | 1.3.6.1.4.1.5504.4.5.2.1.22 | EnableFlag | read-create | current |
| pppNCPExtensionsTable OBJECT-TYPE This table is used to configure attributes not found in the pppIpConfigTable defined in RFC 1473. This table is indexed by the ifIndex of the network (IP) interface to which these NCP attributes apply. | 1.3.6.1.4.1.5504.4.5.3 | not-accessible | current | |
| pppNCPExtensionsEntry OBJECT-TYPE A row must be created in this table when an IP over PPP interface is provisioned. Rows are created by setting ipIfPppEnabled in the ipInterfaceTable to 'true'. Rows are deleted by setting ipIfPppEnabled in the ipInterfaceTable to 'false'. Creating or deleting a row in this table will do the same in the pppIpConfigTable in rfc1473.mib. | 1.3.6.1.4.1.5504.4.5.3.1 | not-accessible | current | |
| ncpExtVJCompMaxSlotID OBJECT-TYPE The maximum slot ID for Van Jacobson Header Compression. | 1.3.6.1.4.1.5504.4.5.3.1.1 | Integer32 (3..16) | read-write | current |
| ncpExtVJCompSlotID OBJECT-TYPE Indicates whether the slot identifier field may be compressed: disabled: The slot identifier must not be compressed. All compressed TCP packets must set the C bit in every change mask, and must include the slot identifier. enabled: The slot identifier may be compressed. | 1.3.6.1.4.1.5504.4.5.3.1.2 | EnableFlag | read-write | current |
| ncpExtIpAddrOptionEnable OBJECT-TYPE Enable or disable IP Address Negotiation. | 1.3.6.1.4.1.5504.4.5.3.1.3 | EnableFlag | read-write | current |
| ncpExtRestartTimer OBJECT-TYPE Number of seconds before retransmission of an IP packet. | 1.3.6.1.4.1.5504.4.5.3.1.4 | Integer32 (1..999) | read-write | current |
| ncpExtMaxConfigRetries OBJECT-TYPE Number of IP configuration retries without response before the session is brought down. | 1.3.6.1.4.1.5504.4.5.3.1.5 | Integer32 (1..999) | read-write | current |
| ncpExtMaxTerminateRetries OBJECT-TYPE Number of IP termination retries without response before the session is brought down. | 1.3.6.1.4.1.5504.4.5.3.1.6 | Integer32 (1..999) | read-write | current |
| ncpExtFailureRetries OBJECT-TYPE Number of times a Configuration Nak is sent before a Configuration Rej is sent | 1.3.6.1.4.1.5504.4.5.3.1.7 | Integer32 (1..999) | read-write | current |
| pppNextAuthId OBJECT-TYPE A GET of this object will return the next available pppAuthId to be used when creating an entry in the pppAuthenticationTable. A GET-NEXT of this object will return the last number given out. | 1.3.6.1.4.1.5504.4.5.4 | Integer32 (1..2147483647) | read-only | current |
| pppAuthenticationTable OBJECT-TYPE This table contains provisioning for incoming and/or outgoing PPP authentication. | 1.3.6.1.4.1.5504.4.5.5 | not-accessible | current | |
| pppAuthenticationEntry OBJECT-TYPE An entry exists in the pppAuthenticationTable for each set of data used for PPP authentication. A set of PPP authentication data can be used for incoming authentication, outgoing authentication or both. A row can be created/deleted using pppAuthRowStatus. The next available pppAuthId value can be obtained using pppNextAuthId. | 1.3.6.1.4.1.5504.4.5.5.1 | not-accessible | current | |
| pppAuthSubId OBJECT-TYPE The unique identifier of the subscriber associated with this authentication entry. A single subscriber may have multiple authenticated users. If this entry is only used for outgoing authentication, there may not be an associated subscriber. Therefore, the subId may be zero. | 1.3.6.1.4.1.5504.4.5.5.1.1 | Integer32 (0..2147483647) | not-accessible | current |
| pppAuthId OBJECT-TYPE A unique number used to identify this authentication entry. | 1.3.6.1.4.1.5504.4.5.5.1.2 | Integer32 (1..2147483647) | not-accessible | current |
| pppAuthIpIfIndex OBJECT-TYPE The ifIndex of the IP record associated with this set of PPP authentication data. If this entry is to be used for incoming authentication, this object must be set to a non-zero value. | 1.3.6.1.4.1.5504.4.5.5.1.3 | InterfaceIndexOrZero | read-create | current |
| pppAuthLgId OBJECT-TYPE The unique identifier of the line group on which this authentication data is allowed to be used. If the value is zero, this authentication data can be used on any line group. | 1.3.6.1.4.1.5504.4.5.5.1.4 | InterfaceIndexOrZero | read-create | current |
| pppAuthProtocol OBJECT-TYPE The protocol used for authentication: PAP - Password Authentication Protocol CHAP - Challenge Handshake Authentication Protocol A bit is set for each authentication protocol that is enabled. All protocols are disabled by default. | 1.3.6.1.4.1.5504.4.5.5.1.5 | Bits {pap(0), chap(1)} | read-create | current |
| pppAuthPAPPeerID OBJECT-TYPE The username used if we are authenticating with the PAP protocol. Default value is the empty string. | 1.3.6.1.4.1.5504.4.5.5.1.6 | OCTET STRING (SIZE(0..24)) | read-create | current |
| pppAuthPAPPassword OBJECT-TYPE The password used if we are authenticating with the PAP protocol. Default value is the empty string. For security, an empty string will be returned on a GET. | 1.3.6.1.4.1.5504.4.5.5.1.7 | OCTET STRING (SIZE(0..24)) | read-create | current |
| pppAuthCHAPName OBJECT-TYPE The username used if we are authenticating with the CHAP protocol. Default value is the empty string. | 1.3.6.1.4.1.5504.4.5.5.1.8 | OCTET STRING (SIZE(0..24)) | read-create | current |
| pppAuthCHAPSecret OBJECT-TYPE The password used if we are authenticating with the CHAP protocol. Default value is the empty string. For security, an empty string will be returned on a GET. | 1.3.6.1.4.1.5504.4.5.5.1.9 | OCTET STRING (SIZE(0..24)) | read-create | current |
| pppAuthStatus OBJECT-TYPE Setting this object to 'invalid' causes the information for that entry to become invalidated. Calls using the authentication information from an invalidated entry will not be accepted or initiated. This allows an entry to be temporarily disabled without deleting it from the table. | 1.3.6.1.4.1.5504.4.5.5.1.10 | INTEGER {valid(1), invalid(2)} | read-create | current |
| pppAuthRowStatus OBJECT-TYPE This object is used to create or delete an entry in the table. Setting this object to 'createAndGo' will cause an entry to be created. Setting this object to 'destroy' will cause an entry to be deleted. Objects required for creating an entry are specified in the pppAuthenticationEntry description. | 1.3.6.1.4.1.5504.4.5.5.1.12 | ZhoneRowStatus | read-create | current |