MIBs Depot

ZHONE-COM-IP-RIPv2-MIB

Registered at
1.3.6.1.4.1.5504.4.1.2
1.3.6.1.4.1.5504.6.52
Last updated
2001-09-12 13:18
Organization
Zhone Technologies, Inc.
Revisions
2001-09-12 13:18, 2000-10-12 17:08, 2000-10-02 08:05, 2000-09-12 10:20
Namespace
zhone
Source file
ZHONE-COM-IP-RIPv2-MIB
Digest
sha256:b82278c67506fe3e3577ef35a21804f23989a8e1446060c670252d9570dd2b99

Description

RIPv2 MIB IP Software Minneapolis, MN

Contact

Postal: Zhone Technologies, Inc. @ Zhone Way 7001 Oakport Street Oakland, CA 94621 USA Toll-Free: +1 877-ZHONE20 (+1 877-946-6320) Tel: +1-510-777-7000 Fax: +1-510-777-7001 E-mail: support@zhone.com

Imports

FromSymbols
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP
SNMPv2-SMICounter32, IpAddress, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, TimeTicks, Unsigned32, iso
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION
ZHONE-COM-IP-RD-MIBrdIndex
ZhonezhoneIp, zhoneModules

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC
ZHONE-COM-IP-RD-MIB
ZHONE-COM-IP-RIPv2-MIB
Zhone
Zhone-TC

Textual conventions

NameOIDSyntaxAccessStatus
RipAuthKey
TEXTUAL-CONVENTION
The RIP authentication key specification. Only the RIP mib should use this.
current

Objects

NameOIDSyntaxAccessStatus
rip2
OBJECT-IDENTITY
The MIB module to describe the RIP2 Version 2 Protocol as represented in Zhone products. The notion of a Routing Domain (RD) is used to group instances of RIP within a system.
1.3.6.1.4.1.5504.4.1.2current
zhRip2GlobalTable
OBJECT-TYPE
A list of global RIP values. Rows are created and destroyed whenever a routing domain is created and destroyed. Rows cannot be created or destroyed via SNMP.
1.3.6.1.4.1.5504.4.1.2.1not-accessiblecurrent
zhRip2GlobalEntry
OBJECT-TYPE
A single routing domain in a single subnet.
1.3.6.1.4.1.5504.4.1.2.1.1not-accessiblecurrent
zhRip2GlobalRouteChanges
OBJECT-TYPE
The number of route changes made to the IP Route Database by RIP. This does not include the refresh of a route's age.
1.3.6.1.4.1.5504.4.1.2.1.1.1Counter32read-onlycurrent
zhRip2GlobalQueries
OBJECT-TYPE
The number of responses sent to RIP queries from other systems.
1.3.6.1.4.1.5504.4.1.2.1.1.2Counter32read-onlycurrent
zhRip2GlobalAdminState
OBJECT-TYPE
An enumeration of the operational state of RIP for a RD. The possible values are either 'disabled' or 'enabled', where the operation of RIP is completely disabled or enabled on all interfaces within a RD. The default is 'enabled'.
1.3.6.1.4.1.5504.4.1.2.1.1.3INTEGER {disabled(1), enabled(2)}read-writecurrent
zhRip2GlobalUpdateTime
OBJECT-TYPE
The time in seconds between transmissions of RIP updates on all interfaces within a RD. The default is 30 seconds, which follows RFC 1058 and subsequent RIP RFCs.
1.3.6.1.4.1.5504.4.1.2.1.1.4Unsigned32read-writecurrent
zhRip2IfStatTable
OBJECT-TYPE
A list of subnets that require separate status monitoring in RIP. Rows are created and destroyed whenever an interface within the RD is created and destroyed. Rows cannot be created or destroyed via SNMP.
1.3.6.1.4.1.5504.4.1.2.2not-accessiblecurrent
zhRip2IfStatEntry
OBJECT-TYPE
A single routing domain in a single subnet.
1.3.6.1.4.1.5504.4.1.2.2.1not-accessiblecurrent
zhRip2IfStatAddress
OBJECT-TYPE
The IP Address of this system on the indicated subnet. For unnumbered interfaces, a unique internal identifier is used.
1.3.6.1.4.1.5504.4.1.2.2.1.1IpAddressnot-accessiblecurrent
zhRip2IfStatRcvBadPackets
OBJECT-TYPE
The number of RIP response packets received by the RIP process that were subsequently discarded for any reason (e.g. a version 0 packet, or an unknown command type).
1.3.6.1.4.1.5504.4.1.2.2.1.2Counter32read-onlycurrent
zhRip2IfStatRcvBadRoutes
OBJECT-TYPE
The number of routes, in valid RIP packets, that were ignored for any reason (e.g. unknown address family, or invalid metric).
1.3.6.1.4.1.5504.4.1.2.2.1.3Counter32read-onlycurrent
zhRip2IfStatSentUpdates
OBJECT-TYPE
The number of triggered RIP updates actually sent on this interface. This explicitly does NOT include full updates sent containing new information.
1.3.6.1.4.1.5504.4.1.2.2.1.4Counter32read-onlycurrent
zhRip2IfConfTable
OBJECT-TYPE
A list of subnets that require separate configuration in RIP. Rows are created and destroyed whenever an interface within the RD is created and destroyed. Rows cannot be created or destroyed via SNMP.
1.3.6.1.4.1.5504.4.1.2.3not-accessiblecurrent
zhRip2IfConfEntry
OBJECT-TYPE
A single routing domain in a single subnet.
1.3.6.1.4.1.5504.4.1.2.3.1not-accessiblecurrent
zhRip2IfConfAddress
OBJECT-TYPE
The IP Address of this system on the indicated subnet. For unnumbered interfaces, a unique internal identifier is used.
1.3.6.1.4.1.5504.4.1.2.3.1.1IpAddressnot-accessiblecurrent
zhRip2IfConfAuthType
OBJECT-TYPE
The type of Authentication used when receiving RIP packets on this interface. When set to 'noAuthentication', no authentication is performed. For 'simplePassword', a clear text password is used in zhRip2IfConfAuthKey. When set to 'md5', an MD5 string is used in zhRip2IfConfAuthKey (see RFC 1321).
1.3.6.1.4.1.5504.4.1.2.3.1.2INTEGER {noAuthentication(1), simplePassword(2), md5(3)}read-writecurrent
zhRip2IfConfAuthKey
OBJECT-TYPE
The value to be used as the Authentication Key whenever the corresponding instance of zhRip2IfConfAuthType has a value other than noAuthentication. A modification of the corresponding instance of zhRip2IfConfAuthType does not modify the zhRip2IfConfAuthKey value. If a string shorter than 16 octets is supplied, it will be left- justified and padded to 16 octets, on the right, with nulls (0x00). Reading this object always results in an OCTET STRING of length zero; authentication may not be bypassed by reading the MIB object.
1.3.6.1.4.1.5504.4.1.2.3.1.3RipAuthKeyread-writecurrent
zhRip2IfConfSend
OBJECT-TYPE
What the router sends on this interface. If set to 'doNotSend', no RIP updates are sent out on this interface. If set to 'ripVersion1', RIP updates compliant with RFC 1058 are sent. 'rip1Compatible' implies broadcasting RIP-2 updates using RFC 1058 route subsumption rules. 'ripVersion2' implies multicasting RIP-2 updates. 'ripV1Demand' indicates the use of Demand RIP on a WAN interface under RIP Version 1 rules. 'ripV2Demand' indicates the use of Demand RIP on a WAN interface under Version 2 rules. The default is 'rip1Compatible'.
1.3.6.1.4.1.5504.4.1.2.3.1.4INTEGER {doNotSend(1), ripVersion1(2), rip1Compatible(3), ripVersion2(4), ripV1Demand(5), ripV2Demand(6)}read-writecurrent
zhRip2IfConfReceive
OBJECT-TYPE
This indicates which version of RIP updates are to be accepted. When set to 'rip1', only RIP updates compliant with RFC 1058 are received. 'rip2' specifies to receive RIP updates compliant with RFC 1388 only. Setting 'rip1OrRip2' allows reception of RFC 1058 and RFC 1388 compliant RIP updates. If set to 'doNotReceive', the intreface accepts no RIP updates. Note that 'rip2' and 'rip1OrRip2' implies reception of multicast packets. The default is 'rip1OrRip2'.
1.3.6.1.4.1.5504.4.1.2.3.1.5INTEGER {rip1(1), rip2(2), rip1OrRip2(3), doNotReceive(4)}read-writecurrent
zhRip2IfConfDefaultMetric
OBJECT-TYPE
This variable indicates the metric that is to be used for the default route entry in RIP updates originated on this interface. A value of zero indicates that no default route should be originated; in this case, a default route via another router may be propagated. The default is set using the metric in the received update.
1.3.6.1.4.1.5504.4.1.2.3.1.6INTEGER (0..15)read-writecurrent
zhRip2IfConfSrcAddress
OBJECT-TYPE
The IP Address this system will use as a source address on this interface. If it is a numbered interface, this MUST be the same value as ipIfAddr (from ZHONE-IP-REC-MIB). On unnumbered interfaces, it must be the value of ipIfAddr for some interface on the system.
1.3.6.1.4.1.5504.4.1.2.3.1.7IpAddressread-writecurrent
zhRip2IfConfStaticRouteAdvertisement
OBJECT-TYPE
This variable specifies whether to advertise static routes. When set to 'none', no static routes are advertised. For 'low', only low preference static routes are advertised, and when set to 'high' only high preference static routes are advertised. 'both' specifies to advertise both low and high preference static routes. Low preference routes are default routes. The default value is 'none'.
1.3.6.1.4.1.5504.4.1.2.3.1.8INTEGER {none(1), low(2), high(3), both(4)}read-writecurrent
zhRip2IfConfPoison
OBJECT-TYPE
This variable specifies whether to send poison reverse updates on this interface. Poison reverse updates are used to prevent larger loops within the network by setting the metric (cost) of neighboring routes to infinity. This will prevent two-hop loops. By default, RIP uses a technique called split horizon to avoid routing loops and allow smaller update packets. Split horizon specifies that when a RIP update is sent out a particular network interface, it should not include routing information acquired over that same interface. Poison Reverse is a variation of the split horizon technique that specifies that all routes are included in an update out a particular interface, but that the metric is set to infinity for routes acquired over that interface. One drawback is that routing update packet sizes are increased when using poison reverse. Setting the value of this object to 'disable' prevents poison reverse updates, where 'enable' allows poison updates to be sent on this interface. The default value is 'disabled'.
1.3.6.1.4.1.5504.4.1.2.3.1.9INTEGER {disabled(1), enabled(2)}read-writecurrent
zhRip2PeerTable
OBJECT-TYPE
A list of RIP Peers. A row (new peer) is created whenever an interface running RIP receives a RIP update from a new peer. The row is destroyed when the interface has not received a RIP update for more tha 180 seconds. Rows cannot be created or destroyed via SNMP.
1.3.6.1.4.1.5504.4.1.2.4not-accessiblecurrent
zhRip2PeerEntry
OBJECT-TYPE
Information regarding a single routing peer.
1.3.6.1.4.1.5504.4.1.2.4.1not-accessiblecurrent
zhRip2PeerAddress
OBJECT-TYPE
The IP Address that the peer is using as its source address. Note that on an unnumbered link, this may not be a member of any subnet on the system.
1.3.6.1.4.1.5504.4.1.2.4.1.1IpAddressnot-accessiblecurrent
zhRip2PeerLastUpdate
OBJECT-TYPE
The value of sysUpTime when the most recent RIP update was received from this system.
1.3.6.1.4.1.5504.4.1.2.4.1.2TimeTicksread-onlycurrent
zhRip2PeerVersion
OBJECT-TYPE
The RIP version number in the header of the last RIP packet received.
1.3.6.1.4.1.5504.4.1.2.4.1.3INTEGER (0..255)read-onlycurrent
zhRip2PeerRcvBadPackets
OBJECT-TYPE
The number of RIP response packets from this peer discarded as invalid.
1.3.6.1.4.1.5504.4.1.2.4.1.4Counter32read-onlycurrent
zhRip2PeerRcvBadRoutes
OBJECT-TYPE
The number of routes from this peer that were ignored because the entry format was invalid.
1.3.6.1.4.1.5504.4.1.2.4.1.5Counter32read-onlycurrent