TRILL-OAM-MIB
- Registered at
- 1.3.6.1.2.1.238
- Last updated
- 2016-01-14 12:00
- Organization
- IETF TRILL WG
- Revisions
- 2016-01-14 12:00
- Namespace
- standard
- Source file
TRILL-OAM-MIB- Digest
sha256:e5354135da04506f03418f7c32a290abe568d258f8f6d7ecc27d97b6208d676a
Description
This MIB module contains the management objects for the management of TRILL Services Operations, Administration and Maintenance. Initial version. Published as RFC 7784. Copyright (c) 2016 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). ------------------------------------------------------------- Abbreviations Used Term Definition CFM Connectivity Fault Management IEEE Institute of Electrical and Electronics Engineers IETF Internet Engineering Task Force ITU-T International Telecommunication Union - Telecommunication Standardization Bureau FCOI The Final, Cross-Connect Error, Out-of-band, and In-band flags from the TRILL OAM Application Identifier TLV. LBM Loopback Message MA Maintenance Association (equivalent to a MEG) MAC Media Access Control MD Maintenance Domain (equivalent to an OAM Domain in Metro Ethernet Forum (MEF) 17) MEG Maintenance Entity Group (equivalent to a MA) MEG Level Maintenance Entity Group Level (equivalent to MD Level) MEP Maintenance Association End Point MIB Management Information Base MIP Maintenance Domain Intermediate Point MTVM Multi-destination Tree Verification Message MTVR Multi-destination Tree Verification Reply OAM Operations, Administration, and Maintenance On-Demand OAM actions that are initiated via manual intervention for a limited time to carry out diagnostics. On-demand OAM can result in singular or periodic OAM actions during the diagnostic time interval. PTM Path Trace Message PTR Path Trace Reply RFC Request for Comments SNMP Simple Network Management Protocol TLV Type-Length-Value, a method of encoding Objects TRILL Transparent Interconnection of Lots of Links VLAN Virtual LAN
Contact
Email: trill@ietf.org
Imports
| From | Symbols |
|---|---|
| IEEE8021-CFM-MIB | Dot1agCfmEgressActionFieldValue, Dot1agCfmIngressActionFieldValue, Dot1agCfmRemoteMepState, dot1agCfmMaIndex, dot1agCfmMdIndex, dot1agCfmMepDbEntry, dot1agCfmMepEntry, dot1agCfmMepIdentifier |
| LLDP-MIB | LldpChassisId, LldpChassisIdSubtype, LldpPortId, LldpPortIdSubtype |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Counter32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2 |
| SNMPv2-TC | DisplayString, MacAddress, RowStatus, TEXTUAL-CONVENTION, TimeStamp, TruthValue |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
BRIDGE-MIB IANA-ADDRESS-FAMILY-NUMBERS-MIB IANAifType-MIB IEEE8021-CFM-MIB IEEE8021-TC-MIB IF-MIB LLDP-MIB P-BRIDGE-MIB Q-BRIDGE-MIB RFC1158-MIB RFC1271-MIB RMON-MIB RMON2-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC TOKEN-RING-RMON-MIB TRILL-OAM-MIB
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| trillOamNotifications OBJECT-IDENTITY | 1.3.6.1.2.1.238.0 | |||
| trillOamMibObjects OBJECT-IDENTITY | 1.3.6.1.2.1.238.1 | |||
| trillOamMep OBJECT-IDENTITY | 1.3.6.1.2.1.238.1.1 | |||
| trillOamMepTable OBJECT-TYPE This table is an extension of the dot1agCfmMepTable and rows are automatically added or deleted from this table based upon row creation and destruction of the dot1agCfmMepTable. This table represents the local MEP TRILL OAM configuration table. The primary purpose of this table is provide local parameters for the TRILL OAM function found in RFC 7455 and instantiated at a MEP. | 1.3.6.1.2.1.238.1.1.1 | not-accessible | current | |
| trillOamMepEntry OBJECT-TYPE The conceptual row of trillOamMepTable. | 1.3.6.1.2.1.238.1.1.1.1 | not-accessible | current | |
| trillOamMepRName OBJECT-TYPE This object contains the RBridge Nickname field of the TRILL RBridge as defined in RFC 6325, Section 3.7. | 1.3.6.1.2.1.238.1.1.1.1.1 | Unsigned32 (0..65471) | read-only | current |
| trillOamMepNextPtmTId OBJECT-TYPE Next Sequence Number / Transaction Identifier to be sent in a Multi-destination message. This Sequence Number can be zero because it wraps around. Implementation of this identifier should be should provide a unique code value in order to identify the Transaction Identifier for a MEP with multiple flows. | 1.3.6.1.2.1.238.1.1.1.1.2 | Counter32 | read-only | current |
| trillOamMepNextMtvmTId OBJECT-TYPE Next Sequence Number / Transaction Identifier to be sent in a Multi-destination message. This Sequence Number can be zero because it wraps around. An implementation should be unique to identify Transaction Identifier for a MEP with multiple flows. | 1.3.6.1.2.1.238.1.1.1.1.3 | Counter32 | read-only | current |
| trillOamMepPtrIn OBJECT-TYPE Total number of valid, in-order Path Trace Replies received. | 1.3.6.1.2.1.238.1.1.1.1.4 | Counter32 | read-only | current |
| trillOamMepPtrInOutofOrder OBJECT-TYPE Total number of valid, out-of-order Path Trace Replies received. | 1.3.6.1.2.1.238.1.1.1.1.5 | Counter32 | read-only | current |
| trillOamMepPtrOut OBJECT-TYPE Total number of valid, Path Trace Replies transmitted. | 1.3.6.1.2.1.238.1.1.1.1.6 | Counter32 | read-only | current |
| trillOamMepMtvrIn OBJECT-TYPE Total number of valid, in-order Multi-destination Replies received. | 1.3.6.1.2.1.238.1.1.1.1.7 | Counter32 | read-only | current |
| trillOamMepMtvrInOutofOrder OBJECT-TYPE Total number of valid, out-of-order Multi-destination Replies received. | 1.3.6.1.2.1.238.1.1.1.1.8 | Counter32 | read-only | current |
| trillOamMepMtvrOut OBJECT-TYPE Total number of valid, Multi-destination Replies transmitted. | 1.3.6.1.2.1.238.1.1.1.1.9 | Counter32 | read-only | current |
| trillOamMepTxLbmDestRName OBJECT-TYPE The Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.10 | Unsigned32 (0..65471) | read-create | current |
| trillOamMepTxLbmHC OBJECT-TYPE The Hop Count field to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.11 | Unsigned32 (1..63) | read-create | current |
| trillOamMepTxLbmReplyModeOob OBJECT-TYPE True indicates that the Reply to an LBM is out of band and the out-of-band IP Address TLV is to be transmitted. False indicates that in-band reply is transmitted. | 1.3.6.1.2.1.238.1.1.1.1.12 | TruthValue | read-create | current |
| trillOamMepTransmitLbmReplyIp OBJECT-TYPE The IP address for an out-of-band IP Address TLV that is to be transmitted. Maximum length for IPv6 is 16 octets and IPv4 is 4 octets. | 1.3.6.1.2.1.238.1.1.1.1.13 | OCTET STRING (SIZE(4..16)) | read-create | current |
| trillOamMepTxLbmFlowEntropy OBJECT-TYPE 96-byte Flow Entropy, as defined in RFC 7455, to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.14 | OCTET STRING (SIZE(96)) | read-create | current |
| trillOamMepTxPtmDestRName OBJECT-TYPE The Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.15 | Unsigned32 (0..65471) | read-create | current |
| trillOamMepTxPtmHC OBJECT-TYPE The Hop Count field to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.16 | Unsigned32 (1..63) | read-create | current |
| trillOamMepTxPtmReplyModeOob OBJECT-TYPE True indicates that a Reply to a PTM will be out of band and the out-of-band IP Address TLV is to be transmitted. False indicates that an in-band reply is transmitted. | 1.3.6.1.2.1.238.1.1.1.1.17 | TruthValue | read-create | current |
| trillOamMepTransmitPtmReplyIp OBJECT-TYPE The IP address for an out-of-band IP Address TLV to be transmitted. The maximum length for an IPv6 address is 16 octets. The maximum length for an IPv4 address is 4 octets. | 1.3.6.1.2.1.238.1.1.1.1.18 | OCTET STRING (SIZE(4..16)) | read-create | current |
| trillOamMepTxPtmFlowEntropy OBJECT-TYPE 96-byte Flow Entropy, as defined in RFC 7455, to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.19 | OCTET STRING (SIZE(96)) | read-create | current |
| trillOamMepTxPtmStatus OBJECT-TYPE A Boolean flag set to TRUE by the MEP Path Trace Initiator State Machine or a MIB manager to indicate that another PTM is being transmitted. This is reset to FALSE by the MEP Initiator State Machine. The PTM managed objects in the MEP table are used in a manner similar to that described for LBM transmission in the dot1agCfmMepTable. As per RFC 7455, Section 10, operation of the Path Trace Message is identical to the Loopback message except that it is first transmitted with a TRILL Header Hop Count field value of 1 and then retransmitted with an incrementing Hop Count until a response is received from the destination RBridge, or the Hop Count reaches a configured maximum value. The trillOamMepTxPtmStatus status is reset to FALSE by the initiator when the last PTM is transmitted. | 1.3.6.1.2.1.238.1.1.1.1.20 | TruthValue | read-create | current |
| trillOamMepTxPtmResultOK OBJECT-TYPE Indicates the following results of the operation: - true indicates the Path Trace Message(s) will be (or has been) sent. - false indicates the Path Trace Message(s) will not be sent. | 1.3.6.1.2.1.238.1.1.1.1.21 | TruthValue | read-create | current |
| trillOamMepTxPtmSeqNumber OBJECT-TYPE The Path Trace Transaction Identifier of the first PTM (to be) sent. The value returned is undefined if trillOamMepTxPtmResultOK is false. | 1.3.6.1.2.1.238.1.1.1.1.22 | Unsigned32 | read-create | current |
| trillOamMepTxPtmMessages OBJECT-TYPE The number of Path Trace messages to be transmitted. As per RFC 7455, Section 10, the first Path Trace Message is transmitted with a Hop Count of 1; an RBridge may continue to retransmit the request at periodic intervals with an incrementing Hop Count until a response is received from the destination RBridge or the Hop Count reaches a configured maximum value. The event of the Destination response being received or the Hop Count reaching its maximum is treated as a single Counter increment of this object. | 1.3.6.1.2.1.238.1.1.1.1.23 | Integer32 (1..1024) | read-create | current |
| trillOamMepTxMtvmTree OBJECT-TYPE The Multi-destination Tree identifier, as defined in RFC 6325, for an MTVM. | 1.3.6.1.2.1.238.1.1.1.1.24 | Unsigned32 | read-create | current |
| trillOamMepTxMtvmHC OBJECT-TYPE The Hop Count field to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.25 | Unsigned32 (1..63) | read-create | current |
| trillOamMepTxMtvmReplyModeOob OBJECT-TYPE True indicates that the reply to an MTVM is out of band and this out-of-band IP Address TLV is where the reply is to be transmitted. False indicates that an in-band reply is transmitted. | 1.3.6.1.2.1.238.1.1.1.1.26 | TruthValue | read-create | current |
| trillOamMepTransmitMtvmReplyIp OBJECT-TYPE IP address for an out-of-band IP Address TLV that is to be transmitted. The maximum length for IPv6 is 16 octets and IPv4 is 4 octets. | 1.3.6.1.2.1.238.1.1.1.1.27 | OCTET STRING (SIZE(4..16)) | read-create | current |
| trillOamMepTxMtvmFlowEntropy OBJECT-TYPE 96-byte Flow Entropy, as defined in RFC 7455, to be transmitted. | 1.3.6.1.2.1.238.1.1.1.1.28 | OCTET STRING (SIZE(96)) | read-create | current |
| trillOamMepTxMtvmStatus OBJECT-TYPE A Boolean flag set to TRUE by the MEP Multi-destination Initiator State Machine or a MIB manager to indicate that another MTVM is being transmitted. Reset to FALSE by the MEP Initiator State Machine. The MTVM-managed objects in the MEP table are used in a manner similar to that described for LBM transmission in the dot1agCfmMepTable. As per RFC 7455, Section 11, operation of the MTVM is identical to the Loopback message except that it is first transmitted with a TRILL Header Hop Count field value of 1 and it is retransmitted incrementing the Hop Count until a response is received from the destination RBridge or the Hop Count reaches a configured maximum value. The trillOamMepTxMtvmStatus Status is reset to FALSE by the initiator when the last MTVM is transmitted. | 1.3.6.1.2.1.238.1.1.1.1.29 | TruthValue | read-create | current |
| trillOamMepTxMtvmResultOK OBJECT-TYPE Indicates the result of the operation in the following way: - true indicates the Multi-destination Message(s) will be (or has been) sent. - false indicates the Multi-destination Message(s) will not be sent. | 1.3.6.1.2.1.238.1.1.1.1.30 | TruthValue | read-create | current |
| trillOamMepTxMtvmMessages OBJECT-TYPE The number of Multi-destination messages to be transmitted. The RBridge transmit the Multi-destination message incrementing the session Identification Number at periodic interval until this count expires. | 1.3.6.1.2.1.238.1.1.1.1.31 | Integer32 (1..1024) | read-create | current |
| trillOamMepTxMtvmSeqNumber OBJECT-TYPE The Multi-destination Transaction Identifier of the first MTVM (to be) sent. The value returned is undefined if trillOamMepTxMtvmResultOK is false. | 1.3.6.1.2.1.238.1.1.1.1.32 | Unsigned32 | read-create | current |
| trillOamMepTxMtvmScopeList OBJECT-TYPE The Multi-destination RBridge Scope list, which requires 2 octets per RBridge. | 1.3.6.1.2.1.238.1.1.1.1.33 | OCTET STRING | read-create | current |
| trillOamMepDiscontinuityTime OBJECT-TYPE Snapshot of the value of the sysUpTime object at the beginning of the latest period of continuity of the statistical counters associated with this MEP. | 1.3.6.1.2.1.238.1.1.1.1.34 | TimeStamp | read-only | current |
| trillOamMepFlowCfgTable OBJECT-TYPE This table includes configuration objects and operations for the TRILL OAM facilities in RFC 7455. Each row in the table represents a Flow Configuration Entry for the defined MEP. This table uses four indices. The first three indices are the indices of the Maintenance Domain, MANET, and MEP tables. The fourth index is the specific Flow Configuration Entry on the selected MEP. Some writable objects in this table are only applicable in certain cases (as described under each object), and attempts to write values for them in other cases will be ignored. | 1.3.6.1.2.1.238.1.1.2 | not-accessible | current | |
| trillOamMepFlowCfgEntry OBJECT-TYPE The conceptual row of trillOamMepFlowCfgTable. | 1.3.6.1.2.1.238.1.1.2.1 | not-accessible | current | |
| trillOamMepFlowCfgIndex OBJECT-TYPE An index to the TRILL OAM MEP Flow Configuration table, which indicates the specific flow for the MEP. The index is never reused for other flow sessions on the same MEP while this session is active. The index value keeps increasing until it wraps to 0. This value can also be used in the flow-identifier TLV RFC 7455. | 1.3.6.1.2.1.238.1.1.2.1.1 | Unsigned32 (1..65535) | not-accessible | current |
| trillOamMepFlowCfgFlowEntropy OBJECT-TYPE This is 96 bytes of Flow Entropy as described in TRILL OAM, RFC 7455. | 1.3.6.1.2.1.238.1.1.2.1.2 | OCTET STRING (SIZE(96)) | read-create | current |
| trillOamMepFlowCfgDestRName OBJECT-TYPE The Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted. | 1.3.6.1.2.1.238.1.1.2.1.3 | Unsigned32 (0..65471) | read-create | current |
| trillOamMepFlowCfgFlowHC OBJECT-TYPE The Hop Count field to be transmitted. | 1.3.6.1.2.1.238.1.1.2.1.4 | Unsigned32 (1..63) | read-create | current |
| trillOamMepFlowCfgRowStatus OBJECT-TYPE The status of the row. The writable columns in a row cannot be changed if the row is active. All columns MUST have a valid value before a row can be activated. | 1.3.6.1.2.1.238.1.1.2.1.5 | RowStatus | read-create | current |
| trillOamPtrTable OBJECT-TYPE This table includes Path Trace Reply objects and operations for the TRILL OAM facilities as described in RFC 7455. Each row in the table represents a Path Trace Reply Entry for the defined MEP and Transaction. This table uses four indices. The first three indices are the indices of the Maintenance Domain, MANET, and MEP tables. The fourth index is the specific Transaction Identifier on the selected MEP. Some writable objects in this table are only applicable in certain cases (as described under each object), and attempts to write values for them in other cases will be ignored. | 1.3.6.1.2.1.238.1.1.3 | not-accessible | current | |
| trillOamPtrEntry OBJECT-TYPE The conceptual row of trillOamPtrTable. | 1.3.6.1.2.1.238.1.1.3.1 | not-accessible | current | |
| trillOamMepPtrTransactionId OBJECT-TYPE Sequence Number / Transaction Identifier returned by a previous transmit path trace message command, indicating which PTM's response is going to be returned. | 1.3.6.1.2.1.238.1.1.3.1.1 | Unsigned32 (0..4294967295) | not-accessible | current |
| trillOamMepPtrHC OBJECT-TYPE Hop Count field value for a returned PTR. | 1.3.6.1.2.1.238.1.1.3.1.2 | Unsigned32 (1..63) | read-only | current |
| trillOamMepPtrFlag OBJECT-TYPE FCOI (TRILL OAM Message TLV) field value for a returned PTR. | 1.3.6.1.2.1.238.1.1.3.1.3 | Unsigned32 (0..15) | read-only | current |
| trillOamMepPtrErrorCode OBJECT-TYPE Return Code and Return Sub-code value for a returned PTR. | 1.3.6.1.2.1.238.1.1.3.1.4 | Unsigned32 (0..65535) | read-only | current |
| trillOamMepPtrTerminalMep OBJECT-TYPE A boolean value stating whether the forwarded PTM reached a MEP enclosing its MA, as returned in the Terminal MEP flag of the Flags field. | 1.3.6.1.2.1.238.1.1.3.1.5 | TruthValue | read-only | current |
| trillOamMepPtrLastEgressId OBJECT-TYPE An Integer field holding the Last Egress Identifier returned in the PTR Upstream RBridge Nickname TLV of the PTR. The Last Egress Identifier identifies the Upstream Nickname. | 1.3.6.1.2.1.238.1.1.3.1.6 | Unsigned32 (0..65535) | read-only | current |
| trillOamMepPtrIngress OBJECT-TYPE The value returned in the Ingress Action field of the PTR. The value ingNoTlv(0) indicates that no Reply Ingress TLV was returned in the PTM. | 1.3.6.1.2.1.238.1.1.3.1.7 | Dot1agCfmIngressActionFieldValue | read-only | current |
| trillOamMepPtrIngressMac OBJECT-TYPE MAC address returned in the ingress MAC address field. | 1.3.6.1.2.1.238.1.1.3.1.8 | MacAddress | read-only | current |
| trillOamMepPtrIngressPortIdSubtype OBJECT-TYPE Ingress Port ID. The format of this object is determined by the value of the trillOamMepPtrIngressPortIdSubtype object. | 1.3.6.1.2.1.238.1.1.3.1.9 | LldpPortIdSubtype | read-only | current |
| trillOamMepPtrIngressPortId OBJECT-TYPE Ingress Port ID. The format of this object is determined by the value of the trillOamMepPtrIngressPortId object. | 1.3.6.1.2.1.238.1.1.3.1.10 | LldpPortId | read-only | current |
| trillOamMepPtrEgress OBJECT-TYPE The value returned in the Egress Action field of the PTR. The value ingNoTlv(0) indicates that no Reply Egress TLV was returned in the PTM. | 1.3.6.1.2.1.238.1.1.3.1.11 | Dot1agCfmEgressActionFieldValue | read-only | current |
| trillOamMepPtrEgressMac OBJECT-TYPE MAC address returned in the egress MAC address field. | 1.3.6.1.2.1.238.1.1.3.1.12 | MacAddress | read-only | current |
| trillOamMepPtrEgressPortIdSubtype OBJECT-TYPE Egress Port ID. The format of this object is determined by the value of the trillOamMepPtrEgressPortIdSubtype object. | 1.3.6.1.2.1.238.1.1.3.1.13 | LldpPortIdSubtype | read-only | current |
| trillOamMepPtrEgressPortId OBJECT-TYPE Egress Port ID. The format of this object is determined by the value of the trillOamMepPtrEgressPortId object. | 1.3.6.1.2.1.238.1.1.3.1.14 | LldpPortId | read-only | current |
| trillOamMepPtrChassisIdSubtype OBJECT-TYPE This object specifies the format of the Chassis ID returned in the Sender ID TLV of the PTR, if any. This value is meaningless if the trillOamMepPtrChassisId has a length of 0. | 1.3.6.1.2.1.238.1.1.3.1.15 | LldpChassisIdSubtype | read-only | current |
| trillOamMepPtrChassisId OBJECT-TYPE The Chassis ID returned in the Sender ID TLV of the PTR, if any. The format of this object is determined by the value of the trillOamMepPtrChassisIdSubtype object. | 1.3.6.1.2.1.238.1.1.3.1.16 | LldpChassisId | read-only | current |
| trillOamMepPtrOrganizationSpecificTlv OBJECT-TYPE All organization-specific TLVs returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together. | 1.3.6.1.2.1.238.1.1.3.1.17 | OCTET STRING (SIZE(0 | 4..1500)) | read-only | current |
| trillOamMepPtrNextHopNicknames OBJECT-TYPE Next hop RBridge List TLV returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together. | 1.3.6.1.2.1.238.1.1.3.1.18 | OCTET STRING (SIZE(0 | 4..1500)) | read-only | current |
| trillOamMtvrTable OBJECT-TYPE This table includes Multi-destination Reply objects and operations for the TRILL OAM facilities described in RFC 7455. Each row in the table represents a Multi-destination Reply Entry for the defined MEP and Transaction. This table uses five indices. The first three indices are the indices of the Maintenance Domain, MANET, and MEP tables. The fourth index is the specific Transaction Identifier on the selected MEP. The fifth index is the receive order of Multi-destination replies. Some writable objects in this table are only applicable in certain cases (as described under each object), and attempts to write values for them in other cases will be ignored. | 1.3.6.1.2.1.238.1.1.4 | not-accessible | current | |
| trillOamMtvrEntry OBJECT-TYPE The conceptual row of trillOamMtvrTable. | 1.3.6.1.2.1.238.1.1.4.1 | not-accessible | current | |
| trillOamMepMtvrTransactionId OBJECT-TYPE Sequence Number / Transaction Identifier returned by a previously transmitted Multi-destination message command indicating which MTVM's response is going to be returned. | 1.3.6.1.2.1.238.1.1.4.1.1 | Unsigned32 (0..4294967295) | not-accessible | current |
| trillOamMepMtvrReceiveOrder OBJECT-TYPE An index to distinguish among multiple MTVRs with same MTVR Transaction Identifier field value. trillOamMepMtvrReceiveOrder is assigned sequentially from 1, in the order that the Multi-destination Tree Initiator received the MTVRs. | 1.3.6.1.2.1.238.1.1.4.1.2 | Unsigned32 (1..4294967295) | not-accessible | current |
| trillOamMepMtvrFlag OBJECT-TYPE FCOI (TRILL OAM Message TLV) field value for a returned MTVR. | 1.3.6.1.2.1.238.1.1.4.1.3 | Unsigned32 (0..15) | read-only | current |
| trillOamMepMtvrErrorCode OBJECT-TYPE Return Code and Return Sub-code value for a returned MTVR. | 1.3.6.1.2.1.238.1.1.4.1.4 | Unsigned32 (0..65535) | read-only | current |
| trillOamMepMtvrLastEgressId OBJECT-TYPE An Integer field holding the Last Egress Identifier returned in the MTVR Upstream RBridge Nickname TLV of the MTVR. The Last Egress Identifier identifies the Upstream Nickname. | 1.3.6.1.2.1.238.1.1.4.1.5 | Unsigned32 (0..65535) | read-only | current |
| trillOamMepMtvrIngress OBJECT-TYPE The value returned in the Ingress Action field of the MTVR. The value ingNoTlv(0) indicates that no Reply Ingress TLV was returned in the MTVM. | 1.3.6.1.2.1.238.1.1.4.1.6 | Dot1agCfmIngressActionFieldValue | read-only | current |
| trillOamMepMtvrIngressMac OBJECT-TYPE MAC address returned in the ingress MAC address field. | 1.3.6.1.2.1.238.1.1.4.1.7 | MacAddress | read-only | current |
| trillOamMepMtvrIngressPortIdSubtype OBJECT-TYPE Ingress Port ID. The format of this object is determined by the value of the trillOamMepMtvrIngressPortIdSubtype object. | 1.3.6.1.2.1.238.1.1.4.1.8 | LldpPortIdSubtype | read-only | current |
| trillOamMepMtvrIngressPortId OBJECT-TYPE Ingress Port ID. The format of this object is determined by the value of the trillOamMepMtvrIngressPortId object. | 1.3.6.1.2.1.238.1.1.4.1.9 | LldpPortId | read-only | current |
| trillOamMepMtvrEgress OBJECT-TYPE The value returned in the Egress Action field of the MTVR. The value ingNoTlv(0) indicates that no Reply Egress TLV was returned in the MTVR. | 1.3.6.1.2.1.238.1.1.4.1.10 | Dot1agCfmEgressActionFieldValue | read-only | current |
| trillOamMepMtvrEgressMac OBJECT-TYPE MAC address returned in the egress MAC address field. | 1.3.6.1.2.1.238.1.1.4.1.11 | MacAddress | read-only | current |
| trillOamMepMtvrEgressPortIdSubtype OBJECT-TYPE Egress Port ID. The format of this object is determined by the value of the trillOamMepMtvrEgressPortIdSubtype object. | 1.3.6.1.2.1.238.1.1.4.1.12 | LldpPortIdSubtype | read-only | current |
| trillOamMepMtvrEgressPortId OBJECT-TYPE Egress Port ID. The format of this object is determined by the value of the trillOamMepMtvrEgressPortId object. | 1.3.6.1.2.1.238.1.1.4.1.13 | LldpPortId | read-only | current |
| trillOamMepMtvrChassisIdSubtype OBJECT-TYPE This object specifies the format of the Chassis ID returned in the Sender ID TLV of the MTVR, if any. This value is meaningless if the trillOamMepMtvrChassisId has a length of 0. | 1.3.6.1.2.1.238.1.1.4.1.14 | LldpChassisIdSubtype | read-only | current |
| trillOamMepMtvrChassisId OBJECT-TYPE The Chassis ID returned in the Sender ID TLV of the MTVR, if any. The format of this object is determined by the value of the trillOamMepMtvrChassisIdSubtype object. | 1.3.6.1.2.1.238.1.1.4.1.15 | LldpChassisId | read-only | current |
| trillOamMepMtvrOrganizationSpecificTlv OBJECT-TYPE All organization-specific TLVs returned in the MTVR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together. | 1.3.6.1.2.1.238.1.1.4.1.16 | OCTET STRING (SIZE(0 | 4..1500)) | read-only | current |
| trillOamMepMtvrNextHopNicknames OBJECT-TYPE Next hop RBridge List TLV returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together. | 1.3.6.1.2.1.238.1.1.4.1.17 | OCTET STRING (SIZE(0 | 4..1500)) | read-only | current |
| trillOamMepMtvrReceiverAvailability OBJECT-TYPE A value of true indicates that the MTVR response contained Multicast receiver availability TLV. | 1.3.6.1.2.1.238.1.1.4.1.18 | TruthValue | read-only | current |
| trillOamMepMtvrReceiverCount OBJECT-TYPE Indicates the number of multicast receivers available on the responding RBridge on the VLAN specified by the diagnostic VLAN. | 1.3.6.1.2.1.238.1.1.4.1.19 | TruthValue | read-only | current |
| trillOamMepDbTable OBJECT-TYPE This table is an extension of the dot1agCfmMepDbTable and rows are automatically added to or deleted from this table based upon row creation and destruction of the dot1agCfmMepDbTable. | 1.3.6.1.2.1.238.1.1.5 | not-accessible | current | |
| trillOamMepDbEntry OBJECT-TYPE The conceptual row of trillOamMepDbTable. | 1.3.6.1.2.1.238.1.1.5.1 | not-accessible | current | |
| trillOamMepDbFlowIndex OBJECT-TYPE This object identifies the flow. If the Flow Identifier TLV is received, then the index received can also be used. | 1.3.6.1.2.1.238.1.1.5.1.1 | Unsigned32 (1..65535) | read-only | current |
| trillOamMepDbFlowEntropy OBJECT-TYPE 96 byte Flow Entropy. | 1.3.6.1.2.1.238.1.1.5.1.2 | OCTET STRING (SIZE(96)) | read-only | current |
| trillOamMepDbFlowState OBJECT-TYPE The operational state of the remote MEP (flow-based) IFF State machines. State Machine is running now per flow. | 1.3.6.1.2.1.238.1.1.5.1.3 | Dot1agCfmRemoteMepState | read-only | current |
| trillOamMepDbFlowFailedOkTime OBJECT-TYPE The Time (sysUpTime) at which the Remote MEP flow state machine last entered either the RMEP_FAILED or RMEP_OK state. | 1.3.6.1.2.1.238.1.1.5.1.4 | TimeStamp | read-only | current |
| trillOamMepDbRBridgeName OBJECT-TYPE Remote MEP RBridge Nickname. | 1.3.6.1.2.1.238.1.1.5.1.5 | Unsigned32 (0..65471) | read-only | current |
| trillOamMepDbLastGoodSeqNum OBJECT-TYPE Last Sequence Number received. | 1.3.6.1.2.1.238.1.1.5.1.6 | Counter32 | read-only | current |
| trillOamMibConformance OBJECT-IDENTITY | 1.3.6.1.2.1.238.2 | |||
| trillOamMibCompliances OBJECT-IDENTITY | 1.3.6.1.2.1.238.2.1 | |||
| trillOamMibGroups OBJECT-IDENTITY | 1.3.6.1.2.1.238.2.2 |
Notifications
| Name | OID | Status |
|---|---|---|
| trillOamFaultAlarm NOTIFICATION-TYPE A MEP flow has a persistent defect condition. A notification (fault alarm) is sent to the management entity with the OID of the flow that has detected the fault. The management entity receiving the notification can identify the system from the network source address of the notification and can identify the flow reporting the defect by the indices in the OID of the trillOamMepFlowIndex and trillOamFlowDefect variable in the notification: dot1agCfmMdIndex - Also the index of the MEP's Maintenance Domain table entry (dot1agCfmMdTable). dot1agCfmMaIndex - Also an index (with the MD table index) of the MEP's Maintenance Association network table entry (dot1agCfmMaNetTable) and (with the MD table index and component ID) of the MEP's MA component table entry (dot1agCfmMaCompTable). dot1agCfmMepIdentifier - MEP Identifier and final index into the MEP table (dot1agCfmMepTable). trillOamMepFlowCfgIndex - Index identifies indicates the specific flow for the MEP | 1.3.6.1.2.1.238.0.1 | current |
Conformance
| Name | OID | Status |
|---|---|---|
| trillOamMibCompliance MODULE-COMPLIANCE The compliance statement for the TRILL OAM MIB. | 1.3.6.1.2.1.238.2.1.1 | current |
| trillOamMibReadOnlyCompliance MODULE-COMPLIANCE Compliance requirement for implementations that only provide read-only support for TRILL-OAM-MIB. Such devices can be monitored but cannot be configured using this MIB module. | 1.3.6.1.2.1.238.2.1.2 | current |
| trillOamMepMandatoryGroup OBJECT-GROUP Mandatory objects for the TRILL OAM MEP group. | 1.3.6.1.2.1.238.2.2.1 | current |
| trillOamMepFlowCfgTableGroup OBJECT-GROUP TRILL OAM MEP Flow Configuration objects group. | 1.3.6.1.2.1.238.2.2.2 | current |
| trillOamPtrTableGroup OBJECT-GROUP TRILL OAM MEP PTR objects group. | 1.3.6.1.2.1.238.2.2.3 | current |
| trillOamMtvrTableGroup OBJECT-GROUP TRILL OAM MEP MTVR objects group. | 1.3.6.1.2.1.238.2.2.4 | current |
| trillOamMepDbGroup OBJECT-GROUP TRILL OAM MEP DB objects group. | 1.3.6.1.2.1.238.2.2.5 | current |
| trillOamNotificationGroup NOTIFICATION-GROUP A collection of objects describing notifications(traps). | 1.3.6.1.2.1.238.2.2.6 | current |