MIBs Depot

TED-MIB

Registered at
1.3.6.1.2.1.10.273
Last updated
2012-12-21 00:00
Organization
IETF CCAMP Working Group.
Revisions
2012-12-21 00:00
Namespace
standard
Source file
TED-MIB
Digest
sha256:789c3f8f2befced0aefc2625db22abcc2e90945e07d2ce47c3bc5627dc3a1633

Description

This MIB module contains managed object definitions for TED in support of MPLS/GMPLS TE Database. Copyright (c) 2013 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).

Contact

Tomohiro Otani Tm-otani@kddi.com Masanori Miyazawa ma-miyazawa@kddilabs.jp Thomas D. Nadeau tnadeau@juniper.net Kenji Kumaki ke-kumaki@kddi.com Comments and discussion to ccamp@ietf.org

Imports

FromSymbols
FLOAT-TC-MIBFloat32TC
IANA-GMPLS-TC-MIBIANAGmplsLSPEncodingTypeTC, IANAGmplsSwitchingTypeTC
INET-ADDRESS-MIBInetAddress, InetAddressType
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, transmission
SNMPv2-TCDisplayString, RowPointer, TEXTUAL-CONVENTION

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

FLOAT-TC-MIB
IANA-GMPLS-TC-MIB
INET-ADDRESS-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC
TED-MIB

Textual conventions

NameOIDSyntaxAccessStatus
TedAreaIdTC
TEXTUAL-CONVENTION
The area identifier of the IGP. If OSPF is used to advertise LSA, this represents an ospfArea. If IS-IS is used, this represents an area address.
current
TedLinkIndexTC
TEXTUAL-CONVENTION
The link identifier. If OSPF is used, this represents an ospfLsdbID. If IS-IS is used, this represents an isisLSPID. If a locally configured link is used, this object represents an arbitrary value, which is locally defined in a router.
current
TedRouterIdTC
TEXTUAL-CONVENTION
The router identifier. If OSPF is used to advertise LSA, this represents a Router ID. If IS-IS is used, this represents a System ID.
current

Objects

NameOIDSyntaxAccessStatus
tedNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.10.273.0
tedObjects
OBJECT-IDENTITY
1.3.6.1.2.1.10.273.1
tedTable
OBJECT-TYPE
This table indicates multiple TED information, which has been supported by RFC 3630 and RFC 5305.
1.3.6.1.2.1.10.273.1.1not-accessiblecurrent
tedEntry
OBJECT-TYPE
This entry contains TED information commonly utilized in both MPLS and GMPLS.
1.3.6.1.2.1.10.273.1.1.1not-accessiblecurrent
tedLinkInformationSource
OBJECT-TYPE
This object indicates the source of the information about the TE link.
1.3.6.1.2.1.10.273.1.1.1.1INTEGER {unknown(0), locallyConfigured(1), ospfv2(2), ospfv3(3), isis(4), other(5)}not-accessiblecurrent
tedLocalRouterId
OBJECT-TYPE
This object represents the Router ID of the router originating the LSA. If OSPF is used to advertise LSA, this represents a Router ID. If IS-IS is used, this represents a System ID. Otherwise, this represents zero.
1.3.6.1.2.1.10.273.1.1.1.2TedRouterIdTCnot-accessiblecurrent
tedRemoteRouterId
OBJECT-TYPE
This object indicates the router at the remote end of the link from the originating router. If OSPF is used to advertise LSA, this represents a Link ID in the Link TLV. If IS-IS is used, this represents a neighbor System ID defined in RFC 5305. Otherwise, this represents zero.
1.3.6.1.2.1.10.273.1.1.1.3TedRouterIdTCnot-accessiblecurrent
tedLinkIndex
OBJECT-TYPE
This object indicates the link state identifier. If OSPF is used, this represents an ospfLsdbID. If IS-IS is used, this represents an isisLSPID. Otherwise, this represents a unique identifier within a node.
1.3.6.1.2.1.10.273.1.1.1.4TedLinkIndexTCnot-accessiblecurrent
tedLinkInformationData
OBJECT-TYPE
If tedLinkInformationSource has the value unknown(0), this object MUST contain a value of zeroDotZero. If tedLinkInformationSource has the value locallyConfigured(1), an implementation can use this object to supply the identifier of the corresponding row entry in the teLinkTable of TE-LINK- STD-MIB (RFC 4220), the identifier of the corresponding row in a local proprietary TE link MIB module, or the value of zeroDotZero. If tedLinkInformationSource has the value ospfv2(2) and ospfv3(3), an implementation can use this object to supply the identifier of the corresponding row entry in the ospfLocalLsdbTable (OSPFv2-MIB) and the ospfv3AreaLsdbTable (OSPFv3-MIB), or the value of zeroDotZero. If tedLinkInformationSource has the value isis(4), an implementation can use this object to supply the identifier of the corresponding row entry in the isisAreaAddr of ISIS-MIB (RFC 4444), or the value of zeroDotZero. If tedLinkInformationSource has the value other(5), an implementation can use this object to supply the identifier of the corresponding row entry in the local proprietary MIB module, or the value of zeroDotZero.
1.3.6.1.2.1.10.273.1.1.1.5RowPointerread-onlycurrent
tedLinkState
OBJECT-TYPE
This object represents the actual operational state of this TE link. For instance, if a row is created in the TED table, but the actual TE link is not available for some reason (e.g., when there is not yet a physical link or the link has been manually disabled), then the object would be down(2) state. In contrast, if a row is added and the TE link is available, this would be operationally up(1).
1.3.6.1.2.1.10.273.1.1.1.6INTEGER {unknown(0), up(1), down(2)}read-onlycurrent
tedAreaId
OBJECT-TYPE
This object indicates the area identifier of the IGP. If OSPF is used to advertise LSA, this represents an ospfArea. If IS-IS is used, this represents an area address. Otherwise, this represents zero.
1.3.6.1.2.1.10.273.1.1.1.7TedAreaIdTCread-onlycurrent
tedLinkType
OBJECT-TYPE
This indicates the type of the link, such as point to point or multi-access.
1.3.6.1.2.1.10.273.1.1.1.8INTEGER {pointToPoint(1), multiAccess(2)}read-onlycurrent
tedTeRouterIdAddrType
OBJECT-TYPE
This object indicates the TE-Router ID address type. Only values unknown(0), ipv4(1), or ipv6(2) are supported.
1.3.6.1.2.1.10.273.1.1.1.9InetAddressTyperead-onlycurrent
tedTeRouterIdAddr
OBJECT-TYPE
This object indicates the TE-Router ID.
1.3.6.1.2.1.10.273.1.1.1.10InetAddressread-onlycurrent
tedLinkIdAddrType
OBJECT-TYPE
This object indicates the address type of the TE Link ID. Only values unknown(0), ipv4(1), or ipv6(2) are supported.
1.3.6.1.2.1.10.273.1.1.1.11InetAddressTyperead-onlycurrent
tedLinkIdAddr
OBJECT-TYPE
This indicates the Router ID of the neighbor in the case of point-to-point links. This also indicates the interface address of the designated router in the case of multi-access links.
1.3.6.1.2.1.10.273.1.1.1.12InetAddressread-onlycurrent
tedMetric
OBJECT-TYPE
This indicates the traffic engineering metric value of the TE link.
1.3.6.1.2.1.10.273.1.1.1.13Integer32read-onlycurrent
tedMaxBandwidth
OBJECT-TYPE
This indicates the maximum bandwidth that can be used on this link in this direction.
1.3.6.1.2.1.10.273.1.1.1.14Float32TCread-onlycurrent
tedMaxReservableBandwidth
OBJECT-TYPE
This indicates the maximum bandwidth that may be reserved on this link in this direction.
1.3.6.1.2.1.10.273.1.1.1.15Float32TCread-onlycurrent
tedUnreservedBandwidthPri0
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 0.
1.3.6.1.2.1.10.273.1.1.1.16Float32TCread-onlycurrent
tedUnreservedBandwidthPri1
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 1.
1.3.6.1.2.1.10.273.1.1.1.17Float32TCread-onlycurrent
tedUnreservedBandwidthPri2
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 2.
1.3.6.1.2.1.10.273.1.1.1.18Float32TCread-onlycurrent
tedUnreservedBandwidthPri3
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 3.
1.3.6.1.2.1.10.273.1.1.1.19Float32TCread-onlycurrent
tedUnreservedBandwidthPri4
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 4.
1.3.6.1.2.1.10.273.1.1.1.20Float32TCread-onlycurrent
tedUnreservedBandwidthPri5
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 5.
1.3.6.1.2.1.10.273.1.1.1.21Float32TCread-onlycurrent
tedUnreservedBandwidthPri6
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 6.
1.3.6.1.2.1.10.273.1.1.1.22Float32TCread-onlycurrent
tedUnreservedBandwidthPri7
OBJECT-TYPE
This indicates the amount of bandwidth not yet reserved at the priority 7.
1.3.6.1.2.1.10.273.1.1.1.23Float32TCread-onlycurrent
tedAdministrativeGroup
OBJECT-TYPE
This indicates the Administrative Group to which the link belongs. Since the value is a bit mask, the link can belong to multiple groups. This is also called Resource Class/Color.
1.3.6.1.2.1.10.273.1.1.1.24Integer32read-onlycurrent
tedLocalId
OBJECT-TYPE
This indicates the Link Local Identifier of an unnumbered link.
1.3.6.1.2.1.10.273.1.1.1.25Integer32read-onlycurrent
tedRemoteId
OBJECT-TYPE
This indicates the Link Remote Identifier of an unnumbered link.
1.3.6.1.2.1.10.273.1.1.1.26Integer32read-onlycurrent
tedLinkProtectionType
OBJECT-TYPE
This object indicates the protection type of the TE link.
1.3.6.1.2.1.10.273.1.1.1.27Bits {extraTraffic(0), unprotected(1), shared(2), dedicatedOneToOne(3), dedicatedOnePlusOne(4), enhanced(5)}read-onlycurrent
tedLocalIfAddrTable
OBJECT-TYPE
This table contains the IP address information of a local TE link.
1.3.6.1.2.1.10.273.1.2not-accessiblecurrent
tedLocalIfAddrEntry
OBJECT-TYPE
This entry contains the IP address information of the local TE link.
1.3.6.1.2.1.10.273.1.2.1not-accessiblecurrent
tedLocalIfAddrType
OBJECT-TYPE
This object indicates the address type of the local TE link. Only values unknown(0), ipv4(1), or ipv6(2) have to be supported.
1.3.6.1.2.1.10.273.1.2.1.1InetAddressTyperead-onlycurrent
tedLocalIfAddr
OBJECT-TYPE
This object indicates the address of the local TE link.
1.3.6.1.2.1.10.273.1.2.1.2InetAddress (SIZE(1..20))not-accessiblecurrent
tedRemoteIfAddrTable
OBJECT-TYPE
This table contains the IP address information of a remote TE link.
1.3.6.1.2.1.10.273.1.3not-accessiblecurrent
tedRemoteIfAddrEntry
OBJECT-TYPE
This entry contains the IP address information of the remote TE link.
1.3.6.1.2.1.10.273.1.3.1not-accessiblecurrent
tedRemoteIfAddrType
OBJECT-TYPE
This object indicates the address type of the remote TE link.
1.3.6.1.2.1.10.273.1.3.1.1InetAddressTyperead-onlycurrent
tedRemoteIfAddr
OBJECT-TYPE
This object indicates the address of the remote TE link.
1.3.6.1.2.1.10.273.1.3.1.2InetAddress (SIZE(1..20))not-accessiblecurrent
tedSwCapTable
OBJECT-TYPE
This table contains the GMPLS TED switching capability information.
1.3.6.1.2.1.10.273.1.4not-accessiblecurrent
tedSwCapEntry
OBJECT-TYPE
This entry relates each TE link with its GMPLS TE switching capability information. If the MIB module deals with only OSPF- TE information, the value of each object related with GMPLS TE extensions should be null.
1.3.6.1.2.1.10.273.1.4.1not-accessiblecurrent
tedSwCapIndex
OBJECT-TYPE
This index is utilized to identify multiple switching functions on a local or remote TE link according to definitions of textual conventions of GMPLS, RFC 4801.
1.3.6.1.2.1.10.273.1.4.1.1Unsigned32 (1..255)not-accessiblecurrent
tedSwCapType
OBJECT-TYPE
This object indicates the GMPLS switching capability assigned to the TE link according to definitions of textual conventions of GMPLS, RFC 4801.
1.3.6.1.2.1.10.273.1.4.1.2IANAGmplsSwitchingTypeTCread-onlycurrent
tedSwCapEncoding
OBJECT-TYPE
This object indicates the GMPLS encoding type assigned to the TE link.
1.3.6.1.2.1.10.273.1.4.1.3IANAGmplsLSPEncodingTypeTCread-onlycurrent
tedSwCapMaxLspBandwidthPri0
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 0 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.4Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri1
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 1 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.5Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri2
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 2 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.6Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri3
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 3 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.7Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri4
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 4 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.8Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri5
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 5 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.9Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri6
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 6 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.10Float32TCread-onlycurrent
tedSwCapMaxLspBandwidthPri7
OBJECT-TYPE
This object indicates the maximum bandwidth of the TE link at the priority 7 for GMPLS LSP creation.
1.3.6.1.2.1.10.273.1.4.1.11Float32TCread-onlycurrent
tedSwCapMinLspBandwidth
OBJECT-TYPE
This object indicates the minimum bandwidth of the TE link for GMPLS LSP creation if the switching capability field is TDM, PSC-1, PSC-2, PSC-3, or PSC-4.
1.3.6.1.2.1.10.273.1.4.1.12Float32TCread-onlycurrent
tedSwCapIfMtu
OBJECT-TYPE
This object indicates the MTU of the local or remote TE link.
1.3.6.1.2.1.10.273.1.4.1.13Integer32read-onlycurrent
tedSwCapIndication
OBJECT-TYPE
This object indicates whether the interface supports Standard or Arbitrary SONET/SDH.
1.3.6.1.2.1.10.273.1.4.1.14INTEGER {standard(0), arbitrary(1)}read-onlycurrent
tedSrlgTable
OBJECT-TYPE
This table contains the SRLG information of the TE link.
1.3.6.1.2.1.10.273.1.5not-accessiblecurrent
tedSrlgEntry
OBJECT-TYPE
This entry relates each TE link with its SRLG information.
1.3.6.1.2.1.10.273.1.5.1not-accessiblecurrent
tedSrlgIndex
OBJECT-TYPE
This index is utilized to identify multiple SRLG values on a local or remote TE link. This object represents an arbitrary value, which is locally defined in a router.
1.3.6.1.2.1.10.273.1.5.1.1Unsigned32 (1..255)not-accessiblecurrent
tedSrlg
OBJECT-TYPE
This object indicates the SRLG value assigned to a local or remote TE link.
1.3.6.1.2.1.10.273.1.5.1.2Integer32read-onlycurrent
tedStatusChangeNotificationMaxRate
OBJECT-TYPE
A lot of notifications relating to the status change are expected to generate in a node, especially when a network failure occurs and might cause a performance degradation of the node itself. To avoid such a defect, this object provides the maximum number of notifications generated per minute. If events occur more rapidly, the implementation may simply fail to emit these notifications during that period, or may queue them until an appropriate time. A value of 0 means no throttling is applied and events may be notified at the rate at which they occur.
1.3.6.1.2.1.10.273.1.6Unsigned32read-writecurrent
tedCreatedDeletedNotificationMaxRate
OBJECT-TYPE
A lot of notifications relating to new registration in the TED table by receiving new TE link information or deletion of existing entries in the TED table are expected to generate in a node. This object provides the maximum number of notifications generated per minute.
1.3.6.1.2.1.10.273.1.7Unsigned32read-writecurrent
tedConformance
OBJECT-IDENTITY
1.3.6.1.2.1.10.273.2
tedCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.10.273.2.1
tedGroups
OBJECT-IDENTITY
1.3.6.1.2.1.10.273.2.2

Notifications

NameOIDStatus
tedStatusChange
NOTIFICATION-TYPE
This notification signifies that there has been change in the TE information of tedTable, tedLocalIfAddrTable, tedRemoteIfAddrTable, tedSwCapTable, and/or tedSrlgTable. For example, this should be generated when tedUnreservedBandwidth is changed to create or delete LSP using the registered TE link.
1.3.6.1.2.1.10.273.0.1current
tedEntryCreated
NOTIFICATION-TYPE
This notification signifies that there has been new registration in the TED table by receiving new TE link information. For example, this should be generated when a new index (tedLinkIndex) is registered in the TED table.
1.3.6.1.2.1.10.273.0.2current
tedEntryDeleted
NOTIFICATION-TYPE
This notification signifies that there has been deletion of an entry in the TED table. For example, this should be generated when one of the existing entries is deleted in the TED table.
1.3.6.1.2.1.10.273.0.3current

Conformance

NameOIDStatus
tedModuleFullCompliance
MODULE-COMPLIANCE
Compliance statement for agents provides full support for the TED MIB.
1.3.6.1.2.1.10.273.2.1.1current
tedModuleReadOnlyCompliance
MODULE-COMPLIANCE
Compliance requirement for implementations only provides read- only support for TED. Such devices can then be monitored but cannot be configured using this MIB module.
1.3.6.1.2.1.10.273.2.1.2current
tedMainGroup
OBJECT-GROUP
Collection of objects for TED management
1.3.6.1.2.1.10.273.2.2.1current
tedObjectsGroup
OBJECT-GROUP
The objects needed to implement notification.
1.3.6.1.2.1.10.273.2.2.2current
tedNotificationGroup
NOTIFICATION-GROUP
This group is mandatory for those implementations that can implement the notifications contained in this group.
1.3.6.1.2.1.10.273.2.2.3current
tedUnnumberedLinkGroup
OBJECT-GROUP
The objects needed to implement the unnumbered links.
1.3.6.1.2.1.10.273.2.2.4current
tedNumberedLinkGroup
OBJECT-GROUP
The objects needed to implement the numbered links.
1.3.6.1.2.1.10.273.2.2.5current
tedSwCapGroup
OBJECT-GROUP
The objects needed to implement the TE links with GMPLS TE switching capability information.
1.3.6.1.2.1.10.273.2.2.6current
tedSwCapMinLspBandwidthGroup
OBJECT-GROUP
The objects needed to implement the minimum bandwidth of the TE link for GMPLS LSP creation.
1.3.6.1.2.1.10.273.2.2.7current
tedSwCapIfMtuGroup
OBJECT-GROUP
The objects needed to implement the MTU information of the local or remote TE link.
1.3.6.1.2.1.10.273.2.2.8current
tedSwCapIndicationGroup
OBJECT-GROUP
The objects needed to implement the indication of whether the interface supports Standard or Arbitrary SONET/SDH.
1.3.6.1.2.1.10.273.2.2.9current
tedSrlgGroup
OBJECT-GROUP
The objects needed to implement multiple SRLG values with GMPLS TE information.
1.3.6.1.2.1.10.273.2.2.10current