SSPM-MIB
- Registered at
- 1.3.6.1.2.1.16.28
- Last updated
- 2005-07-28 00:00
- Organization
- IETF RMON MIB working group
- Revisions
- 2005-07-28 00:00
- Namespace
- standard
- Source file
SSPM-MIB- Digest
sha256:39c9238f1f767cf54b2a6bfb2964bf53394bcf25dfe1f4445203a1768d2e9f43
Description
This SSPM MIB module is applicable to probes implementing Synthetic Source for Performance Monitoring functions. Copyright (C) The Internet Society (2005). This version of this MIB module is part of RFC 4149; see the RFC itself for full legal notices.
Contact
Carl W. Kalbfleisch Consultant E-mail: ietf@kalbfleisch.us Working group mailing list: rmonmib@ietf.org To subscribe send email to rmonmib-request@ietf.org
Imports
| From | Symbols |
|---|---|
| APM-MIB | AppLocalIndex |
| IF-MIB | InterfaceIndexOrZero |
| INET-ADDRESS-MIB | InetAddress, InetAddressType |
| RMON-MIB | OwnerString, rmon |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Counter32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso |
| SNMPv2-TC | DisplayString, RowStatus, StorageType, TEXTUAL-CONVENTION, TruthValue |
| SYSAPPL-MIB | Utf8String |
Imported by
1 module(s) in this corpus import this one.
Load order
Every file a consumer needs in order to load this module, dependencies first.
APM-MIB IANAifType-MIB IF-MIB INET-ADDRESS-MIB RFC1158-MIB RFC1271-MIB RMON-MIB RMON2-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC SSPM-MIB SYSAPPL-MIB TOKEN-RING-RMON-MIB
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| SspmClockMaxSkew TEXTUAL-CONVENTION An indication of the accuracy of the clock as defined by RFC1305. This variable indicates the maximum offset error due to skew of the local clock over the time interval 86400 seconds, in seconds. | current | |||
| SspmClockSource TEXTUAL-CONVENTION An indication of the source of the clock as defined by the NTP specification RFC1305 [RFC1305] definition of stratum: Stratum (sys.stratum, peer.stratum, pkt.stratum): This is an integer indicating the stratum of the local clock, with values defined as follows: 0 unspecified 1 primary reference (e.g., calibrated atomic clock, radio clock) 2-255 secondary reference (via NTP). | current | |||
| SspmMicroSeconds TEXTUAL-CONVENTION A unit of time with resolution of MicroSeconds. | current |
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| sspmMIBObjects OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.1 | |||
| sspmGeneral OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.1.1 | |||
| sspmGeneralClockResolution OBJECT-TYPE A read-only variable indicating the resolution of the measurements possible by this device. | 1.3.6.1.2.1.16.28.1.1.1 | SspmMicroSeconds | read-only | current |
| sspmGeneralClockMaxSkew OBJECT-TYPE A read-only variable indicating the maximum offset error due to skew of the local clock over the time interval 86400 seconds, in seconds. | 1.3.6.1.2.1.16.28.1.1.2 | SspmClockMaxSkew | read-only | current |
| sspmGeneralClockSource OBJECT-TYPE A read-only variable indicating the source of the clock. This is provided to allow a user to determine how accurate the timing mechanism is compared with other devices. This is needed for the coordination of time values between probes for one-way measurements. | 1.3.6.1.2.1.16.28.1.1.3 | SspmClockSource | read-only | current |
| sspmGeneralMinFrequency OBJECT-TYPE A read-only variable that indicates the devices' capability for the minimum supported sspmSourceFrequency. If sspmSourceFrequency is set to a value lower than the value reported by this attribute, then the set of sspmSourceFrequency will fail with an inconsistent value error. | 1.3.6.1.2.1.16.28.1.1.4 | SspmMicroSeconds | read-only | current |
| sspmCapabilitiesTable OBJECT-TYPE The table of SSPM capabilities. | 1.3.6.1.2.1.16.28.1.1.5 | not-accessible | current | |
| sspmCapabilitiesEntry OBJECT-TYPE Details about a particular SSPM capability. | 1.3.6.1.2.1.16.28.1.1.5.1 | not-accessible | current | |
| sspmCapabilitiesInstance OBJECT-TYPE Indicates whether SSPM configuration of the corresponding AppLocalIndex is supported by this device. Generally, entries in this table are only made by the device when the configuration of the measurement is available. | 1.3.6.1.2.1.16.28.1.1.5.1.1 | AppLocalIndex | read-only | current |
| sspmSource OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.1.2 | |||
| sspmSourceProfileTable OBJECT-TYPE The table of SSPM Source Profiles configured. | 1.3.6.1.2.1.16.28.1.2.1 | not-accessible | current | |
| sspmSourceProfileEntry OBJECT-TYPE Details about a particular SSPM Source Profile configuration. Entries must exist in this table in order to be referenced by rows in the sspmSourceControlTable. | 1.3.6.1.2.1.16.28.1.2.1.1 | not-accessible | current | |
| sspmSourceProfileInstance OBJECT-TYPE An arbitrary index. | 1.3.6.1.2.1.16.28.1.2.1.1.1 | Unsigned32 (1..65535) | not-accessible | current |
| sspmSourceProfileType OBJECT-TYPE The AppLocalIndex value that uniquely identifies the measurement per the APM-MIB. In order to create a row in this table, there must be a corresponding row in the sspmCapabilitiesTable. When attempting to set this object, if no corresponding row exists in the sspmCapabilitiesTable, then the agent should return a 'badValue' error. | 1.3.6.1.2.1.16.28.1.2.1.1.2 | AppLocalIndex | read-create | current |
| sspmSourceProfilePacketSize OBJECT-TYPE The size of packet to be transmitted in bytes. The size accounts for all data within the IPv4 or IPv6 payloads, excluding the IP headers, IP header options and link-level protocol headers. If the size is set smaller than the minimum allowed packet size or greater than the maximum allowed packet size, then the set should fail, and the agent should return a 'badValue' error. | 1.3.6.1.2.1.16.28.1.2.1.1.3 | Unsigned32 | read-create | current |
| sspmSourceProfilePacketFillType OBJECT-TYPE Indicates how the packet is filled. 'random' indicates that the packet contains random data patterns. This is probe and implementation dependent. 'pattern' indicates that the pattern defined in the sspmSourceProfilePacketFillValue attribute is used to fill the packet. 'url' indicates that the value of sspmSourceProfilePacketFillValue should contain a URL. The contents of the document at that URL are retrieved when sspmSourceStatus becomes active and utilized in the packet. If the attempt to access that URL fails, then the row status is set to 'notReady', and the set should fail with 'inconsistentValue'. This value must contain a dereferencable URL of the type 'http:', 'https:', or 'ftp:' only. | 1.3.6.1.2.1.16.28.1.2.1.1.4 | INTEGER {random(1), pattern(2), url(3)} | read-create | current |
| sspmSourceProfilePacketFillValue OBJECT-TYPE The string value with which to fill the packet. If sspmSourceProfilePacketFillType is set to 'pattern', then this pattern is repeated until the packet is sspmSourcePacketSize in bytes. Note that if the length of the octet string specified for this value does not divide evenly into the packet size, then an incomplete last copy of this data may be copied into the packet. If the value of sspmSourceProfilePacketFillType is set to 'random', then this attribute is unused. If the value of the sspmSourceProfilePacketFillType is set to 'url', then the URL specified in this attribute is retrieved and used by the probe. In the case of a URL, this value must contain a dereferencable URL of the type 'http:', 'https:', or 'ftp:' only. | 1.3.6.1.2.1.16.28.1.2.1.1.5 | OCTET STRING (SIZE(0..255)) | read-create | current |
| sspmSourceProfileTOS OBJECT-TYPE Represents the TOS field in the IP packet header. The value of this object defaults to zero if not set. | 1.3.6.1.2.1.16.28.1.2.1.1.6 | Integer32 (0..255) | read-create | current |
| sspmSourceProfileFlowLabel OBJECT-TYPE This object is used to specify the Flow Label in a IPv6 packet (RFC 2460) to force special handling by the IPv6 routers; e.g., non-default quality-of-service handling. This object is meaningful only when the object sspmSourceDestAddressType is IPv6(2). The value of this object defaults to zero if not set. | 1.3.6.1.2.1.16.28.1.2.1.1.7 | Integer32 (0..1048575) | read-create | current |
| sspmSourceProfileLooseSrcRteFill OBJECT-TYPE In the event that the test should run over a specific route, the intent is to force the route using the Loose Source Route option in IPv4 [RFC791] and IPv6 [RFC2460]. This object contains a series of IP addresses along the path that would be put into the loose source route option in the IP header. The IPv4 addresses are to be listed as 32-bit address values, and the IPv6 addresses are to be listed as a string of 128-bit addresses. The maximum length allowed within the IPv4 source route option is 63 addresses. To simply account for IPv6 addresses as well, the maximum length of the octet string is 240. This allows up to 60 IPv4 addresses or up to 15 IPv6 addresses in the string. | 1.3.6.1.2.1.16.28.1.2.1.1.8 | OCTET STRING (SIZE(0..240)) | read-create | current |
| sspmSourceProfileLooseSrcRteLen OBJECT-TYPE In the event that the test should run over a specific route, the intent is to force the route. This attribute specifies the length of data to be copied from the sspmSourceProfileLooseSrcRteFill into the route data fields of the loose source route options in the IPv4 or IPv6 headers. | 1.3.6.1.2.1.16.28.1.2.1.1.9 | Integer32 (0..240) | read-create | current |
| sspmSourceProfileTTL OBJECT-TYPE If non-zero, this specifies the value to place into the TTL field on transmission. | 1.3.6.1.2.1.16.28.1.2.1.1.10 | Integer32 (1..255) | read-create | current |
| sspmSourceProfileNoFrag OBJECT-TYPE When true, the 'Don't Fragment Bit' should be set on the packet header. | 1.3.6.1.2.1.16.28.1.2.1.1.11 | TruthValue | read-create | current |
| sspmSourceProfile8021Tagging OBJECT-TYPE IEEE 802.1Q tagging used in IEEE 802.1D bridged environments. A value of -1 indicates that the packets are untagged. A value of 0 to 65535 is the value of the tag to be inserted in the tagged packets. Note that according to IEEE 802.1Q, VLAN-ID tags with a value of 4095 shall not be transmitted on the wire. As the VLAN-ID is encoded in the 12 least significant bits on the tag, values that translate in a binary representation of all 1's in the last 12 bits SHALL NOT be configured. In this case, the set should fail, and return an error-status of 'inconsistentValue'. | 1.3.6.1.2.1.16.28.1.2.1.1.12 | Integer32 (-1..65535) | read-create | current |
| sspmSourceProfileUsername OBJECT-TYPE An optional username used by the application protocol. | 1.3.6.1.2.1.16.28.1.2.1.1.13 | Utf8String | read-create | current |
| sspmSourceProfilePassword OBJECT-TYPE An optional password used by the application protocol. | 1.3.6.1.2.1.16.28.1.2.1.1.14 | Utf8String | read-create | current |
| sspmSourceProfileParameter OBJECT-TYPE An optional parameter used by the application protocol. For DNS, this would be the hostname or IP. For HTTP, this would be the URL. For nntp, this would be the news group. For TCP, this would be the port number. For SMTP, this would be the recipient (and could assume the message is predefined). | 1.3.6.1.2.1.16.28.1.2.1.1.15 | OCTET STRING (SIZE(0..65535)) | read-create | current |
| sspmSourceProfileOwner OBJECT-TYPE Name of the management station/application that set up the profile. | 1.3.6.1.2.1.16.28.1.2.1.1.16 | OwnerString | read-create | current |
| sspmSourceProfileStorageType OBJECT-TYPE The storage type of this sspmSourceProfileEntry. If the value of this object is 'permanent', no objects in this row need to be writable. | 1.3.6.1.2.1.16.28.1.2.1.1.17 | StorageType | read-create | current |
| sspmSourceProfileStatus OBJECT-TYPE Status of this profile. An entry may not exist in the active state unless all objects in the entry have an appropriate value. Once this object is set to active(1), no objects in the sspmSourceProfileTable can be changed. | 1.3.6.1.2.1.16.28.1.2.1.1.18 | RowStatus | read-create | current |
| sspmSourceControlTable OBJECT-TYPE The table of SSPM measurements configured. | 1.3.6.1.2.1.16.28.1.2.2 | not-accessible | current | |
| sspmSourceControlEntry OBJECT-TYPE Details about a particular SSPM configuration. | 1.3.6.1.2.1.16.28.1.2.2.1 | not-accessible | current | |
| sspmSourceControlInstance OBJECT-TYPE An arbitrary index. | 1.3.6.1.2.1.16.28.1.2.2.1.1 | Unsigned32 (1..65535) | not-accessible | current |
| sspmSourceControlProfile OBJECT-TYPE A pointer to the profile (sspmSourceProfileEntry) that this control entry uses to define the test being performed. | 1.3.6.1.2.1.16.28.1.2.2.1.2 | Integer32 (1..65535) | read-create | current |
| sspmSourceControlSrc OBJECT-TYPE The ifIndex where the packet should originate from the probe (if it matters). A value of zero indicates that it does not matter and that the device decides. | 1.3.6.1.2.1.16.28.1.2.2.1.3 | InterfaceIndexOrZero | read-create | current |
| sspmSourceControlDestAddrType OBJECT-TYPE The type of Internet address by which the destination is accessed. | 1.3.6.1.2.1.16.28.1.2.2.1.4 | InetAddressType | read-create | current |
| sspmSourceControlDestAddr OBJECT-TYPE The Internet address for the destination. The formatting of this object is controlled by the sspmSourceControlDestAddrType object above. When this object contains a DNS name, then the name is resolved to an address each time measurement is to be made. Further, the agent should not cache this address, but instead should perform the resolution prior to each measurement. | 1.3.6.1.2.1.16.28.1.2.2.1.5 | InetAddress | read-create | current |
| sspmSourceControlEnabled OBJECT-TYPE When set to 'true', this test is enabled. When set to 'false', it is disabled. | 1.3.6.1.2.1.16.28.1.2.2.1.6 | TruthValue | read-create | current |
| sspmSourceControlTimeOut OBJECT-TYPE Timeout value for the measurement response. If no response is received in the time specified, then the test fails. | 1.3.6.1.2.1.16.28.1.2.2.1.7 | SspmMicroSeconds | read-create | current |
| sspmSourceControlSamplingDist OBJECT-TYPE When this attribute is set to 'deterministic', then packets are generated at with a fixed inter-packet injection time specified by sspmSourceFrequency. When this attribute is set to 'Poisson', then packets are generated with inter-packet injection times sampled from an exponential distribution with the single distributional parameter determined by the inverse frequency). | 1.3.6.1.2.1.16.28.1.2.2.1.8 | INTEGER {deterministic(1), poisson(2)} | read-create | current |
| sspmSourceControlFrequency OBJECT-TYPE The inverse of this value is the rate at which packets are generated. Refer to sspmSourceSamplingDistribution. If the value set is less than the value of sspmGeneralMinFrequency, then the set will fail with an error-status of 'inconsistentValue'. | 1.3.6.1.2.1.16.28.1.2.2.1.9 | SspmMicroSeconds | read-create | current |
| sspmSourceControlFirstSeqNum OBJECT-TYPE The first sequence number of packets to be transmitted. | 1.3.6.1.2.1.16.28.1.2.2.1.10 | Unsigned32 | read-create | current |
| sspmSourceControlLastSeqNum OBJECT-TYPE The last sequence number transmitted. This value is updated by the agent after packet generation. | 1.3.6.1.2.1.16.28.1.2.2.1.11 | Unsigned32 | read-only | current |
| sspmSourceControlOwner OBJECT-TYPE Name of the management station/application that set up the test. | 1.3.6.1.2.1.16.28.1.2.2.1.12 | OwnerString | read-create | current |
| sspmSourceControlStorageType OBJECT-TYPE The storage type of this sspmSourceControlEntry. If the value of this object is 'permanent', no objects in this row need to be writable. | 1.3.6.1.2.1.16.28.1.2.2.1.13 | StorageType | read-create | current |
| sspmSourceControlStatus OBJECT-TYPE Status of this source control entry. An entry may not exist in the active state unless all objects in the entry have an appropriate value. When this attribute has the value of 'active', none of the read-write or read-create attributes in this table may be modified, with the exception of sspmSourceControlEnabled. | 1.3.6.1.2.1.16.28.1.2.2.1.14 | RowStatus | read-create | current |
| sspmSink OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.1.5 | |||
| sspmSinkTable OBJECT-TYPE A table configuring the sink for measurements. | 1.3.6.1.2.1.16.28.1.5.1 | not-accessible | current | |
| sspmSinkEntry OBJECT-TYPE The details of a particular sink entry. If the measurement is a round-trip type, then the sink entry will be on the same probe as the corresponding sspmSourceEntry. If the measurement is a one-way, type then the sink entry will be on a different probe. | 1.3.6.1.2.1.16.28.1.5.1.1 | not-accessible | current | |
| sspmSinkInstance OBJECT-TYPE An index. When the measurement is for a round-trip measurement, then this table entry is on the same probe as the corresponding sspmSourceEntry, and the value of this attribute should correspond to the value of sspmSourceInstance. Management applications configuring sinks for one-way measurements could define some scheme whereby the sspmSinkInstance is unique across all probes. Note that the unique key to this entry is also constructed with sspmSinkType, sspmSinkSourceAddressType, and sspmSinkSourceAddress. To make the implementation simpler, those other attributes are not included in the index but uniqueness is still needed to receive all the packets. | 1.3.6.1.2.1.16.28.1.5.1.1.1 | Unsigned32 (1..65535) | not-accessible | current |
| sspmSinkType OBJECT-TYPE The AppLocalIndex value that uniquely identifies the measurement per the APM-MIB. In order to create a row in this table, there must be a corresponding row in the sspmCapabilitiesTable. If there is no corresponding row in the sspmCapabilitiestable, then the agent will return an error-status of 'inconsistentValue'. | 1.3.6.1.2.1.16.28.1.5.1.1.2 | AppLocalIndex | read-create | current |
| sspmSinkSourceAddressType OBJECT-TYPE The type of Internet address of the source. | 1.3.6.1.2.1.16.28.1.5.1.1.3 | InetAddressType | read-create | current |
| sspmSinkSourceAddress OBJECT-TYPE The Internet address of the source. The formatting of this object is controlled by the sspmSinkSourceAddressType object above. This object should be set only to a valid device address that has been administratively configured into the device. If a set attempts to set this object to an address that does not belong (i.e., is not administratively configured into the device), the set should fail, and the agent should return a error-status of 'inconsistentValue'. | 1.3.6.1.2.1.16.28.1.5.1.1.4 | InetAddress | read-create | current |
| sspmSinkExpectedRate OBJECT-TYPE The expected rate at which packets will arrive. | 1.3.6.1.2.1.16.28.1.5.1.1.5 | SspmMicroSeconds | read-create | current |
| sspmSinkEnable OBJECT-TYPE Indicates if the sink is enabled or not. | 1.3.6.1.2.1.16.28.1.5.1.1.6 | TruthValue | read-create | current |
| sspmSinkExpectedFirstSequenceNum OBJECT-TYPE The expected first sequence number of packets. This is used by the sink to determine if packets were lost at the initiation of the test. | 1.3.6.1.2.1.16.28.1.5.1.1.7 | Unsigned32 | read-create | current |
| sspmSinkLastSequenceNumber OBJECT-TYPE The last sequence number received. | 1.3.6.1.2.1.16.28.1.5.1.1.8 | Unsigned32 | read-only | current |
| sspmSinkLastSequenceInvalid OBJECT-TYPE The number of packets that arrived whose sequence number was not one plus the value of sspmSinkLastSequenceNumber. | 1.3.6.1.2.1.16.28.1.5.1.1.9 | Counter32 | read-only | current |
| sspmSinkStorageType OBJECT-TYPE The storage type of this sspmSinkEntry. If the value of this object is 'permanent', no objects in this row need to be writable. | 1.3.6.1.2.1.16.28.1.5.1.1.10 | StorageType | read-create | current |
| sspmSinkStatus OBJECT-TYPE Status of this conceptual row. An entry may not exist in the active state unless all objects in the entry have an appropriate value. Once this object is set to active(1), no objects with MAX-ACCESS of read-create in the sspmSinkTable can be changed. | 1.3.6.1.2.1.16.28.1.5.1.1.11 | RowStatus | read-create | current |
| sspmMIBNotifications OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.2 | |||
| sspmMIBConformance OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.3 | |||
| sspmCompliances OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.3.1 | |||
| sspmGroups OBJECT-IDENTITY | 1.3.6.1.2.1.16.28.3.2 |
Conformance
| Name | OID | Status |
|---|---|---|
| sspmGeneralCompliance MODULE-COMPLIANCE A general compliance that allows all things to be optional. | 1.3.6.1.2.1.16.28.3.1.1 | current |
| sspmSourceFullCompliance MODULE-COMPLIANCE A source compliance. Use this compliance when implementing a traffic-source-only device. This is useful for implementing devices that probe other devices for intrusive application monitoring. It is also useful for implementing the source of one-way tests used with a sink-only device. | 1.3.6.1.2.1.16.28.3.1.2 | current |
| sspmSinkFullCompliance MODULE-COMPLIANCE A sink-only compliance. Use this compliance when implementing a sink-only device. This is useful for devices to receive one-way measurements. | 1.3.6.1.2.1.16.28.3.1.3 | current |
| sspmGeneralGroup OBJECT-GROUP The objects in the SSPM General Group. | 1.3.6.1.2.1.16.28.3.2.1 | current |
| sspmSourceGroup OBJECT-GROUP The objects in the SSPM Source Group. | 1.3.6.1.2.1.16.28.3.2.2 | current |
| sspmUserPassGroup OBJECT-GROUP The objects in the SSPM Username and password group. | 1.3.6.1.2.1.16.28.3.2.3 | current |
| sspmSinkGroup OBJECT-GROUP The objects in the SSPM Sink Group. | 1.3.6.1.2.1.16.28.3.2.4 | current |