MIBs Depot

SIP-UA-MIB

Registered at
1.3.6.1.2.1.150
Last updated
2007-04-20 00:00
Organization
IETF Session Initiation Protocol Working Group
Revisions
2007-04-20 00:00
Namespace
standard
Source file
SIP-UA-MIB
Digest
sha256:4ba89e8ea980b65b60788b45eade3741b0ed4f30e04b3b528ca31251910db89f

Description

Session Initiation Protocol (SIP) User Agent (UA) MIB module. SIP is an application-layer signaling protocol for creating, modifying, and terminating multimedia sessions with one or more participants. These sessions include Internet multimedia conferences and Internet telephone calls. SIP is defined in RFC 3261 (June 2002). A User Agent is an application that contains both a User Agent Client (UAC) and a User Agent Server (UAS). A UAC is an application that initiates a SIP request. A UAS is an application that contacts the user when a SIP request is received and that returns a response on behalf of the user. The response accepts, rejects, or redirects the request. Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4780; see the RFC itself for full legal notices.

Contact

SIP WG email: sip@ietf.org Co-editor Kevin Lingle Cisco Systems, Inc. postal: 7025 Kit Creek Road P.O. Box 14987 Research Triangle Park, NC 27709 USA email: klingle@cisco.com phone: +1 919 476 2029 Co-editor Joon Maeng email: jmaeng@austin.rr.com Co-editor Jean-Francois Mule CableLabs postal: 858 Coal Creek Circle Louisville, CO 80027 USA email: jf.mule@cablelabs.com phone: +1 303 661 9100 Co-editor Dave Walker email: drwalker@rogers.com

Imports

FromSymbols
INET-ADDRESS-MIBInetAddress, InetAddressType
NETWORK-SERVICES-MIBapplIndex
SIP-TC-MIBSipTCEntityRole
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIMODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

INET-ADDRESS-MIB
NETWORK-SERVICES-MIB
SIP-TC-MIB
SIP-UA-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Objects

NameOIDSyntaxAccessStatus
sipUAMIBObjects
OBJECT-IDENTITY
1.3.6.1.2.1.150.1
sipUACfgServer
OBJECT-IDENTITY
1.3.6.1.2.1.150.1.1
sipUACfgServerTable
OBJECT-TYPE
This table contains SIP server configuration objects applicable to each SIP user agent in this system.
1.3.6.1.2.1.150.1.1.1not-accessiblecurrent
sipUACfgServerEntry
OBJECT-TYPE
A row of server configuration. Each row represents those objects for a particular SIP user agent present in this system. applIndex is used to uniquely identify these instances of SIP user agents and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.150.1.1.1.1not-accessiblecurrent
sipUACfgServerIndex
OBJECT-TYPE
A unique identifier of a server address when multiple addresses are configured by the SIP entity. If one address isn't reachable, then another can be tried.
1.3.6.1.2.1.150.1.1.1.1.1Unsigned32 (1..4294967295)not-accessiblecurrent
sipUACfgServerAddressType
OBJECT-TYPE
This object reflects the type of address contained in the associated instance of sipUACfgServerAddress.
1.3.6.1.2.1.150.1.1.1.1.2InetAddressTyperead-onlycurrent
sipUACfgServerAddress
OBJECT-TYPE
This object reflects the address of a SIP server this user agent will use to proxy/redirect calls. The type of this address is determined by the value of the sipUACfgServerAddressType object.
1.3.6.1.2.1.150.1.1.1.1.3InetAddressread-onlycurrent
sipUACfgServerRole
OBJECT-TYPE
This object reflects the function of the SIP server this user agent should communicate with: registrar, proxy (outbound proxy), etc.
1.3.6.1.2.1.150.1.1.1.1.4SipTCEntityRoleread-onlycurrent
sipUAMIBConformance
OBJECT-IDENTITY
1.3.6.1.2.1.150.2
sipUAMIBCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.150.2.1
sipUAMIBGroups
OBJECT-IDENTITY
1.3.6.1.2.1.150.2.2

Conformance

NameOIDStatus
sipUACompliance
MODULE-COMPLIANCE
The compliance statement for SIP entities that implement the SIP-UA-MIB module.
1.3.6.1.2.1.150.2.1.1current
sipUAConfigGroup
OBJECT-GROUP
A collection of objects providing information about the configuration of SIP User Agents.
1.3.6.1.2.1.150.2.2.1current