MIBs Depot

SIP-SERVER-MIB

Registered at
1.3.6.1.2.1.151
Last updated
2007-04-20 00:00
Organization
IETF Session Initiation Protocol Working Group
Revisions
2007-04-20 00:00
Namespace
standard
Source file
SIP-SERVER-MIB
Digest
sha256:51b8c8a4ae3ca3fad82e3a64347ecc2bd58b12543d6de060f944b1c5aacdf9c0

Description

Session Initiation Protocol (SIP) Server MIB module. SIP is an application-layer signaling protocol for creating, modifying, and terminating multimedia sessions with one or more participants. These sessions include Internet multimedia conferences and Internet telephone calls. SIP is defined in RFC 3261 (June 2002). This MIB is defined for the management of SIP Proxy, Redirect, and Registrar Servers. A Proxy Server acts as both a client and a server. It accepts requests from other clients, either responding to them or passing them on to other servers, possibly after modification. A Redirect Server accepts requests from clients and returns zero or more addresses to that client. Unlike a User Agent Server, it does not accept calls. A Registrar is a server that accepts REGISTER requests. A Registrar is typically co-located with a Proxy or Redirect Server. Copyright (C) The IETF Trust (2007). This version of this MIB module is part of RFC 4780; see the RFC itself for full legal notices.

Contact

SIP WG email: sip@ietf.org Co-editor: Kevin Lingle Cisco Systems, Inc. postal: 7025 Kit Creek Road P.O. Box 14987 Research Triangle Park, NC 27709 USA email: klingle@cisco.com phone: +1 919 476 2029 Co-editor: Joon Maeng email: jmaeng@austin.rr.com Co-editor: Jean-Francois Mule CableLabs postal: 858 Coal Creek Circle Louisville, CO 80027 USA email: jf.mule@cablelabs.com phone: +1 303 661 9100 Co-editor: Dave Walker email: drwalker@rogers.com

Imports

FromSymbols
INET-ADDRESS-MIBInetAddress, InetAddressType
NETWORK-SERVICES-MIBapplIndex
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, Gauge32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2
SNMPv2-TCDateAndTime, DisplayString, TEXTUAL-CONVENTION, TimeStamp, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

INET-ADDRESS-MIB
NETWORK-SERVICES-MIB
SIP-SERVER-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Objects

NameOIDSyntaxAccessStatus
sipServerMIBObjects
OBJECT-IDENTITY
1.3.6.1.2.1.151.1
sipServerCfg
OBJECT-IDENTITY
1.3.6.1.2.1.151.1.1
sipServerCfgTable
OBJECT-TYPE
This table contains configuration objects applicable to SIP Redirect and Proxy Servers.
1.3.6.1.2.1.151.1.1.1not-accessiblecurrent
sipServerCfgEntry
OBJECT-TYPE
A row of common configuration. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.1.1.1not-accessiblecurrent
sipServerCfgHostAddressType
OBJECT-TYPE
The type of Internet address by which the SIP server is reachable.
1.3.6.1.2.1.151.1.1.1.1.1InetAddressTyperead-onlycurrent
sipServerCfgHostAddress
OBJECT-TYPE
This is the host portion of a SIP URI that is assigned to the SIP server. It MAY contain a fully qualified domain name or an IP address. The length of the value will depend on the type of address specified. The type of address given by this object is controlled by sipServerCfgHostAddressType.
1.3.6.1.2.1.151.1.1.1.1.2InetAddressread-onlycurrent
sipServerProxyCfg
OBJECT-IDENTITY
1.3.6.1.2.1.151.1.3
sipServerProxyCfgTable
OBJECT-TYPE
This table contains configuration objects applicable to SIP Proxy Servers.
1.3.6.1.2.1.151.1.3.1not-accessiblecurrent
sipServerProxyCfgEntry
OBJECT-TYPE
A row of common proxy configuration. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.3.1.1not-accessiblecurrent
sipServerCfgProxyStatefulness
OBJECT-TYPE
This object reflects the default mode of operation for the Proxy Server entity. A stateless proxy is a logical entity that does not maintain the client or server transaction state machines when it processes requests. A stateless proxy forwards every request it receives downstream and every response it receives upstream. If the value of this object is stateless(1), the proxy defaults to stateless operations. A transaction stateful proxy, or simply a 'stateful proxy', is a logical entity that maintains the client and server transaction state machines during the processing of a request. A (transaction) stateful proxy is not the same as a call stateful proxy. If the value of this object is transactionStateful(2), the proxy is stateful on a transaction basis. A call stateful proxy is a logical entity if it retains state for a dialog from the initiating INVITE to the terminating BYE request. A call stateful proxy is always transaction stateful, but the converse is not necessarily true. If the value of this object is callStateful(3), the proxy is call stateful.
1.3.6.1.2.1.151.1.3.1.1.1INTEGER {stateless(1), transactionStateful(2), callStateful(3)}read-onlycurrent
sipServerCfgProxyRecursion
OBJECT-TYPE
This object reflects whether or not the Proxy performs a recursive search on the Contacts provided in 3xx redirects. If the value of this object is 'true', a recursive search is performed. If the value is 'false', no search is performed, and the 3xx response is sent upstream towards the source of the request.
1.3.6.1.2.1.151.1.3.1.1.2TruthValueread-onlycurrent
sipServerCfgProxyRecordRoute
OBJECT-TYPE
This object reflects whether or not the proxy adds itself to the Record-Route header as a default action. This header is used to list the proxies that insist on being in the signaling path for subsequent requests related to the call leg. If the value of this object is 'true', the proxy adds itself to the end of the Record-Route header, creating the header if required. If the value is 'false', the proxy does not add itself to the Record-Route header.
1.3.6.1.2.1.151.1.3.1.1.3TruthValueread-onlycurrent
sipServerCfgProxyAuthMethod
OBJECT-TYPE
This object reflects the authentication methods that MAY be used to authenticate request originators. bit 0 no authentication is performed bit 1 TLS is used bit 2 HTTP Digest is used.
1.3.6.1.2.1.151.1.3.1.1.4Bits {none(0), tls(1), digest(2)}read-onlycurrent
sipServerCfgProxyAuthDefaultRealm
OBJECT-TYPE
This object reflects the default realm value used in Proxy-Authenticate headers. Note that this MAY need to be stored per user, in which case, this default value is ignored.
1.3.6.1.2.1.151.1.3.1.1.5SnmpAdminStringread-onlycurrent
sipServerProxyStats
OBJECT-IDENTITY
1.3.6.1.2.1.151.1.4
sipServerProxyStatsTable
OBJECT-TYPE
This table contains the statistics objects applicable to all SIP Proxy Servers in this system.
1.3.6.1.2.1.151.1.4.1not-accessiblecurrent
sipServerProxyStatsEntry
OBJECT-TYPE
A row of summary statistics. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.4.1.1not-accessiblecurrent
sipServerProxyStatProxyReqFailures
OBJECT-TYPE
This object contains the number of occurrences of unsupported options being specified in received Proxy-Require headers. Such occurrences result in a 420 Bad Extension status code being returned. Discontinuities in the value of this counter can occur at re-initialization of the SIP entity or service. A Management Station can detect discontinuities in this counter by monitoring the sipServerProxyStatsDisconTime object in the same row.
1.3.6.1.2.1.151.1.4.1.1.1Counter32read-onlycurrent
sipServerProxyStatsDisconTime
OBJECT-TYPE
The value of the sysUpTime object when the counters for the server statistics objects in this row last experienced a discontinuity.
1.3.6.1.2.1.151.1.4.1.1.2TimeStampread-onlycurrent
sipServerRegCfg
OBJECT-IDENTITY
1.3.6.1.2.1.151.1.5
sipServerRegCfgTable
OBJECT-TYPE
This table contains configuration objects applicable to SIP Registrars.
1.3.6.1.2.1.151.1.5.1not-accessiblecurrent
sipServerRegCfgEntry
OBJECT-TYPE
A row of common Registrar configuration. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.5.1.1not-accessiblecurrent
sipServerRegMaxContactExpiryDuration
OBJECT-TYPE
This object reflects the maximum expiry that may be requested by a User Agent for a particular Contact. User Agents can specify expiry using either an Expiry header in a REGISTER request, or using an Expires parameter in a Contact header in a REGISTER request. If the value requested by the User Agent is greater than the value of this object, then the contact information is given the duration specified by this object, and that duration is indicated to the User Agent in the response.
1.3.6.1.2.1.151.1.5.1.1.1Unsigned32 (0..4294967295)read-onlycurrent
sipServerRegMaxUsers
OBJECT-TYPE
This object reflects the maximum number of users that the Registrar supports. The current number of users is reflected by sipServerRegCurrentUsers.
1.3.6.1.2.1.151.1.5.1.1.2Unsigned32 (1..4294967295)read-onlycurrent
sipServerRegCurrentUsers
OBJECT-TYPE
This object reflects the number of users currently registered with the Registrar.
1.3.6.1.2.1.151.1.5.1.1.3Gauge32 (0..4294967295)read-onlycurrent
sipServerRegDfltRegActiveInterval
OBJECT-TYPE
This object reflects the default time interval the Registrar considers registrations to be active. The value is used to compute the Expires header in the REGISTER response. If a user agent requests a time interval shorter than specified by this object, the Registrar SHOULD honor that request. If a Contact entry does not have an 'expires' parameter, the value of the Expires header field is used instead. If a Contact entry has no 'expires' parameter and no Expires header field is present, the value of this object is used as the default value.
1.3.6.1.2.1.151.1.5.1.1.4Unsigned32 (1..4294967295)read-onlycurrent
sipServerRegUserTable
OBJECT-TYPE
This table contains information on all users registered to each Registrar in this system.
1.3.6.1.2.1.151.1.5.2not-accessiblecurrent
sipServerRegUserEntry
OBJECT-TYPE
This entry contains information for a single user registered to this Registrar. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.5.2.1not-accessiblecurrent
sipServerRegUserIndex
OBJECT-TYPE
This object uniquely identifies a conceptual row in the table.
1.3.6.1.2.1.151.1.5.2.1.1Unsigned32 (1..4294967295)not-accessiblecurrent
sipServerRegUserUri
OBJECT-TYPE
This object contains the user's address-of-record. It is the main form by which the Registrar knows the user. The format is typically 'user@domain'. It is contained in the To header for all REGISTER requests.
1.3.6.1.2.1.151.1.5.2.1.2SnmpAdminStringread-onlycurrent
sipServerRegUserAuthenticationFailures
OBJECT-TYPE
This object contains a count of the number of times the user has failed authentication. Discontinuities in the value of this counter can occur due to successful user authentications and at re-initialization of the SIP entity or service. A Management Station can detect discontinuities in this counter by monitoring the sipServerRegUserDisconTime object in the same row.
1.3.6.1.2.1.151.1.5.2.1.3Counter32read-onlycurrent
sipServerRegUserDisconTime
OBJECT-TYPE
The value of the sysUpTime object when the counters for the user registration statistics objects in this row last experienced a discontinuity.
1.3.6.1.2.1.151.1.5.2.1.4TimeStampread-onlycurrent
sipServerRegContactTable
OBJECT-TYPE
This table contains information on every location where a registered user (specified by sipServerRegUserIndex) wishes to be found (i.e., the user has provided contact information to each SIP Registrar in this system).
1.3.6.1.2.1.151.1.5.3not-accessiblecurrent
sipServerRegContactEntry
OBJECT-TYPE
This entry contains information for a single Contact. Multiple contacts may exist for a single user. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.5.3.1not-accessiblecurrent
sipServerRegContactIndex
OBJECT-TYPE
Along with the sipServerRegUserIndex, this object uniquely identifies a conceptual row in the table.
1.3.6.1.2.1.151.1.5.3.1.1Unsigned32 (1..4294967295)not-accessiblecurrent
sipServerRegContactDisplayName
OBJECT-TYPE
This object contains the display name for the Contact. For example, 'Santa at Home', or 'Santa on his Sled', corresponding to contact URIs of sip:BigGuy@example.com or sip:sclaus817@example.com, respectively.
1.3.6.1.2.1.151.1.5.3.1.2SnmpAdminStringread-onlycurrent
sipServerRegContactURI
OBJECT-TYPE
This object contains either a SIP URI where the user can be contacted. This URI is normally returned to a client from a Redirect Server, or is used as the RequestURI in a SIP request line for requests forwarded by a proxy.
1.3.6.1.2.1.151.1.5.3.1.3SnmpAdminStringread-onlycurrent
sipServerRegContactLastUpdated
OBJECT-TYPE
This object indicates the time when this contact information was accepted. If the contact information is updated via a subsequent REGISTER of the same information, this object is also updated.
1.3.6.1.2.1.151.1.5.3.1.4TimeStampread-onlycurrent
sipServerRegContactExpiry
OBJECT-TYPE
This object contains the date and time when the contact information will no longer be valid. Such times may be specified by the user at registration (i.e., Expires header or expiry parameter in the Contact information), or a system default can be applied.
1.3.6.1.2.1.151.1.5.3.1.5DateAndTimeread-onlycurrent
sipServerRegContactPreference
OBJECT-TYPE
This object indicates a relative preference for the particular Contact header field value compared to other bindings for this address-of-record. A registering user may provide this preference as a 'qvalue' parameter in the Contact header. The format of this item is a decimal number between 0 and 1 (for example 0.9). Higher values indicate locations preferred by the user.
1.3.6.1.2.1.151.1.5.3.1.6SnmpAdminStringread-onlycurrent
sipServerRegStats
OBJECT-IDENTITY
1.3.6.1.2.1.151.1.6
sipServerRegStatsTable
OBJECT-TYPE
This table contains the summary statistics objects applicable to all SIP Registrars in this system.
1.3.6.1.2.1.151.1.6.1not-accessiblecurrent
sipServerRegStatsEntry
OBJECT-TYPE
A row of summary statistics. Each row represents those objects for a particular SIP server present in this system. applIndex is used to uniquely identify these instances of SIP servers and correlate them through the common framework of the NETWORK-SERVICES-MIB (RFC 2788). The same value of applIndex used in the corresponding SIP-COMMON-MIB is used here.
1.3.6.1.2.1.151.1.6.1.1not-accessiblecurrent
sipServerRegStatsAcceptedRegs
OBJECT-TYPE
This object contains a count of the number of REGISTER requests that have been accepted (status code 200) by the Registrar. This includes additions of new contact information, refreshing contact information, as well as requests for deletion of contact information. Discontinuities in the value of this counter can occur at re-initialization of the SIP entity or service. A Management Station can detect discontinuities in this counter by monitoring the sipServerRegStatsDisconTime object in the same row.
1.3.6.1.2.1.151.1.6.1.1.1Counter32read-onlycurrent
sipServerRegStatsRejectedRegs
OBJECT-TYPE
This object contains a count of the number REGISTER requests that have been rejected by the Registrar. Discontinuities in the value of this counter can occur at re-initialization of the SIP entity or service. A Management Station can detect discontinuities in this counter by monitoring the sipServerRegStatsDisconTime object in the same row.
1.3.6.1.2.1.151.1.6.1.1.2Counter32read-onlycurrent
sipServerRegStatsDisconTime
OBJECT-TYPE
The value of the sysUpTime object when the counters for the registrar statistics objects in this row last experienced a discontinuity.
1.3.6.1.2.1.151.1.6.1.1.3TimeStampread-onlycurrent
sipServerMIBConformance
OBJECT-IDENTITY
1.3.6.1.2.1.151.2
sipServerMIBCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.151.2.1
sipServerMIBGroups
OBJECT-IDENTITY
1.3.6.1.2.1.151.2.2

Conformance

NameOIDStatus
sipServerProxyServerCompliance
MODULE-COMPLIANCE
The compliance statement for SIP entities acting as Proxy Servers.
1.3.6.1.2.1.151.2.1.1current
sipRedirectServerCompliance
MODULE-COMPLIANCE
The compliance statement for SIP entities acting as Redirect Servers.
1.3.6.1.2.1.151.2.1.2current
sipServerRegistrarServerCompliance
MODULE-COMPLIANCE
The compliance statement for SIP entities acting as Registrars.
1.3.6.1.2.1.151.2.1.3current
sipServerConfigGroup
OBJECT-GROUP
A collection of objects providing configuration common to SIP Proxy and Redirect servers.
1.3.6.1.2.1.151.2.2.1current
sipServerProxyConfigGroup
OBJECT-GROUP
A collection of objects providing configuration for SIP Proxy servers.
1.3.6.1.2.1.151.2.2.2current
sipServerProxyStatsGroup
OBJECT-GROUP
A collection of objects providing statistics for SIP Proxy servers.
1.3.6.1.2.1.151.2.2.3current
sipServerRegistrarConfigGroup
OBJECT-GROUP
A collection of objects providing configuration for SIP Registrars.
1.3.6.1.2.1.151.2.2.4current
sipServerRegistrarStatsGroup
OBJECT-GROUP
A collection of objects providing statistics for SIP Registrars.
1.3.6.1.2.1.151.2.2.5current
sipServerRegistrarUsersGroup
OBJECT-GROUP
A collection of objects related to registered users.
1.3.6.1.2.1.151.2.2.6current