SAMSUNG-HOST-RESOURCES-EXT-MIB
- Registered at
- 1.3.6.1.4.1.236.11.5.11.53
- Last updated
- 1904-07-17 00:00
- Organization
- Samsung Corporation - SCMI Working Group
- Namespace
- samsung
- Source file
SAMSUNG-HOST-RESOURCES-EXT-MIB- Digest
sha256:514308462466397c33d1474ddf7f85d8b7ce35a6f5caba1a3e7647b569bb7017
Description
Version: 1.00 The MIB module for extended configuration and management of various host resources for network accessible host systems. This module augments and extends the original IETF Host Resources MIB (RFC 2790). Usage: This MIB module introduces support for the 'realization' of both 'physical' and 'logical' devices, consistent with the Document Printing Application (DPA), ISO/IEC 10175, as reflected in the object 'scmHrDevInfoRealization'. Note: Conforming implementations SHALL NOT 'bubble up' status from 'physical' devices to associated 'logical' devices. All devices SHALL report their own status ONLY. See: Section 9 'Supplement' in SCMI Extensions to IETF Host Resources TC, for implementation guidance for this MIB module. Copyright (C) 1995-2002 Samsung Corporation. All Rights Reserved.
Contact
SCMI Editors Email: coherence@crt.samsung.com -- --
Imports
| From | Symbols |
|---|---|
| HOST-RESOURCES-MIB | hrDeviceIndex |
| SAMSUNG-COMMON-MIB | samsungCommonMIB |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Counter32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
HOST-RESOURCES-MIB IANAifType-MIB IF-MIB SAMSUNG-COMMON-MIB SAMSUNG-HOST-RESOURCES-EXT-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC
Textual conventions
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| ScmHrDevCountColorTC TEXTUAL-CONVENTION The color type of job | current | |||
| ScmHrDevCountDuplexTC TEXTUAL-CONVENTION The duplex type of job | current | |||
| ScmHrDevCountJobTypeTC TEXTUAL-CONVENTION The type of count job. | current | |||
| ScmHrDevCountMediaSizeTC TEXTUAL-CONVENTION The size of media. | current | |||
| ScmHrDevCountUnitTC TEXTUAL-CONVENTION The count unit of job count. | current |
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| scmHrMIBConformance OBJECT-IDENTITY | 1.3.6.1.4.1.236.11.5.11.53.2 | |||
| scmHrMIBGroups OBJECT-IDENTITY | 1.3.6.1.4.1.236.11.5.11.53.2.2 | |||
| scmHrDevCount OBJECT-IDENTITY | 1.3.6.1.4.1.236.11.5.11.53.11 | |||
| scmHrDevCountSimple OBJECT-IDENTITY | 1.3.6.1.4.1.236.11.5.11.53.11.1 | |||
| scmHrDevCountTable OBJECT-TYPE Samsung Common Mib Host Resource Count MIB | 1.3.6.1.4.1.236.11.5.11.53.11.2 | not-accessible | current | |
| scmHrDevCountEntry OBJECT-TYPE An entry for a device alert which has been generated and recorded on this host system. | 1.3.6.1.4.1.236.11.5.11.53.11.2.1 | not-accessible | current | |
| scmHrDevCountIndex OBJECT-TYPE A unique value used by the host to identify this Count item. This value indicate index of usage count value. If host device supports three count value (total page count, total color print count, total mono print count), this device has three count value and index. | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.1 | Integer32 (1..32767) | read-only | current |
| scmHrDevCountJobType OBJECT-TYPE scmHrDevCount defines items that are outside of the normal numeric range: other(-1), unknown(-2). scm defines many a job type. but current samsung device supports counts of print, fax, copy and scan job. Thus, the other items is not used. | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.2 | ScmHrDevCountJobTypeTC | read-only | current |
| scmHrDevCountMediaSize OBJECT-TYPE smcHrDevCount defines items that are outside of the normal numeric range: other(-1), unknown(-2). scm defines many a size of media. But, We use 'small' or 'large' as media size so that application simply manage. | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.3 | ScmHrDevCountMediaSizeTC | read-only | current |
| scmHrDevCountUnit OBJECT-TYPE smcHrDevCount define items that are outside of the normal numeric range: other(-1), unknown(-2). PWG define count unit in printer mib(RFC1759, RFC3805). Default value is sheet(8), but specifically use impression (for example OEM Model). | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.4 | ScmHrDevCountUnitTC | read-only | current |
| scmHrDevCountDuplex OBJECT-TYPE smcHrDevCount define items that are outside of the normal numeric range: other(-1), unknown(-2). samsung device suppor three duplex job type, simple, duplex, duplex(single). | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.5 | ScmHrDevCountDuplexTC | read-only | current |
| scmHrDevCountColor OBJECT-TYPE smcHrDevCount define items that are outside of the normal numeric range: other(-1), unknown(-2). single-color is defined for extension of color job count. | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.6 | ScmHrDevCountColorTC | read-only | current |
| scmHrDevCountValue OBJECT-TYPE Value of usage count. | 1.3.6.1.4.1.236.11.5.11.53.11.2.1.7 | Counter32 | read-only | current |
Conformance
| Name | OID | Status |
|---|---|---|
| scmHrDevInfoGroup OBJECT-GROUP The Host Resources Extensions MIB Device Info Group | 1.3.6.1.4.1.236.11.5.11.53.2.2.3 | current |