MIBs Depot

RPKI-ROUTER-MIB

Registered at
1.3.6.1.2.1.218
Last updated
2013-05-01 00:00
Organization
IETF Secure Inter-Domain Routing (SIDR) Working Group
Revisions
2013-05-01 00:00
Namespace
standard
Source file
RPKI-ROUTER-MIB
Digest
sha256:d32b800c5f13c81e37ac6922cc5474b9adaa71e671cf2f89bd25eba488d3d337

Description

This MIB module contains management objects to support monitoring of the Resource Public Key Infrastructure (RPKI) protocol on routers. Copyright (c) 2013 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 6945; see the RFC itself for full legal notices.

Contact

Working Group Email: sidr@ietf.org Randy Bush Internet Initiative Japan 5147 Crystal Springs Bainbridge Island, WA 98110 USA Email: randy@psg.com Bert Wijnen RIPE NCC Schagen 33 3461 GL Linschoten Netherlands Email: bertietf@bwijnen.net Keyur Patel Cisco Systems 170 W. Tasman Drive San Jose, CA 95134 USA Email: keyupate@cisco.com Michael Baer SPARTA P.O. Box 72682 Davis, CA 95617 USA Email: baerm@tislabs.com

Imports

FromSymbols
INET-ADDRESS-MIBInetAddress, InetAddressPrefixLength, InetAddressType, InetAutonomousSystemNumber, InetPortNumber
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, Gauge32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION, TimeStamp
SYSAPPL-MIBLongUtf8String

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

INET-ADDRESS-MIB
RPKI-ROUTER-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC
SYSAPPL-MIB

Textual conventions

NameOIDSyntaxAccessStatus
RpkiRtrConnectionType
TEXTUAL-CONVENTION
The connection type used between a router (as a client) and a cache server. The following types have been defined in RFC 6810: ssh(1) - Section 7.1; see also RFC 4252. tls(2) - Section 7.2; see also RFC 5246. tcpMD5(3) - Section 7.3; see also RFC 2385. tcpAO(4) - Section 7.4; see also RFC 5925. tcp(5) - Section 7. ipsec(6) - Section 7; see also RFC 4301. other(7) - none of the above.
current

Objects

NameOIDSyntaxAccessStatus
rpkiRtrNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.218.0
rpkiRtrObjects
OBJECT-IDENTITY
1.3.6.1.2.1.218.1
rpkiRtrDiscontinuityTimer
OBJECT-TYPE
This timer represents the timestamp (value of sysUpTime) at which time any of the Counter32 objects in this MIB module encountered a discontinuity. For objects that use rpkiRtrDiscontinuityTimer to indicate discontinuity, only values received since the time indicated by rpkiRtrDiscontinuityTimer are comparable to each other. A manager should take the possibility of rollover into account when calculating difference values. In principle, that should only happen if the SNMP agent or the instrumentation for this MIB module starts or restarts.
1.3.6.1.2.1.218.1.1TimeStampread-onlycurrent
rpkiRtrCacheServerTable
OBJECT-TYPE
This table lists the RPKI cache servers known to this router/system.
1.3.6.1.2.1.218.1.2not-accessiblecurrent
rpkiRtrCacheServerTableEntry
OBJECT-TYPE
An entry in the rpkiRtrCacheServerTable. It holds management attributes associated with one connection to a RPKI cache server. Implementers should be aware that if the rpkiRtrCacheServerRemoteAddress object exceeds 114 octets, the index values will exceed the 128 sub-identifier limit and cannot be accessed using SNMPv1, SNMPv2c, or SNMPv3.
1.3.6.1.2.1.218.1.2.1not-accessiblecurrent
rpkiRtrCacheServerRemoteAddressType
OBJECT-TYPE
The network address type of the connection to this RPKI cache server. Note: Only IPv4, IPv6, and DNS support are required for read-only compliance with RFC 6945.
1.3.6.1.2.1.218.1.2.1.1InetAddressTypenot-accessiblecurrent
rpkiRtrCacheServerRemoteAddress
OBJECT-TYPE
The remote network address for this connection to this RPKI cache server. The format of the address is defined by the value of the corresponding instance of rpkiRtrCacheServerRemoteAddressType. This object matches the address type used within the local router configuration. If the address is of type dns (fqdn), then the router will resolve it at the time it connects to the cache server.
1.3.6.1.2.1.218.1.2.1.2InetAddressnot-accessiblecurrent
rpkiRtrCacheServerRemotePort
OBJECT-TYPE
The remote port number for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.3InetPortNumber (1..65535)not-accessiblecurrent
rpkiRtrCacheServerLocalAddressType
OBJECT-TYPE
The network address type of the connection to this RPKI cache server. Note: Only IPv4, IPv6, and DNS support are required for read-only compliance with RFC 6945.
1.3.6.1.2.1.218.1.2.1.4InetAddressTyperead-onlycurrent
rpkiRtrCacheServerLocalAddress
OBJECT-TYPE
The local network address for this connection to this RPKI cache server. The format of the address is defined by the value of the corresponding instance of rpkiRtrCacheServerLocalAddressType. This object matches the address type used within the local router configuration. If the address is of type dns (fqdn), then the router will resolve it at the time it connects to the cache server.
1.3.6.1.2.1.218.1.2.1.5InetAddressread-onlycurrent
rpkiRtrCacheServerLocalPort
OBJECT-TYPE
The local port number for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.6InetPortNumber (1..65535)read-onlycurrent
rpkiRtrCacheServerPreference
OBJECT-TYPE
The routers' preference for this RPKI cache server. A lower value means more preferred. If two entries have the same preference, then the order is arbitrary. In two cases, the maximum value for an Unsigned32 object should be returned for this object: - If no order is specified in the RPKI-Router configuration. - If a preference value is configured that is larger than the max value for an Unsigned32 object.
1.3.6.1.2.1.218.1.2.1.7Unsigned32read-onlycurrent
rpkiRtrCacheServerConnectionType
OBJECT-TYPE
The connection type or transport security suite in use for this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.8RpkiRtrConnectionTyperead-onlycurrent
rpkiRtrCacheServerConnectionStatus
OBJECT-TYPE
The connection status for this entry (connection to this RPKI cache server).
1.3.6.1.2.1.218.1.2.1.9INTEGER {up(1), down(2)}read-onlycurrent
rpkiRtrCacheServerDescription
OBJECT-TYPE
Free form description/information for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.10LongUtf8Stringread-onlycurrent
rpkiRtrCacheServerMsgsReceived
OBJECT-TYPE
Number of messages received from this RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.11Counter32read-onlycurrent
rpkiRtrCacheServerMsgsSent
OBJECT-TYPE
Number of messages sent to this RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.12Counter32read-onlycurrent
rpkiRtrCacheServerV4ActiveRecords
OBJECT-TYPE
Number of active IPv4 records received from this RPKI cache server via this connection.
1.3.6.1.2.1.218.1.2.1.13Gauge32read-onlycurrent
rpkiRtrCacheServerV4Announcements
OBJECT-TYPE
The number of IPv4 records announced by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.14Counter32read-onlycurrent
rpkiRtrCacheServerV4Withdrawals
OBJECT-TYPE
The number of IPv4 records withdrawn by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.15Counter32read-onlycurrent
rpkiRtrCacheServerV6ActiveRecords
OBJECT-TYPE
Number of active IPv6 records received from this RPKI cache server via this connection.
1.3.6.1.2.1.218.1.2.1.16Gauge32read-onlycurrent
rpkiRtrCacheServerV6Announcements
OBJECT-TYPE
The number of IPv6 records announced by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.17Counter32read-onlycurrent
rpkiRtrCacheServerV6Withdrawals
OBJECT-TYPE
The number of IPv6 records withdrawn by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.2.1.18Counter32read-onlycurrent
rpkiRtrCacheServerLatestSerial
OBJECT-TYPE
The latest serial number of data received from this RPKI server on this connection. Note: this value wraps back to zero when it reaches its maximum value.
1.3.6.1.2.1.218.1.2.1.19Unsigned32read-onlycurrent
rpkiRtrCacheServerSessionID
OBJECT-TYPE
The Session ID associated with the RPKI cache server at the other end of this connection.
1.3.6.1.2.1.218.1.2.1.20Unsigned32 (0..65535)read-onlycurrent
rpkiRtrCacheServerRefreshTimer
OBJECT-TYPE
The number of seconds configured for the refresh timer for this connection to this RPKI cache server.
1.3.6.1.2.1.218.1.2.1.21Unsigned32 (60..7200)read-onlycurrent
rpkiRtrCacheServerTimeToRefresh
OBJECT-TYPE
The number of seconds remaining before a new refresh is performed via a Serial Query to this cache server over this connection. A negative value means that the refresh time has passed this many seconds and the refresh has not yet been completed. It will stop decrementing at the maximum negative value. Upon a completed refresh (i.e., a successful and complete response to a Serial Query) the value of this attribute will be reinitialized with the value of the corresponding rpkiRtrCacheServerRefreshTimer attribute.
1.3.6.1.2.1.218.1.2.1.22Integer32read-onlycurrent
rpkiRtrCacheServerId
OBJECT-TYPE
The unique ID for this connection. An implementation must make sure this ID is unique within this table. It is this ID that can be used to find entries in the rpkiRtrPrefixOriginTable that were created by announcements received on this connection from this cache server.
1.3.6.1.2.1.218.1.2.1.23Unsigned32 (1..4294967295)read-onlycurrent
rpkiRtrCacheServerErrorsTable
OBJECT-TYPE
This table provides statistics on errors per RPKI peer connection. These can be used for debugging.
1.3.6.1.2.1.218.1.3not-accessiblecurrent
rpkiRtrCacheServerErrorsTableEntry
OBJECT-TYPE
An entry in the rpkiCacheServerErrorTable. It holds management objects associated with errors codes that were received on the specified connection to a specific cache server.
1.3.6.1.2.1.218.1.3.1not-accessiblecurrent
rpkiRtrCacheServerErrorsCorruptData
OBJECT-TYPE
The number of 'Corrupt Data' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.1Counter32read-onlycurrent
rpkiRtrCacheServerErrorsInternalError
OBJECT-TYPE
The number of 'Internal Error' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.2Counter32read-onlycurrent
rpkiRtrCacheServerErrorsNoData
OBJECT-TYPE
The number of 'No Data Available' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.3Counter32read-onlycurrent
rpkiRtrCacheServerErrorsInvalidRequest
OBJECT-TYPE
The number of 'Invalid Request' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.4Counter32read-onlycurrent
rpkiRtrCacheServerErrorsUnsupportedVersion
OBJECT-TYPE
The number of 'Unsupported Protocol Version' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.5Counter32read-onlycurrent
rpkiRtrCacheServerErrorsUnsupportedPdu
OBJECT-TYPE
The number of 'Unsupported PDU Type' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.6Counter32read-onlycurrent
rpkiRtrCacheServerErrorsWithdrawalUnknown
OBJECT-TYPE
The number of 'Withdrawal of Unknown Record' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.7Counter32read-onlycurrent
rpkiRtrCacheServerErrorsDuplicateAnnounce
OBJECT-TYPE
The number of 'Duplicate Announcement Received' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.
1.3.6.1.2.1.218.1.3.1.8Counter32read-onlycurrent
rpkiRtrPrefixOriginTable
OBJECT-TYPE
This table lists the prefixes that were announced by RPKI cache servers to this system. That is the prefixes and their Origin Autonomous System Number (ASN) as received by announcements via the RPKI-Router Protocol.
1.3.6.1.2.1.218.1.4not-accessiblecurrent
rpkiRtrPrefixOriginTableEntry
OBJECT-TYPE
An entry in the rpkiRtrPrefixOriginTable. This represents one announced prefix. If a cache server is removed from the local configuration, any table rows associated with that server (indicated by rpkiRtrPrefixOriginCacheServerId) are also removed from this table. Implementers should be aware that if the rpkiRtrPrefixOriginAddress object exceeds 111 octets, the index values will exceed the 128 sub-identifier limit and cannot be accessed using SNMPv1, SNMPv2c, or SNMPv3.
1.3.6.1.2.1.218.1.4.1not-accessiblecurrent
rpkiRtrPrefixOriginAddressType
OBJECT-TYPE
The network address type for this prefix. Note: Only IPv4 and IPv6 support are required for read-only compliance with RFC 6945.
1.3.6.1.2.1.218.1.4.1.1InetAddressTypenot-accessiblecurrent
rpkiRtrPrefixOriginAddress
OBJECT-TYPE
The network address for this prefix. The format of the address is defined by the value of the corresponding instance of rpkiRtrPrefixOriginAddressType.
1.3.6.1.2.1.218.1.4.1.2InetAddressnot-accessiblecurrent
rpkiRtrPrefixOriginMinLength
OBJECT-TYPE
The minimum prefix length allowed for this prefix.
1.3.6.1.2.1.218.1.4.1.3InetAddressPrefixLengthnot-accessiblecurrent
rpkiRtrPrefixOriginMaxLength
OBJECT-TYPE
The maximum prefix length allowed for this prefix. Note, this value must be greater or equal to the value of rpkiRtrPrefixOriginMinLength.
1.3.6.1.2.1.218.1.4.1.4InetAddressPrefixLengthnot-accessiblecurrent
rpkiRtrPrefixOriginASN
OBJECT-TYPE
The ASN that is authorized to announce the prefix or sub-prefixes covered by this entry.
1.3.6.1.2.1.218.1.4.1.5InetAutonomousSystemNumber (0..4294967295)not-accessiblecurrent
rpkiRtrPrefixOriginCacheServerId
OBJECT-TYPE
The unique ID of the connection to the cache server from which this announcement was received. That connection is identified/found by a matching value in attribute rpkiRtrCacheServerId.
1.3.6.1.2.1.218.1.4.1.6Unsigned32 (1..4294967295)read-onlycurrent
rpkiRtrConformance
OBJECT-IDENTITY
1.3.6.1.2.1.218.2
rpkiRtrCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.218.2.1
rpkiRtrGroups
OBJECT-IDENTITY
1.3.6.1.2.1.218.2.2

Notifications

NameOIDStatus
rpkiRtrCacheServerConnectionStateChange
NOTIFICATION-TYPE
This notification signals a change in the status of an rpkiRtrCacheServerConnection. The management agent MUST throttle the generation of consecutive rpkiRtrCacheServerConnectionStateChange notifications such that there is at least a 5 second gap between them. If more than one notification has occurred locally during that time, the most recent notification is sent at the end of the 5 second gap and the others are discarded.
1.3.6.1.2.1.218.0.1current
rpkiRtrCacheServerConnectionToGoStale
NOTIFICATION-TYPE
This notification signals that an RPKI cache server connection is about to go stale. It is suggested that this notification is generated when the value of the rpkiRtrCacheServerTimeToRefresh attribute goes below 60 seconds. The SNMP agent MUST throttle the generation of consecutive rpkiRtrCacheServerConnectionToGoStale notifications such that there is at least a 5 second gap between them.
1.3.6.1.2.1.218.0.2current

Conformance

NameOIDStatus
rpkiRtrRFC6945ReadOnlyCompliance
MODULE-COMPLIANCE
The compliance statement for the rpkiRtrMIB module. There are only read-only objects in this MIB module, so the 'ReadOnly' in the name of this compliance statement is there only for clarity and truth in advertising. There are a number of INDEX objects that cannot be represented in the form of OBJECT clauses in SMIv2, but for which there are compliance requirements. Those requirements and similar requirements for related objects are expressed below, in pseudo-OBJECT clause form, in this description: -- OBJECT rpkiRtrCacheServerRemoteAddressType -- SYNTAX InetAddressType { ipv4(1), ipv6(2), dns(16) } -- DESCRIPTION -- The MIB requires support for the IPv4, IPv6, and DNS -- InetAddressTypes for this object. -- OBJECT rpkiRtrCacheServerLocalAddressType -- SYNTAX InetAddressType { ipv4(1), ipv6(2), dns(16) } -- DESCRIPTION -- The MIB requires support for the IPv4, IPv6, and DNS -- InetAddressTypes for this object. -- OBJECT rpkiRtrPrefixOriginAddressType -- SYNTAX InetAddressType { ipv4(1), ipv6(2) } -- DESCRIPTION -- The MIB requires support for the IPv4, and IPv6 -- InetAddressTypes for this object.
1.3.6.1.2.1.218.2.1.1current
rpkiRtrCacheServerGroup
OBJECT-GROUP
The collection of objects to monitor the RPKI peer connections.
1.3.6.1.2.1.218.2.2.1current
rpkiRtrCacheServerErrorsGroup
OBJECT-GROUP
The collection of objects that may help in debugging the communication between RPKI clients and cache servers.
1.3.6.1.2.1.218.2.2.2current
rpkiRtrPrefixOriginGroup
OBJECT-GROUP
The collection of objects that represent the prefix(es) and their validated Origin ASes.
1.3.6.1.2.1.218.2.2.3current
rpkiRtrNotificationsGroup
NOTIFICATION-GROUP
The set of notifications to alert an NMS of change in connections to RPKI cache servers.
1.3.6.1.2.1.218.2.2.4current