ROHC-RTP-MIB
- Registered at
- 1.3.6.1.2.1.114
- Last updated
- 2004-06-03 00:00
- Organization
- IETF Robust Header Compression Working Group
- Revisions
- 2004-06-03 00:00
- Namespace
- standard
- Source file
ROHC-RTP-MIB- Digest
sha256:f5d80ac2e21bc35d145f4f03df0681f681558566f60978ba6c1708a53073566f
Description
This MIB module defines a set of objects for monitoring and configuring RObust Header Compression (ROHC). The objects are specific to ROHC RTP (profile 0x0001), ROHC UDP (profile 0x0002), and ROHC ESP (profile 0x0003) defined in RFC 3095 and for the ROHC LLA profile (profile 0x0005) defined in RFC 3242. Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3816. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html
Contact
WG charter: http://www.ietf.org/html.charters/rohc-charter.html Mailing Lists: General Discussion: rohc@ietf.org To Subscribe: rohc-request@ietf.org In Body: subscribe your_email_address Editor: Juergen Quittek NEC Europe Ltd. Network Laboratories Kurfuersten-Anlage 36 69221 Heidelberg Germany Tel: +49 6221 90511-15 EMail: quittek@netlab.nec.de
Imports
| From | Symbols |
|---|---|
| ROHC-MIB | rohcChannelID, rohcContextCID |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Counter32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2 |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION, TruthValue |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
IANAifType-MIB IF-MIB ROHC-MIB ROHC-RTP-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| rohcRtpObjects OBJECT-IDENTITY | 1.3.6.1.2.1.114.1 | |||
| rohcRtpContextTable OBJECT-TYPE This table lists and describes RTP profile specific properties of compressor contexts and decompressor contexts. It extends the rohcContextTable of the ROHC-MIB module. | 1.3.6.1.2.1.114.1.1 | not-accessible | current | |
| rohcRtpContextEntry OBJECT-TYPE An entry describing a particular context. | 1.3.6.1.2.1.114.1.1.1 | not-accessible | current | |
| rohcRtpContextState OBJECT-TYPE State of the context as defined in RFC 3095. States initAndRefresh(1), firstOrder(2), and secondOrder(3) are states of compressor contexts, states noContext(4), staticContext(5) and fullContext(6) are states of decompressor contexts. | 1.3.6.1.2.1.114.1.1.1.3 | INTEGER {initAndRefresh(1), firstOrder(2), secondOrder(3), noContext(4), staticContext(5), fullContext(6)} | read-only | current |
| rohcRtpContextMode OBJECT-TYPE Mode of the context. | 1.3.6.1.2.1.114.1.1.1.4 | INTEGER {unidirectional(1), optimistic(2), reliable(3)} | read-only | current |
| rohcRtpContextAlwaysPad OBJECT-TYPE Boolean, only applicable to compressor contexts using the LLA profile. If its value is true, the compressor must pad every RHP packet with a minimum of one octet ROHC padding. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.5 | TruthValue | read-only | current |
| rohcRtpContextLargePktsAllowed OBJECT-TYPE Boolean, only applicable to compressor contexts using the LLA profile. It specifies how to handle packets that do not fit any of the preferred packet sizes specified. If its value is true, the compressor must deliver the larger packet as-is and must not use segmentation. If it is set to false, the ROHC segmentation scheme must be used to split the packet into two or more segments, and each segment must further be padded to fit one of the preferred packet sizes. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.6 | TruthValue | read-only | current |
| rohcRtpContextVerifyPeriod OBJECT-TYPE This object is only applicable to compressor contexts using the LLA profile. It specifies the minimum frequency with which a packet validating the context must be sent. This tells the compressor that a packet containing a CRC field must be sent at least once every N packets, where N is the value of the object. A value of 0 indicates that periodical verifications are disabled. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.7 | Unsigned32 | read-only | current |
| rohcRtpContextSizesAllowed OBJECT-TYPE The value of this object is only valid for decompressor contexts, i.e., if rohcInstanceType of the corresponding rohcContextEntry has the value decompressor(2). For compressor contexts where rohcInstanceType has the value compressor(1), this object MUST NOT be instantiated. This object contains the number of different packet sizes that may be used in the context. | 1.3.6.1.2.1.114.1.1.1.8 | Unsigned32 (1..4294967295) | read-only | current |
| rohcRtpContextSizesUsed OBJECT-TYPE The value of this object is only valid for decompressor contexts, i.e., if rohcInstanceType of the corresponding rohcContextEntry has the value decompressor(2). For compressor contexts where rohcInstanceType has the value compressor(1), this object MUST NOT be instantiated. This object contains the number of different packet sizes that are used in the context. | 1.3.6.1.2.1.114.1.1.1.9 | Unsigned32 (1..4294967295) | read-only | current |
| rohcRtpContextACKs OBJECT-TYPE The number of all positive feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. | 1.3.6.1.2.1.114.1.1.1.10 | Counter32 | read-only | current |
| rohcRtpContextNACKs OBJECT-TYPE The number of all dynamic negative feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. | 1.3.6.1.2.1.114.1.1.1.11 | Counter32 | read-only | current |
| rohcRtpContextSNACKs OBJECT-TYPE The number of all static negative feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. | 1.3.6.1.2.1.114.1.1.1.12 | Counter32 | read-only | current |
| rohcRtpContextNHPs OBJECT-TYPE This object is only applicable to contexts using the LLA profile. It contains the number of all no-header packets (NHP) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.13 | Counter32 | read-only | current |
| rohcRtpContextCSPs OBJECT-TYPE This object is only applicable to contexts using the LLA profile. It contains the number of all context synchronization packets (CSP) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.14 | Counter32 | read-only | current |
| rohcRtpContextCCPs OBJECT-TYPE This object is only applicable to contexts using the LLA profile. It contains the number of all context check packets (CCP) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.15 | Counter32 | read-only | current |
| rohcRtpContextPktsLostPhysical OBJECT-TYPE This object is only applicable to decompressor contexts using the LLA profile. It contains the number of physical packet losses on the link between compressor and decompressor, that have been indicated to the decompressor. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.16 | Counter32 | read-only | current |
| rohcRtpContextPktsLostPreLink OBJECT-TYPE This object is only applicable to decompressor contexts using the LLA profile. It contains the number of pre-link packet losses on the link between compressor and decompressor, that have been indicated to the decompressor. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.1.1.17 | Counter32 | read-only | current |
| rohcRtpPacketSizeTable OBJECT-TYPE This table lists all allowed, preferred, and used packet sizes per compressor context and channel. Note, that the sizes table represents implementation parameters that are suggested by RFC 3095 and/or RFC 3242, but that are not mandatory. | 1.3.6.1.2.1.114.1.2 | not-accessible | current | |
| rohcRtpPacketSizeEntry OBJECT-TYPE An entry of a particular packet size. | 1.3.6.1.2.1.114.1.2.1 | not-accessible | current | |
| rohcRtpPacketSize OBJECT-TYPE A packet size used as index. | 1.3.6.1.2.1.114.1.2.1.3 | Unsigned32 (1..4294967295) | not-accessible | current |
| rohcRtpPacketSizePreferred OBJECT-TYPE This object is only applicable to compressor contexts using the LLA profile. When retrieved, it will have the value true(1) if the packet size is preferred. Otherwise, its value will be false(2). The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.2.1.4 | TruthValue | read-only | current |
| rohcRtpPacketSizeUsed OBJECT-TYPE This object is only applicable to compressor contexts using the UDP, RTP, or ESP profile. When retrieved, it will have the value true(1) if the packet size is used. Otherwise, its value will be false(2). The value of this object is only valid for UDP, RTP, and ESP profiles, i.e., if the corresponding rohcProfile has a value of either 0x0001, 0x0002 or 0x0003. If the corresponding rohcProfile has a value other than 0x0001, 0x0002 or 0x0003, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.2.1.5 | TruthValue | read-only | current |
| rohcRtpPacketSizeRestrictedType OBJECT-TYPE This object is only applicable to preferred packet sizes of compressor contexts using the LLA profile. When retrieved, it will indicate whether the packet size is preferred for NHP only, for RHP only, or for both of them. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated. | 1.3.6.1.2.1.114.1.2.1.6 | INTEGER {nhpOnly(1), rhpOnly(2), noRestrictions(3)} | read-only | current |
| rohcRtpConformance OBJECT-IDENTITY | 1.3.6.1.2.1.114.2 | |||
| rohcRtpCompliances OBJECT-IDENTITY | 1.3.6.1.2.1.114.2.1 | |||
| rohcRtpGroups OBJECT-IDENTITY | 1.3.6.1.2.1.114.2.2 |
Conformance
| Name | OID | Status |
|---|---|---|
| rohcRtpCompliance MODULE-COMPLIANCE The compliance statement for SNMP entities that implement the ROHC-RTP-MIB. Note that compliance with this compliance statement requires compliance with the rohcCompliance MODULE-COMPLIANCE statement of the ROHC-MIB and with the ifCompliance3 MODULE-COMPLIANCE statement of the IF-MIB (RFC2863). | 1.3.6.1.2.1.114.2.1.1 | current |
| rohcRtpContextGroup OBJECT-GROUP A collection of objects providing information about ROHC RTP compressors and decompressors. | 1.3.6.1.2.1.114.2.2.1 | current |
| rohcRtpPacketSizesGroup OBJECT-GROUP A collection of objects providing information about allowed and used packet sizes at a ROHC RTP compressor. | 1.3.6.1.2.1.114.2.2.2 | current |
| rohcRtpStatisticsGroup OBJECT-GROUP A collection of objects providing ROHC compressor and decompressor statistics. | 1.3.6.1.2.1.114.2.2.3 | current |