PSAMP-MIB
- Registered at
- 1.3.6.1.2.1.194.1.1.21.3.6.1.2.1.194.1.1.31.3.6.1.2.1.194.1.1.41.3.6.1.2.1.194.1.1.51.3.6.1.2.1.194.1.1.61.3.6.1.2.1.194.1.1.71.3.6.1.2.1.212
- Last updated
- 2012-09-05 12:00
- Organization
- IETF IPFIX Working Group
- Revisions
- 2012-09-05 12:00
- Namespace
- standard
- Source file
PSAMP-MIB- Digest
sha256:d40a1ced7b0f946fa63d01033b4a9b003ea0b00c40ac6d60ab3536494226a162
Description
The PSAMP MIB defines managed objects for packet sampling and filtering. These objects provide information about managed nodes supporting packet sampling, including packet sampling capabilities, configuration, and statistics. The PSAMP MIB module registers additional top-level OIDs for the parameter subtrees of its Selector functions in the IPFIX-SELECTOR-MIB Function sub-registry according to the procedures defined in RFC 6615. Copyright (c) 2012 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 6727; see the RFC itself for full legal notices.
Contact
WG charter: http://datatracker.ietf.org/wg/ipfix/charter/ Mailing Lists: General Discussion: ipfix@ietf.org To Subscribe: https://www.ietf.org/mailman/listinfo/ipfix Archive: http://www.ietf.org/mail-archive/web/ipfix/current/maillist.html Thomas Dietz (editor) NEC Europe Ltd. NEC Laboratories Europe Network Research Division Kurfuersten-Anlage 36 69115 Heidelberg Germany Phone: +49 6221 4342-128 EMail: Thomas.Dietz@neclab.eu Benoit Claise Cisco Systems, Inc. De Kleetlaan 6a b1 Diegem 1831 Belgium Phone: +32 2 704 5622 EMail: bclaise@cisco.com Juergen Quittek NEC Europe Ltd. NEC Laboratories Europe Network Research Division Kurfuersten-Anlage 36 69115 Heidelberg Germany Phone: +49 6221 4342-115 EMail: quittek@neclab.eu
Imports
| From | Symbols |
|---|---|
| APPLICATION-MIB | Unsigned64TC |
| FLOAT-TC-MIB | Float64TC |
| IPFIX-SELECTOR-MIB | ipfixSelectorFunctions |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2 |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION, TruthValue |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
APPLICATION-MIB FLOAT-TC-MIB IPFIX-SELECTOR-MIB PSAMP-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-SMI SNMPv2-TC SYSAPPL-MIB
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| psampSampCountBased OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.2 | |||
| psampSampCountBasedAvail OBJECT-TYPE This object indicates the availability of systematic count-based sampling at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar. | 1.3.6.1.2.1.194.1.1.2.1 | TruthValue | read-only | current |
| psampSampCountBasedParamSetTable OBJECT-TYPE This table lists configurations of systematic count-based packet sampling. A parameter set describing a configuration contains two parameters: the sampling interval length and space. | 1.3.6.1.2.1.194.1.1.2.2 | not-accessible | current | |
| psampSampCountBasedParamSetEntry OBJECT-TYPE Defines an entry in the psampSampCountBasedParamSetTable. | 1.3.6.1.2.1.194.1.1.2.2.1 | not-accessible | current | |
| psampSampCountBasedIndex OBJECT-TYPE The index of this parameter set in the psampSampCountBasedParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set. | 1.3.6.1.2.1.194.1.1.2.2.1.1 | Integer32 (1..2147483647) | not-accessible | current |
| psampSampCountBasedInterval OBJECT-TYPE This object specifies the number of packets that are consecutively sampled. A value of 100 means that 100 consecutive packets are sampled. | 1.3.6.1.2.1.194.1.1.2.2.1.2 | Unsigned32 | read-only | current |
| psampSampCountBasedSpace OBJECT-TYPE This object specifies the number of packets between two intervals specified by the object psampSampCountBasedInterval. A value of 100 means that the next interval starts 100 packets (which are not sampled) after the current psampSampCountBasedInterval is over. | 1.3.6.1.2.1.194.1.1.2.2.1.3 | Unsigned32 | read-only | current |
| psampSampTimeBased OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.3 | |||
| psampSampTimeBasedAvail OBJECT-TYPE This object indicates the availability of systematic time-based sampling at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar. | 1.3.6.1.2.1.194.1.1.3.1 | TruthValue | read-only | current |
| psampSampTimeBasedParamSetTable OBJECT-TYPE This table lists configurations of systematic time-based packet sampling. A parameter set describing a configuration contains two parameters: the sampling interval length and the space. | 1.3.6.1.2.1.194.1.1.3.2 | not-accessible | current | |
| psampSampTimeBasedParamSetEntry OBJECT-TYPE Defines an entry in the psampSampTimeBasedParamSetTable. | 1.3.6.1.2.1.194.1.1.3.2.1 | not-accessible | current | |
| psampSampTimeBasedIndex OBJECT-TYPE The index of this parameter set in the psampSampTimeBasedParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set. | 1.3.6.1.2.1.194.1.1.3.2.1.1 | Integer32 (1..2147483647) | not-accessible | current |
| psampSampTimeBasedInterval OBJECT-TYPE This object specifies the time interval in microseconds during which all arriving packets are sampled. | 1.3.6.1.2.1.194.1.1.3.2.1.2 | Unsigned32 | read-only | current |
| psampSampTimeBasedSpace OBJECT-TYPE This object specifies the time interval in microseconds between two intervals specified by the object psampSampTimeBasedInterval. A value of 100 means that the next interval starts 100 microseconds (during which no packets are sampled) after the current psampSampTimeBasedInterval is over. | 1.3.6.1.2.1.194.1.1.3.2.1.3 | Unsigned32 | read-only | current |
| psampSampRandOutOfN OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.4 | |||
| psampSampRandOutOfNAvail OBJECT-TYPE This object indicates the availability of random n-out-of-N sampling at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar. | 1.3.6.1.2.1.194.1.1.4.1 | TruthValue | read-only | current |
| psampSampRandOutOfNParamSetTable OBJECT-TYPE This table lists configurations of random n-out-of-N sampling. A parameter set describing a configuration contains two parameters: the sampling size and the parent population. | 1.3.6.1.2.1.194.1.1.4.2 | not-accessible | current | |
| psampSampRandOutOfNParamSetEntry OBJECT-TYPE Defines an entry in the psampSampRandOutOfNParamSetTable. | 1.3.6.1.2.1.194.1.1.4.2.1 | not-accessible | current | |
| psampSampRandOutOfNIndex OBJECT-TYPE The index of this parameter set in the psampSampRandOutOfNParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set. | 1.3.6.1.2.1.194.1.1.4.2.1.1 | Integer32 (1..2147483647) | not-accessible | current |
| psampSampRandOutOfNSize OBJECT-TYPE This object specifies the number of elements taken from the parent Population specified in psampSampRandOutOfNPopulation. | 1.3.6.1.2.1.194.1.1.4.2.1.2 | Unsigned32 | read-only | current |
| psampSampRandOutOfNPopulation OBJECT-TYPE This object specifies the number of elements in the parent Population. | 1.3.6.1.2.1.194.1.1.4.2.1.3 | Unsigned32 | read-only | current |
| psampSampUniProb OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.5 | |||
| psampSampUniProbAvail OBJECT-TYPE This object indicates the availability of random uniform probabilistic sampling at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar. | 1.3.6.1.2.1.194.1.1.5.1 | TruthValue | read-only | current |
| psampSampUniProbParamSetTable OBJECT-TYPE This table lists configurations of random probabilistic sampling. A parameter set describing a configuration contains a single parameter only: the sampling probability. | 1.3.6.1.2.1.194.1.1.5.2 | not-accessible | current | |
| psampSampUniProbParamSetEntry OBJECT-TYPE Defines an entry in the psampSampUniProbParamSetTable. | 1.3.6.1.2.1.194.1.1.5.2.1 | not-accessible | current | |
| psampSampUniProbIndex OBJECT-TYPE The index of this parameter set in the psampSampUniProbParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set. | 1.3.6.1.2.1.194.1.1.5.2.1.1 | Integer32 (1..2147483647) | not-accessible | current |
| psampSampUniProbProbability OBJECT-TYPE This object specifies the probability that a packet is sampled, expressed as a value between 0 and 1. The probability is equal for every packet. A value of 0 means no packet is sampled since the probability is 0. A value of 1 means all packets are sampled since the probability is 1. NaN (not a number) and infinity MUST NOT be used. | 1.3.6.1.2.1.194.1.1.5.2.1.2 | Float64TC | read-only | current |
| psampFiltPropMatch OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.6 | |||
| psampFiltPropMatchAvail OBJECT-TYPE This object indicates the availability of property match filtering at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar. | 1.3.6.1.2.1.194.1.1.6.1 | TruthValue | read-only | current |
| psampFiltHash OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.7 | |||
| psampFiltHashAvail OBJECT-TYPE This object indicates the availability of hash filtering at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar. | 1.3.6.1.2.1.194.1.1.7.1 | TruthValue | read-only | current |
| psampFiltHashCapabilities OBJECT-IDENTITY | 1.3.6.1.2.1.194.1.1.7.2 | |||
| psampFiltHashParamSetTable OBJECT-TYPE This table lists configurations of hash filtering. A parameter set describing a configuration contains eight parameters describing the hash function. | 1.3.6.1.2.1.194.1.1.7.3 | not-accessible | current | |
| psampFiltHashParamSetEntry OBJECT-TYPE Defines an entry in the psampFiltHashParamSetTable. | 1.3.6.1.2.1.194.1.1.7.3.1 | not-accessible | current | |
| psampFiltHashIndex OBJECT-TYPE The index of this parameter set in the psampFiltHashParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set. | 1.3.6.1.2.1.194.1.1.7.3.1.1 | Integer32 (1..2147483647) | not-accessible | current |
| psampFiltHashFunction OBJECT-TYPE The hash function used by this filter. The PSAMP-MIB defines the following hash functions: crc32(1): The CRC-32 Hash Function as defined in RFC 1141. ipsx(2): The IPSX Hash Function as described in RFC 5475, Appendix A.1. bob(3): The BOB Hash Function as described in RFC 5475, Appendix A.2. | 1.3.6.1.2.1.194.1.1.7.3.1.2 | INTEGER {crc32(1), ipsx(2), bob(3)} | read-only | current |
| psampFiltHashInitializerValue OBJECT-TYPE This object specifies the initializer value to the hash function. | 1.3.6.1.2.1.194.1.1.7.3.1.3 | Unsigned64TC | read-only | current |
| psampFiltHashIpPayloadOffset OBJECT-TYPE This object specifies the IP payload offset used by a Hash-based Selection Selector. | 1.3.6.1.2.1.194.1.1.7.3.1.4 | Unsigned64TC | read-only | current |
| psampFiltHashIpPayloadSize OBJECT-TYPE This object specifies the IP payload size used by a Hash-based Selection Selector. | 1.3.6.1.2.1.194.1.1.7.3.1.5 | Unsigned64TC | read-only | current |
| psampFiltHashSelectedRangeMin OBJECT-TYPE This object specifies the value for the beginning of a hash function's selected range. | 1.3.6.1.2.1.194.1.1.7.3.1.6 | Unsigned64TC | read-only | current |
| psampFiltHashSelectedRangeMax OBJECT-TYPE This object specifies the value for the end of a hash function's selected range. | 1.3.6.1.2.1.194.1.1.7.3.1.7 | Unsigned64TC | read-only | current |
| psampFiltHashOutputRangeMin OBJECT-TYPE This object specifies the value for the beginning of a hash function's potential output range. | 1.3.6.1.2.1.194.1.1.7.3.1.8 | Unsigned64TC | read-only | current |
| psampFiltHashOutputRangeMax OBJECT-TYPE This object specifies the value for the end of a hash function's potential output range. | 1.3.6.1.2.1.194.1.1.7.3.1.9 | Unsigned64TC | read-only | current |
| psampObjects OBJECT-IDENTITY | 1.3.6.1.2.1.212.1 | |||
| psampConformance OBJECT-IDENTITY | 1.3.6.1.2.1.212.2 | |||
| psampCompliances OBJECT-IDENTITY | 1.3.6.1.2.1.212.2.1 | |||
| psampGroups OBJECT-IDENTITY | 1.3.6.1.2.1.212.2.2 |
Conformance
| Name | OID | Status |
|---|---|---|
| psampCompliance MODULE-COMPLIANCE The implementation of all objects is optional and depends on the implementation of the corresponding functionality in the equipment. | 1.3.6.1.2.1.212.2.1.1 | current |
| psampGroupSampCountBased OBJECT-GROUP These objects are needed if count based sampling is implemented. | 1.3.6.1.2.1.212.2.2.1 | current |
| psampGroupSampTimeBased OBJECT-GROUP These objects are needed if time based sampling is implemented. | 1.3.6.1.2.1.212.2.2.2 | current |
| psampGroupSampRandOutOfN OBJECT-GROUP These objects are needed if random n-out-of-N sampling is implemented. | 1.3.6.1.2.1.212.2.2.3 | current |
| psampGroupSampUniProb OBJECT-GROUP These objects are needed if uniform probabilistic sampling is implemented. | 1.3.6.1.2.1.212.2.2.4 | current |
| psampGroupFiltPropMatch OBJECT-GROUP These objects are needed if property match filtering is implemented. | 1.3.6.1.2.1.212.2.2.5 | current |
| psampGroupFiltHash OBJECT-GROUP These objects are needed if hash filtering is implemented. | 1.3.6.1.2.1.212.2.2.6 | current |