MIBs Depot

PDN-DOT1QEXT-MIB

Registered at
1.3.6.1.4.1.1795.2.24.2.39.1
Last updated
2005-07-26 00:00
Organization
Paradyne Corp MIB Working Group
Revisions
2005-07-26 00:00, 2003-11-12 00:00, 2002-11-30 00:00
Namespace
zhone
Source file
PDN-DOT1QEXT-MIB
Digest
sha256:4334c6930d9b970863103fb01e17e70af2576cdcbd131e6005b9bd25507c44de

Description

The Paradyne enterprise DOT1q extension MIB. This MIB provides additional DOT1q configuration objects not provided by rfc2674.

Contact

Paradyne Networks, Inc. 8545, 126th Ave. N., Largo, FL 33779 www.paradyne.com General Comments to: mibwg_team@paradyne.com Editors: Dragana Gough Jesus A. Pinto Dave Hammers

Imports

FromSymbols
IF-MIBifIndex
PDN-HEADER-MIBpdn-dot1q
PDN-TCTblCmd
Q-BRIDGE-MIBdot1qVlanStaticEntry
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, IpAddress, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

BRIDGE-MIB
IANAifType-MIB
IF-MIB
P-BRIDGE-MIB
PDN-DOT1QEXT-MIB
PDN-HEADER-MIB
PDN-TC
Q-BRIDGE-MIB
RFC1158-MIB
RFC1271-MIB
RMON-MIB
RMON2-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
TOKEN-RING-RMON-MIB

Objects

NameOIDSyntaxAccessStatus
pdnDot1qExtObjects
OBJECT-IDENTITY
1.3.6.1.4.1.1795.2.24.2.39.1.1
pdnDot1qVlanStaticExtTable
OBJECT-TYPE
The Paradyne dot1qVlanStatic extension table. This table is used for configuring extensions to static vlans.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1not-accessiblecurrent
pdnDot1qVlanStaticExtEntry
OBJECT-TYPE
An entry in the Paradyne dot1q extension to Static Vlan Table
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1not-accessiblecurrent
pdnDot1qVlanStaticSecureModeStatus
OBJECT-TYPE
This is objects configure secure mode status for the selected VLAN. The secure VLAN mode implies that the users on this VLAN cannot talk to users on a different VLAN. This setting also validates the configuration of the next three objects in this table. If the pdnDot1qVlanStaticSecureModeStatus is disabled non of the other three objects configurations apply.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1.1INTEGER {enable(1), disable(2)}read-writecurrent
pdnDot1qVlanStaticProxyArpStatus
OBJECT-TYPE
This objects enables/disabled proxy arp on secure VLAN. If the VLAN is secure, it can optionally have Proxy ARP enabled. This object is not valid unless pdnDot1qVlanStaticSecureModeStatus is set to ENABLED.This object will be disabled(1) by default.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1.2INTEGER {enable(1), disable(2)}read-writecurrent
pdnDot1qVlanStaticDefaultNHR
OBJECT-TYPE
This object is used to configure Default Next Hop Router Ip Address that would be used only if the Next Hop Router cannot be learned (i.e from snooping messages). This object is not valid unless pdnDot1qVlanStaticSecureModeStatus is set to ENABLED. If pdnDot1qVlanStaticSecureModeStatus is disabled this object will read 0.0.0.0 address.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1.4IpAddressread-writecurrent
pdnDot1qVlanStaticOuterTag
OBJECT-TYPE
When VLAN stacking (Q in Q) is desired, this object contains the value of the outer 802.1q VLAN outer tag. A value of zero (0) indicates that VLAN stacking is not enabled.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1.5Integer32 (0..4094)read-writecurrent
pdnDot1qVlanStaticOuterDefaultPriority
OBJECT-TYPE
When VLAN stacking (Q in Q) is desired, this object contains the default value of the priority bits in the 802.1q VLAN outer tag for unknown unicast, broadcast and multicast packets. For known unicast traffic, the inner VLAN tag priority is copied to the outer tag priority. If pdnDot1qVlanStaticOuterTag (above) is zero (0) this object is ignored.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1.6Integer32 (0..7)read-writecurrent
pdnDot1qVlanStaticOuterEthertype
OBJECT-TYPE
When VLAN stacking (Q in Q) is desired, this object contains the value of the ethertype in the 802.1q VLAN outer tag. If pdnDot1qVlanStaticOuterTag (above) is zero (0) this object is ignored.
1.3.6.1.4.1.1795.2.24.2.39.1.1.1.1.7Integer32 (0..65535)read-writecurrent
pdnDot1BasePortPIWGTable
OBJECT-TYPE
This table allows mapping of Bridge Ports and Priorities. In General, every bridge port has an associated physical port port (identified by its ifIndex). This relationship is defined in the Dot1dBasePortTable (RFC1493). In addition, each bridge port is associated with one priority (PIWG) from a range of valid priorities. This table defines this relationship. The range of priorities can vary from product to product.
1.3.6.1.4.1.1795.2.24.2.39.1.1.2not-accessiblecurrent
pdnDot1BasePortPIWGEntry
OBJECT-TYPE
The priority (PIWG) defined on a Bridge port.
1.3.6.1.4.1.1795.2.24.2.39.1.1.2.1not-accessiblecurrent
pdnDot1BasePort
OBJECT-TYPE
This object specifies the bridge port associated with this PIWG
1.3.6.1.4.1.1795.2.24.2.39.1.1.2.1.1Unsigned32 (1..65535)not-accessiblecurrent
pdnDot1BasePortPIWGId
OBJECT-TYPE
This is the integer identifier of the priority (PIWG)
1.3.6.1.4.1.1795.2.24.2.39.1.1.2.1.2Unsigned32 (1..8)read-onlycurrent
pdnDot1BasePortPIWGCircuit
OBJECT-TYPE
This is the object identifier of the priority (PIWG), The value of this object must be a valid identifier defined under the Paradyne Enterprise Definitions (pdn_Header.mib).
1.3.6.1.4.1.1795.2.24.2.39.1.1.2.1.3OBJECT IDENTIFIERread-onlycurrent
pdnDot1TpFdbClear
OBJECT-TYPE
This object is used to perform a clear on the Bridge Forwarding Table (dot1dTpFdbTable). A set operation to this object with the value of 'clear (2)' will clear the entire Bridge Forwarding Table. A get operation will always return the value of 'noCmd (1)'.
1.3.6.1.4.1.1795.2.24.2.39.1.1.3TblCmdread-writecurrent
pdnDot1qExtConformance
OBJECT-IDENTITY
1.3.6.1.4.1.1795.2.24.2.39.1.2
pdnDot1qExtGroups
OBJECT-IDENTITY
1.3.6.1.4.1.1795.2.24.2.39.1.2.1
pdnDot1qExtCompliances
OBJECT-IDENTITY
1.3.6.1.4.1.1795.2.24.2.39.1.2.2

Conformance

NameOIDStatus
pdnDot1qVlanExtGroup
OBJECT-GROUP
A collection of configuration objects required for configuring Static Vlan Table.
1.3.6.1.4.1.1795.2.24.2.39.1.2.1.1current
pdnDot1BasePortPIWGGroup
OBJECT-GROUP
A collection of read-only objects to provide associations between bridge ports and priorities.
1.3.6.1.4.1.1795.2.24.2.39.1.2.1.2current
pdnDot1GeneralGroup
OBJECT-GROUP
This group is optional, but if suppported it should be read-writtable.
1.3.6.1.4.1.1795.2.24.2.39.1.2.1.3current
pdnDot1dVlanStackingGroup
OBJECT-GROUP
Provides the ability to configure VLAN Stacking (Q in Q) parameters.
1.3.6.1.4.1.1795.2.24.2.39.1.2.1.4current
pdnDot1qExtCompliance
MODULE-COMPLIANCE
Compliance statement for using this MIB for configuring Dot1q Static Vlan table.
1.3.6.1.4.1.1795.2.24.2.39.1.2.2.1current