MIBs Depot

MTA-MIB

Registered at
1.3.6.1.2.1.28
Last updated
2000-03-03 00:00
Organization
IETF Mail and Directory Management Working Group
Revisions
2000-03-03 00:00, 1999-05-12 00:00, 1997-08-17 00:00, 1993-11-28 00:00
Namespace
standard
Source file
MTA-MIB
Digest
sha256:aedf8e3b47479cfc580cc6a580e8ef746aa64ae1fe24cff8ccb82a4e6297d461

Description

The MIB module describing Message Transfer Agents (MTAs)

Contact

Ned Freed Postal: Innosoft International, Inc. 1050 Lakes Drive West Covina, CA 91790 US Tel: +1 626 919 3600 Fax: +1 626 919 3614 E-Mail: ned.freed@innosoft.com

Imports

FromSymbols
NETWORK-SERVICES-MIBURLString, applIndex
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, Gauge32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION, TimeInterval

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

MTA-MIB
NETWORK-SERVICES-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Objects

NameOIDSyntaxAccessStatus
mtaTable
OBJECT-TYPE
The table holding information specific to an MTA.
1.3.6.1.2.1.28.1not-accessiblecurrent
mtaEntry
OBJECT-TYPE
The entry associated with each MTA.
1.3.6.1.2.1.28.1.1not-accessiblecurrent
mtaReceivedMessages
OBJECT-TYPE
The number of messages received since MTA initialization. This includes messages transmitted to this MTA from other MTAs as well as messages that have been submitted to the MTA directly by end-users or applications.
1.3.6.1.2.1.28.1.1.1Counter32read-onlycurrent
mtaStoredMessages
OBJECT-TYPE
The total number of messages currently stored in the MTA. This includes messages that are awaiting transmission to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.2Gauge32read-onlycurrent
mtaTransmittedMessages
OBJECT-TYPE
The number of messages transmitted since MTA initialization. This includes messages that were transmitted to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.3Counter32read-onlycurrent
mtaReceivedVolume
OBJECT-TYPE
The total volume of messages received since MTA initialization, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data. This includes messages transmitted to this MTA from other MTAs as well as messages that have been submitted to the MTA directly by end-users or applications.
1.3.6.1.2.1.28.1.1.4Counter32read-onlycurrent
mtaStoredVolume
OBJECT-TYPE
The total volume of messages currently stored in the MTA, measured in kilo-octets. This volume should include all stored data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA would use the number of kilo-octets of P2 data. This includes messages that are awaiting transmission to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.5Gauge32read-onlycurrent
mtaTransmittedVolume
OBJECT-TYPE
The total volume of messages transmitted since MTA initialization, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data. This includes messages that were transmitted to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.6Counter32read-onlycurrent
mtaReceivedRecipients
OBJECT-TYPE
The total number of recipients specified in all messages received since MTA initialization. Recipients this MTA has no responsibility for, i.e. inactive envelope recipients or ones referred to in message headers, should not be counted even if information about such recipients is available. This includes messages transmitted to this MTA from other MTAs as well as messages that have been submitted to the MTA directly by end-users or applications.
1.3.6.1.2.1.28.1.1.7Counter32read-onlycurrent
mtaStoredRecipients
OBJECT-TYPE
The total number of recipients specified in all messages currently stored in the MTA. Recipients this MTA has no responsibility for, i.e. inactive envelope recipients or ones referred to in message headers, should not be counted. This includes messages that are awaiting transmission to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.8Gauge32read-onlycurrent
mtaTransmittedRecipients
OBJECT-TYPE
The total number of recipients specified in all messages transmitted since MTA initialization. Recipients this MTA had no responsibility for, i.e. inactive envelope recipients or ones referred to in message headers, should not be counted. This includes messages that were transmitted to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.9Counter32read-onlycurrent
mtaSuccessfulConvertedMessages
OBJECT-TYPE
The number of messages that have been successfully converted from one form to another since MTA initialization.
1.3.6.1.2.1.28.1.1.10Counter32read-onlycurrent
mtaFailedConvertedMessages
OBJECT-TYPE
The number of messages for which an unsuccessful attempt was made to convert them from one form to another since MTA initialization.
1.3.6.1.2.1.28.1.1.11Counter32read-onlycurrent
mtaLoopsDetected
OBJECT-TYPE
A message loop is defined as a situation where the MTA decides that a given message will never be delivered to one or more recipients and instead will continue to loop endlessly through one or more MTAs. This variable counts the number of times the MTA has detected such a situation since MTA initialization. Note that the mechanism MTAs use to detect loops (e.g., trace field counting, count of references to this MTA in a trace field, examination of DNS or other directory information, etc.), the level at which loops are detected (e.g., per message, per recipient, per directory entry, etc.), and the handling of a loop once it is detected (e.g., looping messages are held, looping messages are bounced or sent to the postmaster, messages that the MTA knows will loop won't be accepted, etc.) vary widely from one MTA to the next and cannot be inferred from this variable.
1.3.6.1.2.1.28.1.1.12Counter32read-onlycurrent
mtaGroupTable
OBJECT-TYPE
The table holding information specific to each MTA group.
1.3.6.1.2.1.28.2not-accessiblecurrent
mtaGroupEntry
OBJECT-TYPE
The entry associated with each MTA group.
1.3.6.1.2.1.28.2.1not-accessiblecurrent
mtaGroupIndex
OBJECT-TYPE
The index associated with a group for a given MTA.
1.3.6.1.2.1.28.2.1.1INTEGER (1..2147483647)not-accessiblecurrent
mtaGroupReceivedMessages
OBJECT-TYPE
The number of messages received to this group since group creation.
1.3.6.1.2.1.28.2.1.2Counter32read-onlycurrent
mtaGroupRejectedMessages
OBJECT-TYPE
The number of messages rejected by this group since group creation.
1.3.6.1.2.1.28.2.1.3Counter32read-onlycurrent
mtaGroupStoredMessages
OBJECT-TYPE
The total number of messages currently stored in this group's queue.
1.3.6.1.2.1.28.2.1.4Gauge32read-onlycurrent
mtaGroupTransmittedMessages
OBJECT-TYPE
The number of messages transmitted by this group since group creation.
1.3.6.1.2.1.28.2.1.5Counter32read-onlycurrent
mtaGroupReceivedVolume
OBJECT-TYPE
The total volume of messages received to this group since group creation, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data.
1.3.6.1.2.1.28.2.1.6Counter32read-onlycurrent
mtaGroupStoredVolume
OBJECT-TYPE
The total volume of messages currently stored in this group's queue, measured in kilo-octets. This volume should include all stored data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA would use the number of kilo-octets of P2 data.
1.3.6.1.2.1.28.2.1.7Gauge32read-onlycurrent
mtaGroupTransmittedVolume
OBJECT-TYPE
The total volume of messages transmitted by this group since group creation, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data.
1.3.6.1.2.1.28.2.1.8Counter32read-onlycurrent
mtaGroupReceivedRecipients
OBJECT-TYPE
The total number of recipients specified in all messages received to this group since group creation. Recipients this MTA has no responsibility for should not be counted.
1.3.6.1.2.1.28.2.1.9Counter32read-onlycurrent
mtaGroupStoredRecipients
OBJECT-TYPE
The total number of recipients specified in all messages currently stored in this group's queue. Recipients this MTA has no responsibility for should not be counted.
1.3.6.1.2.1.28.2.1.10Gauge32read-onlycurrent
mtaGroupTransmittedRecipients
OBJECT-TYPE
The total number of recipients specified in all messages transmitted by this group since group creation. Recipients this MTA had no responsibility for should not be counted.
1.3.6.1.2.1.28.2.1.11Counter32read-onlycurrent
mtaGroupOldestMessageStored
OBJECT-TYPE
Time since the oldest message in this group's queue was placed in the queue.
1.3.6.1.2.1.28.2.1.12TimeIntervalread-onlycurrent
mtaGroupInboundAssociations
OBJECT-TYPE
The number of current associations to the group, where the group is the responder.
1.3.6.1.2.1.28.2.1.13Gauge32read-onlycurrent
mtaGroupOutboundAssociations
OBJECT-TYPE
The number of current associations to the group, where the group is the initiator.
1.3.6.1.2.1.28.2.1.14Gauge32read-onlycurrent
mtaGroupAccumulatedInboundAssociations
OBJECT-TYPE
The total number of associations to the group since group creation, where the MTA was the responder.
1.3.6.1.2.1.28.2.1.15Counter32read-onlycurrent
mtaGroupAccumulatedOutboundAssociations
OBJECT-TYPE
The total number of associations from the group since group creation, where the MTA was the initiator.
1.3.6.1.2.1.28.2.1.16Counter32read-onlycurrent
mtaGroupLastInboundActivity
OBJECT-TYPE
Time since the last time that this group had an active inbound association for purposes of message reception.
1.3.6.1.2.1.28.2.1.17TimeIntervalread-onlycurrent
mtaGroupLastOutboundActivity
OBJECT-TYPE
Time since the last time that this group had a successful outbound association for purposes of message delivery.
1.3.6.1.2.1.28.2.1.18TimeIntervalread-onlycurrent
mtaGroupRejectedInboundAssociations
OBJECT-TYPE
The total number of inbound associations the group has rejected, since group creation. Rejected associations are not counted in the accumulated association totals.
1.3.6.1.2.1.28.2.1.19Counter32read-onlycurrent
mtaGroupFailedOutboundAssociations
OBJECT-TYPE
The total number associations where the group was the initiator and association establishment has failed, since group creation. Failed associations are not counted in the accumulated association totals.
1.3.6.1.2.1.28.2.1.20Counter32read-onlycurrent
mtaGroupInboundRejectionReason
OBJECT-TYPE
The failure reason, if any, for the last association this group refused to respond to. If no association attempt has been made since the MTA was initialized the value should be 'never'.
1.3.6.1.2.1.28.2.1.21SnmpAdminStringread-onlycurrent
mtaGroupOutboundConnectFailureReason
OBJECT-TYPE
The failure reason, if any, for the last association attempt this group initiated. If no association attempt has been made since the MTA was initialized the value should be 'never'.
1.3.6.1.2.1.28.2.1.22SnmpAdminStringread-onlycurrent
mtaGroupScheduledRetry
OBJECT-TYPE
The amount of time until this group is next scheduled to attempt to make an association.
1.3.6.1.2.1.28.2.1.23TimeIntervalread-onlycurrent
mtaGroupMailProtocol
OBJECT-TYPE
An identification of the protocol being used by this group. For an group employing OSI protocols, this will be the Application Context. For Internet applications, OID values of the form {applTCPProtoID port} or {applUDPProtoID port} are used for TCP-based and UDP-based protocols, respectively. In either case 'port' corresponds to the primary port number being used by the protocol. The usual IANA procedures may be used to register ports for new protocols. applTCPProtoID and applUDPProtoID are defined in the NETWORK-SERVICES-MIB, RFC 2788.
1.3.6.1.2.1.28.2.1.24OBJECT IDENTIFIERread-onlycurrent
mtaGroupName
OBJECT-TYPE
A descriptive name for the group. If this group connects to a single remote MTA this should be the name of that MTA. If this in turn is an Internet MTA this should be the domain name. For an OSI MTA it should be the string encoded distinguished name of the managed object using the format defined in RFC 2253. For X.400(1984) MTAs which do not have a Distinguished Name, the RFC 2156 syntax 'mta in globalid' used in X400-Received: fields can be used.
1.3.6.1.2.1.28.2.1.25SnmpAdminStringread-onlycurrent
mtaGroupSuccessfulConvertedMessages
OBJECT-TYPE
The number of messages that have been successfully converted from one form to another in this group since group creation.
1.3.6.1.2.1.28.2.1.26Counter32read-onlycurrent
mtaGroupFailedConvertedMessages
OBJECT-TYPE
The number of messages for which an unsuccessful attempt was made to convert them from one form to another in this group since group creation.
1.3.6.1.2.1.28.2.1.27Counter32read-onlycurrent
mtaGroupDescription
OBJECT-TYPE
A description of the group's purpose. This information is intended to identify the group in a status display.
1.3.6.1.2.1.28.2.1.28SnmpAdminStringread-onlycurrent
mtaGroupURL
OBJECT-TYPE
A URL pointing to a description of the group. This information is intended to identify and briefly describe the group in a status display.
1.3.6.1.2.1.28.2.1.29URLStringread-onlycurrent
mtaGroupCreationTime
OBJECT-TYPE
Time since this group was first created.
1.3.6.1.2.1.28.2.1.30TimeIntervalread-onlycurrent
mtaGroupHierarchy
OBJECT-TYPE
Describes how this group fits into the hierarchy. A positive value is interpreted as an mtaGroupIndex value for some other group whose variables include those of this group (and usually others). A negative value is interpreted as a group collection code: Groups with common negative hierarchy values comprise one particular breakdown of MTA activity as a whole. A zero value means that this MIB implementation doesn't implement hierarchy indicators and thus the overall group hierarchy cannot be determined.
1.3.6.1.2.1.28.2.1.31INTEGER (-2147483648..2147483647)read-onlycurrent
mtaGroupOldestMessageId
OBJECT-TYPE
Message ID of the oldest message in the group's queue. Whenever possible this should be in the form of an RFC 822 msg-id; X.400 may convert X.400 message identifiers to this form by following the rules laid out in RFC2156.
1.3.6.1.2.1.28.2.1.32SnmpAdminStringread-onlycurrent
mtaGroupLoopsDetected
OBJECT-TYPE
A message loop is defined as a situation where the MTA decides that a given message will never be delivered to one or more recipients and instead will continue to loop endlessly through one or more MTAs. This variable counts the number of times the MTA has detected such a situation in conjunction with something associated with this group since group creation. Note that the mechanism MTAs use to detect loops (e.g., trace field counting, count of references to this MTA in a trace field, examination of DNS or other directory information, etc.), the level at which loops are detected (e.g., per message, per recipient, per directory entry, etc.), and the handling of a loop once it is detected (e.g., looping messages are held, looping messages are bounced or sent to the postmaster, messages that the MTA knows will loop won't be accepted, etc.) vary widely from one MTA to the next and cannot be inferred from this variable.
1.3.6.1.2.1.28.2.1.33Counter32read-onlycurrent
mtaGroupLastOutboundAssociationAttempt
OBJECT-TYPE
Time since the last time that this group attempted to make an outbound association for purposes of message delivery.
1.3.6.1.2.1.28.2.1.34TimeIntervalread-onlycurrent
mtaGroupAssociationTable
OBJECT-TYPE
The table holding information regarding the associations for each MTA group.
1.3.6.1.2.1.28.3not-accessiblecurrent
mtaGroupAssociationEntry
OBJECT-TYPE
The entry holding information regarding the associations for each MTA group.
1.3.6.1.2.1.28.3.1not-accessiblecurrent
mtaGroupAssociationIndex
OBJECT-TYPE
Reference into association table to allow correlation of this group's active associations with the association table.
1.3.6.1.2.1.28.3.1.1INTEGER (1..2147483647)read-onlycurrent
mtaConformance
OBJECT-IDENTITY
1.3.6.1.2.1.28.4
mtaGroups
OBJECT-IDENTITY
1.3.6.1.2.1.28.4.1
mtaCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.28.4.2
mtaGroupErrorTable
OBJECT-TYPE
The table holding information regarding accumulated errors for each MTA group.
1.3.6.1.2.1.28.5not-accessiblecurrent
mtaGroupErrorEntry
OBJECT-TYPE
The entry holding information regarding accumulated errors for each MTA group.
1.3.6.1.2.1.28.5.1not-accessiblecurrent
mtaGroupInboundErrorCount
OBJECT-TYPE
Count of the number of errors of a given type that have been accumulated in association with a particular group while processing incoming messages. In the case of SMTP these will typically be errors reporting by an SMTP server to the remote client; in the case of X.400 these will typically be errors encountered while processing an incoming message.
1.3.6.1.2.1.28.5.1.1Counter32read-onlycurrent
mtaGroupInternalErrorCount
OBJECT-TYPE
Count of the number of errors of a given type that have been accumulated in association with a particular group during internal MTA processing.
1.3.6.1.2.1.28.5.1.2Counter32read-onlycurrent
mtaGroupOutboundErrorCount
OBJECT-TYPE
Count of the number of errors of a given type that have been accumulated in association with a particular group's outbound connection activities. In the case of an SMTP client these will typically be errors reported while attempting to contact or while communicating with the remote SMTP server. In the case of X.400 these will typically be errors encountered while constructing or attempting to deliver an outgoing message.
1.3.6.1.2.1.28.5.1.3Counter32read-onlycurrent
mtaStatusCode
OBJECT-TYPE
An index capable of representing an Enhanced Mail System Status Code. Enhanced Mail System Status Codes are defined in RFC 1893. These codes have the form class.subject.detail Here 'class' is either 2, 4, or 5 and both 'subject' and 'detail' are integers in the range 0..999. Given a status code the corresponding index value is defined to be ((class * 1000) + subject) * 1000 + detail. Both SMTP error response codes and X.400 reason and diagnostic codes can be mapped into these codes, resulting in a namespace capable of describing most error conditions a mail system encounters in a generic yet detailed way.
1.3.6.1.2.1.28.5.1.4INTEGER (4000000..5999999)not-accessiblecurrent

Conformance

NameOIDStatus
mtaRFC2249Group
OBJECT-GROUP
A collection of objects providing basic monitoring of MTAs. This group was originally defined in RFC 2249.
1.3.6.1.2.1.28.4.1.4current
mtaRFC2249AssocGroup
OBJECT-GROUP
A collection of objects providing monitoring of MTA associations. This group was originally defined in RFC 2249.
1.3.6.1.2.1.28.4.1.5current
mtaRFC2249ErrorGroup
OBJECT-GROUP
A collection of objects providing monitoring of detailed MTA errors. This group was originally defined in RFC 2249.
1.3.6.1.2.1.28.4.1.6current
mtaRFC2789Group
OBJECT-GROUP
A collection of objects providing basic monitoring of MTAs. This is the appropriate group for RFC 2789.
1.3.6.1.2.1.28.4.1.7current
mtaRFC2789AssocGroup
OBJECT-GROUP
A collection of objects providing monitoring of MTA associations. This is the appropriate group for RFC 2789 association monitoring.
1.3.6.1.2.1.28.4.1.8current
mtaRFC2789ErrorGroup
OBJECT-GROUP
A collection of objects providing monitoring of detailed MTA errors. This is the appropriate group for RFC 2789 error monitoring.
1.3.6.1.2.1.28.4.1.9current
mtaRFC1566Group
OBJECT-GROUP
A collection of objects providing basic monitoring of MTAs. This is the original set of such objects defined in RFC 1566.
1.3.6.1.2.1.28.4.1.10current
mtaRFC1566AssocGroup
OBJECT-GROUP
A collection of objects providing monitoring of MTA associations. This is the original set of such objects defined in RFC 1566.
1.3.6.1.2.1.28.4.1.11current
mtaCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 1566 implementations which support the Mail Monitoring MIB for basic monitoring of MTAs.
1.3.6.1.2.1.28.4.2.1current
mtaAssocCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 1566 implementations which support the Mail Monitoring MIB for monitoring of MTAs and their associations.
1.3.6.1.2.1.28.4.2.2current
mtaRFC2249Compliance
MODULE-COMPLIANCE
The compliance statement for RFC 2249 implementations which support the Mail Monitoring MIB for basic monitoring of MTAs.
1.3.6.1.2.1.28.4.2.5current
mtaRFC2249AssocCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 2249 implementations which support the Mail Monitoring MIB for monitoring of MTAs and their associations.
1.3.6.1.2.1.28.4.2.6current
mtaRFC2249ErrorCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 2249 implementations which support the Mail Monitoring MIB for monitoring of MTAs and detailed errors.
1.3.6.1.2.1.28.4.2.7current
mtaRFC2249FullCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 2249 implementations which support the full Mail Monitoring MIB for monitoring of MTAs, associations, and detailed errors.
1.3.6.1.2.1.28.4.2.8current
mtaRFC2789Compliance
MODULE-COMPLIANCE
The compliance statement for RFC 2789 implementations which support the Mail Monitoring MIB for basic monitoring of MTAs.
1.3.6.1.2.1.28.4.2.9current
mtaRFC2789AssocCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 2789 implementations which support the Mail Monitoring MIB for monitoring of MTAs and their associations.
1.3.6.1.2.1.28.4.2.10current
mtaRFC2789ErrorCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 2789 implementations which support the Mail Monitoring MIB for monitoring of MTAs and detailed errors.
1.3.6.1.2.1.28.4.2.11current
mtaRFC2789FullCompliance
MODULE-COMPLIANCE
The compliance statement for RFC 2789 implementations which support the full Mail Monitoring MIB for monitoring of MTAs, associations, and detailed errors.
1.3.6.1.2.1.28.4.2.12current