MIBs Depot

MPLS-LC-ATM-STD-MIB

Registered at
1.3.6.1.2.1.10.166.9
Last updated
2006-01-12 00:00
Organization
Multiprotocol Label Switching (MPLS) Working Group
Revisions
2006-01-12 00:00
Namespace
standard
Source file
MPLS-LC-ATM-STD-MIB
Digest
sha256:b5d11d89c5edd02bf93fb285e4df59826fdf0b5770498dbbb1a855fc3b3b69e0

Description

This MIB module contains managed object definitions for MPLS Label-Controlled ATM interfaces as defined in [RFC3035]. Copyright (C) The Internet Society (2006). This version of this MIB module is part of RFC 4368; see the RFC itself for full legal notices.

Contact

Thomas D. Nadeau Postal: Cisco Systems, Inc. 250 Apollo Drive Chelmsford, MA 01824 Tel: +1-978-244-3051 Email: tnadeau@cisco.com Subrahmanya Hegde Postal: Cisco Systems, Inc. 225 East Tazman Drive Tel: +1-408-525-6562 Email: subrah@cisco.com General comments should be sent to mpls@uu.net

Imports

FromSymbols
ATM-TC-MIBAtmVpIdentifier
MPLS-LSR-STD-MIBmplsInterfaceIndex
MPLS-TC-STD-MIBMplsAtmVcIdentifier, mplsStdMIB
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIMODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, RowStatus, StorageType, TEXTUAL-CONVENTION, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

ATM-TC-MIB
IANA-ADDRESS-FAMILY-NUMBERS-MIB
IANAifType-MIB
IF-MIB
INET-ADDRESS-MIB
MPLS-LC-ATM-STD-MIB
MPLS-LSR-STD-MIB
MPLS-TC-STD-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC

Objects

NameOIDSyntaxAccessStatus
mplsLcAtmStdNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.10.166.9.0
mplsLcAtmStdObjects
OBJECT-IDENTITY
1.3.6.1.2.1.10.166.9.1
mplsLcAtmStdInterfaceConfTable
OBJECT-TYPE
This table specifies per-interface MPLS LC-ATM capability and associated information. In particular, this table sparsely extends the MPLS-LSR-STD-MIB's mplsInterfaceConfTable.
1.3.6.1.2.1.10.166.9.1.1not-accessiblecurrent
mplsLcAtmStdInterfaceConfEntry
OBJECT-TYPE
An entry in this table is created by an LSR for every interface capable of supporting MPLS LC-ATM. Each entry in this table will exist only if a corresponding entry in ifTable and mplsInterfaceConfTable exists. If the associated entries in ifTable and mplsInterfaceConfTable are deleted, the corresponding entry in this table must also be deleted shortly thereafter.
1.3.6.1.2.1.10.166.9.1.1.1not-accessiblecurrent
mplsLcAtmStdCtrlVpi
OBJECT-TYPE
This is the VPI value over which this LSR is willing to accept control traffic on this interface.
1.3.6.1.2.1.10.166.9.1.1.1.1AtmVpIdentifierread-createcurrent
mplsLcAtmStdCtrlVci
OBJECT-TYPE
This is the VCI value over which this LSR is willing to accept control traffic on this interface.
1.3.6.1.2.1.10.166.9.1.1.1.2MplsAtmVcIdentifierread-createcurrent
mplsLcAtmStdUnlabTrafVpi
OBJECT-TYPE
This is the VPI value over which this LSR is willing to accept unlabeled traffic on this interface.
1.3.6.1.2.1.10.166.9.1.1.1.3AtmVpIdentifierread-createcurrent
mplsLcAtmStdUnlabTrafVci
OBJECT-TYPE
This is the VCI value over which this LSR is willing to accept unlabeled traffic on this interface.
1.3.6.1.2.1.10.166.9.1.1.1.4MplsAtmVcIdentifierread-createcurrent
mplsLcAtmStdVcMerge
OBJECT-TYPE
If set to true(1), indicates that this interface is capable of ATM VC merge; otherwise, it MUST be set to false(2).
1.3.6.1.2.1.10.166.9.1.1.1.5TruthValueread-createcurrent
mplsLcAtmVcDirectlyConnected
OBJECT-TYPE
This value indicates whether an LC-ATM is directly or indirectly (by means of a VP) connected. If set to true(1), indicates that this interface is directly connected LC-ATM; otherwise, it MUST be set to false(2). Note that although it can be intimated from RFC 3057 that multiple VPs may be used, in practice only a single one is used, and therefore the authors of this MIB module have chosen to model it as such.
1.3.6.1.2.1.10.166.9.1.1.1.6TruthValueread-createcurrent
mplsLcAtmLcAtmVPI
OBJECT-TYPE
This is the VPI value used for indirectly connected LC-ATM interfaces. For these interfaces, the VPI field is not available to MPLS, and the label MUST be encoded entirely within the VCI field (see [RFC3035]). If the interface is directly connected, this value MUST be set to zero.
1.3.6.1.2.1.10.166.9.1.1.1.7AtmVpIdentifierread-createcurrent
mplsLcAtmStdIfConfRowStatus
OBJECT-TYPE
This object is used to create and delete entries in this table. When configuring entries in this table, the corresponding ifEntry and mplsInterfaceConfEntry MUST exist beforehand. If a manager attempts to create an entry for a corresponding mplsInterfaceConfEntry that does not support LC-ATM, the agent MUST return an inconsistentValue error. If this table is implemented read-only, then the agent must set this object to active(1) when this row is made active. If this table is implemented writable, then an agent MUST not allow modification to its objects once this value is set to active(1), except to mplsLcAtmStdIfConfRowStatus and mplsLcAtmStdIfConfStorageType.
1.3.6.1.2.1.10.166.9.1.1.1.8RowStatusread-createcurrent
mplsLcAtmStdIfConfStorageType
OBJECT-TYPE
The storage type for this conceptual row. Conceptual rows having the value 'permanent(4)' need not allow write-access to any columnar objects in the row.
1.3.6.1.2.1.10.166.9.1.1.1.9StorageTyperead-createcurrent
mplsLcAtmStdConformance
OBJECT-IDENTITY
1.3.6.1.2.1.10.166.9.2
mplsLcAtmStdCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.10.166.9.2.1
mplsLcAtmStdGroups
OBJECT-IDENTITY
1.3.6.1.2.1.10.166.9.2.2

Conformance

NameOIDStatus
mplsLcAtmStdModuleFullCompliance
MODULE-COMPLIANCE
Compliance statement for agents that provide full support for MPLS-LC-ATM-STD-MIB. Such devices can be monitored and also be configured using this MIB module.
1.3.6.1.2.1.10.166.9.2.1.1current
mplsLcAtmStdModuleReadOnlyCompliance
MODULE-COMPLIANCE
Compliance requirement for implementations that only provide read-only support for MPLS-LC-ATM-STD-MIB. Such devices can be monitored but cannot be configured using this MIB module.
1.3.6.1.2.1.10.166.9.2.1.2current
mplsLcAtmStdIfGroup
OBJECT-GROUP
Collection of objects needed for MPLS LC-ATM interface configuration.
1.3.6.1.2.1.10.166.9.2.2.1current