LLDP-EXT-DOT3-V2-MIB
- Registered at
- 1.3.111.2.802.1.1.13.1.5.4623
- Last updated
- 2009-06-08 00:00
- Organization
- IEEE 802.1 Working Group
- Revisions
- 2009-06-08 00:00
- Namespace
- standard
- Source file
LLDP-EXT-DOT3-V2-MIB- Digest
sha256:ddce8ad37ede6740351b4a192aab937f5ea58385634575740652f08eb4e72560
Description
The LLDP Management Information Base extension module for IEEE 802.3 organizationally defined discovery information. In order to assure the uniqueness of the LLDP-MIB, lldpV2Xdot3MIB is branched from lldpV2Extensions using OUI value as the node. An OUI/'company_id' is a 24 bit globally unique assigned number referenced by various standards. Unless otherwise indicated, the references in this MIB module are to IEEE 802.1AB-2009. Copyright (C) IEEE (2009). This version of this MIB module is published as Annex F.6.5 of IEEE Std 802.1AB-2009; see the standard itself for full legal notices.
Contact
WG-URL: http://grouper.ieee.org/groups/802/1/index.html WG-EMail: STDS-802-1-L@LISTSERV.IEEE.ORG Contact: Tony Jeffree Postal: 11a Poplar Grove Sale Cheshire M33 3AX UK Tel: +44-161-973-4278 E-mail: tony@jeffree.co.uk
Imports
| From | Symbols |
|---|---|
| IF-MIB | ifGeneralInformationGroup |
| LLDP-V2-MIB | lldpV2Extensions, lldpV2LocPortIfIndex, lldpV2PortConfigEntry, lldpV2RemIndex, lldpV2RemLocalDestMACAddress, lldpV2RemLocalIfIndex, lldpV2RemTimeMark |
| LLDP-V2-TC-MIB | LldpV2PowerPortClass |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso |
| SNMPv2-TC | DisplayString, TEXTUAL-CONVENTION, TruthValue |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
IANA-ADDRESS-FAMILY-NUMBERS-MIB IANAifType-MIB IF-MIB LLDP-EXT-DOT3-V2-MIB LLDP-V2-MIB LLDP-V2-TC-MIB RFC1158-MIB RFC1271-MIB RMON-MIB RMON2-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC TOKEN-RING-RMON-MIB
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| lldpV2Xdot3Objects OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.1 | |||
| lldpV2Xdot3Config OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.1.1 | |||
| lldpV2Xdot3PortConfigTable OBJECT-TYPE A table that controls selection of LLDP TLVs to be transmitted on individual ports. | 1.3.111.2.802.1.1.13.1.5.4623.1.1.1 | not-accessible | current | |
| lldpV2Xdot3PortConfigEntry OBJECT-TYPE LLDP configuration information that controls the transmission of IEEE 802.3 organizationally defined TLVs on LLDP transmission capable ports. This configuration object augments the lldpV2PortConfigEntry of the LLDP-MIB, therefore it is only present along with the port configuration defined by the associated lldpV2PortConfigEntry entry. Each active lldpV2Xdot3PortConfigEntry is restored from non-volatile storage (along with the corresponding lldpV2PortConfigEntry) after a re-initialization of the management system. | 1.3.111.2.802.1.1.13.1.5.4623.1.1.1.1 | not-accessible | current | |
| lldpV2Xdot3PortConfigTLVsTxEnable OBJECT-TYPE The lldpV2Xdot3PortConfigTLVsTxEnable, defined as a bitmap, includes the IEEE 802.3 organizationally defined set of LLDP TLVs whose transmission is allowed on the local LLDP agent by the network management. Each bit in the bitmap corresponds to an IEEE 802.3 subtype associated with a specific IEEE 802.3 optional TLV. The bit 0 is not used since there is no corresponding subtype. The bit 'macPhyConfigStatus(0)' indicates that LLDP agent should transmit 'MAC/PHY configuration/status TLV'. The bit 'powerViaMDI(1)' indicates that LLDP agent should transmit 'Power via MDI TLV'. The bit 'unused(2)' is no longer used; this was used for the 'Link Aggregation TLV' in the previous version. The bit 'maxFrameSize(3)' indicates that LLDP agent should transmit 'Maximum-frame-size TLV'. The default value for lldpV2Xdot3PortConfigTLVsTxEnable object is an empty set, which means no enumerated values are set. The value of this object is restored from non-volatile storage after a re-initialization of the management system. | 1.3.111.2.802.1.1.13.1.5.4623.1.1.1.1.1 | Bits {macPhyConfigStatus(0), powerViaMDI(1), unused(2), maxFrameSize(3)} | read-write | current |
| lldpV2Xdot3LocalData OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.1.2 | |||
| lldpV2Xdot3LocPortTable OBJECT-TYPE This table contains one row per port of Ethernet port information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.1 | not-accessible | current | |
| lldpV2Xdot3LocPortEntry OBJECT-TYPE Information about a particular port component. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1 | not-accessible | current | |
| lldpV2Xdot3LocPortAutoNegSupported OBJECT-TYPE The truth value used to indicate whether the given port (associated with the local system) supports Auto-negotiation. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.1 | TruthValue | read-only | current |
| lldpV2Xdot3LocPortAutoNegEnabled OBJECT-TYPE The truth value used to indicate whether port Auto-negotiation is enabled on the given port associated with the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.2 | TruthValue | read-only | current |
| lldpV2Xdot3LocPortAutoNegAdvertisedCap OBJECT-TYPE This object contains the value (bitmap) of the ifMauAutoNegCapAdvertisedBits object (defined in IETF RFC 3636) which is associated with the given port on the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.3 | OCTET STRING (SIZE(2)) | read-only | current |
| lldpV2Xdot3LocPortOperMauType OBJECT-TYPE An integer value that indicates the operational MAU type of the given port on the local system. This object contains the integer value derived from the list position of the corresponding dot3MauType as listed in IETF RFC 4836 (or subsequent revisions) and is equal to the last number in the respective dot3MauType OID. For example, if the ifMauType object is dot3MauType1000BaseTHD which corresponds to {dot3MauType 29}, the numerical value of this field is 29. For MAU types not listed in RFC 4836 (or subsequent revisions), the value of this field shall be set to zero. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.4 | Unsigned32 (0..2147483647) | read-only | current |
| lldpV2Xdot3LocPowerTable OBJECT-TYPE This table contains one row per port of power ethernet information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2 | not-accessible | current | |
| lldpV2Xdot3LocPowerEntry OBJECT-TYPE Information about a particular port component. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1 | not-accessible | current | |
| lldpV2Xdot3LocPowerPortClass OBJECT-TYPE The value that identifies the port Class of the given port associated with the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.1 | LldpV2PowerPortClass | read-only | current |
| lldpV2Xdot3LocPowerMDISupported OBJECT-TYPE The truth value used to indicate whether the MDI power is supported on the given port associated with the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.2 | TruthValue | read-only | current |
| lldpV2Xdot3LocPowerMDIEnabled OBJECT-TYPE The truth value used to identify whether MDI power is enabled on the given port associated with the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.3 | TruthValue | read-only | current |
| lldpV2Xdot3LocPowerPairControlable OBJECT-TYPE The truth value is derived from the value of pethPsePortPowerPairsControlAbility object (defined in IETF RFC 3621) and is used to indicate whether the pair selection can be controlled on the given port associated with the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.4 | TruthValue | read-only | current |
| lldpV2Xdot3LocPowerPairs OBJECT-TYPE This object contains the value of the pethPsePortPowerPairs object (defined in IETF RFC 3621) which is associated with the given port on the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.5 | Unsigned32 (1 | 2) | read-only | current |
| lldpV2Xdot3LocPowerClass OBJECT-TYPE This object contains the value of the pethPsePortPowerClassifications object (defined in IETF RFC 3621) which is associated with the given port on the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.6 | Unsigned32 (1 | 2 | 3 | 4 | 5) | read-only | current |
| lldpV2Xdot3LocMaxFrameSizeTable OBJECT-TYPE This table contains one row per port of maximum frame size information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.3 | not-accessible | current | |
| lldpV2Xdot3LocMaxFrameSizeEntry OBJECT-TYPE Maximum Frame Size information about a particular port component. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.3.1 | not-accessible | current | |
| lldpV2Xdot3LocMaxFrameSize OBJECT-TYPE An integer value indicating the maximum supported frame size in octets on the given port of the local system. | 1.3.111.2.802.1.1.13.1.5.4623.1.2.3.1.1 | Unsigned32 (0..65535) | read-only | current |
| lldpV2Xdot3RemoteData OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.1.3 | |||
| lldpV2Xdot3RemPortTable OBJECT-TYPE This table contains Ethernet port information (as a part of the LLDP 802.3 organizational extension) of the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.1 | not-accessible | current | |
| lldpV2Xdot3RemPortEntry OBJECT-TYPE Information about a particular physical network connection. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1 | not-accessible | current | |
| lldpV2Xdot3RemPortAutoNegSupported OBJECT-TYPE The truth value used to indicate whether the given port (associated with remote system) supports Auto-negotiation. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.1 | TruthValue | read-only | current |
| lldpV2Xdot3RemPortAutoNegEnabled OBJECT-TYPE The truth value used to indicate whether port Auto-negotiation is enabled on the given port associated with the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.2 | TruthValue | read-only | current |
| lldpV2Xdot3RemPortAutoNegAdvertisedCap OBJECT-TYPE This object contains the value (bitmap) of the ifMauAutoNegCapAdvertisedBits object (defined in IETF RFC 3636) which is associated with the given port on the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.3 | OCTET STRING (SIZE(2)) | read-only | current |
| lldpV2Xdot3RemPortOperMauType OBJECT-TYPE An integer value that indicates the operational MAU type of the sending device. This object contains the integer value derived from the list position of the corresponding dot3MauType as listed in in IETF RFC 4836 (or subsequent revisions) and is equal to the last number in the respective dot3MauType OID. For example, if the ifMauType object is dot3MauType1000BaseTHD which corresponds to {dot3MauType 29}, the numerical value of this field is 29. For MAU types not listed in RFC 4836 (or subsequent revisions), the value of this field shall be set to zero. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.4 | Unsigned32 (0..2147483647) | read-only | current |
| lldpV2Xdot3RemPowerTable OBJECT-TYPE This table contains Ethernet power information (as a part of the LLDP 802.3 organizational extension) of the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2 | not-accessible | current | |
| lldpV2Xdot3RemPowerEntry OBJECT-TYPE Information about a particular physical network connection. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1 | not-accessible | current | |
| lldpV2Xdot3RemPowerPortClass OBJECT-TYPE The value that identifies the port Class of the given port associated with the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.1 | LldpV2PowerPortClass | read-only | current |
| lldpV2Xdot3RemPowerMDISupported OBJECT-TYPE The truth value used to indicate whether the MDI power is supported on the given port associated with the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.2 | TruthValue | read-only | current |
| lldpV2Xdot3RemPowerMDIEnabled OBJECT-TYPE The truth value used to identify whether MDI power is enabled on the given port associated with the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.3 | TruthValue | read-only | current |
| lldpV2Xdot3RemPowerPairControlable OBJECT-TYPE The truth value is derived from the value of pethPsePortPowerPairsControlAbility object (defined in IETF RFC 3621) and is used to indicate whether the pair selection can be controlled on the given port associated with the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.4 | TruthValue | read-only | current |
| lldpV2Xdot3RemPowerPairs OBJECT-TYPE This object contains the value of the pethPsePortPowerPairs object (defined in IETF RFC 3621) which is associated with the given port on the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.5 | Unsigned32 (1 | 2) | read-only | current |
| lldpV2Xdot3RemPowerClass OBJECT-TYPE This object contains the value of the pethPsePortPowerClassifications object (defined in IETF RFC 3621) which is associated with the given port on the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.6 | Unsigned32 (1 | 2 | 3 | 4 | 5) | read-only | current |
| lldpV2Xdot3RemMaxFrameSizeTable OBJECT-TYPE This table contains one row per port/destination address pair of maximum frame size information (as a part of the LLDP IEEE 802.3 organizational extension) of the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.3 | not-accessible | current | |
| lldpV2Xdot3RemMaxFrameSizeEntry OBJECT-TYPE Maximum Frame Size information about a particular port component. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.3.1 | not-accessible | current | |
| lldpV2Xdot3RemMaxFrameSize OBJECT-TYPE An integer value indicating the maximum supported frame size in octets on the port component associated with the remote system. | 1.3.111.2.802.1.1.13.1.5.4623.1.3.3.1.1 | Unsigned32 (0..65535) | read-only | current |
| lldpV2Xdot3Conformance OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.2 | |||
| lldpV2Xdot3Compliances OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.2.1 | |||
| lldpV2Xdot3Groups OBJECT-IDENTITY | 1.3.111.2.802.1.1.13.1.5.4623.2.2 |
Conformance
| Name | OID | Status |
|---|---|---|
| lldpV2Xdot3TxRxCompliance MODULE-COMPLIANCE A compliance statement for SNMP entities that implement the LLDP 802.3 organizational extension MIB. This group is mandatory for all agents that implement the LLDP 802.3 organizational extension in TX and/or RX mode. This version defines compliance requirements for V2 of the LLDP MIB. | 1.3.111.2.802.1.1.13.1.5.4623.2.1.1 | current |
| lldpV2Xdot3TxCompliance MODULE-COMPLIANCE The compliance statement for SNMP entities which implement the LLDP 802.3 organizational extension MIB. This group is mandatory for agents which implement the LLDP 802.3 organizational extension in the TX mode. This version defines compliance requirements for V2 of the LLDP MIB. | 1.3.111.2.802.1.1.13.1.5.4623.2.1.2 | current |
| lldpV2Xdot3RxCompliance MODULE-COMPLIANCE The compliance statement for SNMP entities which implement the LLDP 802.3 organizational extension MIB. This group is mandatory for agents which implement the LLDP 802.3 organizational extension in the RX mode. This version defines compliance requirements for V2 of the LLDP MIB. | 1.3.111.2.802.1.1.13.1.5.4623.2.1.3 | current |
| lldpV2Xdot3ConfigGroup OBJECT-GROUP The collection of objects which are used to configure the LLDP 802.3 organizational extension implementation behavior. | 1.3.111.2.802.1.1.13.1.5.4623.2.2.1 | current |
| lldpV2Xdot3LocSysGroup OBJECT-GROUP The collection of objects which are used to represent LLDP 802.3 organizational extension Local Device Information. | 1.3.111.2.802.1.1.13.1.5.4623.2.2.2 | current |
| lldpV2Xdot3RemSysGroup OBJECT-GROUP The collection of objects which are used to represent LLDP 802.3 organizational extension Local Device Information. | 1.3.111.2.802.1.1.13.1.5.4623.2.2.3 | current |