MIBs Depot

LLDP-EXT-DOT3-MIB

Registered at
1.0.8802.1.1.2.1.5.4623
Last updated
2005-05-06 00:00
Organization
IEEE 802.1 Working Group
Revisions
2005-05-06 00:00
Namespace
standard
Source file
LLDP-EXT-DOT3-MIB
Digest
sha256:f25645cd3ba80b9351425dd7890e5df236aa3566c72d8ed3c6f9a808bdf3dbd2

Description

The LLDP Management Information Base extension module for IEEE 802.3 organizationally defined discovery information. In order to assure the uniqueness of the LLDP-MIB, lldpXdot3MIB is branched from lldpExtensions using OUI value as the node. An OUI/'company_id' is a 24 bit globally unique assigned number referenced by various standards. Copyright (C) IEEE (2005). This version of this MIB module is published as Annex G.6.1 of IEEE Std 802.1AB-2005; see the standard itself for full legal notices.

Contact

WG-URL: http://grouper.ieee.org/groups/802/1/index.html WG-EMail: stds-802-1@ieee.org Contact: Paul Congdon Postal: Hewlett-Packard Company 8000 Foothills Blvd. Roseville, CA 95747 USA Tel: +1-916-785-5753 E-mail: paul_congdon@hp.com

Imports

FromSymbols
LLDP-MIBlldpExtensions, lldpLocPortNum, lldpPortConfigEntry, lldpRemIndex, lldpRemLocalPortNum, lldpRemTimeMark
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

IANA-ADDRESS-FAMILY-NUMBERS-MIB
IANAifType-MIB
IF-MIB
LLDP-EXT-DOT3-MIB
LLDP-MIB
RFC1158-MIB
RFC1271-MIB
RMON-MIB
RMON2-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
TOKEN-RING-RMON-MIB

Textual conventions

NameOIDSyntaxAccessStatus
LldpLinkAggStatusMap
TEXTUAL-CONVENTION
This TC describes the link aggregation status. The bit 'aggCapable(0)' indicates the link is capable of being aggregated. The bit 'aggEnabled(1)' indicates the link is currently in aggregation.
current
LldpPowerPortClass
TEXTUAL-CONVENTION
This TC describes the Power over Ethernet (PoE) port class.
current

Objects

NameOIDSyntaxAccessStatus
lldpXdot3Objects
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.1
lldpXdot3Config
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.1.1
lldpXdot3PortConfigTable
OBJECT-TYPE
A table that controls selection of LLDP TLVs to be transmitted on individual ports.
1.0.8802.1.1.2.1.5.4623.1.1.1not-accessiblecurrent
lldpXdot3PortConfigEntry
OBJECT-TYPE
LLDP configuration information that controls the transmission of IEEE 802.3 organizationally defined TLVs on LLDP transmission capable ports. This configuration object augments the lldpPortConfigEntry of the LLDP-MIB, therefore it is only present along with the port configuration defined by the associated lldpPortConfigEntry entry. Each active lldpXdot3PortConfigEntry must be from non-volatile storage (along with the corresponding lldpPortConfigEntry) after a re-initialization of the management system.
1.0.8802.1.1.2.1.5.4623.1.1.1.1not-accessiblecurrent
lldpXdot3PortConfigTLVsTxEnable
OBJECT-TYPE
The lldpXdot3PortConfigTLVsTxEnable, defined as a bitmap, includes the IEEE 802.3 organizationally defined set of LLDP TLVs whose transmission is allowed on the local LLDP agent by the network management. Each bit in the bitmap corresponds to an IEEE 802.3 subtype associated with a specific IEEE 802.3 optional TLV. The bit 0 is not used since there is no corresponding subtype. The bit 'macPhyConfigStatus(0)' indicates that LLDP agent should transmit 'MAC/PHY configuration/status TLV'. The bit 'powerViaMDI(1)' indicates that LLDP agent should transmit 'Power via MDI TLV'. The bit 'linkAggregation(2)' indicates that LLDP agent should transmit 'Link Aggregation TLV'. The bit 'maxFrameSize(3)' indicates that LLDP agent should transmit 'Maximum-frame-size TLV'. The default value for lldpXdot3PortConfigTLVsTxEnable object is an empty set, which means no enumerated values are set. The value of this object must be restored from non-volatile storage after a re-initialization of the management system.
1.0.8802.1.1.2.1.5.4623.1.1.1.1.1Bits {macPhyConfigStatus(0), powerViaMDI(1), linkAggregation(2), maxFrameSize(3)}read-writecurrent
lldpXdot3LocalData
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.1.2
lldpXdot3LocPortTable
OBJECT-TYPE
This table contains one row per port of Ethernet port information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
1.0.8802.1.1.2.1.5.4623.1.2.1not-accessiblecurrent
lldpXdot3LocPortEntry
OBJECT-TYPE
Information about a particular port component.
1.0.8802.1.1.2.1.5.4623.1.2.1.1not-accessiblecurrent
lldpXdot3LocPortAutoNegSupported
OBJECT-TYPE
The truth value used to indicate whether the given port (associated with the local system) supports Auto-negotiation.
1.0.8802.1.1.2.1.5.4623.1.2.1.1.1TruthValueread-onlycurrent
lldpXdot3LocPortAutoNegEnabled
OBJECT-TYPE
The truth value used to indicate whether port Auto-negotiation is enabled on the given port associated with the local system.
1.0.8802.1.1.2.1.5.4623.1.2.1.1.2TruthValueread-onlycurrent
lldpXdot3LocPortAutoNegAdvertisedCap
OBJECT-TYPE
This object contains the value (bitmap) of the ifMauAutoNegCapAdvertisedBits object (defined in IETF RFC 3636) which is associated with the given port on the local system.
1.0.8802.1.1.2.1.5.4623.1.2.1.1.3OCTET STRING (SIZE(2))read-onlycurrent
lldpXdot3LocPortOperMauType
OBJECT-TYPE
An integer value that indicates the operational MAU type of the given port on the local system. This object contains the integer value derived from the list position of the corresponding dot3MauType as listed in IETF RFC 3636 (or subsequent revisions) and is equal to the last number in the respective dot3MauType OID. For example, if the ifMauType object is dot3MauType1000BaseTHD which corresponds to {dot3MauType 29}, the numerical value of this field will be 29. For MAU types not listed in RFC 3636 (or subsequent revisions), the value of this field shall be set to zero.
1.0.8802.1.1.2.1.5.4623.1.2.1.1.4Integer32 (0..2147483647)read-onlycurrent
lldpXdot3LocPowerTable
OBJECT-TYPE
This table contains one row per port of power ethernet information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
1.0.8802.1.1.2.1.5.4623.1.2.2not-accessiblecurrent
lldpXdot3LocPowerEntry
OBJECT-TYPE
Information about a particular port component.
1.0.8802.1.1.2.1.5.4623.1.2.2.1not-accessiblecurrent
lldpXdot3LocPowerPortClass
OBJECT-TYPE
The value that identifies the port Class of the given port associated with the local system.
1.0.8802.1.1.2.1.5.4623.1.2.2.1.1LldpPowerPortClassread-onlycurrent
lldpXdot3LocPowerMDISupported
OBJECT-TYPE
The truth value used to indicate whether the MDI power is supported on the given port associated with the local system.
1.0.8802.1.1.2.1.5.4623.1.2.2.1.2TruthValueread-onlycurrent
lldpXdot3LocPowerMDIEnabled
OBJECT-TYPE
The truth value used to identify whether MDI power is enabled on the given port associated with the local system.
1.0.8802.1.1.2.1.5.4623.1.2.2.1.3TruthValueread-onlycurrent
lldpXdot3LocPowerPairControlable
OBJECT-TYPE
The truth value is derived from the value of pethPsePortPowerPairsControlAbility object (defined in IETF RFC 3621) and is used to indicate whether the pair selection can be controlled on the given port associated with the local system.
1.0.8802.1.1.2.1.5.4623.1.2.2.1.4TruthValueread-onlycurrent
lldpXdot3LocPowerPairs
OBJECT-TYPE
This object contains the value of the pethPsePortPowerPairs object (defined in IETF RFC 3621) which is associated with the given port on the local system.
1.0.8802.1.1.2.1.5.4623.1.2.2.1.5Integer32 (1 | 2)read-onlycurrent
lldpXdot3LocPowerClass
OBJECT-TYPE
This object contains the value of the pethPsePortPowerClassifications object (defined in IETF RFC 3621) which is associated with the given port on the local system.
1.0.8802.1.1.2.1.5.4623.1.2.2.1.6Integer32 (1 | 2 | 3 | 4 | 5)read-onlycurrent
lldpXdot3LocLinkAggTable
OBJECT-TYPE
This table contains one row per port of link aggregation information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
1.0.8802.1.1.2.1.5.4623.1.2.3not-accessiblecurrent
lldpXdot3LocLinkAggEntry
OBJECT-TYPE
Link Aggregation information about a particular port component.
1.0.8802.1.1.2.1.5.4623.1.2.3.1not-accessiblecurrent
lldpXdot3LocLinkAggStatus
OBJECT-TYPE
The bitmap value contains the link aggregation capabilities and the current aggregation status of the link.
1.0.8802.1.1.2.1.5.4623.1.2.3.1.1LldpLinkAggStatusMapread-onlycurrent
lldpXdot3LocLinkAggPortId
OBJECT-TYPE
This object contains the IEEE 802.3 aggregated port identifier, aAggPortID (IEEE 802.3-2002, 30.7.2.1.1), derived from the ifNumber of the ifIndex for the port component in link aggregation. If the port is not in link aggregation state and/or it does not support link aggregation, this value should be set to zero.
1.0.8802.1.1.2.1.5.4623.1.2.3.1.2Integer32 (0 | 1..2147483647)read-onlycurrent
lldpXdot3LocMaxFrameSizeTable
OBJECT-TYPE
This table contains one row per port of maximum frame size information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
1.0.8802.1.1.2.1.5.4623.1.2.4not-accessiblecurrent
lldpXdot3LocMaxFrameSizeEntry
OBJECT-TYPE
Maximum Frame Size information about a particular port component.
1.0.8802.1.1.2.1.5.4623.1.2.4.1not-accessiblecurrent
lldpXdot3LocMaxFrameSize
OBJECT-TYPE
An integer value indicating the maximum supported frame size in octets on the given port of the local system.
1.0.8802.1.1.2.1.5.4623.1.2.4.1.1Integer32 (0..65535)read-onlycurrent
lldpXdot3RemoteData
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.1.3
lldpXdot3RemPortTable
OBJECT-TYPE
This table contains Ethernet port information (as a part of the LLDP 802.3 organizational extension) of the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.1not-accessiblecurrent
lldpXdot3RemPortEntry
OBJECT-TYPE
Information about a particular physical network connection.
1.0.8802.1.1.2.1.5.4623.1.3.1.1not-accessiblecurrent
lldpXdot3RemPortAutoNegSupported
OBJECT-TYPE
The truth value used to indicate whether the given port (associated with remote system) supports Auto-negotiation.
1.0.8802.1.1.2.1.5.4623.1.3.1.1.1TruthValueread-onlycurrent
lldpXdot3RemPortAutoNegEnabled
OBJECT-TYPE
The truth value used to indicate whether port Auto-negotiation is enabled on the given port associated with the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.1.1.2TruthValueread-onlycurrent
lldpXdot3RemPortAutoNegAdvertisedCap
OBJECT-TYPE
This object contains the value (bitmap) of the ifMauAutoNegCapAdvertisedBits object (defined in IETF RFC 3636) which is associated with the given port on the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.1.1.3OCTET STRING (SIZE(2))read-onlycurrent
lldpXdot3RemPortOperMauType
OBJECT-TYPE
An integer value that indicates the operational MAU type of the sending device. This object contains the integer value derived from the list position of the corresponding dot3MauType as listed in in IETF RFC 3636 (or subsequent revisions) and is equal to the last number in the respective dot3MauType OID. For example, if the ifMauType object is dot3MauType1000BaseTHD which corresponds to {dot3MauType 29}, the numerical value of this field will be 29. For MAU types not listed in RFC 3636 (or subsequent revisions), the value of this field shall be set to zero.
1.0.8802.1.1.2.1.5.4623.1.3.1.1.4Integer32 (0..2147483647)read-onlycurrent
lldpXdot3RemPowerTable
OBJECT-TYPE
This table contains Ethernet power information (as a part of the LLDP 802.3 organizational extension) of the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2not-accessiblecurrent
lldpXdot3RemPowerEntry
OBJECT-TYPE
Information about a particular physical network connection.
1.0.8802.1.1.2.1.5.4623.1.3.2.1not-accessiblecurrent
lldpXdot3RemPowerPortClass
OBJECT-TYPE
The value that identifies the port Class of the given port associated with the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2.1.1LldpPowerPortClassread-onlycurrent
lldpXdot3RemPowerMDISupported
OBJECT-TYPE
The truth value used to indicate whether the MDI power is supported on the given port associated with the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2.1.2TruthValueread-onlycurrent
lldpXdot3RemPowerMDIEnabled
OBJECT-TYPE
The truth value used to identify whether MDI power is enabled on the given port associated with the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2.1.3TruthValueread-onlycurrent
lldpXdot3RemPowerPairControlable
OBJECT-TYPE
The truth value is derived from the value of pethPsePortPowerPairsControlAbility object (defined in IETF RFC 3621) and is used to indicate whether the pair selection can be controlled on the given port associated with the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2.1.4TruthValueread-onlycurrent
lldpXdot3RemPowerPairs
OBJECT-TYPE
This object contains the value of the pethPsePortPowerPairs object (defined in IETF RFC 3621) which is associated with the given port on the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2.1.5Integer32 (1 | 2)read-onlycurrent
lldpXdot3RemPowerClass
OBJECT-TYPE
This object contains the value of the pethPsePortPowerClassifications object (defined in IETF RFC 3621) which is associated with the given port on the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.2.1.6Integer32 (1 | 2 | 3 | 4 | 5)read-onlycurrent
lldpXdot3RemLinkAggTable
OBJECT-TYPE
This table contains port link aggregation information (as a part of the LLDP 802.3 organizational extension) of the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.3not-accessiblecurrent
lldpXdot3RemLinkAggEntry
OBJECT-TYPE
Link Aggregation information about remote system's port component.
1.0.8802.1.1.2.1.5.4623.1.3.3.1not-accessiblecurrent
lldpXdot3RemLinkAggStatus
OBJECT-TYPE
The bitmap value contains the link aggregation capabilities and the current aggregation status of the link.
1.0.8802.1.1.2.1.5.4623.1.3.3.1.1LldpLinkAggStatusMapread-onlycurrent
lldpXdot3RemLinkAggPortId
OBJECT-TYPE
This object contains the IEEE 802.3 aggregated port identifier, aAggPortID (IEEE 802.3-2002, 30.7.2.1.1), derived from the ifNumber of the ifIndex for the port component associated with the remote system. If the remote port is not in link aggregation state and/or it does not support link aggregation, this value should be zero.
1.0.8802.1.1.2.1.5.4623.1.3.3.1.2Integer32 (0 | 1..2147483647)read-onlycurrent
lldpXdot3RemMaxFrameSizeTable
OBJECT-TYPE
This table contains one row per port of maximum frame size information (as a part of the LLDP 802.3 organizational extension) of the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.4not-accessiblecurrent
lldpXdot3RemMaxFrameSizeEntry
OBJECT-TYPE
Maximum Frame Size information about a particular port component.
1.0.8802.1.1.2.1.5.4623.1.3.4.1not-accessiblecurrent
lldpXdot3RemMaxFrameSize
OBJECT-TYPE
An integer value indicating the maximum supported frame size in octets on the port component associated with the remote system.
1.0.8802.1.1.2.1.5.4623.1.3.4.1.1Integer32 (0..65535)read-onlycurrent
lldpXdot3Conformance
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.2
lldpXdot3Compliances
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.2.1
lldpXdot3Groups
OBJECT-IDENTITY
1.0.8802.1.1.2.1.5.4623.2.2

Conformance

NameOIDStatus
lldpXdot3Compliance
MODULE-COMPLIANCE
The compliance statement for SNMP entities which implement the LLDP 802.3 organizational extension MIB.
1.0.8802.1.1.2.1.5.4623.2.1.1current
lldpXdot3ConfigGroup
OBJECT-GROUP
The collection of objects which are used to configure the LLDP 802.3 organizational extension implementation behavior. This group is mandatory for agents which implement the LLDP 802.3 organizational extension.
1.0.8802.1.1.2.1.5.4623.2.2.1current
lldpXdot3LocSysGroup
OBJECT-GROUP
The collection of objects which are used to represent LLDP 802.3 organizational extension Local Device Information. This group is mandatory for agents which implement the LLDP 802.3 organizational extension in the TX mode.
1.0.8802.1.1.2.1.5.4623.2.2.2current
lldpXdot3RemSysGroup
OBJECT-GROUP
The collection of objects which are used to represent LLDP 802.3 organizational extension Local Device Information. This group is mandatory for agents which implement the LLDP 802.3 organizational extension in the RX mode.
1.0.8802.1.1.2.1.5.4623.2.2.3current