L2L3-VPN-MULTICAST-MIB
- Registered at
- 1.3.6.1.2.1.245
- Last updated
- 2018-12-14 00:00
- Organization
- IETF BESS Working Group
- Revisions
- 2018-12-14 00:00
- Namespace
- standard
- Source file
L2L3-VPN-MULTICAST-MIB- Digest
sha256:f9a6e2e8c87978ac9e2c63dd46546e650becc0c2162c0f3a373244b30fbf4018
Description
This MIB module defines a table representing the attribute information of the provider tunnels (P-tunnels) on a PE router. This MIB module will be used by other MIB modules designed for monitoring and/or configuring Border Gateway Protocol/Multiprotocol Label Switching Layer 2 and Layer 3 Virtual Private Network that support multicast (L2L3VpnMCast network). Copyright (c) 2018 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
Contact
Zhaohui Zhang Juniper Networks, Inc. 10 Technology Park Drive Westford, MA 01886 United States of America Email: zzhang@juniper.net Hiroshi Tsunoda Tohoku Institute of Technology 35-1, Yagiyama Kasumi-cho Taihaku-ku, Sendai, 982-8577 Japan Email: tsuno@m.ieice.org
Imports
| From | Symbols |
|---|---|
| L2L3-VPN-MULTICAST-TC-MIB | L2L3VpnMcastProviderTunnelId, L2L3VpnMcastProviderTunnelType |
| MPLS-TC-STD-MIB | MplsLabel |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso, mib-2, zeroDotZero |
| SNMPv2-TC | DisplayString, RowPointer, TEXTUAL-CONVENTION |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
L2L3-VPN-MULTICAST-MIB L2L3-VPN-MULTICAST-TC-MIB MPLS-TC-STD-MIB SNMPv2-CONF SNMPv2-SMI SNMPv2-TC
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| l2L3VpnMcastStates OBJECT-IDENTITY | 1.3.6.1.2.1.245.1 | |||
| l2L3VpnMcastPmsiTunnelAttributeTable OBJECT-TYPE An entry in this table corresponds to the attribute information of a specific P-tunnel on a PE router. A part of the attributes corresponds to fields in a Provider Multicast Service Interface (PMSI) Tunnel attribute advertised and received by a PE router. The entries will be referred to by other MIB modules for monitoring and/or configuring L2L3VpnMCast networks. | 1.3.6.1.2.1.245.1.1 | not-accessible | current | |
| l2L3VpnMcastPmsiTunnelAttributeEntry OBJECT-TYPE A conceptual row corresponding to a specific P-tunnel on this router. | 1.3.6.1.2.1.245.1.1.1 | not-accessible | current | |
| l2L3VpnMcastPmsiTunnelAttributeType OBJECT-TYPE This object indicates the type of tunneling technology used to establish the P-tunnel corresponding to this entry. When BGP-based PMSI signaling is used, the value of this object corresponds to the Tunnel Type field in the PMSI Tunnel attribute advertised/received in a PMSI auto-discovery (A-D) route. | 1.3.6.1.2.1.245.1.1.1.1 | L2L3VpnMcastProviderTunnelType | not-accessible | current |
| l2L3VpnMcastPmsiTunnelAttributeId OBJECT-TYPE This object represents the Tunnel Identifier field, which uniquely identifies a P-tunnel, in the PMSI Tunnel attribute of the P-tunnel corresponding to this entry. The size of the identifier depends on the address family (IPv4 or IPv6) and the value of the corresponding l2L3VpnMcastPmsiTunnelAttributeType object, i.e., the type of tunneling technology used to establish the P-tunnel. | 1.3.6.1.2.1.245.1.1.1.2 | L2L3VpnMcastProviderTunnelId | not-accessible | current |
| l2L3VpnMCastPmsiTunnelLeafInfoRequired OBJECT-TYPE When the value of this object is set to 1 (true), it indicates that the PE that originated the PMSI Tunnel attribute of the P-tunnel corresponding to this entry requests receivers to originate a new Leaf A-D route. A value of zero (false) indicates that there is no such request. When the P-tunnel does not have a corresponding PMSI Tunnel attribute, the value of this object will be 2 (notAvailable). In the case of multicast in MPLS/BGP IP VPNs, this object represents the 'Leaf Information Required flag' (RFC 6514) in the Flags field in the PMSI Tunnel attribute of the P-tunnel corresponding to this entry. | 1.3.6.1.2.1.245.1.1.1.3 | INTEGER {false(0), true(1), notAvailable(2)} | read-only | current |
| l2L3VpnMcastPmsiTunnelAttributeMplsLabel OBJECT-TYPE This object represents the MPLS Label in the PMSI Tunnel attribute of the P-tunnel corresponding to this entry. When BGP-based PMSI signaling is used, the PMSI Tunnel attribute of the P-tunnel will be advertised/received in a PMSI A-D route. The value of this object corresponds to the MPLS Label in the attribute. When the P-tunnel does not have a PMSI tunnel attribute, the value of this object will be zero. | 1.3.6.1.2.1.245.1.1.1.4 | MplsLabel | read-only | current |
| l2L3VpnMcastPmsiTunnelPointer OBJECT-TYPE Details of a P-tunnel identified by l2L3VpnMcastPmsiTunnelAttributeId may be present in some other table, e.g., mplsTunnelTable (RFC 3812). This object specifies the pointer to the row that pertains to the entry in the table. If no such entry exists, the value of this object will be zeroDotZero. | 1.3.6.1.2.1.245.1.1.1.5 | RowPointer | read-only | current |
| l2L3VpnMcastPmsiTunnelIf OBJECT-TYPE If the P-tunnel identified by l2L3VpnMcastPmsiTunnelAttributeId has a corresponding entry in ifXTable (RFC 2863), this object will point to the row in ifXTable that pertains to the entry. Otherwise, the value of this object will be zeroDotZero. | 1.3.6.1.2.1.245.1.1.1.6 | RowPointer | read-only | current |
| l2L3VpnMcastConformance OBJECT-IDENTITY | 1.3.6.1.2.1.245.2 | |||
| l2L3VpnMcastCompliances OBJECT-IDENTITY | 1.3.6.1.2.1.245.2.1 | |||
| l2L3VpnMcastGroups OBJECT-IDENTITY | 1.3.6.1.2.1.245.2.2 |
Conformance
| Name | OID | Status |
|---|---|---|
| l2L3VpnMcastCoreCompliance MODULE-COMPLIANCE The core compliance statement for SNMP entities that implement the L2L3-VPN-MULTICAST-MIB module. | 1.3.6.1.2.1.245.2.1.1 | current |
| l2L3VpnMcastFullCompliance MODULE-COMPLIANCE The full compliance statement for SNMP entities that implement the L2L3-VPN-MULTICAST-MIB module. | 1.3.6.1.2.1.245.2.1.2 | current |
| l2L3VpnMcastCoreGroup OBJECT-GROUP Support of these objects is required. | 1.3.6.1.2.1.245.2.2.1 | current |
| l2L3VpnMcastOptionalGroup OBJECT-GROUP Support of these objects is optional. | 1.3.6.1.2.1.245.2.2.2 | current |