MIBs Depot

HUAWEI-LAG-MIB

Registered at
1.3.6.1.4.1.2011.5.25.25
Last updated
2003-10-09 19:42
Organization
Hangzhou H3C Tech. Co., Ltd.
Namespace
huawei
Source file
HUAWEI-LAG-MIB
Digest
sha256:8d95c5410b699b2f868ed21664baf38d9b0342dec88f2d4c8c4dcf3bd8af84b9

Description

LACP extend MIB.

Contact

Platform Team Hangzhou H3C Tech. Co., Ltd. Hai-Dian District Beijing P.R. China http://www.h3c.com Zip:100085

Imports

FromSymbols
HUAWEI-3COM-OID-MIBhuaweiDatacomm, huaweiMgmt
Q-BRIDGE-MIBPortList
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIGauge32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, RowStatus, TEXTUAL-CONVENTION, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

BRIDGE-MIB
HUAWEI-3COM-OID-MIB
HUAWEI-LAG-MIB
IANAifType-MIB
IF-MIB
P-BRIDGE-MIB
Q-BRIDGE-MIB
RFC1158-MIB
RFC1271-MIB
RMON-MIB
RMON2-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
TOKEN-RING-RMON-MIB

Objects

NameOIDSyntaxAccessStatus
hwLAGMibObjects
OBJECT-IDENTITY
1.3.6.1.4.1.2011.5.25.25.1
hwAggLinkTable
OBJECT-TYPE
A table of aggregate link objects.
1.3.6.1.4.1.2011.5.25.25.1.1not-accessiblecurrent
hwAggLinkEntry
OBJECT-TYPE
Entry of table.
1.3.6.1.4.1.2011.5.25.25.1.1.1not-accessiblecurrent
hwAggLinkNumber
OBJECT-TYPE
The serial number of aggregation group.
1.3.6.1.4.1.2011.5.25.25.1.1.1.1Integer32accessible-for-notifycurrent
hwAggLinkName
OBJECT-TYPE
Aggregation name.
1.3.6.1.4.1.2011.5.25.25.1.1.1.2DisplayString (SIZE(0..32))read-createcurrent
hwAggLinkMode
OBJECT-TYPE
Type of aggregation. manual: Manual aggregation, no LACP. static: Membership specified by user, LACP is used to validate. dynamic: Completely dynamic aggregation detected by LACP.
1.3.6.1.4.1.2011.5.25.25.1.1.1.3INTEGER {manual(1), static(2), dynamic(3)}read-createcurrent
hwAggLinkPortList
OBJECT-TYPE
List of ports in this link aggregation group, by bridge port number. If the mode of the link aggregation group is manual or static, you can update this list to your hearts content. However, if the link aggregation group is dynamic, the system will maintain it. You are not permitted to set the value of this to all zeroes.
1.3.6.1.4.1.2011.5.25.25.1.1.1.4PortListread-createcurrent
hwAggLinkState
OBJECT-TYPE
RowStatus, now support three states: createAndGo, active, destroy.
1.3.6.1.4.1.2011.5.25.25.1.1.1.5RowStatusread-createcurrent
hwAggPortListSelectedPorts
OBJECT-TYPE
A PortList of physical ports that have been selected but not attached to this aggregator. When the bit is set to 1,it means the corresponding port is in the portlist.
1.3.6.1.4.1.2011.5.25.25.1.1.1.6PortListread-onlycurrent
hwAggPortListSamePartnerPorts
OBJECT-TYPE
PortList of physical ports that have the same Actor SystemID and partner systemID as this aggregator, but have different actor and partner keys of aggregator.
1.3.6.1.4.1.2011.5.25.25.1.1.1.7PortListread-onlycurrent
hwAggPortTable
OBJECT-TYPE
A table of aggregate port objects.
1.3.6.1.4.1.2011.5.25.25.1.2not-accessiblecurrent
hwAggPortEntry
OBJECT-TYPE
Entry of table.
1.3.6.1.4.1.2011.5.25.25.1.2.1not-accessiblecurrent
hwAggPortIndex
OBJECT-TYPE
Port ifindex which is according to RFC1213 MIB.
1.3.6.1.4.1.2011.5.25.25.1.2.1.1Gauge32accessible-for-notifycurrent
hwAggPortNotAttachedReason
OBJECT-TYPE
Reason why this port is selected for an aggregator but not attached, 0: The port is attached to this aggregator. 1: The current number of active ports has reached the upper limit. 2: All aggregation resources are already in-use. 3: The port's configuration is improper for being attached. 4: The port's partner is improper for being attached. 5: The number of current active ports has not reached the lower limit. 6: The port's physical state (down) is improper for being attached. 7: The port is not selected for an aggregator. 8: The port's hardware restriction is improper for being attached. 9: The port's speed is improper for being attached. 10: The port's duplex mode is improper for being attached.
1.3.6.1.4.1.2011.5.25.25.1.2.1.2Integer32 (0..10)read-writecurrent
hwAggPortLacpState
OBJECT-TYPE
Control ports' lacp enble or disable.
1.3.6.1.4.1.2011.5.25.25.1.2.1.3TruthValueread-writecurrent
hwAggPortNotAttachedString
OBJECT-TYPE
The string which interprets this port is selected for an aggregator but not attached.
1.3.6.1.4.1.2011.5.25.25.1.2.1.4DisplayString (SIZE(0..255))read-writecurrent
hwAggResourceAllocationValue
OBJECT-TYPE
The priority value calculated to decide which aggregations have first call on the load-sharing aggregation resources in the hardware. It depends on the aggregation type and total speed.
1.3.6.1.4.1.2011.5.25.25.1.3PortListread-onlycurrent
hwLAGMibNotifications
OBJECT-IDENTITY
1.3.6.1.4.1.2011.5.25.25.2
hwLAGMibConformance
OBJECT-IDENTITY
1.3.6.1.4.1.2011.5.25.25.3
hwLAGMibCompliances
OBJECT-IDENTITY
1.3.6.1.4.1.2011.5.25.25.3.1
hwLAGMibGroup
OBJECT-IDENTITY
1.3.6.1.4.1.2011.5.25.25.3.2

Notifications

NameOIDStatus
hwAggSpeedChangedNotification
NOTIFICATION-TYPE
This event will be triggered whenever an aggregation changes its speed.
1.3.6.1.4.1.2011.5.25.25.2.1current
hwAggPortInactiveNotification
NOTIFICATION-TYPE
This event will be triggered whenever any port in aggregator is made inactive.
1.3.6.1.4.1.2011.5.25.25.2.2current
hwAggPortInactiveNotification2
NOTIFICATION-TYPE
This event will be triggered whenever the port in aggregator is made inactive.
1.3.6.1.4.1.2011.5.25.25.2.3current
hwAggPortActiveNotification
NOTIFICATION-TYPE
This event will be triggered whenever the port in aggregator is made active.
1.3.6.1.4.1.2011.5.25.25.2.4current

Conformance

NameOIDStatus
hwLAGMibCompliance
MODULE-COMPLIANCE
The compliance statement for SNMP entities which implement the Lag MIB.
1.3.6.1.4.1.2011.5.25.25.3.1.1current
hwLAGMibObjectGroup
OBJECT-GROUP
The collection of objects which are used to represent LAG objects.
1.3.6.1.4.1.2011.5.25.25.3.2.1current
hwLAGMibNotificationGroup
NOTIFICATION-GROUP
The collection of objects which are used to represent notifications.
1.3.6.1.4.1.2011.5.25.25.3.2.2current