MIBs Depot

FORCES-MIB

Registered at
1.3.6.1.2.1.187
Last updated
2010-03-10 00:00
Organization
IETF Forwarding and Control Element Separation (ForCES) Working Group
Revisions
2010-03-10 00:00
Namespace
standard
Source file
FORCES-MIB
Digest
sha256:8cb615921a6c1c40e40c43a897108e4baae58fee9531c47f5a9cbe342b449ca5

Description

This MIB module contains managed object definitions for the ForCES Protocol. Copyright (c) 2010 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 5813; see the RFC itself for full legal notices.

Contact

WG Charter: http://www.ietf.org/html.charters/forces-charter.html Mailing lists: General Discussion: forces@ietf.org To Subscribe: https://www.ietf.org/mailman/listinfo/forces Chairs: Patrick Droz Email: dro@zurich.ibm.com Jamal Hadi Salim Email: hadi@mojatatu.com Editor: Robert Haas IBM Email: rha@zurich.ibm.com

Imports

FromSymbols
RMON2-MIBZeroBasedCounter32
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso, mib-2
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION, TimeStamp

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

FORCES-MIB
IANAifType-MIB
IF-MIB
RFC1158-MIB
RFC1271-MIB
RMON-MIB
RMON2-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
TOKEN-RING-RMON-MIB

Textual conventions

NameOIDSyntaxAccessStatus
ForcesID
TEXTUAL-CONVENTION
The ForCES identifier is a 4-octet quantity.
current
ForcesProtocolVersion
TEXTUAL-CONVENTION
ForCES protocol version number. The version numbers used are defined in the specifications of the respective protocol: 1 - ForCESv1, RFC 5810.
current

Objects

NameOIDSyntaxAccessStatus
forcesMibNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.187.0
forcesMibObjects
OBJECT-IDENTITY
1.3.6.1.2.1.187.1
forcesLatestProtocolVersionSupported
OBJECT-TYPE
The ForCES protocol version supported by the CE. The current protocol version is 1. Note that the CE must also allow interaction with FEs supporting earlier versions.
1.3.6.1.2.1.187.1.1ForcesProtocolVersionread-onlycurrent
forcesAssociations
OBJECT-IDENTITY
1.3.6.1.2.1.187.1.2
forcesAssociationTable
OBJECT-TYPE
The (conceptual) table of associations.
1.3.6.1.2.1.187.1.2.1not-accessiblecurrent
forcesAssociationEntry
OBJECT-TYPE
A (conceptual) entry for one association.
1.3.6.1.2.1.187.1.2.1.1not-accessiblecurrent
forcesAssociationCEID
OBJECT-TYPE
The ForCES ID of the CE.
1.3.6.1.2.1.187.1.2.1.1.1ForcesIDnot-accessiblecurrent
forcesAssociationFEID
OBJECT-TYPE
The ForCES ID of the FE.
1.3.6.1.2.1.187.1.2.1.1.2ForcesIDnot-accessiblecurrent
forcesAssociationRunningProtocolVersion
OBJECT-TYPE
The current ForCES protocol version used in this association. The current protocol version is 1.
1.3.6.1.2.1.187.1.2.1.1.3ForcesProtocolVersionread-onlycurrent
forcesAssociationTimeUp
OBJECT-TYPE
The value of sysUpTime at the time this association entered the UP state. If this association started prior to the last initialization of the network subsystem, then this object contains a zero value. This object allows to uniquely identify associations with the same CE and FE IDs.
1.3.6.1.2.1.187.1.2.1.1.4TimeStampread-onlycurrent
forcesAssociationTimeDown
OBJECT-TYPE
The value of sysUpTime at the time this association left the UP state.
1.3.6.1.2.1.187.1.2.1.1.5TimeStampaccessible-for-notifycurrent
forcesAssociationHBMsgSent
OBJECT-TYPE
A counter of how many Heartbeat messages have been sent by the CE on this association since the association entered the UP state. Discontinuities in the value of this counter can occur at reinitialization of the management system, and at other times as indicated by the value of forcesAssociationCounterDiscontinuityTime.
1.3.6.1.2.1.187.1.2.1.1.6ZeroBasedCounter32read-onlycurrent
forcesAssociationHBMsgReceived
OBJECT-TYPE
A counter of how many Heartbeat messages have been received by the CE on this association since the association entered the UP state. Discontinuities in the value of this counter can occur at reinitialization of the management system, and at other times as indicated by the value of forcesAssociationCounterDiscontinuityTime.
1.3.6.1.2.1.187.1.2.1.1.7ZeroBasedCounter32read-onlycurrent
forcesAssociationOperMsgSent
OBJECT-TYPE
A counter of how many messages other than Heartbeat (i.e., Config and Query) have been sent by the CE on this association since the association entered the UP state. Discontinuities in the value of this counter can occur at reinitialization of the management system, and at other times as indicated by the value of forcesAssociationCounterDiscontinuityTime.
1.3.6.1.2.1.187.1.2.1.1.8ZeroBasedCounter32read-onlycurrent
forcesAssociationOperMsgReceived
OBJECT-TYPE
A counter of how many messages other than Heartbeat (i.e., Config response, Query response, event notification, and packet redirect) have been received by the CE on this association since the association entered the UP state. Discontinuities in the value of this counter can occur at reinitialization of the management system, and at other times as indicated by the value of forcesAssociationCounterDiscontinuityTime.
1.3.6.1.2.1.187.1.2.1.1.9ZeroBasedCounter32read-onlycurrent
forcesAssociationCounterDiscontinuityTime
OBJECT-TYPE
The value of sysUpTime on the most recent occasion at which any one or more of this association's counters suffered a discontinuity. The relevant counters are the specific instances associated with this association of any ZeroBasedCounter32 object contained in the forcesAssociationTable. If no such discontinuities have occurred since the last reinitialization of the local management subsystem, then this object contains a zero value.
1.3.6.1.2.1.187.1.2.1.1.10TimeStampread-onlycurrent
forcesMibConformance
OBJECT-IDENTITY
1.3.6.1.2.1.187.2
forcesMibCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.187.2.1
forcesMibGroups
OBJECT-IDENTITY
1.3.6.1.2.1.187.2.2

Notifications

NameOIDStatus
forcesAssociationEntryUp
NOTIFICATION-TYPE
This notification is generated as soon as an association enters the UP state. Note that these notifications are not throttled as the CE itself should throttle the setup of associations.
1.3.6.1.2.1.187.0.1current
forcesAssociationEntryDown
NOTIFICATION-TYPE
This notification is generated as soon as an association leaves the UP state. Note that these notifications are not throttled as the CE itself should throttle the setup of associations.
1.3.6.1.2.1.187.0.2current
forcesAssociationEntryUpStats
NOTIFICATION-TYPE
This notification is generated as soon as an association enters the UP state. Note that these notifications are not throttled as the CE itself should throttle the setup of associations.
1.3.6.1.2.1.187.0.3current
forcesAssociationEntryDownStats
NOTIFICATION-TYPE
This notification is generated as soon as an association leaves the UP state. Note that these notifications are not throttled as the CE itself should throttle the setup of associations.
1.3.6.1.2.1.187.0.4current

Conformance

NameOIDStatus
forcesMibCompliance
MODULE-COMPLIANCE
The compliance statement for routers running ForCES and implementing the ForCES MIB.
1.3.6.1.2.1.187.2.1.1current
forcesNotificationGroup
NOTIFICATION-GROUP
A collection of notifications for signaling important ForCES events.
1.3.6.1.2.1.187.2.2.1current
forcesMibGroup
OBJECT-GROUP
A collection of objects to support management of ForCES routers.
1.3.6.1.2.1.187.2.2.2current
forcesNotificationStatsGroup
NOTIFICATION-GROUP
A collection of optional notifications for signaling important ForCES events including statistics.
1.3.6.1.2.1.187.2.2.3current
forcesStatsGroup
OBJECT-GROUP
A collection of optional objects to provide extra information about the associations. There is no protocol reason to keep such information, but these objects can be very useful in debugging connectivity problems.
1.3.6.1.2.1.187.2.2.4current