MIBs Depot

ENTERASYS-SERVICE-LEVEL-REPORTING-MIB

Registered at
1.3.6.1.4.1.5624.1.2.39
Last updated
2003-11-06 15:15
Organization
Enterasys Networks Inc.
Revisions
2003-11-06 15:15, 2003-10-24 19:02, 2003-10-22 23:32
Namespace
enterasys
Source file
ENTERASYS-SERVICE-LEVEL-REPORTING-MIB
Digest
sha256:f8a1a6009855bdc6ba64aabeb7604dd1ca93ae1152ca6d81225bb2202127d73f

Description

This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP-based internets. In particular, it specifies the objects used for managing the results of the service level metrics measurements.

Contact

Postal: Enterasys Networks 50 Minuteman Rd. Andover, MA 01810-1008 USA Phone: +1 978 684 1000 E-mail: support@enterasys.com WWW: http://www.enterasys.com

Imports

FromSymbols
ENTERASYS-MIB-NAMESetsysModules
INET-ADDRESS-MIBInetAddress, InetAddressType
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, RowStatus, StorageType, TEXTUAL-CONVENTION

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

ENTERASYS-MIB-NAMES
ENTERASYS-SERVICE-LEVEL-REPORTING-MIB
INET-ADDRESS-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Textual conventions

NameOIDSyntaxAccessStatus
EtsysSrvcLvlOwnerString
TEXTUAL-CONVENTION
An OwnerString. The string length is limited to 32 octets.
current
EtsysSrvcLvlStandardMetrics
TEXTUAL-CONVENTION
Each standard metric is identified below. In order to allow for several metrics to be calculated in a single measure, there is a need to describe in a bit string the metrics to be measured. This textual convention defines a BITS construct that gathers in a bit string a sequence of bits. The bit order corresponds to the order of the metric identifiers in the registry. The first bit (most significant bit) of the string has the index 0. The index 1 corresponds to the first metric of the registry (instantaneousUnidirectionalConnectivity ). Example: One-way-Delay(6) is identified as 6. One-way-Packet-Loss(12) is as 12. A network measure performing both One-way-Delay(6) and One-way-Packet-Loss(12) will be described as '0000001000001000'b, '208'B. Below is a list of defined metrics: reserved (0) Setting this reserved bit has no effect. instantUnidirectionConnectivity (1) The identifier for the Type-P-Instantaneous-Unidirectional- Connectivity metric. REFERENCE RFC2678, section 2. instantBidirectionConnectivity (2) The identifier for the Type-P-Instantaneous-Bidirectional- Connectivity metric. REFERENCE RFC2678, section 3. intervalUnidirectionConnectivity (3) The identifier for the Type-P-Interval-Unidirectional- Connectivity metric. REFERENCE RFC2678, section 4. intervalBidirectionConnectivity (4) The identifier for the Type-P-Interval-Bidirectional- Connectivity metric. REFERENCE RFC2678, section 5. intervalTemporalConnectivity (5) The identifier for the Type-P1-P2-Interval-Temporal- Connectivity metric. REFERENCE RFC2678, section 6. oneWayDelay (6) The identifier for the Type-P-One-way-Delay metric. REFERENCE RFC2679, section 3. oneWayDelayPoissonStream (7) The identifier for the Type-P-One-way-Delay-Poisson-Stream metric. REFERENCE RFC2679, section 4. oneWayDelayPercentile (8) The identifier for the Type-P-One-way-Delay-Percentile metric. REFERENCE RFC2679, section 5.1. oneWayDelayMedian (9) The identifier for the Type-P-One-way-Delay-Median metric. REFERENCE RFC2679, section 5.2. oneWayDelayMinimum (10) The identifier for the Type-P-One-way-Delay-Minimum metric. REFERENCE RFC2679, section 5.3. oneWayDelayInversePercentile (11) The identifier for the Type-P-One-way-Delay-Inverse- Percentile metric. REFERENCE RFC2679, section 5.4. oneWayPacketLoss (12) The identifier for the Type-P-One-way-Packet-Loss metric. REFERENCE RFC2680, section 2. oneWayPacketLossPoissonStream (13) The identifier for the Type-P-One-way-Packet-Loss-Poisson- Stream metric. REFERENCE RFC2680, section 3. oneWayPacketLossAverage (14) The identifier for the Type-P-One-way-Packet-Loss-Average metric. REFERENCE RFC2680, section 4. roundtripDelay (15) The identifier for the Type-P-Round-trip-Delay metric. REFERENCE section 2 of the rfc2681. roundtripDelayPoissonStream (16) The identifier for the Type-P-Round-trip-Delay-Poisson-Stream metric. REFERENCE RFC2681, section 4. roundtripDelayPercentile (17) The identifier for the Type-P-Round-trip-Delay-Percentile metric. REFERENCE RFC2681, section 4.1. roundtripDelayMedian (18) The identifier for the Type-P-Round-trip-Delay-Median metric. REFERENCE RFC2681, section 4.2. roundtripDelayMinimum (19) The identifier for the Type-P-Round-trip-Delay-Minimum metric. REFERENCE RFC2681, section 4.3. roundtripDelayInversePercentile (20) The identifier for the Type-P-Round-trip-Inverse-Percentile metric. REFERENCE RFC2681, section 4.4. oneWayLossDistanceStream (21) The identifier for the Type-P-One-Way-Loss-Distance-Stream metric. REFERENCE RFC3357, section 5.4.1. oneWayLossPeriodStream (22) The identifier for the Type-P-One-Way-Loss-Period-Stream metric. REFERENCE RFC3357, section 5.4.2. oneWayLossNoticeableRate (23) The identifier for the Type-P-One-Way-Loss-Noticeable-Rate metric. REFERENCE RFC3357, section 6.1. oneWayLossPeriodTotal (24) The identifier for the Type-P-One-Way-Loss-Period-Total metric. REFERENCE RFC3357, section 6.2. oneWayLossPeriodLengths (25) The identifier for the Type-P-One-Way-Loss-Period-Lengths metric. REFERENCE RFC3357, section 6.3. oneWayInterLossPeriodLengths (26) The identifier for the Type-P-One-Way-Inter-Loss-Period- Lengths metric. REFERENCE RFC3357, section 6.4. oneWayIpdv (27) The identifier for the Type-P-One-way-ipdv metric. REFERENCE RFC3393, section 2. oneWayIpdvPoissonStream (28) The identifier for the Type-P-One-way-ipdv-Poisson-stream metric. REFERENCE RFC3393, section 3. oneWayIpdvPercentile (29) The identifier for the Type-P-One-way-ipdv-percentile metric. REFERENCE RFC3393, section 4.3. oneWayIpdvInversePercentile (30) The identifier for the Type-P-One-way-ipdv-inverse-percentile metric. REFERENCE RFC3393, section 4.4. oneWayIpdvJitter (31) The identifier for the Type-P-One-way-ipdv-jitter metric. REFERENCE RFC3393, section 4.5. oneWayPeakToPeakIpdv (32) The identifier for the Type-P-One-way-peak-to-peak-ipdv metric. REFERENCE RFC3393, section 4.6. oneWayDelayPeriodicStream (33) The identifier for the Type-P-One-way-Delay-Periodic-Stream metric. REFERENCE RFC3432, section 4. roundtripDelayAverage (34) The identifier for the Type-P-Round-trip-Delay-Average metric. roundtripPacketLoss (35) The identifier for the Type-P-Round-trip-Packet-Loss metric. roundtripPacketLossAverage (36) The identifier for the Type-P-Round-trip-Packet-Loss-Average metric. roundtripIpdv (37) The identifier for the Type-P-Round-trip-ipdv metric.
current
GMTTimeStamp
TEXTUAL-CONVENTION
The value at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. field octets contents range ----- ------ -------- ----- 1 1-4 second since 1 Jan 2000 0H00* 0..2^31 - 1 2 5-8 fractional part of the second* 0..2^32 - 1 * the value is in network-byte order The timestamp format is directly inspired from the NTP timestamp format. It differs because it counts the second since 1 Jan 2000 0H00 instead of 1 Jan 1900 0H00. The most significant bit of the part that represents the second is reserved. It will wrap in year 2068 (The NTP timestamp will wrap in year 2036). This bit is set to indicate if the fractional part of the second contains a precision field and a synchronization field. When this bit is not set the resolution is maximal. The maximal resolution is close to 250 picoseconds. The precision of the timestamp is provided in etsysSrvcLvlSystemClockResolution.
current
TimeUnit
TEXTUAL-CONVENTION
A enumerated list of time units.
current
TypeP
TEXTUAL-CONVENTION
This textual convention is a display string used to describe the protocol encapsulation list of a packet, and is used as the value of the SYNTAX clause for the type of the Src and Dst of a measure. The RFC2895 specifies a macro named PROTOCOL-IDENTIFIER for the definition of protocol identifiers, while its companion document, the RFC2896 defines a set of protocol identifiers. TypeP is defined as a display string. It consists of a list of dot separated protocol names. Each protocol name has been previously defined using the macro PROTOCOL-IDENTIFIER of the RFC 2895. Examples: The RFC2896 defines the protocol identifiers 'ether2', 'ip', 'ipip4', 'udp', 'tcp', 'telnet'... The TypeP of the source address corresponding to telnet is the string 'ip.tcp.telnet'. The TypeP of the source address corresponding to UDP packets sent in an IP tunnel is the string 'ip.ipip4.udp'. Note: A performance measure is active, so generally a TypeP value does not describe the link layer (i.e. ether2...). Valid Internet packets are sent from Src to Dst. Then the choice of the link layer relies on the Internet stack.
current
TypePaddress
TEXTUAL-CONVENTION
This textual convention is a Display string used to describe the parameters of the protocol encapsulation list of a packet, basically the address. TypePaddress is defined as a display string. It consists in a list of space separated parameter list. Each parameter in the list corresponds to a parameter of a PROTOCOL-IDENTIFIER of the TypeP. Example: The TypeP 'ip.ipip4' has 2 parameters. A valid TypePaddress value is '192.168.1.1 128.2.6.7'.
current

Objects

NameOIDSyntaxAccessStatus
etsysSrvcLvlConfigObjects
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.1
etsysSrvcLvlSystem
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.1.1
etsysSrvcLvlSystemTime
OBJECT-TYPE
The current time of the system.
1.3.6.1.4.1.5624.1.2.39.1.1.1GMTTimeStampread-onlycurrent
etsysSrvcLvlSystemClockResolution
OBJECT-TYPE
etsysSrvcLvlSystemClockResolution provides the precision of the clock used for the measures . The unit is the picosecond. For example, the clock on an old Unix host might advance only once every msec, and thus have a resolution of 1 msec. So its resolution is 1,000,000,000 picosecond and the value of etsysSrvcLvlSystemClockResolution is 1000000000.
1.3.6.1.4.1.5624.1.2.39.1.1.2Integer32read-onlycurrent
etsysSrvcLvlMetricTable
OBJECT-TYPE
This table is mandatory. It describes the current implementation. Each defined metric must be described in the table. etsysSrvcLvlMetricTable content is read only.
1.3.6.1.4.1.5624.1.2.39.1.1.3not-accessiblecurrent
etsysSrvcLvlMetricEntry
OBJECT-TYPE
An entry describes the static capabilities of a metric implementation.
1.3.6.1.4.1.5624.1.2.39.1.1.3.1not-accessiblecurrent
etsysSrvcLvlMetricIndex
OBJECT-TYPE
etsysSrvcLvlMetricIndex defines an unambiguous index for each standardized metric. It identifies a metric. Its value is defined above. This value is the same in any implementation of the ENTERASYS-SERVICE-LEVEL-REPORTING-MIB. See EtsysSrvcLvlStandardMetrics for description of the metrics. Example: onewayPacketLossAverage is defined as the 14. Consequently the index of the metric onewayPacketLossAverage in the EtsysSrvcLvlMetricTable will always be '14'
1.3.6.1.4.1.5624.1.2.39.1.1.3.1.1INTEGER {instantUnidirectionConnectivity(1), instantBidirectionConnectivity(2), intervalUnidirectionConnectivity(3), intervalBidirectionConnectivity(4), intervalTemporalConnectivity(5), oneWayDelay(6), oneWayDelayPoissonStream(7), oneWayDelayPercentile(8), oneWayDelayMedian(9), oneWayDelayMinimum(10), oneWayDelayInversePercentile(11), oneWayPacketLoss(12), oneWayPacketLossPoissonStream(13), oneWayPacketLossAverage(14), roundtripDelay(15), roundtripDelayPoissonStream(16), roundtripDelayPercentile(17), roundtripDelayMedian(18), roundtripDelayMinimum(19), roundtripDelayInversePercentile(20), oneWayLossDistanceStream(21), oneWayLossPeriodStream(22), oneWayLossNoticeableRate(23), oneWayLossPeriodTotal(24), oneWayLossPeriodLengths(25), oneWayInterLossPeriodLengths(26), oneWayIpdv(27), oneWayIpdvPoissonStream(28), oneWayIpdvPercentile(29), oneWayIpdvInversePercentile(30), oneWayIpdvJitter(31), oneWayPeakToPeakIpdv(32), oneWayDelayPeriodicStream(33), roundtripDelayAverage(34), roundtripPacketLoss(35), roundtripPacketLossAverage(36), roundtripIpdv(37)}not-accessiblecurrent
etsysSrvcLvlMetricCapabilities
OBJECT-TYPE
A value of notImplemented implies the metric is not implemented. A value of implemented implies the metric is implemented.
1.3.6.1.4.1.5624.1.2.39.1.1.3.1.2INTEGER {notImplemented(0), implemented(1)}read-onlycurrent
etsysSrvcLvlMetricType
OBJECT-TYPE
Indicates the metric type, whether it is network or aggregated
1.3.6.1.4.1.5624.1.2.39.1.1.3.1.3INTEGER {network(0), aggregated(1)}read-onlycurrent
etsysSrvcLvlMetricUnit
OBJECT-TYPE
The unit used in the current entity for the results of the measurement of this metric.
1.3.6.1.4.1.5624.1.2.39.1.1.3.1.4INTEGER {noUnit(0), second(1), millisecond(2), microsecond(3), nanosecond(4), percentage(5), packet(6), byte(7), kilobyte(8), megabyte(9)}read-onlycurrent
etsysSrvcLvlMetricDescription
OBJECT-TYPE
A textual description of the metric implementation following the exact name of this metric in the registry. For example: oneWayDelay: text .
1.3.6.1.4.1.5624.1.2.39.1.1.3.1.5SnmpAdminStringread-onlycurrent
etsysSrvcLvlOwners
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.1.2
etsysSrvcLvlOwnersTable
OBJECT-TYPE
A management entity wishing to create and activate remote EtsysSrvcLvl measurements in an agent must previously be registered in the etsysSrvcLvlOwnersTable. etsysSrvcLvlOwnersTable content is read-create. It contains at least the owner 'monitor'.
1.3.6.1.4.1.5624.1.2.39.1.2.1not-accessiblecurrent
etsysSrvcLvlOwnersEntry
OBJECT-TYPE
The description of the resources granted to an SNMP application. For example, an instance of etsysSrvcLvlOwnersOwner with an EtsysSrvcLvlOwnerString 'acme', which represents the 14th owner created in etsysSrvcLvlOwnersTable would be named etsysSrvcLvlOwnersEntryOwner.14. Notes: The etsysSrvcLvlOwnersIndex value is a local index managed directly by the agent. The management application must poll to get the next available index value. It is not used in anyway in other tables.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1not-accessiblecurrent
etsysSrvcLvlOwnersIndex
OBJECT-TYPE
An arbitrary index that identifies an entry in the owners table.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.1Integer32 (1..65535)not-accessiblecurrent
etsysSrvcLvlOwnersOwner
OBJECT-TYPE
The owner described by this entry.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.2EtsysSrvcLvlOwnerStringread-createcurrent
etsysSrvcLvlOwnersGrantedMetrics
OBJECT-TYPE
Defines the metrics granted to an owner for which measurements can be performed.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.3EtsysSrvcLvlStandardMetricsread-createcurrent
etsysSrvcLvlOwnersQuota
OBJECT-TYPE
The maximum number of records that this owner may have in the history table.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.4Integer32read-createcurrent
etsysSrvcLvlOwnersIpAddressType
OBJECT-TYPE
The IP address type of the management entity corresponding to this owner. InetAddressType is restricted to ipv4(1),ipv6(2)and dns(16).
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.5InetAddressTyperead-createcurrent
etsysSrvcLvlOwnersIpAddress
OBJECT-TYPE
The IP address of the management entity corresponding to this owner.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.6InetAddress (SIZE(1..128))read-createcurrent
etsysSrvcLvlOwnersEmail
OBJECT-TYPE
The email address of the management entity corresponding to this owner.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.7SnmpAdminStringread-createcurrent
etsysSrvcLvlOwnersSMS
OBJECT-TYPE
The SMS phone number of the management entity corresponding to this owner.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.8SnmpAdminStringread-createcurrent
etsysSrvcLvlOwnersStatus
OBJECT-TYPE
The status of this table entry.
1.3.6.1.4.1.5624.1.2.39.1.2.1.1.9RowStatusread-createcurrent
etsysSrvcLvlHistory
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.1.3
etsysSrvcLvlHistoryTable
OBJECT-TYPE
The table containing the measurement results.
1.3.6.1.4.1.5624.1.2.39.1.3.1not-accessiblecurrent
etsysSrvcLvlHistoryEntry
OBJECT-TYPE
An etsysSrvcLvlHistoryEntry entry is one of the results of a measure identified by etsysSrvcLvlHistoryMeasureOwner, etsysSrvcLvlHistoryMeasureIndex, etsysSrvcLvlHistoryMetricIndex and etsysSrvcLvlHistoryIndex. In the index : + etsysSrvcLvlHistoryMeasureOwner identifies the owner of the measure + etsysSrvcLvlHistoryMeasureIndex identifies the measure in the owner namespace + etsysSrvcLvlHistoryMetricIndex identifies the metric measured by the measure. The metric is described in the corresponding entry of the n etsysSrvcLvlMetricTable + etsysSrvcLvlHistoryIndex is the local index of the result on the history table.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1not-accessiblecurrent
etsysSrvcLvlHistoryMeasureOwner
OBJECT-TYPE
The owner of the measure that produced this result.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.1EtsysSrvcLvlOwnerStringnot-accessiblecurrent
etsysSrvcLvlHistoryMeasureIndex
OBJECT-TYPE
The index (in owner's namespace) of the measure that produced this result.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.2Integer32 (1..65535)not-accessiblecurrent
etsysSrvcLvlHistoryMetricIndex
OBJECT-TYPE
etsysSrvcLvlHistoryMetricIndex identifies the metric measured by the measure. The metric is described in the corresponding entry of the etsysSrvcLvlMetricTable.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.3Integer32 (1..65535)not-accessiblecurrent
etsysSrvcLvlHistoryIndex
OBJECT-TYPE
A local index that identifies a result in the history table.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.4Integer32 (1..65535)not-accessiblecurrent
etsysSrvcLvlHistorySequence
OBJECT-TYPE
etsysSrvcLvlHistorySequence is the sequence index of the measurement results for a metric. Network metrics: It's the sequence index of a measurement packet. Typically, it identifies the order of the packet in the stream of packets sends by the source. Aggregated metrics: It is the sequence index of the computed aggregated metric result.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.5Integer32 (0..65535)read-onlycurrent
etsysSrvcLvlHistoryTimestamp
OBJECT-TYPE
The timestamp when the measurement occurred.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.6GMTTimeStampread-onlycurrent
etsysSrvcLvlHistoryValue
OBJECT-TYPE
The observed value of the measurement.
1.3.6.1.4.1.5624.1.2.39.1.3.1.1.7Integer32read-onlycurrent
etsysSrvcLvlMeasure
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.1.4
etsysSrvcLvlNetMeasureTable
OBJECT-TYPE
An entry is a measurement that performs network measures and provides results. It performs several metric measurements per packet exchange. Each step of a measure produces a singleton result per metric. The time of the measurement and the value of the metric are saved in the etsysSrvcLvlHistoryTable.
1.3.6.1.4.1.5624.1.2.39.1.4.1not-accessiblecurrent
etsysSrvcLvlNetMeasureEntry
OBJECT-TYPE
The EtsysSrvcLvlNetMeasureTable is mandatory. The etsysSrvcLvlNetMeasureMetrics is set to a list of metrics to be computed from the same raw packet exchange. Each step of measurement delivers a singleton per chosen metric. Results are timestamped and saved in the etsysSrvcLvlHistoryTable. The etsysSrvcLvlNetMeasureTable typical usage consists in providing network measure indices in order to allow aggregated measures to perform aggregation on the results of network measures.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1not-accessiblecurrent
etsysSrvcLvlNetMeasureOwner
OBJECT-TYPE
The owner of the network measurement.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.1EtsysSrvcLvlOwnerStringnot-accessiblecurrent
etsysSrvcLvlNetMeasureIndex
OBJECT-TYPE
The index (in owner's namespace) of the network measure.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.2Integer32 (1..65535)not-accessiblecurrent
etsysSrvcLvlNetMeasureName
OBJECT-TYPE
The name of the metric instance. It illustrates the specificity of the metric and includes the metric and the TypeP. Example: IP-TCP-HTTP-One-way-Delay: free text
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.3SnmpAdminStringread-writecurrent
etsysSrvcLvlNetMeasureMetrics
OBJECT-TYPE
Defines the metrics to compute within this measure. ONLY network metrics of the same type are allowed in this field. A measure may be configured for the result of different metric singletons to be archived in the etsysSrvcLvlHistoryTable. The etsysSrvcLvlMetricIndex of the created result has the value of the bit index of the corresponding etsysSrvcLvlMeasureMetrics as explained above in the etsysSrvcLvlMetricIndex definition. Example: A measure asking for One-way-Delay(6) and One-way-Packet-Loss(12) generated a flow of singletons which are logged in the etsysSrvcLvlHistoryTable. The singletons created for the One-way-Delay measure have a value of etsysSrvcLvlMetricIndex of 6 while the created singletons for the One-way-Packet-Loss measure have a value of etsysSrvcLvlMetricIndex of 12. One measure may perform simultaneously either several network metrics either several aggregated metrics
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.4EtsysSrvcLvlStandardMetricsread-writecurrent
etsysSrvcLvlNetMeasureBeginTime
OBJECT-TYPE
Specifies the time at which the measurement begins.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.5GMTTimeStampread-writecurrent
etsysSrvcLvlNetMeasureDurationUnit
OBJECT-TYPE
Specifies the measurement duration unit.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.6TimeUnitread-writecurrent
etsysSrvcLvlNetMeasureDuration
OBJECT-TYPE
Specifies the measurement duration.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.7Integer32read-writecurrent
etsysSrvcLvlNetMeasureHistorySize
OBJECT-TYPE
Specifies the maximum number of results saved for each metric of this measure. Overflow condition will be managed by the object etsysSrvcLvlNetMeasureResultsMgmt.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.8Integer32read-writecurrent
etsysSrvcLvlNetMeasureFailureMgmtMode
OBJECT-TYPE
This object defines whether this row is discarded on failure. 'auto' the failure is handled automatically depending on the implementation. 'manual' the entry should be discarded manually. 'discarded' the entry is discarded all the time.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.9INTEGER {auto(1), manual(2), discarded(3)}read-writecurrent
etsysSrvcLvlNetMeasureResultsMgmt
OBJECT-TYPE
Action to take when the log is full. The user may choose to either wrap, in which case the agent writes over existing records. The user may choose to suspend writing to the log in the event that he wishes to archive the data. The delete action causes the agent to begin to write in the log, and assumes the data has been cleared. This object indicates the way the measurement results are managed when the owner quota has been exceeded: 'wrap' continue the measurement and erase the older entries in the history. 'suspend' stop the measure and keep the results in the history. 'delete' remove the results from the history.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.10INTEGER {wrap(1), suspend(2), delete(3)}read-writecurrent
etsysSrvcLvlNetMeasureSrcTypeP
OBJECT-TYPE
Defines the type P of the source address of the packets sent by the measure.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.11TypePread-writecurrent
etsysSrvcLvlNetMeasureSrc
OBJECT-TYPE
Specifies the address of the source of the measure. It is represented as a list of parameters corresponding to those of the PROTOCOL IDENTIFIER sets in etsysSrvcLvlNetMeasureSrcTypeP.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.12TypePaddressread-writecurrent
etsysSrvcLvlNetMeasureDstTypeP
OBJECT-TYPE
Defines the type P of the destination address of the packets sent by the measure.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.13TypePread-writecurrent
etsysSrvcLvlNetMeasureDst
OBJECT-TYPE
Specifies the address of the destination of the measure. It is represented as a list of parameters corresponding to those of the PROTOCOL IDENTIFIER set in etsysSrvcLvlNetMeasureDstTypeP.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.14TypePaddressread-writecurrent
etsysSrvcLvlNetMeasureTxMode
OBJECT-TYPE
The transmit mode used to send the packets: 'other' The rule used to send the packets is unknown. 'periodic' Packets are sent periodically at etsysSrvcLvlNetMeasureTxPacketRate rate. 'poisson' Packets are sent using a Poisson law, the median is the value of etsysSrvcLvlNetMeasureMedOrIntBurstSize, the deviation is etsysSrvcLvlNetMeasureDevtnOrBurstSize. 'multiburst' Packets are sent bursty at etsysSrvcLvlNetMeasureTxPacketRate. The size of the burst is made of etsysSrvcLvlNetMeasureDevtnOrBurstSize packets.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.15INTEGER {other(0), periodic(1), poisson(2), multiburst(3)}read-writecurrent
etsysSrvcLvlNetMeasureTxPacketRateUnit
OBJECT-TYPE
The packet rate unit used to send the packets.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.16TimeUnitread-writecurrent
etsysSrvcLvlNetMeasureTxPacketRate
OBJECT-TYPE
The rate the packets are sent.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.17Integer32read-writecurrent
etsysSrvcLvlNetMeasureDevtnOrBurstSize
OBJECT-TYPE
Indicates the average number of packets per seconds sent using a poisson law.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.18Integer32read-writecurrent
etsysSrvcLvlNetMeasureMedOrIntBurstSize
OBJECT-TYPE
According to the transmit mode, this value indicates the average number of packets per seconds sent using a poisson law, or the number of packets to wait between consecutive bursts.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.19Integer32read-writecurrent
etsysSrvcLvlNetMeasureLossTimeout
OBJECT-TYPE
Specifies the delay after which the packet is considered lost by the sink.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.20Integer32read-writecurrent
etsysSrvcLvlNetMeasureL3PacketSize
OBJECT-TYPE
Specifies the size of the packets counted at the IP network layer in regards to the TypeP definition. Example: For a TypeP 'ip ipip4' the L3 size will be the size of the packet at ipip4 level.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.21Integer32read-writecurrent
etsysSrvcLvlNetMeasureDataPattern
OBJECT-TYPE
The pattern used to fill the payload of the packet.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.22OCTET STRINGread-writecurrent
etsysSrvcLvlNetMeasureMap
OBJECT-TYPE
An administrative name of a network management map to which the measure belongs.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.23SnmpAdminStringread-writecurrent
etsysSrvcLvlNetMeasureSingletons
OBJECT-TYPE
Reports the number of singletons performed per metric by the measure since the beginning of the measure. This parameters is required for aggregation.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.24Integer32read-onlycurrent
etsysSrvcLvlNetMeasureOperState
OBJECT-TYPE
Reports the operational status of the network measure.
1.3.6.1.4.1.5624.1.2.39.1.4.1.1.25INTEGER {unknown(0), running(1), stopped(2)}read-onlycurrent
etsysSrvcLvlAggrMeasureTable
OBJECT-TYPE
An aggregated measure summarizes the results of previous network or aggregated measures. The results may be saved in the etsysSrvcLvlHistoryTable. Each step of the calculation for the measure produces a singleton result per metric.
1.3.6.1.4.1.5624.1.2.39.1.4.2not-accessiblecurrent
etsysSrvcLvlAggrMeasureEntry
OBJECT-TYPE
Typically the configuration operation sets the value of the EtsysSrvcLvlAggrMeasureEntry. etsysSrvcLvlAggrMeasureTable is mandatory. The etsysSrvcLvlAggrMeasureMetrics defines the metric to compute. The results of the measure to summarize are identified by: + etsysSrvcLvlAggrMeasureHistoryOwner, + etsysSrvcLvlAggrMeasureHistoryOwnerIndex and + etsysSrvcLvlAggrMeasureHistoryMetric The aggregated task starts at etsysSrvcLvlAggrMeasureBeginTime and ends after etsysSrvcLvlAggrMeasureDuration. An aggregated result is performed and saved in the etsysSrvcLvlHistoryTable for each etsysSrvcLvlAggrMeasureAggrPeriod.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1not-accessiblecurrent
etsysSrvcLvlAggrMeasureOwner
OBJECT-TYPE
The owner who has configured this entry.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.1EtsysSrvcLvlOwnerStringnot-accessiblecurrent
etsysSrvcLvlAggrMeasureIndex
OBJECT-TYPE
The index (in owner's namespace) of the measure. The value is managed by the owner.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.2Integer32 (1..65535)not-accessiblecurrent
etsysSrvcLvlAggrMeasureName
OBJECT-TYPE
The name of the instance of the metric. It illustrates the specificity of the metric and includes the metric and the typeP. example: IP-port-HTTP-connectivity
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.3SnmpAdminStringread-createcurrent
etsysSrvcLvlAggrMeasureMetrics
OBJECT-TYPE
Defines the metrics to compute within this aggregated measure. ONLY aggregated metrics of the same type are allowed in this field. A measure may be configured for the result of different metric singletons to be archived in the etsysSrvcLvlHistoryTable. The etsysSrvcLvlMetricIndex of the created result has the value of the bit index of the corresponding etsysSrvcLvlAggrMeasureMetrics as explained above in the etsysSrvcLvlMetricIndex definition. Example: A measure asking for One-way-Delay(6) and One-way-Packet-Loss(12) generated a flow of singletons which are logged in the etsysSrvcLvlHistoryTable. The singletons created for the One-way-Delay measure have a value of etsysSrvcLvlMetricIndex of 6 while the created singletons for the One-way-Packet-Loss measure have a value of etsysSrvcLvlMetricIndex of 12.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.4EtsysSrvcLvlStandardMetricsread-createcurrent
etsysSrvcLvlAggrMeasureBeginTime
OBJECT-TYPE
Specifies the time at which the aggregated measure starts.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.5GMTTimeStampread-createcurrent
etsysSrvcLvlAggrMeasureAggrPeriodUnit
OBJECT-TYPE
Specifies the unit of the aggregated measure period.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.6TimeUnitread-createcurrent
etsysSrvcLvlAggrMeasureAggrPeriod
OBJECT-TYPE
Specifies the amount of time between 2 measurement action intervals. The action is specific to the semantic of the measure. They are performed periodically on a sequence of results of other measures. The period corresponds to the interval between two successive computations of the metric. The value of etsysSrvcLvlHistoryTimestamp result of a aggregated metric computed corresponds to the value of the etsysSrvcLvlHistoryTimestamp of the last metric result of the sequence used in to compute the aggregated metric.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.7Integer32read-createcurrent
etsysSrvcLvlAggrMeasureDurationUnit
OBJECT-TYPE
Specifies the unit of the measure duration.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.8TimeUnitread-createcurrent
etsysSrvcLvlAggrMeasureDuration
OBJECT-TYPE
Specifies the duration of the measure.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.9Integer32read-createcurrent
etsysSrvcLvlAggrMeasureHistorySize
OBJECT-TYPE
Specifies the maximum number of results saved for each metric of this measure. Overflow condition will be managed by the object etsysSrvcLvlAggrMeasureResultsMgmt.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.10Integer32read-createcurrent
etsysSrvcLvlAggrMeasureStorageType
OBJECT-TYPE
This object defines whether this row and the corresponding entry in the etsysSrvcLvlNetMeasureTable is kept in volatile storage and lost upon reboot or if this row is backed up by non-volatile or permanent storage. Possible values are: other(1), volatile(2), nonVolatile(3), permanent(4), readOnly(5).
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.11StorageTyperead-createcurrent
etsysSrvcLvlAggrMeasureResultsMgmt
OBJECT-TYPE
This object displays the way the history of the aggregated measure is managed. 'wrap' continue the measure and erase the older entries in the history. 'suspend' stop the measure and keep the results in the history.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.12INTEGER {wrap(1), suspend(2)}read-onlycurrent
etsysSrvcLvlAggrMeasureHistoryOwner
OBJECT-TYPE
The owner of the measure to summarize.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.13EtsysSrvcLvlOwnerStringread-createcurrent
etsysSrvcLvlAggrMeasureHistoryOwnerIndex
OBJECT-TYPE
The index (in owner's namespace) of the measure to summarize.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.14Integer32 (1..65535)read-createcurrent
etsysSrvcLvlAggrMeasureHistoryMetric
OBJECT-TYPE
The metric of the measure to summarize.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.15Integer32read-createcurrent
etsysSrvcLvlAggrMeasureAdminState
OBJECT-TYPE
This object controls the activity of the aggregated measure. 'start' The aggregated measure is started. 'stop' The aggregated measure is stopped.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.16INTEGER {start(0), stop(1)}read-createcurrent
etsysSrvcLvlAggrMeasureMap
OBJECT-TYPE
This object allows for classification of the measure. It is typically the name of an administrative map.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.17SnmpAdminStringread-createcurrent
etsysSrvcLvlAggrMeasureStatus
OBJECT-TYPE
The status of this table entry. Once the entry status is set to active, the associate entry cannot be modified. The creation of an aggregated measure forced the creation of the corresponding entry in etsysSrvcLvlNetMeasureTable.
1.3.6.1.4.1.5624.1.2.39.1.4.2.1.18RowStatusread-createcurrent
etsysSrvcLvlReportingConformance
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.2
etsysSrvcLvlReportingGroups
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.2.1
etsysSrvcLvlReportingCompliances
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.39.2.2

Conformance

NameOIDStatus
etsysSrvcLvlSystemGroup
OBJECT-GROUP
The System Group.
1.3.6.1.4.1.5624.1.2.39.2.1.1current
etsysSrvcLvlOwnersGroup
OBJECT-GROUP
The Owners Group.
1.3.6.1.4.1.5624.1.2.39.2.1.2current
etsysSrvcLvlHistoryGroup
OBJECT-GROUP
The History Group.
1.3.6.1.4.1.5624.1.2.39.2.1.3current
etsysSrvcLvlMeasureGroup
OBJECT-GROUP
The Network and Aggregate Measures Group.
1.3.6.1.4.1.5624.1.2.39.2.1.4current
etsysSrvcLvlReportingCompliance
MODULE-COMPLIANCE
The compliance statement for devices that support the etsysSrvcLvlReportingMib.
1.3.6.1.4.1.5624.1.2.39.2.2.1current