MIBs Depot

ENTERASYS-RADIUS-AUTH-CLIENT-MIB

Registered at
1.3.6.1.4.1.5624.1.2.4
Last updated
2011-06-29 17:14
Organization
Enterasys Networks, Inc
Revisions
2011-06-29 17:14, 2009-08-06 18:38, 2005-07-29 13:48, 2004-07-27 19:53, 2003-11-06 18:23, 2002-01-24 15:57, 2000-11-08 00:00
Namespace
enterasys
Source file
ENTERASYS-RADIUS-AUTH-CLIENT-MIB
Digest
sha256:71ce781f84e773f05aec98aacea5a84b4b5a2048ee3560d2aeacb4eab004af4e

Description

The Enterasys Networks Proprietary MIB module for entities implementing the client side of the Remote Access Dialin User Service (RADIUS) authentication protocol (RFC2865). This MIB provides read-write access to configuration objects not provided in the standard RADIUS Authentication Client MIB (RFC2618).

Contact

Postal: Enterasys Networks 50 Minuteman Rd. Andover, MA 01810-1008 USA Phone: +1 978 684 1000 E-mail: support@enterasys.com WWW: http://www.enterasys.com

Imports

FromSymbols
ENTERASYS-MIB-NAMESetsysModules
INET-ADDRESS-MIBInetAddress, InetAddressType
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, RowStatus, TEXTUAL-CONVENTION, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

ENTERASYS-MIB-NAMES
ENTERASYS-RADIUS-AUTH-CLIENT-MIB
INET-ADDRESS-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Objects

NameOIDSyntaxAccessStatus
etsysRadiusAuthClientMIBObjects
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.4.1
etsysRadiusAuthClientRetryTimeout
OBJECT-TYPE
The number of seconds to wait for a RADIUS Server to respond to a request. Maintaining the value of this object across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.1Integer32 (0..2147483647)read-writecurrent
etsysRadiusAuthClientRetries
OBJECT-TYPE
The number of times to resend an authentication packet if a RADIUS Server does not respond to a request. Maintaining the value of this object across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.2Integer32 (0..2147483647)read-writecurrent
etsysRadiusAuthClientEnable
OBJECT-TYPE
Controls and indicates the operational state of the RADIUS client functionality. Maintaining the value of this object across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.3INTEGER {enable(1), disable(2)}read-writecurrent
etsysRadiusAuthClientAuthType
OBJECT-TYPE
This indicates which method is being used for authentication. mac(1) - indicates MAC address authentication eapol(2) - indicates EAPOL authentication This list of enumeration constants is subject to change. This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.4.1.4INTEGER {mac(1), eapol(2)}read-writedeprecated
etsysRadiusAuthServerTable
OBJECT-TYPE
A list of RADIUS servers that this client may attempt to use.
1.3.6.1.4.1.5624.1.2.4.1.5not-accessiblecurrent
etsysRadiusAuthServerEntry
OBJECT-TYPE
A RADIUS server that this client may attempt to use.
1.3.6.1.4.1.5624.1.2.4.1.5.1not-accessiblecurrent
etsysRadiusAuthServerIndex
OBJECT-TYPE
A number uniquely identifying each conceptual row in the etsysRadiusAuthServerTable. This value also indicates the relative priority of the servers. The initial authentication attempt will be against the server with the lowest value of etsysRadiusAuthServerIndex and any successive attempt will be with the next higher value, and so on. Maintaining the value of etsysRadiusAuthServerIndex for all active(1) entries across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.5.1.1Integer32 (1..2147483647)not-accessiblecurrent
etsysRadiusAuthClientServerAddressType
OBJECT-TYPE
This object specifies how etsysRadiusAuthClientServerAddress is encoded. Support for all possible enumerations defined by InetAddressType is NOT REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.5.1.2InetAddressTyperead-createcurrent
etsysRadiusAuthClientServerAddress
OBJECT-TYPE
The encoded unicast IP address or hostname of a RADIUS server. RADIUS requests will be sent to this address. If this address is a DNS hostname, then that hostname SHOULD be resolved into an IP address each time an authentication session is initialized.
1.3.6.1.4.1.5624.1.2.4.1.5.1.3InetAddress (SIZE(1..64))read-createcurrent
etsysRadiusAuthClientServerPortNumber
OBJECT-TYPE
The UDP port number (0-65535) the client will use to send RADIUS requests to this server.
1.3.6.1.4.1.5624.1.2.4.1.5.1.4Integer32 (0..65535)read-createcurrent
etsysRadiusAuthClientServerSecret
OBJECT-TYPE
This object is the secret shared between the RADIUS authentication server and the RADIUS client. On a read operation this object MUST return a zero length string. Writing this object with a zero length string clears the secret.
1.3.6.1.4.1.5624.1.2.4.1.5.1.5OCTET STRING (SIZE(0..255))read-createcurrent
etsysRadiusAuthClientServerSecretEntered
OBJECT-TYPE
true(1) - Indicates that etsysRadiusAuthClientServerSecret was last set with some value other than the empty string. false(2) - Indicates that etsysRadiusAuthClientServerSecret has never been set, or was last set to the empty string.
1.3.6.1.4.1.5624.1.2.4.1.5.1.6TruthValueread-onlycurrent
etsysRadiusAuthClientServerClearTime
OBJECT-TYPE
The number of seconds elapsed since the counters were last cleared. Writing the value zero will cause the servers counters to be cleared and the clear time will be set to zero. Writing any value other than zero will have no effect.
1.3.6.1.4.1.5624.1.2.4.1.5.1.7Integer32 (1..2147483647)read-createdeprecated
etsysRadiusAuthClientServerStatus
OBJECT-TYPE
The row status of this conceptual row in the table. active - The server is available for performing RADIUS operations. Other writable leaves in this row MUST NOT be modified while the row is in the active state. notInService - The entry is fully configured but is not available for performing RADIUS operations. Conceptual rows with this status MAY be deleted at the discretion of the agent, at which time it will be treated as if destroy(6) was SET to this object. notReady - The entry exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instantiated); createAndGo - Not possible. createAndWait - Creates a new instance of a conceptual row, but does not make it available for use by the managed device. destroy - This will remove the conceptual row from the table and make it unavailable for RADIUS client operations. This MUST also cause any persistent data related to this row to be removed from the system. Maintaining active(1) entries across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.5.1.8RowStatusread-createcurrent
etsysRadiusAuthClientServerRealmType
OBJECT-TYPE
This object allows a server to be restricted to providing authentication services to certain classes of access methods. any(1) - the server will be available to authenticate users originating from any of the access methods. mgmtAccess(2) - the server will only be available for authenticating users that have requested management access via the console, telnet, SSH, HTTP, etc. networkAccess(3) - the server will only be available for authenticating users that are attempting to gain access to the network via 802.1X, Port Web Authentication, MAC Authentication, etc. Non-default values for this object should be used when there is a desire to have one set of servers used for authenticating management access requests and a different set used for authenticating network access requests. When this object has the value of any(1) then the associated server will be in each set. The precedence order defined by the relative value of the etsysRadiusAuthServerIndex will be maintained within each set of servers.
1.3.6.1.4.1.5624.1.2.4.1.5.1.9INTEGER {any(1), mgmtAccess(2), networkAccess(3)}read-createcurrent
etsysRadiusAuthClientServerTimeout
OBJECT-TYPE
The number of seconds to wait for a RADIUS Server to respond to a request. A value of -1 indicates that the server timeout specified by etsysRadiusAuthClientRetryTimeout should be used for this server. Maintaining the value of this object across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.5.1.10Integer32 (-1 | 1..60)read-createcurrent
etsysRadiusAuthClientServerRetries
OBJECT-TYPE
The number of times to resend an authentication packet if a RADIUS Server does not respond to a request. A value of -1 indicates that the server retries specified by etsysRadiusAuthClientRetries should be used for this server. Maintaining the value of this object across agent reboots is REQUIRED.
1.3.6.1.4.1.5624.1.2.4.1.5.1.11Integer32 (-1 | 1..10)read-createcurrent
etsysRadiusAuthClientAttrMgmtPassword
OBJECT-TYPE
This value indicates which method is being used to send management access passwords to the RADIUS server. standard(1) - Use the User-Password attribute at defined in RFC2865 mschapv2(2) - Use the MS-CHAP2-Response attribute as defined in RFC2548 This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.4.1.6INTEGER {standard(1), mschapv2(2)}read-writecurrent
etsysRadiusAuthClientMIBConformance
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.4.2
etsysRadiusAuthClientMIBCompliances
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.4.2.1
etsysRadiusAuthClientMIBGroups
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.4.2.2

Conformance

NameOIDStatus
etsysRadiusClientMIBCompliance
MODULE-COMPLIANCE
The compliance statement for authentication clients implementing the RADIUS Authentication Client MIB.
1.3.6.1.4.1.5624.1.2.4.2.1.1deprecated
etsysRadiusClientMIBComplianceV2
MODULE-COMPLIANCE
The compliance statement for authentication clients implementing the RADIUS Authentication Client MIB.
1.3.6.1.4.1.5624.1.2.4.2.1.2deprecated
etsysRadiusClientMIBComplianceV3
MODULE-COMPLIANCE
The compliance statement for authentication clients implementing the RADIUS Authentication Client MIB.
1.3.6.1.4.1.5624.1.2.4.2.1.3deprecated
etsysRadiusClientMIBComplianceV4
MODULE-COMPLIANCE
The compliance statement for authentication clients implementing the RADIUS Authentication Client MIB.
1.3.6.1.4.1.5624.1.2.4.2.1.4current
etsysRadiusAuthClientMIBGroup
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. This MIB provides read-write access to configuration objects not provided in the standard RADIUS Authentication Client MIB (RFC2618).
1.3.6.1.4.1.5624.1.2.4.2.2.1deprecated
etsysRadiusAuthClientMIBGroupV2
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. This MIB provides read-write access to configuration objects not provided in the standard RADIUS Authentication Client MIB (RFC2618).
1.3.6.1.4.1.5624.1.2.4.2.2.2deprecated
etsysRadiusAuthClientMIBGroupV3
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. This MIB provides read-write access to configuration objects not provided in the standard RADIUS Authentication Client MIB (RFC2618).
1.3.6.1.4.1.5624.1.2.4.2.2.3deprecated
etsysRadiusAuthClientMIBGroupV4
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. This MIB provides read-write access to configuration objects not provided in the standard RADIUS Authentication Client MIB (RFC2618).
1.3.6.1.4.1.5624.1.2.4.2.2.4current