MIBs Depot

ENTERASYS-RADIUS-ACCT-CLIENT-EXT-MIB

Registered at
1.3.6.1.4.1.5624.1.2.27
Last updated
2009-08-07 15:48
Organization
Enterasys Networks
Revisions
2009-08-07 15:48, 2004-11-12 15:23, 2004-09-09 14:37, 2004-08-30 15:55, 2004-08-25 15:03, 2002-09-13 19:30
Namespace
enterasys
Source file
ENTERASYS-RADIUS-ACCT-CLIENT-EXT-MIB
Digest
sha256:d902ad0bbaa4892b4deb4ddd65859cdb44c17da232b1a44760a060d003675b59

Description

This MIB module defines a portion of the SNMP enterprise MIBs under Enterasys Networks' enterprise OID pertaining to the client side of the Remote Access Dialin User Service (RADIUS) Accounting protocol (RFC2866). This MIB provides read-write access to configuration objects not provided in the standard RADIUS Accounting Client MIB (RFC2620). However, the write capability must only be supported for SNMPv3, or other SNMP versions with adequately strong security. Security concerns include Object ID verification, source address verification and timeliness verification.

Contact

Postal: Enterasys Networks 50 Minuteman Rd. Andover, MA 01810-1008 USA Phone: +1 978 684 1000 E-mail: support@enterasys.com WWW: http://www.enterasys.com

Imports

FromSymbols
ENTERASYS-MIB-NAMESetsysModules
INET-ADDRESS-MIBInetAddress, InetAddressType
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIInteger32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, RowStatus, TEXTUAL-CONVENTION, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

ENTERASYS-MIB-NAMES
ENTERASYS-RADIUS-ACCT-CLIENT-EXT-MIB
INET-ADDRESS-MIB
SNMPv2-CONF
SNMPv2-SMI
SNMPv2-TC

Objects

NameOIDSyntaxAccessStatus
etsysRadiusAcctClientMIBObjects
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.27.1
etsysRadiusAcctClientEnable
OBJECT-TYPE
This object indicates whether or not RADIUS Accounting is enabled or disabled. This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.27.1.1INTEGER {enable(1), disable(2)}read-writecurrent
etsysRadiusAcctClientUpdateInterval
OBJECT-TYPE
This indicates how many seconds elapse between accounting interim updates. This parameter value is maintained across system reboots. A value of zero means no Interim Updates. If the value is less than etsysRadiusAcctClientIntervalMinimum, the etsysRadiusAcctClientIntervalMinimum value will be used for the update interval time. If RADIUS Accounting is not enabled, this object is ignored. Note that Accounting Interim Updates are not issued by the RADIUS Accounting Client, unless so requested by the RADIUS Server in an Access Accept packet.
1.3.6.1.4.1.5624.1.2.27.1.2Integer32 (0..2147483647)read-writecurrent
etsysRadiusAcctClientIntervalMinimum
OBJECT-TYPE
This indicates the minimum value in seconds between accounting interim updates supported by the managed entity. This parameter value is maintained across system reboots. If RADIUS Accounting is not enabled, this object is ignored.
1.3.6.1.4.1.5624.1.2.27.1.3Integer32 (60..2147483647)read-writecurrent
etsysRadiusAcctClientServerTable
OBJECT-TYPE
The (conceptual) table listing the RADIUS Accounting servers.
1.3.6.1.4.1.5624.1.2.27.1.4not-accessiblecurrent
etsysRadiusAcctClientServerEntry
OBJECT-TYPE
An entry (conceptual row) representing a RADIUS Accounting server with which the client shares a secret. If RADIUS Accounting is not enabled, this table is ignored. All created conceptual rows are non-volatile and as such must be maintained upon restart of the agent.
1.3.6.1.4.1.5624.1.2.27.1.4.1not-accessiblecurrent
etsysRadiusAcctClientServerIndex
OBJECT-TYPE
A number uniquely identifying each conceptual row in the etsysRadiusAcctClientServerTable. In the event of an agent restart, the same value of etsysRadiusAcctClientServerIndex must be used to identify each conceptual row in etsysRadiusAcctClientServerTable as was used prior to the restart.
1.3.6.1.4.1.5624.1.2.27.1.4.1.1Integer32 (1..2147483647)not-accessiblecurrent
etsysRadiusAcctClientServerAddressType
OBJECT-TYPE
The type of Internet address by which the RADIUS Accounting server is reachable.
1.3.6.1.4.1.5624.1.2.27.1.4.1.2InetAddressTyperead-createcurrent
etsysRadiusAcctClientServerAddress
OBJECT-TYPE
The Internet address for the RADIUS Accounting server. Note that implementations must limit themselves to a single entry in this table per reachable server. The etsysRadiusAcctClientServerAddress may not be empty due to the SIZE restriction. Also the size of a DNS name is limited to 64 characters. This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.27.1.4.1.3InetAddress (SIZE(1..64))read-createcurrent
etsysRadiusAcctClientServerPortNumber
OBJECT-TYPE
The UDP port number (1-65535) the client is using to send requests to this server. The officially assigned port number for RADIUS Accounting is 1813. This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.27.1.4.1.4Integer32 (1..65535)read-createcurrent
etsysRadiusAcctClientServerSecret
OBJECT-TYPE
This object is the secret shared between the RADIUS Accounting server and RADIUS client. This parameter value is maintained across system reboots. While the 'official' MAX-ACCESS for this object is read-create, all security-conscious implementations will 'lie' on a read, and return a null-string, or something else that is fairly innocuous. The ability to read back passwords and secret encryption keys is generally a Bad Thing (tm).
1.3.6.1.4.1.5624.1.2.27.1.4.1.5OCTET STRING (SIZE(0..255))read-createcurrent
etsysRadiusAcctClientServerSecretEntered
OBJECT-TYPE
This indicates the existence of a shared secret.
1.3.6.1.4.1.5624.1.2.27.1.4.1.6TruthValueread-onlycurrent
etsysRadiusAcctClientServerRetryTimeout
OBJECT-TYPE
The number of seconds to wait for a RADIUS Accounting Server to respond to a request. This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.27.1.4.1.7Integer32 (2..10)read-createcurrent
etsysRadiusAcctClientServerRetries
OBJECT-TYPE
The number of times to resend an accounting packet if a RADIUS Accounting Server does not respond to a request. This parameter value is maintained across system reboots.
1.3.6.1.4.1.5624.1.2.27.1.4.1.8Integer32 (0..20)read-createcurrent
etsysRadiusAcctClientServerClearTime
OBJECT-TYPE
On a read, this value indicates the number of seconds since the counters, as defined in the IETF standard RADIUS Accounting Client MIB (RFC2618), were cleared. On a write, the client counters will be cleared and the clear time will be set to zero.
1.3.6.1.4.1.5624.1.2.27.1.4.1.9Integer32 (1..2147483647)read-createdeprecated
etsysRadiusAcctClientServerStatus
OBJECT-TYPE
Lets users create and delete RADIUS Accounting server entries on systems that support this capability. Rules 1. When creating a RADIUS Accounting Client, it is up to the management station to determine a suitable etsysRadiusAcctClientServerIndex. To facilitate interoperability, agents should not put any restrictions on the etsysRadiusAcctClientServerIndex beyond the obvious ones that it be valid and unused. 2. Before a new row can become 'active', values must be supplied for the columnar objects etsysRadiusAcctClientClientServerAddress, and etsysRadiusAcctClientServerSecret. 3. The value of etsysRadiusAcctClientServerStatus must be set to 'notInService' in order to modify a writable object in the same conceptual row. 4. etsysRadiusAcctClientServer entries whose status is 'notReady' or 'notInService' will not be used for Accounting.
1.3.6.1.4.1.5624.1.2.27.1.4.1.10RowStatusread-createcurrent
etsysRadiusAcctClientServerUpdateInterval
OBJECT-TYPE
This indicates how many seconds elapse between accounting interim updates from the client to this RADIUS server. This parameter value is maintained across system reboots. A value of zero means no Interim Updates. If the value is less than etsysRadiusAcctClientServerIntervalMinimum, the etsysRadiusAcctClientServerIntervalMinimum value will be used for the update interval time. If RADIUS Accounting is not enabled, this object is ignored. Note that Accounting Interim Updates are not issued by the RADIUS Accounting Client, unless so requested by the RADIUS Server in an Access Accept packet. A value of -1 indicates that this object is not configured and this device will use the value configured in etsysRadiusAcctClientUpdateInterval for the minimum value in seconds between accounting interim updates for this RADIUS server.
1.3.6.1.4.1.5624.1.2.27.1.4.1.11Integer32 (-1 | 0..2147483647)read-createcurrent
etsysRadiusAcctClientServerIntervalMinimum
OBJECT-TYPE
This indicates the minimum value in seconds between accounting interim updates supported by the managed entity for this RADIUS server. This parameter value is maintained across system reboots. If RADIUS Accounting is not enabled, this object is ignored. A value of -1 indicates that this object is not configured and this device will use the value configured in etsysRadiusAcctClientIntervalMinimum for the minimum value in seconds between accounting interim updates for this RADIUS server.
1.3.6.1.4.1.5624.1.2.27.1.4.1.12Integer32 (-1 | 60..2147483647)read-createcurrent
etsysRadiusAcctClientMIBConformance
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.27.2
etsysRadiusAcctClientMIBCompliances
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.27.2.1
etsysRadiusAcctClientMIBGroups
OBJECT-IDENTITY
1.3.6.1.4.1.5624.1.2.27.2.2

Conformance

NameOIDStatus
etsysRadiusAcctClientMIBCompliance
MODULE-COMPLIANCE
The compliance statement for Accounting clients implementing the RADIUS Accounting Client MIB.
1.3.6.1.4.1.5624.1.2.27.2.1.2deprecated
etsysRadiusAcctClientMIBComplianceV2
MODULE-COMPLIANCE
The compliance statement for Accounting clients implementing the RADIUS Accounting Client MIB.
1.3.6.1.4.1.5624.1.2.27.2.1.3deprecated
etsysRadiusAcctClientMIBComplianceV3
MODULE-COMPLIANCE
The compliance statement for Accounting clients implementing the RADIUS Accounting Client MIB.
1.3.6.1.4.1.5624.1.2.27.2.1.4current
etsysRadiusAcctClientMIBGroup
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. This MIB provides read-write access to configuration objects not provided in the standard RADIUS Accounting Client MIB (RFC2618). However, the write capability must only be supported for SNMPv3, or other SNMP versions with adequately strong security.
1.3.6.1.4.1.5624.1.2.27.2.2.1deprecated
etsysRadiusAcctClientMIBGroupV2
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. etsysRadiusAcctClientServerClearTime was deprecated in this group.
1.3.6.1.4.1.5624.1.2.27.2.2.2deprecated
etsysRadiusAcctClientMIBGroupV3
OBJECT-GROUP
The basic collection of objects providing a proprietary extension to the standard RADIUS Client MIB. etsysRadiusAcctClientServerClearTime was deprecated in this group.
1.3.6.1.4.1.5624.1.2.27.2.2.3current