MIBs Depot

DOCS-IETF-QOS-MIB

Registered at
1.3.6.1.2.1.127
Last updated
2006-01-23 00:00
Organization
IETF IP over Cable Data Network (IPCDN) Working Group
Revisions
2006-01-23 00:00
Namespace
standard
Source file
DOCS-IETF-QOS-MIB
Digest
sha256:bd31dc1b43724c247a00f401ed8c5221605d16c1d7060463c8e5b69022cd3182

Description

This is the management information for Quality Of Service (QOS) for DOCSIS 1.1 and 2.0. Copyright (C) The Internet Society (2006). This version of this MIB module is part of RFC 4323; see the RFC itself for full legal notices.

Contact

Co-Author: Michael Patrick Postal: Motorola BCS 111 Locke Drive Marlborough, MA 01752-7214 U.S.A. Phone: +1 508 786 7563 E-mail: michael.patrick@motorola.com Co-Author: William Murwin Postal: Motorola BCS 111 Locke Drive Marlborough, MA 01752-7214 U.S.A. Phone: +1 508 786 7594 E-mail: w.murwin@motorola.com IETF IPCDN Working Group General Discussion: ipcdn@ietf.org Subscribe: http://www.ietf.org/mailman/listinfo/ipcdn Archive: ftp://ftp.ietf.org/ietf-mail-archive/ipcdn Co-chairs: Richard Woundy, Richard_Woundy@cable.comcast.com Jean-Francois Mule, jfm@cablelabs.com

Imports

FromSymbols
DIFFSERV-DSCP-TCDscpOrAny
IF-MIBInterfaceIndex, ifIndex
INET-ADDRESS-MIBInetAddress, InetAddressType, InetPortNumber
SNMP-FRAMEWORK-MIBSnmpAdminString
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMICounter32, Counter64, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, Unsigned32, iso, mib-2
SNMPv2-TCDisplayString, MacAddress, RowStatus, StorageType, TEXTUAL-CONVENTION, TimeStamp, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

DIFFSERV-DSCP-TC
DOCS-IETF-QOS-MIB
IANAifType-MIB
IF-MIB
INET-ADDRESS-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC

Textual conventions

NameOIDSyntaxAccessStatus
DocsIetfQosBitRate
TEXTUAL-CONVENTION
The rate of traffic in unit of bits per second. Used to specify traffic rate for QOS.
current
DocsIetfQosRfMacIfDirection
TEXTUAL-CONVENTION
Indicates a direction on an RF MAC interface. The value downstream(1) is from Cable Modem Termination System to Cable Modem. The value upstream(2) is from Cable Modem to Cable Modem Termination System.
current
DocsIetfQosSchedulingType
TEXTUAL-CONVENTION
The scheduling service provided by a CMTS for an upstream Service Flow. If the parameter is omitted from an upstream QOS Parameter Set, this object takes the value of bestEffort (2). This parameter must be reported as undefined (1) for downstream QOS Parameter Sets.
current

Objects

NameOIDSyntaxAccessStatus
docsIetfQosNotifications
OBJECT-IDENTITY
1.3.6.1.2.1.127.0
docsIetfQosMIBObjects
OBJECT-IDENTITY
1.3.6.1.2.1.127.1
docsIetfQosPktClassTable
OBJECT-TYPE
This table describes the packet classification configured on the CM or CMTS. The model is that a packet either received as input from an interface or transmitted for output on an interface may be compared against an ordered list of rules pertaining to the packet contents. Each rule is a row of this table. A matching rule provides a Service Flow ID to which the packet is classified. All rules need to match for a packet to match a classifier. The objects in this row correspond to a set of Classifier Encoding parameters in a DOCSIS MAC management message. The docsIetfQosPktClassBitMap indicates which particular parameters were present in the classifier as signaled in the DOCSIS message. If the referenced parameter was not present in the signaled DOCSIS 1.1 and 2.0 Classifier, the corresponding object in this row reports a value as specified in the DESCRIPTION section.
1.3.6.1.2.1.127.1.1not-accessiblecurrent
docsIetfQosPktClassEntry
OBJECT-TYPE
An entry in this table provides a single packet classifier rule. The index ifIndex is an ifType of docsCableMaclayer(127).
1.3.6.1.2.1.127.1.1.1not-accessiblecurrent
docsIetfQosPktClassId
OBJECT-TYPE
Index assigned to packet classifier entry by the CMTS, which is unique per Service Flow.
1.3.6.1.2.1.127.1.1.1.1Unsigned32 (1..65535)not-accessiblecurrent
docsIetfQosPktClassDirection
OBJECT-TYPE
Indicates the direction to which the classifier is applied.
1.3.6.1.2.1.127.1.1.1.2DocsIetfQosRfMacIfDirectionread-onlycurrent
docsIetfQosPktClassPriority
OBJECT-TYPE
The value specifies the order of evaluation of the classifiers. The higher the value, the higher the priority. The value of 0 is used as default in provisioned Service Flows Classifiers. The default value of 64 is used for dynamic Service Flow Classifiers. If the referenced parameter is not present in a classifier, this object reports the default value as defined above.
1.3.6.1.2.1.127.1.1.1.3Integer32 (0..255)read-onlycurrent
docsIetfQosPktClassIpTosLow
OBJECT-TYPE
The low value of a range of TOS byte values. If the referenced parameter is not present in a classifier, this object reports the value of 0. The IP TOS octet, as originally defined in RFC 791, has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). This object is defined as an 8-bit octet as per the DOCSIS Specification for packet classification.
1.3.6.1.2.1.127.1.1.1.4OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosPktClassIpTosHigh
OBJECT-TYPE
The 8-bit high value of a range of TOS byte values. If the referenced parameter is not present in a classifier, this object reports the value of 0. The IP TOS octet as originally defined in RFC 791 has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). This object is defined as an 8-bit octet as defined by the DOCSIS Specification for packet classification.
1.3.6.1.2.1.127.1.1.1.5OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosPktClassIpTosMask
OBJECT-TYPE
The mask value is bitwise ANDed with TOS byte in an IP packet, and this value is used for range checking of TosLow and TosHigh. If the referenced parameter is not present in a classifier, this object reports the value of 0. The IP TOS octet as originally defined in RFC 791 has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). This object is defined as an 8-bit octet per the DOCSIS Specification for packet classification.
1.3.6.1.2.1.127.1.1.1.6OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosPktClassIpProtocol
OBJECT-TYPE
This object indicates the value of the IP Protocol field required for IP packets to match this rule. The value 256 matches traffic with any IP Protocol value. The value 257 by convention matches both TCP and UDP. If the referenced parameter is not present in a classifier, this object reports the value of 258.
1.3.6.1.2.1.127.1.1.1.7Integer32 (0..258)read-onlycurrent
docsIetfQosPktClassInetAddressType
OBJECT-TYPE
The type of the Internet address for docsIetfQosPktClassInetSourceAddr, docsIetfQosPktClassInetSourceMask, docsIetfQosPktClassInetDestAddr, and docsIetfQosPktClassInetDestMask. If the referenced parameter is not present in a classifier, this object reports the value of ipv4(1).
1.3.6.1.2.1.127.1.1.1.8InetAddressTyperead-onlycurrent
docsIetfQosPktClassInetSourceAddr
OBJECT-TYPE
This object specifies the value of the IP Source Address required for packets to match this rule. An IP packet matches the rule when the packet IP Source Address bitwise ANDed with the docsIetfQosPktClassInetSourceMask value equals the docsIetfQosPktClassInetSourceAddr value. The address type of this object is specified by docsIetfQosPktClassInetAddressType. If the referenced parameter is not present in a classifier, this object reports the value of '00000000'H.
1.3.6.1.2.1.127.1.1.1.9InetAddressread-onlycurrent
docsIetfQosPktClassInetSourceMask
OBJECT-TYPE
This object specifies which bits of a packet's IP Source Address are compared to match this rule. An IP packet matches the rule when the packet source address bitwise ANDed with the docsIetfQosPktClassInetSourceMask value equals the docsIetfQosIpPktClassInetSourceAddr value. The address type of this object is specified by docsIetfQosPktClassInetAddressType. If the referenced parameter is not present in a classifier, this object reports the value of 'FFFFFFFF'H.
1.3.6.1.2.1.127.1.1.1.10InetAddressread-onlycurrent
docsIetfQosPktClassInetDestAddr
OBJECT-TYPE
This object specifies the value of the IP Destination Address required for packets to match this rule. An IP packet matches the rule when the packet IP Destination Address bitwise ANDed with the docsIetfQosPktClassInetDestMask value equals the docsIetfQosPktClassInetDestAddr value. The address type of this object is specified by docsIetfQosPktClassInetAddressType. If the referenced parameter is not present in a classifier, this object reports the value of '00000000'H.
1.3.6.1.2.1.127.1.1.1.11InetAddressread-onlycurrent
docsIetfQosPktClassInetDestMask
OBJECT-TYPE
This object specifies which bits of a packet's IP Destination Address are compared to match this rule. An IP packet matches the rule when the packet destination address bitwise ANDed with the docsIetfQosPktClassInetDestMask value equals the docsIetfQosIpPktClassInetDestAddr value. The address type of this object is specified by docsIetfQosPktClassInetAddressType. If the referenced parameter is not present in a classifier, this object reports the value of 'FFFFFFFF'H.
1.3.6.1.2.1.127.1.1.1.12InetAddressread-onlycurrent
docsIetfQosPktClassSourcePortStart
OBJECT-TYPE
This object specifies the low-end inclusive range of TCP/UDP source port numbers to which a packet is compared. This object is irrelevant for non-TCP/UDP IP packets. If the referenced parameter is not present in a classifier, this object reports the value of 0.
1.3.6.1.2.1.127.1.1.1.13InetPortNumberread-onlycurrent
docsIetfQosPktClassSourcePortEnd
OBJECT-TYPE
This object specifies the high-end inclusive range of TCP/UDP source port numbers to which a packet is compared. This object is irrelevant for non-TCP/UDP IP packets. If the referenced parameter is not present in a classifier, this object reports the value of 65535.
1.3.6.1.2.1.127.1.1.1.14InetPortNumberread-onlycurrent
docsIetfQosPktClassDestPortStart
OBJECT-TYPE
This object specifies the low-end inclusive range of TCP/UDP destination port numbers to which a packet is compared. If the referenced parameter is not present in a classifier, this object reports the value of 0.
1.3.6.1.2.1.127.1.1.1.15InetPortNumberread-onlycurrent
docsIetfQosPktClassDestPortEnd
OBJECT-TYPE
This object specifies the high-end inclusive range of TCP/UDP destination port numbers to which a packet is compared. If the referenced parameter is not present in a classifier, this object reports the value of 65535.
1.3.6.1.2.1.127.1.1.1.16InetPortNumberread-onlycurrent
docsIetfQosPktClassDestMacAddr
OBJECT-TYPE
An Ethernet packet matches an entry when its destination MAC address bitwise ANDed with docsIetfQosPktClassDestMacMask equals the value of docsIetfQosPktClassDestMacAddr. If the referenced parameter is not present in a classifier, this object reports the value of '000000000000'H.
1.3.6.1.2.1.127.1.1.1.17MacAddressread-onlycurrent
docsIetfQosPktClassDestMacMask
OBJECT-TYPE
An Ethernet packet matches an entry when its destination MAC address bitwise ANDed with docsIetfQosPktClassDestMacMask equals the value of docsIetfQosPktClassDestMacAddr. If the referenced parameter is not present in a classifier, this object reports the value of '000000000000'H.
1.3.6.1.2.1.127.1.1.1.18MacAddressread-onlycurrent
docsIetfQosPktClassSourceMacAddr
OBJECT-TYPE
An Ethernet packet matches this entry when its source MAC address equals the value of this object. If the referenced parameter is not present in a classifier, this object reports the value of 'FFFFFFFFFFFF'H.
1.3.6.1.2.1.127.1.1.1.19MacAddressread-onlycurrent
docsIetfQosPktClassEnetProtocolType
OBJECT-TYPE
This object indicates the format of the layer 3 protocol ID in the Ethernet packet. A value of none(0) means that the rule does not use the layer 3 protocol type as a matching criteria. A value of ethertype(1) means that the rule applies only to frames that contain an EtherType value. Ethertype values are contained in packets using the Dec-Intel-Xerox (DIX) encapsulation or the RFC1042 Sub-Network Access Protocol (SNAP) encapsulation formats. A value of dsap(2) means that the rule applies only to frames using the IEEE802.3 encapsulation format with a Destination Service Access Point (DSAP) other than 0xAA (which is reserved for SNAP). A value of mac(3) means that the rule applies only to MAC management messages for MAC management messages. A value of all(4) means that the rule matches all Ethernet packets. If the Ethernet frame contains an 802.1P/Q Tag header (i.e., EtherType 0x8100), this object applies to the embedded EtherType field within the 802.1P/Q header. If the referenced parameter is not present in a classifier, this object reports the value of 0.
1.3.6.1.2.1.127.1.1.1.20INTEGER {none(0), ethertype(1), dsap(2), mac(3), all(4)}read-onlycurrent
docsIetfQosPktClassEnetProtocol
OBJECT-TYPE
If docsIetfQosEthPktClassProtocolType is none(0), this object is ignored when considering whether a packet matches the current rule. If dosQosPktClassEnetProtocolType is ethertype(1), this object gives the 16-bit value of the EtherType that the packet must match in order to match the rule. If docsIetfQosPktClassEnetProtocolType is dsap(2), the lower 8 bits of this object's value must match the DSAP byte of the packet in order to match the rule. If docsIetfQosPktClassEnetProtocolType is mac(3), the lower 8 bits of this object's value represent a lower bound (inclusive) of MAC management message type codes matched, and the upper 8 bits represent the upper bound (inclusive) of matched MAC message type codes. Certain message type codes are excluded from matching, as specified in the reference. If the Ethernet frame contains an 802.1P/Q Tag header (i.e., EtherType 0x8100), this object applies to the embedded EtherType field within the 802.1P/Q header. If the referenced parameter is not present in the classifier, the value of this object is reported as 0.
1.3.6.1.2.1.127.1.1.1.21Integer32 (0..65535)read-onlycurrent
docsIetfQosPktClassUserPriLow
OBJECT-TYPE
This object applies only to Ethernet frames using the 802.1P/Q tag header (indicated with EtherType 0x8100). Such frames include a 16-bit Tag that contains a 3-bit Priority field and a 12-bit VLAN number. Tagged Ethernet packets must have a 3-bit Priority field within the range of docsIetfQosPktClassPriLow to docsIetfQosPktClassPriHigh in order to match this rule. If the referenced parameter is not present in the classifier, the value of this object is reported as 0.
1.3.6.1.2.1.127.1.1.1.22Integer32 (0..7)read-onlycurrent
docsIetfQosPktClassUserPriHigh
OBJECT-TYPE
This object applies only to Ethernet frames using the 802.1P/Qtag header (indicated with EtherType 0x8100). Such frames include a 16-bit Tag that contains a 3-bit Priority field and a 12-bit VLAN number. Tagged Ethernet packets must have a 3-bit Priority field within the range of docsIetfQosPktClassPriLow to docsIetfQosPktClassPriHigh in order to match this rule. If the referenced parameter is not present in the classifier, the value of this object is reported as 7.
1.3.6.1.2.1.127.1.1.1.23Integer32 (0..7)read-onlycurrent
docsIetfQosPktClassVlanId
OBJECT-TYPE
This object applies only to Ethernet frames using the 802.1P/Q tag header. Tagged packets must have a VLAN Identifier that matches the value in order to match the rule. If the referenced parameter is not present in the classifier, the value of this object is reported as 0.
1.3.6.1.2.1.127.1.1.1.24Integer32 (0 | 1..4094)read-onlycurrent
docsIetfQosPktClassStateActive
OBJECT-TYPE
This object indicates whether or not the classifier is enabled to classify packets to a Service Flow. If the referenced parameter is not present in the classifier, the value of this object is reported as true(1).
1.3.6.1.2.1.127.1.1.1.25TruthValueread-onlycurrent
docsIetfQosPktClassPkts
OBJECT-TYPE
This object counts the number of packets that have been classified using this entry. This includes all packets delivered to a Service Flow maximum rate policing function, whether or not that function drops the packets. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.1.1.26Counter64read-onlycurrent
docsIetfQosPktClassBitMap
OBJECT-TYPE
This object indicates which parameter encodings were actually present in the DOCSIS packet classifier encoding signaled in the DOCSIS message that created or modified the classifier. Note that Dynamic Service Change messages have replace semantics, so that all non-default parameters must be present whether the classifier is being created or changed. A bit of this object is set to 1 if the parameter indicated by the comment was present in the classifier encoding, and to 0 otherwise. Note that BITS are encoded most significant bit first, so that if, for example, bits 6 and 7 are set, this object is encoded as the octet string '030000'H.
1.3.6.1.2.1.127.1.1.1.27Bits {rulePriority(0), activationState(1), ipTos(2), ipProtocol(3), ipSourceAddr(4), ipSourceMask(5), ipDestAddr(6), ipDestMask(7), sourcePortStart(8), sourcePortEnd(9), destPortStart(10), destPortEnd(11), destMac(12), sourceMac(13), ethertype(14), userPri(15), vlanId(16)}read-onlycurrent
docsIetfQosParamSetTable
OBJECT-TYPE
This table describes the set of DOCSIS 1.1 and 2.0 QOS parameters defined in a managed device. The ifIndex index specifies a DOCSIS MAC Domain. The docsIetfQosServiceFlowId index specifies a particular Service Flow. The docsIetfQosParamSetType index indicates whether the active, admitted, or provisioned QOS Parameter Set is being described by the row. Only the QOS Parameter Sets of DOCSIS 1.1 and 2.0 Service Flows are represented in this table. DOCSIS 1.0 QOS service profiles are not represented in this table. Each row corresponds to a DOCSIS QOS Parameter Set as signaled via DOCSIS MAC management messages. Each object in the row corresponds to one or part of one DOCSIS 1.1 Service Flow Encoding. The docsIetfQosParamSetBitMap object in the row indicates which particular parameters were signaled in the original registration or dynamic service request message that created the QOS Parameter Set. In many cases, even if a QOS Parameter Set parameter was not signaled, the DOCSIS specification calls for a default value to be used. That default value is reported as the value of the corresponding object in this row. Many objects are not applicable, depending on the Service Flow direction or upstream scheduling type. The object value reported in this case is specified in the DESCRIPTION clause.
1.3.6.1.2.1.127.1.2not-accessiblecurrent
docsIetfQosParamSetEntry
OBJECT-TYPE
A unique set of QOS parameters.
1.3.6.1.2.1.127.1.2.1not-accessiblecurrent
docsIetfQosParamSetServiceClassName
OBJECT-TYPE
Refers to the Service Class Name from which the parameter set values were derived. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object is a zero-length string.
1.3.6.1.2.1.127.1.2.1.1SnmpAdminStringread-onlycurrent
docsIetfQosParamSetPriority
OBJECT-TYPE
The relative priority of a Service Flow. Higher numbers indicate higher priority. This priority should only be used to differentiate Service Flow from identical parameter sets. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object is 0. If the parameter is not applicable, the reported value is 0.
1.3.6.1.2.1.127.1.2.1.2Integer32 (0..7)read-onlycurrent
docsIetfQosParamSetMaxTrafficRate
OBJECT-TYPE
Maximum sustained traffic rate allowed for this Service Flow in bits/sec. Must count all MAC frame data PDU from the bytes following the MAC header HCS to the end of the CRC. The number of bytes forwarded is limited during any time interval. The value 0 means no maximum traffic rate is enforced. This object applies to both upstream and downstream Service Flows. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object is 0. If the parameter is not applicable, it is reported as 0.
1.3.6.1.2.1.127.1.2.1.3DocsIetfQosBitRateread-onlycurrent
docsIetfQosParamSetMaxTrafficBurst
OBJECT-TYPE
Specifies the token bucket size in bytes for this parameter set. The value is calculated from the byte following the MAC header HCS to the end of the CRC. This object is applied in conjunction with docsIetfQosParamSetMaxTrafficRate to calculate maximum sustained traffic rate. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object for scheduling types bestEffort (2), nonRealTimePollingService(3), and realTimePollingService(4) is 3044. If this parameter is not applicable, it is reported as 0.
1.3.6.1.2.1.127.1.2.1.4Unsigned32read-onlycurrent
docsIetfQosParamSetMinReservedRate
OBJECT-TYPE
Specifies the guaranteed minimum rate in bits/sec for this parameter set. The value is calculated from the byte following the MAC header HCS to the end of the CRC. The default value of 0 means that no bandwidth is reserved. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object is 0. If the parameter is not applicable, it is reported as 0.
1.3.6.1.2.1.127.1.2.1.5DocsIetfQosBitRateread-onlycurrent
docsIetfQosParamSetMinReservedPkt
OBJECT-TYPE
Specifies an assumed minimum packet size in bytes for which the docsIetfQosParamSetMinReservedRate will be provided. The value is calculated from the byte following the MAC header HCS to the end of the CRC. If the referenced parameter is omitted from a DOCSIS QOS parameter set, the default value is CMTS implementation dependent. In this case, the CMTS reports the default value it is using, and the CM reports a value of 0. If the referenced parameter is not applicable to the direction or scheduling type of the Service Flow, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.6Integer32 (0..65535)read-onlycurrent
docsIetfQosParamSetActiveTimeout
OBJECT-TYPE
Specifies the maximum duration in seconds that resources remain unused on an active service flow before CMTS signals that both active and admitted parameters set are null. The default value of 0 signifies an infinite amount of time. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object is 0.
1.3.6.1.2.1.127.1.2.1.7Integer32 (0..65535)read-onlycurrent
docsIetfQosParamSetAdmittedTimeout
OBJECT-TYPE
Specifies the maximum duration in seconds that resources remain in admitted state before resources must be released. The value of 0 signifies an infinite amount of time. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object is 200.
1.3.6.1.2.1.127.1.2.1.8Integer32 (0..65535)read-onlycurrent
docsIetfQosParamSetMaxConcatBurst
OBJECT-TYPE
Specifies the maximum concatenated burst in bytes that an upstream Service Flow is allowed. The value is calculated from the FC byte of the Concatenation MAC Header to the last CRC byte in of the last concatenated MAC frame, inclusive. The value of 0 specifies no maximum burst. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set, the default value of this object for scheduling types bestEffort(2), nonRealTimePollingService(3), and realTimePollingService(4) is 1522. If the parameter is not applicable, this object's value is reported as 0.
1.3.6.1.2.1.127.1.2.1.9Integer32 (0..65535)read-onlycurrent
docsIetfQosParamSetSchedulingType
OBJECT-TYPE
Specifies the upstream scheduling service used for upstream Service Flow. If the referenced parameter is not present in the corresponding DOCSIS QOS Parameter Set of an upstream Service Flow, the default value of this object is bestEffort(2). For QOS parameter sets of downstream Service Flows, this object's value is reported as undefined(1).
1.3.6.1.2.1.127.1.2.1.10DocsIetfQosSchedulingTyperead-onlycurrent
docsIetfQosParamSetNomPollInterval
OBJECT-TYPE
Specifies the nominal interval in microseconds between successive unicast request opportunities on an upstream Service Flow. This object applies only to upstream Service Flows with DocsIetfQosSchedulingType of value nonRealTimePollingService(3), realTimePollingService(4), and unsolictedGrantServiceWithAD(5). The parameter is mandatory for realTimePollingService(4). If the parameter is omitted with nonRealTimePollingService(3), the CMTS uses an implementation-dependent value. If the parameter is omitted with unsolictedGrantServiceWithAD(5), the CMTS uses as a default value the value of the Nominal Grant Interval parameter. In all cases, the CMTS reports the value it is using when the parameter is applicable. The CM reports the signaled parameter value if it was signaled, and 0 otherwise. If the referenced parameter is not applicable to the direction or scheduling type of the corresponding DOCSIS QOS Parameter Set, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.11Unsigned32read-onlycurrent
docsIetfQosParamSetTolPollJitter
OBJECT-TYPE
Specifies the maximum amount of time in microseconds that the unicast request interval may be delayed from the nominal periodic schedule on an upstream Service Flow. This parameter is applicable only to upstream Service Flows with a DocsIetfQosSchedulingType of realTimePollingService(4) or unsolictedGrantServiceWithAD(5). If the referenced parameter is applicable but not present in the corresponding DOCSIS QOS Parameter Set, the CMTS uses an implementation-dependent value and reports the value it is using. The CM reports a value of 0 in this case. If the parameter is not applicable to the direction or upstream scheduling type of the Service Flow, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.12Unsigned32read-onlycurrent
docsIetfQosParamSetUnsolicitGrantSize
OBJECT-TYPE
Specifies the unsolicited grant size in bytes. The grant size includes the entire MAC frame data PDU from the Frame Control byte to the end of the MAC frame. The referenced parameter is applicable only for upstream flows with a DocsIetfQosSchedulingType of unsolicitedGrantServicewithAD(5) or unsolicitedGrantService(6), and it is mandatory when applicable. Both CMTS and CM report the signaled value of the parameter in this case. If the referenced parameter is not applicable to the direction or scheduling type of the corresponding DOCSIS QOS Parameter Set, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.13Integer32 (0..65535)read-onlycurrent
docsIetfQosParamSetNomGrantInterval
OBJECT-TYPE
Specifies the nominal interval in microseconds between successive data grant opportunities on an upstream Service Flow. The referenced parameter is applicable only for upstream flows with a DocsIetfQosSchedulingType of unsolicitedGrantServicewithAD(5) or unsolicitedGrantService(6), and it is mandatory when applicable. Both CMTS and CM report the signaled value of the parameter in this case. If the referenced parameter is not applicable to the direction or scheduling type of the corresponding DOCSIS QOS Parameter Set, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.14Unsigned32read-onlycurrent
docsIetfQosParamSetTolGrantJitter
OBJECT-TYPE
Specifies the maximum amount of time in microseconds that the transmission opportunities may be delayed from the nominal periodic schedule. The referenced parameter is applicable only for upstream flows with a DocsIetfQosSchedulingType of unsolicitedGrantServicewithAD(5) or unsolicitedGrantService(6), and it is mandatory when applicable. Both CMTS and CM report the signaled value of the parameter in this case. If the referenced parameter is not applicable to the direction or scheduling type of the corresponding DOCSIS QOS Parameter Set, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.15Unsigned32read-onlycurrent
docsIetfQosParamSetGrantsPerInterval
OBJECT-TYPE
Specifies the number of data grants per Nominal Grant Interval (docsIetfQosParamSetNomGrantInterval). The referenced parameter is applicable only for upstream flows with a DocsIetfQosSchedulingType of unsolicitedGrantServicewithAD(5) or unsolicitedGrantService(6), and it is mandatory when applicable. Both CMTS and CM report the signaled value of the parameter in this case. If the referenced parameter is not applicable to the direction or scheduling type of the corresponding DOCSIS QOS Parameter Set, both CMTS and CM report this object's value as 0.
1.3.6.1.2.1.127.1.2.1.16Integer32 (0..127)read-onlycurrent
docsIetfQosParamSetTosAndMask
OBJECT-TYPE
Specifies the AND mask for the IP TOS byte for overwriting IP packet's TOS value. The IP packet TOS byte is bitwise ANDed with docsIetfQosParamSetTosAndMask, and the result is bitwise ORed with docsIetfQosParamSetTosORMask and the result is written to the IP packet TOS byte. A value of 'FF'H for docsIetfQosParamSetTosAndMask and a value of '00'H for docsIetfQosParamSetTosOrMask means that the IP Packet TOS byte is not overwritten. This combination is reported if the referenced parameter is not present in a QOS Parameter Set. The IP TOS octet as originally defined in RFC 791 has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). Network operators SHOULD avoid specifying values of docsIetfQosParamSetTosAndMask and docsIetfQosParamSetTosORMask that would result in the modification of the ECN bits. In particular, operators should not use values of docsIetfQosParamSetTosAndMask that have either of the least-significant two bits set to 0. Similarly, operators should not use values of docsIetfQosParamSetTosORMask that have either of the least-significant two bits set to 1. Even though this object is only enforced by the Cable Modem Termination System (CMTS), Cable Modems MUST report the value as signaled in the referenced parameter.
1.3.6.1.2.1.127.1.2.1.17OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosParamSetTosOrMask
OBJECT-TYPE
Specifies the OR mask for the IP TOS byte. See the description of docsIetfQosParamSetTosAndMask for further details. The IP TOS octet as originally defined in RFC 791 has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). Network operators SHOULD avoid specifying values of docsIetfQosParamSetTosAndMask and docsIetfQosParamSetTosORMask that would result in the modification of the ECN bits.
1.3.6.1.2.1.127.1.2.1.18OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosParamSetMaxLatency
OBJECT-TYPE
Specifies the maximum latency between the reception of a packet by the CMTS on its NSI and the forwarding of the packet to the RF interface. A value of 0 signifies no maximum latency is enforced. This object only applies to downstream Service Flows. If the referenced parameter is not present in the corresponding downstream DOCSIS QOS Parameter Set, the default value is 0. This parameter is not applicable to upstream DOCSIS QOS Parameter Sets, and its value is reported as 0 in this case.
1.3.6.1.2.1.127.1.2.1.19Unsigned32read-onlycurrent
docsIetfQosParamSetType
OBJECT-TYPE
Defines the type of the QOS parameter set defined by this row. active(1) indicates the Active QOS parameter set, describing the service currently being provided by the DOCSIS MAC domain to the Service Flow. admitted(2) indicates the Admitted QOS Parameter Set, describing services reserved by the DOCSIS MAC domain for use by the service flow. provisioned (3) describes the QOS Parameter Set defined in the DOCSIS CM Configuration file for the Service Flow.
1.3.6.1.2.1.127.1.2.1.20INTEGER {active(1), admitted(2), provisioned(3)}not-accessiblecurrent
docsIetfQosParamSetRequestPolicyOct
OBJECT-TYPE
Specifies which transmit interval opportunities the CM omits for upstream transmission requests and packet transmissions. This object takes its default value for downstream Service Flows. Unless otherwise indicated, a bit value of 1 means that a CM must not use that opportunity for upstream transmission. If bit 0 is the least significant bit of the least significant (4th) octet, and if bit number is increased with significance, the bit definitions are defined as follows: broadcastReqOpp(0): all CMs broadcast request opportunities priorityReqMulticastReq(1): priority request multicast request opportunities reqDataForReq(2): request/data opportunities for requests reqDataForData(3): request/data opportunities for data piggybackReqWithData(4): piggyback requests with data concatenateData(5): concatenate data fragmentData(6): fragment data suppresspayloadheaders(7): suppress payload headers dropPktsExceedUGSize(8): A value of 1 means that the Service Flow must drop packets that do not fit in the Unsolicited Grant size. If the referenced parameter is not present in a QOS Parameter Set, the value of this object is reported as '00000000'H.
1.3.6.1.2.1.127.1.2.1.21OCTET STRING (SIZE(4))read-onlycurrent
docsIetfQosParamSetBitMap
OBJECT-TYPE
This object indicates the set of QOS Parameter Set parameters actually signaled in the DOCSIS registration or dynamic service request message that created or modified the QOS Parameter Set. A bit is set to 1 when the parameter described by the indicated reference section is present in the original request. Note that when Service Class names are expanded, the registration or dynamic response message may contain parameters as expanded by the CMTS based on a stored service class. These expanded parameters are not indicated by a 1 bit in this object. Note that even though some QOS Parameter Set parameters may not be signaled in a message (so that the paramater's bit in this object is 0), the DOCSIS specification requires that default values be used. These default values are reported as the corresponding object's value in the row. Note that BITS objects are encoded most significant bit first. For example, if bits 1 and 16 are set, the value of this object is the octet string '400080'H.
1.3.6.1.2.1.127.1.2.1.22Bits {trafficPriority(0), maxTrafficRate(1), maxTrafficBurst(2), minReservedRate(3), minReservedPkt(4), activeTimeout(5), admittedTimeout(6), maxConcatBurst(7), schedulingType(8), requestPolicy(9), nomPollInterval(10), tolPollJitter(11), unsolicitGrantSize(12), nomGrantInterval(13), tolGrantJitter(14), grantsPerInterval(15), tosOverwrite(16), maxLatency(17)}read-onlycurrent
docsIetfQosServiceFlowTable
OBJECT-TYPE
This table describes the set of DOCSIS-QOS Service Flows in a managed device.
1.3.6.1.2.1.127.1.3not-accessiblecurrent
docsIetfQosServiceFlowEntry
OBJECT-TYPE
Describes a Service Flow. An entry in the table exists for each Service Flow ID. The ifIndex is an ifType of docsCableMaclayer(127).
1.3.6.1.2.1.127.1.3.1not-accessiblecurrent
docsIetfQosServiceFlowId
OBJECT-TYPE
An index assigned to a Service Flow by CMTS.
1.3.6.1.2.1.127.1.3.1.1Unsigned32 (1..4294967295)not-accessiblecurrent
docsIetfQosServiceFlowSID
OBJECT-TYPE
Service Identifier (SID) assigned to an admitted or active Service Flow. This object reports a value of 0 if a Service ID is not associated with the Service Flow. Only active or admitted upstream Service Flows will have a Service ID (SID).
1.3.6.1.2.1.127.1.3.1.2Unsigned32 (0..16383)read-onlycurrent
docsIetfQosServiceFlowDirection
OBJECT-TYPE
The direction of the Service Flow.
1.3.6.1.2.1.127.1.3.1.3DocsIetfQosRfMacIfDirectionread-onlycurrent
docsIetfQosServiceFlowPrimary
OBJECT-TYPE
Object reflects whether Service Flow is the primary or a secondary Service Flow. A primary Service Flow is the default Service Flow for otherwise unclassified traffic and all MAC messages.
1.3.6.1.2.1.127.1.3.1.4TruthValueread-onlycurrent
docsIetfQosServiceFlowStatsTable
OBJECT-TYPE
This table describes statistics associated with the Service Flows in a managed device.
1.3.6.1.2.1.127.1.4not-accessiblecurrent
docsIetfQosServiceFlowStatsEntry
OBJECT-TYPE
Describes a set of Service Flow statistics. An entry in the table exists for each Service Flow ID. The ifIndex is an ifType of docsCableMaclayer(127).
1.3.6.1.2.1.127.1.4.1not-accessiblecurrent
docsIetfQosServiceFlowPkts
OBJECT-TYPE
For outgoing Service Flows, this object counts the number of Packet Data PDUs forwarded to this Service Flow. For incoming upstream CMTS service flows, this object counts the number of Packet Data PDUs actually received on the Service Flow identified by the SID for which the packet was scheduled. CMs not classifying downstream packets may report this object's value as 0 for downstream Service Flows. This object does not count MAC-specific management messages. Particularly for UGS flows, packets sent on the primary Service Flow in violation of the UGS grant size should be counted only by the instance of this object that is associated with the primary service flow. Unclassified upstream user data packets (i.e., non- MAC-management) forwarded to the primary upstream Service Flow should be counted by the instance of this object that is associated with the primary service flow. This object does include packets counted by docsIetfQosServiceFlowPolicedDelayPkts, but does not include packets counted by docsIetfQosServiceFlowPolicedDropPkts and docsIetfQosServiceFlowPHSUnknowns. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.4.1.1Counter64read-onlycurrent
docsIetfQosServiceFlowOctets
OBJECT-TYPE
The number of octets from the byte after the MAC header HCS to the end of the CRC for all packets counted in the docsIetfQosServiceFlowPkts object for this row. Note that this counts the octets after payload header suppression and before payload header expansion have been applied. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.4.1.2Counter64read-onlycurrent
docsIetfQosServiceFlowTimeCreated
OBJECT-TYPE
The value of sysUpTime when the service flow was created.
1.3.6.1.2.1.127.1.4.1.3TimeStampread-onlycurrent
docsIetfQosServiceFlowTimeActive
OBJECT-TYPE
The number of seconds that the service flow has been active. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.4.1.4Counter32read-onlycurrent
docsIetfQosServiceFlowPHSUnknowns
OBJECT-TYPE
For incoming upstream CMTS service flows, this object counts the number of packets received with an unknown payload header suppression index. The service flow is identified by the SID for which the packet was scheduled. On a CM, only this object's instance for the primary downstream service flow counts packets received with an unknown payload header suppression index. All other downstream service flows on CM report this objects value as 0. All outgoing service flows report this object's value as 0. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.4.1.5Counter32read-onlycurrent
docsIetfQosServiceFlowPolicedDropPkts
OBJECT-TYPE
For outgoing service flows, this object counts the number of Packet Data PDUs classified to this service flow dropped due to: (1) implementation-dependent excessive delay while enforcing the Maximum Sustained Traffic Rate; or (2) UGS packets dropped due to exceeding the Unsolicited Grant Size with a Request/Transmission policy that requires such packets to be dropped. Classified packets dropped due to other reasons must be counted in ifOutDiscards for the interface of this service flow. This object reports 0 for incoming service flows. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.4.1.6Counter32read-onlycurrent
docsIetfQosServiceFlowPolicedDelayPkts
OBJECT-TYPE
This object counts only outgoing packets delayed in order to maintain the Maximum Sustained Traffic Rate. This object will always report a value of 0 for UGS flows because the Maximum Sustained Traffic Rate does not apply. This object is 0 for incoming service flows. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.4.1.7Counter32read-onlycurrent
docsIetfQosUpstreamStatsTable
OBJECT-TYPE
This table describes statistics associated with upstream service flows. All counted frames must be received without a Frame Check Sequence (FCS) error.
1.3.6.1.2.1.127.1.5not-accessiblecurrent
docsIetfQosUpstreamStatsEntry
OBJECT-TYPE
Describes a set of upstream service flow statistics. An entry in the table exists for each upstream Service Flow in a managed device. The ifIndex is an ifType of docsCableMaclayer(127).
1.3.6.1.2.1.127.1.5.1not-accessiblecurrent
docsIetfQosSID
OBJECT-TYPE
Identifies a service ID for an admitted or active upstream service flow.
1.3.6.1.2.1.127.1.5.1.1Unsigned32 (1..16383)not-accessiblecurrent
docsIetfQosUpstreamFragments
OBJECT-TYPE
The number of fragmentation headers received on an upstream service flow, regardless of whether the fragment was correctly reassembled into a valid packet. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.5.1.2Counter32read-onlycurrent
docsIetfQosUpstreamFragDiscards
OBJECT-TYPE
The number of upstream fragments discarded and not assembled into a valid upstream packet. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.5.1.3Counter32read-onlycurrent
docsIetfQosUpstreamConcatBursts
OBJECT-TYPE
The number of concatenation headers received on an upstream service flow. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.5.1.4Counter32read-onlycurrent
docsIetfQosDynamicServiceStatsTable
OBJECT-TYPE
This table describes statistics associated with the Dynamic Service Flows in a managed device.
1.3.6.1.2.1.127.1.6not-accessiblecurrent
docsIetfQosDynamicServiceStatsEntry
OBJECT-TYPE
Describes a set of dynamic service flow statistics. Two entries exist for each DOCSIS MAC layer interface for the upstream and downstream direction. On the CMTS, the downstream direction row indicates messages transmitted or transactions originated by the CMTS. The upstream direction row indicates messages received or transaction originated by the CM. On the CM, the downstream direction row indicates messages received or transactions originated by the CMTS. The upstream direction row indicates messages transmitted by the CM or transactions originated by the CM. The ifIndex is an ifType of docsCableMaclayer(127).
1.3.6.1.2.1.127.1.6.1not-accessiblecurrent
docsIetfQosIfDirection
OBJECT-TYPE
The direction of interface.
1.3.6.1.2.1.127.1.6.1.1DocsIetfQosRfMacIfDirectionnot-accessiblecurrent
docsIetfQosDSAReqs
OBJECT-TYPE
The number of Dynamic Service Addition Requests, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.2Counter32read-onlycurrent
docsIetfQosDSARsps
OBJECT-TYPE
The number of Dynamic Service Addition Responses, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.3Counter32read-onlycurrent
docsIetfQosDSAAcks
OBJECT-TYPE
The number of Dynamic Service Addition Acknowledgements, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.4Counter32read-onlycurrent
docsIetfQosDSCReqs
OBJECT-TYPE
The number of Dynamic Service Change Requests, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.5Counter32read-onlycurrent
docsIetfQosDSCRsps
OBJECT-TYPE
The number of Dynamic Service Change Responses, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.6Counter32read-onlycurrent
docsIetfQosDSCAcks
OBJECT-TYPE
The number of Dynamic Service Change Acknowledgements, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.7Counter32read-onlycurrent
docsIetfQosDSDReqs
OBJECT-TYPE
The number of Dynamic Service Delete Requests, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.8Counter32read-onlycurrent
docsIetfQosDSDRsps
OBJECT-TYPE
The number of Dynamic Service Delete Responses, including retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.9Counter32read-onlycurrent
docsIetfQosDynamicAdds
OBJECT-TYPE
The number of successful Dynamic Service Addition transactions. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.10Counter32read-onlycurrent
docsIetfQosDynamicAddFails
OBJECT-TYPE
The number of failed Dynamic Service Addition transactions. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.11Counter32read-onlycurrent
docsIetfQosDynamicChanges
OBJECT-TYPE
The number of successful Dynamic Service Change transactions. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.12Counter32read-onlycurrent
docsIetfQosDynamicChangeFails
OBJECT-TYPE
The number of failed Dynamic Service Change transactions. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.13Counter32read-onlycurrent
docsIetfQosDynamicDeletes
OBJECT-TYPE
The number of successful Dynamic Service Delete transactions. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.14Counter32read-onlycurrent
docsIetfQosDynamicDeleteFails
OBJECT-TYPE
The number of failed Dynamic Service Delete transactions. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.15Counter32read-onlycurrent
docsIetfQosDCCReqs
OBJECT-TYPE
The number of Dynamic Channel Change Request messages traversing an interface. This count is nonzero only on downstream direction rows. This count should include the number of retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.16Counter32read-onlycurrent
docsIetfQosDCCRsps
OBJECT-TYPE
The number of Dynamic Channel Change Response messages traversing an interface. This count is nonzero only on upstream direction rows. This count should include the number of retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.17Counter32read-onlycurrent
docsIetfQosDCCAcks
OBJECT-TYPE
The number of Dynamic Channel Change Acknowledgement messages traversing an interface. This count is nonzero only on downstream direction rows. This count should include the number of retries. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.18Counter32read-onlycurrent
docsIetfQosDCCs
OBJECT-TYPE
The number of successful Dynamic Channel Change transactions. This count is nonzero only on downstream direction rows. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.19Counter32read-onlycurrent
docsIetfQosDCCFails
OBJECT-TYPE
The number of failed Dynamic Channel Change transactions. This count is nonzero only on downstream direction rows. This counter's last discontinuity is the ifCounterDiscontinuityTime for the same ifIndex that indexes this object.
1.3.6.1.2.1.127.1.6.1.20Counter32read-onlycurrent
docsIetfQosServiceFlowLogTable
OBJECT-TYPE
This table contains a log of the disconnected Service Flows in a managed device.
1.3.6.1.2.1.127.1.7not-accessiblecurrent
docsIetfQosServiceFlowLogEntry
OBJECT-TYPE
The information regarding a single disconnected service flow.
1.3.6.1.2.1.127.1.7.1not-accessiblecurrent
docsIetfQosServiceFlowLogIndex
OBJECT-TYPE
Unique index for a logged service flow.
1.3.6.1.2.1.127.1.7.1.1Unsigned32 (1..4294967295)not-accessiblecurrent
docsIetfQosServiceFlowLogIfIndex
OBJECT-TYPE
The ifIndex of ifType docsCableMaclayer(127) on the CMTS where the service flow was present.
1.3.6.1.2.1.127.1.7.1.2InterfaceIndexread-onlycurrent
docsIetfQosServiceFlowLogSFID
OBJECT-TYPE
The index assigned to the service flow by the CMTS.
1.3.6.1.2.1.127.1.7.1.3Unsigned32 (1..4294967295)read-onlycurrent
docsIetfQosServiceFlowLogCmMac
OBJECT-TYPE
The MAC address for the cable modem associated with the service flow.
1.3.6.1.2.1.127.1.7.1.4MacAddressread-onlycurrent
docsIetfQosServiceFlowLogPkts
OBJECT-TYPE
The number of packets counted on this service flow after payload header suppression.
1.3.6.1.2.1.127.1.7.1.5Counter64read-onlycurrent
docsIetfQosServiceFlowLogOctets
OBJECT-TYPE
The number of octets counted on this service flow after payload header suppression.
1.3.6.1.2.1.127.1.7.1.6Counter64read-onlycurrent
docsIetfQosServiceFlowLogTimeDeleted
OBJECT-TYPE
The value of sysUpTime when the service flow was deleted.
1.3.6.1.2.1.127.1.7.1.7TimeStampread-onlycurrent
docsIetfQosServiceFlowLogTimeCreated
OBJECT-TYPE
The value of sysUpTime when the service flow was created.
1.3.6.1.2.1.127.1.7.1.8TimeStampread-onlycurrent
docsIetfQosServiceFlowLogTimeActive
OBJECT-TYPE
The total time that the service flow was active.
1.3.6.1.2.1.127.1.7.1.9Counter32read-onlycurrent
docsIetfQosServiceFlowLogDirection
OBJECT-TYPE
The value of docsIetfQosServiceFlowDirection for the service flow.
1.3.6.1.2.1.127.1.7.1.10DocsIetfQosRfMacIfDirectionread-onlycurrent
docsIetfQosServiceFlowLogPrimary
OBJECT-TYPE
The value of docsIetfQosServiceFlowPrimary for the service flow.
1.3.6.1.2.1.127.1.7.1.11TruthValueread-onlycurrent
docsIetfQosServiceFlowLogServiceClassName
OBJECT-TYPE
The value of docsIetfQosParamSetServiceClassName for the provisioned QOS Parameter Set of the service flow.
1.3.6.1.2.1.127.1.7.1.12SnmpAdminStringread-onlycurrent
docsIetfQosServiceFlowLogPolicedDropPkts
OBJECT-TYPE
The final value of docsIetfQosServiceFlowPolicedDropPkts for the service flow.
1.3.6.1.2.1.127.1.7.1.13Counter32read-onlycurrent
docsIetfQosServiceFlowLogPolicedDelayPkts
OBJECT-TYPE
The final value of docsIetfQosServiceFlowPolicedDelayPkts for the service flow.
1.3.6.1.2.1.127.1.7.1.14Counter32read-onlycurrent
docsIetfQosServiceFlowLogControl
OBJECT-TYPE
Setting this object to the value destroy(6) removes this entry from the table. Reading this object returns the value active(1).
1.3.6.1.2.1.127.1.7.1.15INTEGER {active(1), destroy(6)}read-writecurrent
docsIetfQosServiceClassTable
OBJECT-TYPE
This table describes the set of DOCSIS-QOS Service Classes in a CMTS.
1.3.6.1.2.1.127.1.8not-accessiblecurrent
docsIetfQosServiceClassEntry
OBJECT-TYPE
A provisioned service class on a CMTS. Each entry defines a template for certain DOCSIS QOS Parameter Set values. When a CM creates or modifies an Admitted QOS Parameter Set for a Service Flow, it may reference a Service Class Name instead of providing explicit QOS Parameter Set values. In this case, the CMTS populates the QOS Parameter Set with the applicable corresponding values from the named Service Class. Subsequent changes to a Service Class row do not affect the QOS Parameter Set values of any service flows already admitted. A service class template applies to only a single direction, as indicated in the docsIetfQosServiceClassDirection object.
1.3.6.1.2.1.127.1.8.1not-accessiblecurrent
docsIetfQosServiceClassName
OBJECT-TYPE
Service Class Name. DOCSIS specifies that the maximum size is 16 ASCII characters including a terminating zero. The terminating zero is not represented in this SnmpAdminString syntax object.
1.3.6.1.2.1.127.1.8.1.1SnmpAdminString (SIZE(1..15))not-accessiblecurrent
docsIetfQosServiceClassStatus
OBJECT-TYPE
Used to create or delete rows in this table. There is no restriction on the ability to change values in this row while the row is active. Inactive rows need not be timed out.
1.3.6.1.2.1.127.1.8.1.2RowStatusread-createcurrent
docsIetfQosServiceClassPriority
OBJECT-TYPE
Template for docsIetfQosParamSetPriority.
1.3.6.1.2.1.127.1.8.1.3Integer32 (0..7)read-createcurrent
docsIetfQosServiceClassMaxTrafficRate
OBJECT-TYPE
Template for docsIetfQosParamSetMaxTrafficRate.
1.3.6.1.2.1.127.1.8.1.4DocsIetfQosBitRateread-createcurrent
docsIetfQosServiceClassMaxTrafficBurst
OBJECT-TYPE
Template for docsIetfQosParamSetMaxTrafficBurst.
1.3.6.1.2.1.127.1.8.1.5Unsigned32read-createcurrent
docsIetfQosServiceClassMinReservedRate
OBJECT-TYPE
Template for docsIetfQosParamSEtMinReservedRate.
1.3.6.1.2.1.127.1.8.1.6DocsIetfQosBitRateread-createcurrent
docsIetfQosServiceClassMinReservedPkt
OBJECT-TYPE
Template for docsIetfQosParamSetMinReservedPkt.
1.3.6.1.2.1.127.1.8.1.7Integer32 (0..65535)read-createcurrent
docsIetfQosServiceClassMaxConcatBurst
OBJECT-TYPE
Template for docsIetfQosParamSetMaxConcatBurst.
1.3.6.1.2.1.127.1.8.1.8Integer32 (0..65535)read-createcurrent
docsIetfQosServiceClassNomPollInterval
OBJECT-TYPE
Template for docsIetfQosParamSetNomPollInterval.
1.3.6.1.2.1.127.1.8.1.9Unsigned32read-createcurrent
docsIetfQosServiceClassTolPollJitter
OBJECT-TYPE
Template for docsIetfQosParamSetTolPollJitter.
1.3.6.1.2.1.127.1.8.1.10Unsigned32read-createcurrent
docsIetfQosServiceClassUnsolicitGrantSize
OBJECT-TYPE
Template for docsIetfQosParamSetUnsolicitGrantSize.
1.3.6.1.2.1.127.1.8.1.11Integer32 (0..65535)read-createcurrent
docsIetfQosServiceClassNomGrantInterval
OBJECT-TYPE
Template for docsIetfQosParamSetNomGrantInterval.
1.3.6.1.2.1.127.1.8.1.12Unsigned32read-createcurrent
docsIetfQosServiceClassTolGrantJitter
OBJECT-TYPE
Template for docsIetfQosParamSetTolGrantJitter.
1.3.6.1.2.1.127.1.8.1.13Unsigned32read-createcurrent
docsIetfQosServiceClassGrantsPerInterval
OBJECT-TYPE
Template for docsIetfQosParamSetGrantsPerInterval.
1.3.6.1.2.1.127.1.8.1.14Integer32 (0..127)read-createcurrent
docsIetfQosServiceClassMaxLatency
OBJECT-TYPE
Template for docsIetfQosParamSetClassMaxLatency.
1.3.6.1.2.1.127.1.8.1.15Unsigned32read-createcurrent
docsIetfQosServiceClassActiveTimeout
OBJECT-TYPE
Template for docsIetfQosParamSetActiveTimeout.
1.3.6.1.2.1.127.1.8.1.16Integer32 (0..65535)read-createcurrent
docsIetfQosServiceClassAdmittedTimeout
OBJECT-TYPE
Template for docsIetfQosParamSetAdmittedTimeout.
1.3.6.1.2.1.127.1.8.1.17Integer32 (0..65535)read-createcurrent
docsIetfQosServiceClassSchedulingType
OBJECT-TYPE
Template for docsIetfQosParamSetSchedulingType.
1.3.6.1.2.1.127.1.8.1.18DocsIetfQosSchedulingTyperead-createcurrent
docsIetfQosServiceClassRequestPolicy
OBJECT-TYPE
Template for docsIetfQosParamSetRequestPolicyOct.
1.3.6.1.2.1.127.1.8.1.19OCTET STRING (SIZE(4))read-createcurrent
docsIetfQosServiceClassTosAndMask
OBJECT-TYPE
Template for docsIetfQosParamSetTosAndMask. The IP TOS octet as originally defined in RFC 791 has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). Network operators SHOULD avoid specifying values of docsIetfQosServiceClassTosAndMask and docsIetfQosServiceClassTosOrMask that would result in the modification of the ECN bits. In particular, operators should not use values of docsIetfQosServiceClassTosAndMask that have either of the least-significant two bits set to 0. Similarly,operators should not use values of docsIetfQosServiceClassTosOrMask that have either of the least-significant two bits set to 1.
1.3.6.1.2.1.127.1.8.1.20OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosServiceClassTosOrMask
OBJECT-TYPE
Template for docsIetfQosParamSetTosOrMask. The IP TOS octet as originally defined in RFC 791 has been superseded by the 6-bit Differentiated Services Field (DSField, RFC 3260) and the 2-bit Explicit Congestion Notification Field (ECN field, RFC 3168). Network operators SHOULD avoid specifying values of docsIetfQosServiceClassTosAndMask and docsIetfQosServiceClassTosOrMask that would result in the modification of the ECN bits. In particular, operators should not use values of docsIetfQosServiceClassTosAndMask that have either of the least-significant two bits set to 0. Similarly, operators should not use values of docsIetfQosServiceClassTosOrMask that have either of the least-significant two bits set to 1.
1.3.6.1.2.1.127.1.8.1.21OCTET STRING (SIZE(1))read-onlycurrent
docsIetfQosServiceClassDirection
OBJECT-TYPE
Specifies whether the service class template applies to upstream or downstream service flows.
1.3.6.1.2.1.127.1.8.1.22DocsIetfQosRfMacIfDirectionread-createcurrent
docsIetfQosServiceClassStorageType
OBJECT-TYPE
This object defines whether this row is kept in volatile storage and lost upon reboot or whether it is backed up by non-volatile or permanent storage. 'permanent' entries need not allow writable access to any object.
1.3.6.1.2.1.127.1.8.1.23StorageTyperead-createcurrent
docsIetfQosServiceClassDSCPOverwrite
OBJECT-TYPE
This object allows the overwrite of the DSCP field per RFC 3260. If this object is -1, then the corresponding entry's docsIetfQosServiceClassTosAndMask value MUST be 'FF'H and docsIetfQosServiceClassTosOrMask MUST be '00'H. Otherwise, this object is in the range of 0..63, and the corresponding entry's docsIetfQosServiceClassTosAndMask value MUST be '03'H and the docsIetfQosServiceClassTosOrMask MUST be this object's value shifted left by two bit positions.
1.3.6.1.2.1.127.1.8.1.24DscpOrAnyread-createcurrent
docsIetfQosServiceClassPolicyTable
OBJECT-TYPE
This table describes the set of DOCSIS-QOS Service Class Policies. This table is an adjunct to the docsDevFilterPolicy table. Entries in the docsDevFilterPolicy table can point to specific rows in this table. This table permits mapping a packet to a service class name of an active service flow so long as a classifier does not exist at a higher priority.
1.3.6.1.2.1.127.1.9not-accessiblecurrent
docsIetfQosServiceClassPolicyEntry
OBJECT-TYPE
A service class name policy entry.
1.3.6.1.2.1.127.1.9.1not-accessiblecurrent
docsIetfQosServiceClassPolicyIndex
OBJECT-TYPE
Index value to identify an entry in this table uniquely.
1.3.6.1.2.1.127.1.9.1.1Unsigned32 (1..2147483647)not-accessiblecurrent
docsIetfQosServiceClassPolicyName
OBJECT-TYPE
Service Class Name to identify the name of the service class flow to which the packet should be directed.
1.3.6.1.2.1.127.1.9.1.2SnmpAdminStringread-createcurrent
docsIetfQosServiceClassPolicyRulePriority
OBJECT-TYPE
Service Class Policy rule priority for the entry.
1.3.6.1.2.1.127.1.9.1.3Integer32 (0..255)read-createcurrent
docsIetfQosServiceClassPolicyStatus
OBJECT-TYPE
Used to create or delete rows in this table. This object should not be deleted if it is referenced by an entry in docsDevFilterPolicy. The reference should be deleted first. There is no restriction on the ability to change values in this row while the row is active. Inactive rows need not be timed out.
1.3.6.1.2.1.127.1.9.1.4RowStatusread-createcurrent
docsIetfQosServiceClassPolicyStorageType
OBJECT-TYPE
This object defines whether this row is kept in volatile storage and lost upon reboot or whether it is backed up by non-volatile or permanent storage. 'permanent' entries need not allow writable access to any object.
1.3.6.1.2.1.127.1.9.1.5StorageTyperead-createcurrent
docsIetfQosPHSTable
OBJECT-TYPE
This table describes the set of payload header suppression entries.
1.3.6.1.2.1.127.1.10not-accessiblecurrent
docsIetfQosPHSEntry
OBJECT-TYPE
A payload header suppression entry. The ifIndex is an ifType of docsCableMaclayer(127). The index docsIetfQosServiceFlowId selects one service flow from the cable MAC layer interface. The docsIetfQosPktClassId index matches an index of the docsIetfQosPktClassTable.
1.3.6.1.2.1.127.1.10.1not-accessiblecurrent
docsIetfQosPHSField
OBJECT-TYPE
Payload header suppression field defines the bytes of the header that must be suppressed/restored by the sending/receiving device. The number of octets in this object should be the same as the value of docsIetfQosPHSSize.
1.3.6.1.2.1.127.1.10.1.1OCTET STRING (SIZE(0..255))read-onlycurrent
docsIetfQosPHSMask
OBJECT-TYPE
Payload header suppression mask defines the bit mask that is used in combination with the docsIetfQosPHSField. It defines which bytes in the header must be suppressed/restored by the sending or receiving device. Each bit of this bit mask corresponds to a byte in the docsIetfQosPHSField, with the least significant bit corresponding to the first byte of the docsIetfQosPHSField. Each bit of the bit mask specifies whether the corresponding byte should be suppressed in the packet. A bit value of '1' indicates that the byte should be suppressed by the sending device and restored by the receiving device. A bit value of '0' indicates that the byte should not be suppressed by the sending device or restored by the receiving device. If the bit mask does not contain a bit for each byte in the docsIetfQosPHSField, then the bit mask is extended with bit values of '1' to be the necessary length.
1.3.6.1.2.1.127.1.10.1.2OCTET STRING (SIZE(0..32))read-onlycurrent
docsIetfQosPHSSize
OBJECT-TYPE
Payload header suppression size specifies the number of bytes in the header to be suppressed and restored. The value of this object must match the number of bytes in the docsIetfQosPHSField.
1.3.6.1.2.1.127.1.10.1.3Integer32 (0..255)read-onlycurrent
docsIetfQosPHSVerify
OBJECT-TYPE
Payload header suppression verification value. If 'true', the sender must verify docsIetfQosPHSField is the same as what is contained in the packet to be suppressed.
1.3.6.1.2.1.127.1.10.1.4TruthValueread-onlycurrent
docsIetfQosPHSIndex
OBJECT-TYPE
Payload header suppression index uniquely references the PHS rule for a given service flow.
1.3.6.1.2.1.127.1.10.1.5Integer32 (1..255)read-onlycurrent
docsIetfQosCmtsMacToSrvFlowTable
OBJECT-TYPE
This table provides for referencing the service flows associated with a particular cable modem. This allows indexing into other docsIetfQos tables that are indexed by docsIetfQosServiceFlowId and ifIndex.
1.3.6.1.2.1.127.1.11not-accessiblecurrent
docsIetfQosCmtsMacToSrvFlowEntry
OBJECT-TYPE
An entry is created by CMTS for each service flow connected to this CMTS.
1.3.6.1.2.1.127.1.11.1not-accessiblecurrent
docsIetfQosCmtsCmMac
OBJECT-TYPE
The MAC address for the referenced CM.
1.3.6.1.2.1.127.1.11.1.1MacAddressnot-accessiblecurrent
docsIetfQosCmtsServiceFlowId
OBJECT-TYPE
An index assigned to a service flow by CMTS.
1.3.6.1.2.1.127.1.11.1.2Unsigned32 (1..4294967295)not-accessiblecurrent
docsIetfQosCmtsIfIndex
OBJECT-TYPE
The ifIndex of ifType docsCableMacLayer(127) on the CMTS that is connected to the Cable Modem.
1.3.6.1.2.1.127.1.11.1.3InterfaceIndexread-onlycurrent
docsIetfQosConformance
OBJECT-IDENTITY
1.3.6.1.2.1.127.2
docsIetfQosGroups
OBJECT-IDENTITY
1.3.6.1.2.1.127.2.1
docsIetfQosCompliances
OBJECT-IDENTITY
1.3.6.1.2.1.127.2.2

Conformance

NameOIDStatus
docsIetfQosBaseGroup
OBJECT-GROUP
Group of objects implemented in both Cable Modems and Cable Modem Termination Systems.
1.3.6.1.2.1.127.2.1.1current
docsIetfQosParamSetGroup
OBJECT-GROUP
Group of objects implemented in both Cable Modems and Cable Modem Termination Systems for QOS Parameter Sets.
1.3.6.1.2.1.127.2.1.2current
docsIetfQosCmtsGroup
OBJECT-GROUP
Group of objects implemented only in the CMTS.
1.3.6.1.2.1.127.2.1.3current
docsIetfQosSrvClassPolicyGroup
OBJECT-GROUP
Group of objects implemented in both Cable Modems and Cable Modem Termination Systems when supporting policy-based service flows.
1.3.6.1.2.1.127.2.1.4current
docsIetfQosServiceClassGroup
OBJECT-GROUP
Group of objects implemented only in Cable Modem Termination Systems when supporting expansion of Service Class Names in a QOS Parameter Set
1.3.6.1.2.1.127.2.1.5current
docsIetfQosCompliance
MODULE-COMPLIANCE
The compliance statement for MCNS Cable Modems and Cable Modem Termination Systems that implement DOCSIS Service Flows.
1.3.6.1.2.1.127.2.2.1current