MIBs Depot

CTRON-Q-BRIDGE-MIB-EXT

Registered at
1.3.6.1.4.1.52.4.1.2.16.7
Last updated
2007-02-16 17:44
Organization
Enterasys Networks, Inc.
Revisions
2007-02-16 17:44, 2005-01-21 17:17, 2004-06-04 12:41, 2003-12-15 20:53, 2002-07-26 20:45, 2002-07-19 14:12, 2001-04-16 18:16, 2001-01-10 13:29, 1999-10-06 08:12
Namespace
enterasys
Source file
CTRON-Q-BRIDGE-MIB-EXT
Digest
sha256:a3890057b7cc8b4e74fae3574268527c3d6f6d27af3dc4a1abe7b6a071ca3f3f

Description

This MIB module defines a portion of the SNMP enterprise MIBs under the Cabletron enterprise OID pertaining to the configuration of switches that support IEEE 802.1Q [802.1Q] and the Q-BRIDGE-MIB [RFC2674].

Contact

Postal: Enterasys Networks 50 Minuteman Rd. Andover, MA 01810-1008 USA Phone: +1 978 684 1000 E-mail: support@enterasys.com WWW: http://www.enterasys.com

Imports

FromSymbols
BRIDGE-MIBdot1dBasePort, dot1dBasePortEntry
CTRON-MIB-NAMESctVlanExt
P-BRIDGE-MIBEnabledStatus
Q-BRIDGE-MIBPortList, VlanIndex, dot1qFdbId, dot1qTpFdbAddress, dot1qVlanCurrentEntry, dot1qVlanIndex
SNMPv2-CONFMODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP
SNMPv2-SMIMODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso
SNMPv2-TCDisplayString, TEXTUAL-CONVENTION, TruthValue

Imported by

Nothing in this corpus imports this module.

Load order

Every file a consumer needs in order to load this module, dependencies first.

BRIDGE-MIB
CTRON-MIB-NAMES
CTRON-OIDS
CTRON-Q-BRIDGE-MIB-EXT
IANAifType-MIB
IF-MIB
P-BRIDGE-MIB
Q-BRIDGE-MIB
RFC1158-MIB
RFC1271-MIB
RMON-MIB
RMON2-MIB
SNMP-FRAMEWORK-MIB
SNMPv2-CONF
SNMPv2-MIB
SNMPv2-SMI
SNMPv2-TC
TOKEN-RING-RMON-MIB

Objects

NameOIDSyntaxAccessStatus
ctQBridgeMIBObjects
OBJECT-IDENTITY
1.3.6.1.4.1.52.4.1.2.16.7.1
ctDot1qPortVlanExtTable
OBJECT-TYPE
A table containing per port control and status information for Cabletron proprietary extensions pertaining to VLAN configuration in the device.
1.3.6.1.4.1.52.4.1.2.16.7.1.1not-accessiblecurrent
ctDot1qPortVlanEntry
OBJECT-TYPE
Information controlling proprietary VLAN configuration for a port on the device. This is indexed by dot1dBasePort.
1.3.6.1.4.1.52.4.1.2.16.7.1.1.1not-accessiblecurrent
ctDot1qPortDefaultForwardMode
OBJECT-TYPE
The method used to forward frames belonging to VLANs that do not have an entry in the dot1qVlanCurrentTable. When this is forwardNoFrames(1), the device will not forward traffic out this port, for any VLAN that does not have an entry in the dot1qVlanCurrentTable. When this is forwardAllFramesAsTagged(2), the device will forward all traffic out this port, with an 802.1Q VLAN tag, for any VLAN that does not have an entry in dot1qVlanCurrentTable. When this is forwardAllFramesAsUntagged(3), the device will forward all traffic out this port, without an 802.1Q VLAN tag, for any VLAN that does not have an entry in dot1qVlanCurrentTable. This control does not affect VLAN independent BPDU frames, such as GVRP and STP. It does affect VLAN dependent BPDU frames, such as GMRP.
1.3.6.1.4.1.52.4.1.2.16.7.1.1.1.1INTEGER {forwardNoFrames(1), forwardAllFramesAsTagged(2), forwardAllFramesAsUntagged(3)}read-writecurrent
ctDot1qPortDiscardTagged
OBJECT-TYPE
The method used to discard all incoming VLAN tagged frames for the port specified by the indexing of this entry. When this is enabled(1), the device will discard all 802.1Q tagged packets received on this port. When this is disabled(2), the device will NOT discard frames received on this port based on the presence of an 802.1Q tag. The behavior of this method in conjunction with the dot1qPortAcceptableFrameTypes leaf of Q-BRIDGE-MIB [RFC2674] is that of a logical OR.
1.3.6.1.4.1.52.4.1.2.16.7.1.1.1.2EnabledStatusread-writecurrent
ctDot1qPortReplaceTCI
OBJECT-TYPE
The method used to replace the Tag Control Information (TCI) field in all VLAN tagged frames received on the port specified by the indexing of this entry. When this is enabled(1), the device will replace the 802.1Q TCI field with results of the INGRESS stage of frame forwarding. Logically, this happens immediately prior to the PROGRESS stage of frame relay. When this is disabled(2), the device operates in compliance with the IEEE 802.1Q standard and honors the TCI field of incident frames.
1.3.6.1.4.1.52.4.1.2.16.7.1.1.1.3EnabledStatusread-writecurrent
ctDot1qVlanDynamicEgressTable
OBJECT-TYPE
A table containing per VLAN control and status information for Cabletron proprietary egress extensions for VLAN configuration in the device.
1.3.6.1.4.1.52.4.1.2.16.7.1.2not-accessiblecurrent
ctDot1qVlanDynamicEgressEntry
OBJECT-TYPE
Information controlling proprietary VLAN configuration for a device.
1.3.6.1.4.1.52.4.1.2.16.7.1.2.1not-accessiblecurrent
ctDot1qVlanDynamicEgressIndex
OBJECT-TYPE
The VLAN to which this entries' dynamic egress status applies.
1.3.6.1.4.1.52.4.1.2.16.7.1.2.1.1VlanIndexnot-accessiblecurrent
ctDot1qVlanDynamicEgressStatus
OBJECT-TYPE
The state of Dynamic Egress operation on this VLAN. The value enabled(1) indicates that Dynamic Egress is enabled on this VLAN. If Dynamic Egress is enabled for a VLAN the following rules are applied to received frames: 1. If the frame is untagged, and 2. The frame is successfully classified to the specified VLAN, and 3. The port the frame was received on is not configured in dot1qVlanCurrentEgressPorts, dot1qVlanCurrentUntaggedPorts, or dot1qVlanForbiddenEgressPorts, for the classified VLAN, and 4. The port is configured for forwardNoFrames(1) in ctDot1qPortDefaultForwardMode (if supported), then 5. The port the frame was received on will be added to the dot1qVlanCurrentEgressPorts and dot1qVlanCurrentUntaggedPorts for the classified VLAN. If the VLAN was not preexisting the dot1qVlanStatus leaf for the VLAN will return other(1).
1.3.6.1.4.1.52.4.1.2.16.7.1.2.1.2EnabledStatusread-writecurrent
ctDot1qVlanCurrentExtTable
OBJECT-TYPE
A table containing current configuration information for each VLAN currently configured into the device by (local or network) management or created dynamically created. This table provides proprietary extensions to dot1qVlanCurrentTable as defined in RFC2674.
1.3.6.1.4.1.52.4.1.2.16.7.1.3not-accessiblecurrent
ctDot1qVlanCurrentEntryExt
OBJECT-TYPE
Information for a VLAN configured into the device by (local or network) management or created dynamically.
1.3.6.1.4.1.52.4.1.2.16.7.1.3.1not-accessiblecurrent
ctDot1qVlanForbidEgressPorts
OBJECT-TYPE
The current set of ports which are prohibited from being included in the egress list for this VLAN. This object is a logical combination of dot1qVlanForbiddenEgressPorts and zero or more proprietary methods of forbidding egress on a per port per VLAN basis.
1.3.6.1.4.1.52.4.1.2.16.7.1.3.1.1PortListread-onlycurrent
ctDot1qPortVlanEgressTable
OBJECT-TYPE
A table containing per port, per VLAN egress information. This table represents information contained in the dot1qVlanCurrentTable, but indexed by port instead of by VLAN. Only ports that a given VLAN is actively egressing are represented in this table.
1.3.6.1.4.1.52.4.1.2.16.7.1.4not-accessiblecurrent
ctDot1qPortVlanEgressEntry
OBJECT-TYPE
Information related to egress on a per port, per VLAN basis. The entry also represents the method that caused the port to have egress.
1.3.6.1.4.1.52.4.1.2.16.7.1.4.1not-accessiblecurrent
ctDot1qPortVlanEgressStatus
OBJECT-TYPE
This object indicates the method that is causing the VLAN to egress on this port. other(1) - The VLAN is currently egressing on this port but the conditions under which it will remain so differ from the following values. static(2) - The VLAN is currently egressing on this port as a result of static configuration in the dot1qVlanStaticTable. gvrp(3) - The VLAN is currently egressing on this port as a result of GVRP. ctDynamicEgress(4) - The VLAN is currently egressing on this port as a result of ctDyanmicEgress. This feature is controlled by the ctDot1qVlanDynamicEgressStatus object. etsysPolicyProfile(5) - The VLAN is currently egressing on this port as a result of policy configuration in the ENTERASYS-POLICY-PROFILE-MIB. ctPortDefFwdMode(6) - The VLAN is currently egressing on this port as a result of explicit configuration of the ctDot1qPortDefaultForwardMode object for this port. rfc3580VlanTunnelAttribute(7) - The VLAN is currently egressing on this port as a result of a specified RFC2580 VLAN Tunnel Attribute.
1.3.6.1.4.1.52.4.1.2.16.7.1.4.1.1INTEGER {other(1), static(2), gvrp(3), ctDynamicEgress(4), etsysPolicyProfile(5), ctPortDefFwdMode(6), rfc3580VlanTunnelAttribute(7)}read-onlycurrent
ctDot1qPortVlanEgressType
OBJECT-TYPE
This object indicates the type of egress the VLAN has on this port. tagged(1) - Frames for the specified VLAN egressing this port have an 802.1Q tag. untagged(2) - Frames for the specified VLAN egressing this port do not have an 802.1Q tag. forbidden(3) - Frames for the specified VLAN are not allowed to egress this port under any circumstances.
1.3.6.1.4.1.52.4.1.2.16.7.1.4.1.2INTEGER {tagged(1), untagged(2), forbidden(3)}read-onlycurrent
ctDot1qTpFdbExtTable
OBJECT-TYPE
A table that extends the functionality provided by the dot1qTpFdbTable of Q-BRIDGE-MIB. Only unicast MAC addresses with a dot1qTpFdbStatus of learned(3) will appear in this table.
1.3.6.1.4.1.52.4.1.2.16.7.1.5not-accessiblecurrent
ctDot1qTpFdbExtEntry
OBJECT-TYPE
Information about a specific unicast MAC address for which the device has some forwarding and/or filtering information.
1.3.6.1.4.1.52.4.1.2.16.7.1.5.1not-accessiblecurrent
ctDot1qTpFdbRemoveAddress
OBJECT-TYPE
When this is object is set to true(1) the unicast MAC address specified by the indexing will be removed from transparent filter database. A set to false(2) will have no effect. This object will always return false(2).
1.3.6.1.4.1.52.4.1.2.16.7.1.5.1.1TruthValueread-writecurrent
ctQBridgeConformance
OBJECT-IDENTITY
1.3.6.1.4.1.52.4.1.2.16.7.2
ctQBridgeGroups
OBJECT-IDENTITY
1.3.6.1.4.1.52.4.1.2.16.7.2.1
ctQBridgeCompliances
OBJECT-IDENTITY
1.3.6.1.4.1.52.4.1.2.16.7.2.2

Conformance

NameOIDStatus
ctQBridgePortGroup
OBJECT-GROUP
********* THIS GROUP IS DEPRECATED ********** A collection of objects providing port level control over the forwarding behavior of frames classified to unconfigured VLANs.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.1deprecated
ctQBridgeVlanGroup
OBJECT-GROUP
A collection of objects providing device level control over the addition and deletion of unconfigured ports to the egress lists of VLANs.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.2current
ctQBridgePortGroup2
OBJECT-GROUP
A collection of objects providing port level control over the ingress and egress of frames received by the device.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.3current
ctQBridgeVlanCurrentForbidGroup
OBJECT-GROUP
A collection of objects providing read-only current operational information pertaining to forbidden egress on a per VLAN basis.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.4current
ctQBridgePortReplaceTCIGroup
OBJECT-GROUP
An object providing port level control TCI replacement.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.5current
ctQBridgePortVlanEgressGroup
OBJECT-GROUP
Objects providing per port, per VLAN egress information.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.6current
ctQBridgeTpFdbTableExtGroup
OBJECT-GROUP
Objects providing per 802.1Q unicast MAC address configuration.
1.3.6.1.4.1.52.4.1.2.16.7.2.1.7current
ctDot1qVlan
MODULE-COMPLIANCE
******** THIS COMPLIANCE IS DEPRECATED ******** The compliance statement for devices that support Cabletron extensions to Q-BRIDGE-MIB.
1.3.6.1.4.1.52.4.1.2.16.7.2.2.1deprecated
ctDot1qVlan2
MODULE-COMPLIANCE
The compliance statement for devices that support Cabletron extensions to Q-BRIDGE-MIB.
1.3.6.1.4.1.52.4.1.2.16.7.2.2.2current
ctDot1qVlanCurentCompliance
MODULE-COMPLIANCE
The compliance statement for devices that support Cabletron extensions to the dot1qVlanCurrentTable of the Q-BRIDGE-MIB.
1.3.6.1.4.1.52.4.1.2.16.7.2.2.3current
ctDot1qPortVlanEgressCompliance
MODULE-COMPLIANCE
The compliance statement for devices that support reporting of VLAN egress on a per port, per VLAN basis.
1.3.6.1.4.1.52.4.1.2.16.7.2.2.4current
ctDot1qTpFdbTableExtCompliance
MODULE-COMPLIANCE
The compliance statement for devices that support extensions to the dot1qTpFdbTable of Q-BRIDGE-MIB.
1.3.6.1.4.1.52.4.1.2.16.7.2.2.5current