A3COM-HUAWEI-LAG-MIB
- Registered at
- 1.3.6.1.4.1.43.45.1.5.25.25
- Last updated
- 2003-10-09 19:42
- Organization
- Hangzhou H3C Tech. Co., Ltd.
- Namespace
- 3com
- Source file
A3COM-HUAWEI-LAG-MIB- Digest
sha256:44abb8be9d133f89a912520cef15cc504faa4807eaa93fd5470f9babd240d8cd
Description
LACP extend MIB.
Contact
Platform Team Hangzhou H3C Tech. Co., Ltd. Hai-Dian District Beijing P.R. China http://www.h3c.com Zip:100085
Imports
| From | Symbols |
|---|---|
| A3COM-HUAWEI-OID-MIB | huaweiDatacomm, huaweiMgmt |
| Q-BRIDGE-MIB | PortList |
| SNMPv2-CONF | MODULE-COMPLIANCE, NOTIFICATION-GROUP, OBJECT-GROUP |
| SNMPv2-SMI | Gauge32, Integer32, MODULE-IDENTITY, NOTIFICATION-TYPE, OBJECT-IDENTITY, OBJECT-TYPE, iso |
| SNMPv2-TC | DisplayString, RowStatus, TEXTUAL-CONVENTION, TruthValue |
Imported by
Nothing in this corpus imports this module.
Load order
Every file a consumer needs in order to load this module, dependencies first.
A3COM-HUAWEI-LAG-MIB A3COM-HUAWEI-OID-MIB BRIDGE-MIB IANAifType-MIB IF-MIB P-BRIDGE-MIB Q-BRIDGE-MIB RFC1158-MIB RFC1271-MIB RMON-MIB RMON2-MIB SNMP-FRAMEWORK-MIB SNMPv2-CONF SNMPv2-MIB SNMPv2-SMI SNMPv2-TC TOKEN-RING-RMON-MIB
Objects
| Name | OID | Syntax | Access | Status |
|---|---|---|---|---|
| hwLAGMibObjects OBJECT-IDENTITY | 1.3.6.1.4.1.43.45.1.5.25.25.1 | |||
| hwAggLinkTable OBJECT-TYPE A table of aggregate link objects. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1 | not-accessible | current | |
| hwAggLinkEntry OBJECT-TYPE Entry of table. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1 | not-accessible | current | |
| hwAggLinkNumber OBJECT-TYPE The serial number of aggregation group. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.1 | Integer32 | accessible-for-notify | current |
| hwAggLinkName OBJECT-TYPE Aggregation name. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.2 | DisplayString (SIZE(0..32)) | read-create | current |
| hwAggLinkMode OBJECT-TYPE Type of aggregation. manual: Manual aggregation, no LACP. static: Membership specified by user, LACP is used to validate. dynamic: Completely dynamic aggregation detected by LACP. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.3 | INTEGER {manual(1), static(2), dynamic(3)} | read-create | current |
| hwAggLinkPortList OBJECT-TYPE List of ports in this link aggregation group, by bridge port number. If the mode of the link aggregation group is manual or static, you can update this list to your hearts content. However, if the link aggregation group is dynamic, the system will maintain it. You are not permitted to set the value of this to all zeroes. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.4 | PortList | read-create | current |
| hwAggLinkState OBJECT-TYPE RowStatus, now support three states: createAndGo, active, destroy. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.5 | RowStatus | read-create | current |
| hwAggPortListSelectedPorts OBJECT-TYPE A PortList of physical ports that have been selected but not attached to this aggregator. When the bit is set to 1,it means the corresponding port is in the portlist. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.6 | PortList | read-only | current |
| hwAggPortListSamePartnerPorts OBJECT-TYPE PortList of physical ports that have the same Actor SystemID and partner systemID as this aggregator, but have different actor and partner keys of aggregator. | 1.3.6.1.4.1.43.45.1.5.25.25.1.1.1.7 | PortList | read-only | current |
| hwAggPortTable OBJECT-TYPE A table of aggregate port objects. | 1.3.6.1.4.1.43.45.1.5.25.25.1.2 | not-accessible | current | |
| hwAggPortEntry OBJECT-TYPE Entry of table. | 1.3.6.1.4.1.43.45.1.5.25.25.1.2.1 | not-accessible | current | |
| hwAggPortIndex OBJECT-TYPE Port ifindex which is according to RFC1213 MIB. | 1.3.6.1.4.1.43.45.1.5.25.25.1.2.1.1 | Gauge32 | accessible-for-notify | current |
| hwAggPortNotAttachedReason OBJECT-TYPE Reason why this port is selected for an aggregator but not attached, 0: The port is attached to this aggregator. 1: The current number of active ports has reached the upper limit. 2: All aggregation resources are already in-use. 3: The port's configuration is improper for being attached. 4: The port's partner is improper for being attached. 5: The number of current active ports has not reached the lower limit. 6: The port's physical state (down) is improper for being attached. 7: The port is not selected for an aggregator. 8: The port's hardware restriction is improper for being attached. 9: The port's speed is improper for being attached. 10: The port's duplex mode is improper for being attached. | 1.3.6.1.4.1.43.45.1.5.25.25.1.2.1.2 | Integer32 (0..10) | read-write | current |
| hwAggPortLacpState OBJECT-TYPE Control ports' lacp enble or disable. | 1.3.6.1.4.1.43.45.1.5.25.25.1.2.1.3 | TruthValue | read-write | current |
| hwAggPortNotAttachedString OBJECT-TYPE The string which interprets this port is selected for an aggregator but not attached. | 1.3.6.1.4.1.43.45.1.5.25.25.1.2.1.4 | DisplayString (SIZE(0..255)) | read-write | current |
| hwAggResourceAllocationValue OBJECT-TYPE The priority value calculated to decide which aggregations have first call on the load-sharing aggregation resources in the hardware. It depends on the aggregation type and total speed. | 1.3.6.1.4.1.43.45.1.5.25.25.1.3 | PortList | read-only | current |
| hwLAGMibNotifications OBJECT-IDENTITY | 1.3.6.1.4.1.43.45.1.5.25.25.2 | |||
| hwLAGMibConformance OBJECT-IDENTITY | 1.3.6.1.4.1.43.45.1.5.25.25.3 | |||
| hwLAGMibCompliances OBJECT-IDENTITY | 1.3.6.1.4.1.43.45.1.5.25.25.3.1 | |||
| hwLAGMibGroup OBJECT-IDENTITY | 1.3.6.1.4.1.43.45.1.5.25.25.3.2 |
Notifications
| Name | OID | Status |
|---|---|---|
| hwAggSpeedChangedNotification NOTIFICATION-TYPE This event will be triggered whenever an aggregation changes its speed. | 1.3.6.1.4.1.43.45.1.5.25.25.2.1 | current |
| hwAggPortInactiveNotification NOTIFICATION-TYPE This event will be triggered whenever any port in aggregator is made inactive. | 1.3.6.1.4.1.43.45.1.5.25.25.2.2 | current |
| hwAggPortInactiveNotification2 NOTIFICATION-TYPE This event will be triggered whenever the port in aggregator is made inactive. | 1.3.6.1.4.1.43.45.1.5.25.25.2.3 | current |
| hwAggPortActiveNotification NOTIFICATION-TYPE This event will be triggered whenever the port in aggregator is made active. | 1.3.6.1.4.1.43.45.1.5.25.25.2.4 | current |
Conformance
| Name | OID | Status |
|---|---|---|
| hwLAGMibCompliance MODULE-COMPLIANCE The compliance statement for SNMP entities which implement the Lag MIB. | 1.3.6.1.4.1.43.45.1.5.25.25.3.1.1 | current |
| hwLAGMibObjectGroup OBJECT-GROUP The collection of objects which are used to represent LAG objects. | 1.3.6.1.4.1.43.45.1.5.25.25.3.2.1 | current |
| hwLAGMibNotificationGroup NOTIFICATION-GROUP The collection of objects which are used to represent notifications. | 1.3.6.1.4.1.43.45.1.5.25.25.3.2.2 | current |